Subject: [Dots] comments on draft-ietf-dots-signal-channel-01:

From: "Xialiang (Frank)" <[email-masked]>
Date: Thu, 8 Jun 2017 09:31:54 +0000

Hi,
I have reviewed the latest signal channel daft and think it's now in a good shape. I also have some comments about it as below:

1.       What is DOTS client identity used for coupling the signal channel with corresponding data channel? I think current draft does not clarify its definition and the way using it clearly. More texts are needed.

2.       Why does DOTS client efficacy message have the redundant information as mitigation request message? If they are the same information, it's not necessary.

3.       Can a DOTS client have multiple signal channel sessions with a dots server? I don't think it's necessary.

B.R.
Frank

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 9 Jun 2017 14:54:22 +0000

Hi Frank,

Thanks for the review, Please see inline

From: Dots [mailto:[email-masked]] On Behalf Of Xialiang (Frank)
Sent: Thursday, June 8, 2017 3:02 PM
To: [email-masked]
Subject: [Dots] comments on draft-ietf-dots-signal-channel-01:

Hi,

[TR] Sure, will add more details. The DOTS client identity can be extracted from SubjectAltName OR if EST is used by the domain operating DOTS server to generate the DOTS client certificate then DOTS client identifier could be the public key in subject public key info field of the certificate.

[TR] The DOTS client efficacy is conveyed in PUT message, PUT updates the mitigation request and hence it needs to carry all the parameters + efficacy (see https://tools.ietf.org/html/rfc7252#section-5.8.3).

[TR] Yup, https://tools.ietf.org/html/draft-ietf-dots-signal-channel-01#section-12 explains to reduce DOTS client and DOTS server workload, DOTS client SHOULD re-use the (D)TLS session.

Cheers,
-Tiru

B.R.
Frank

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 12 Jun 2017 14:14:42 +0000

Hi Frank,

For comment#1, we can just follow the algorithm given in https://tools.ietf.org/html/rfc7589#section-7 to extract the DOTS client identity or username from the client certificate.

-Tiru

From: Konda, Tirumaleswar Reddy
Sent: Friday, June 9, 2017 8:24 PM
To: 'Xialiang (Frank)' <[email-masked]>; [email-masked]
Subject: RE: comments on draft-ietf-dots-signal-channel-01:

Hi Frank,

From: Dots [mailto:[email-masked]] On Behalf Of Xialiang (Frank)
Sent: Thursday, June 8, 2017 3:02 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] comments on draft-ietf-dots-signal-channel-01:

Hi,

Cheers,
-Tiru

B.R.
Frank