Subject: [Dots] Fwd: New Version Notification for draft-ietf-dots-use-cases-06.txt

From: "Roland Dobbins" <[email-masked]>
Date: Tue, 04 Jul 2017 03:26:25 +0700

Changes in -06 include 8 new/updated interdomain use-cases, reworking of 
the intradomain section with a new use-case, and some spelling and 
grammatical corrections.

TODO in -07:

Add at least one additional interdomain use-case.

Add at least two additional intradomain use-cases.

Incorporate recent feedback from editors and contributors.

Rework orchestration section and move to its own top-level section.

Add additional references.

Grammatical and stylistic clean-up, and clean-up of typos.

-07 will be edited over the next week-and-a-half, and submitted on 
17Jul2017.  -07 is currently targeted for WGLC.

-----------------------------------
Roland Dobbins <[email-masked]>

Forwarded message:

> From: [email-masked]
>
> Subject: New Version Notification for draft-ietf-dots-use-cases-06.txt
> Date: Mon, 3 Jul 2017 13:16:52 -0700
>
> A new version of I-D, draft-ietf-dots-use-cases-06.txt
> has been successfully submitted by Roland Dobbins and posted to the
> IETF repository.
>
> Name:		draft-ietf-dots-use-cases
> Revision:	06
> Title:		Use cases for DDoS Open Threat Signaling
> Document date:	2017-07-03
> Group:		dots
> Pages:		16
> URL:            
> https://www.ietf.org/internet-drafts/draft-ietf-dots-use-cases-06.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-ietf-dots-use-cases/
> Htmlized:       
> https://tools.ietf.org/html/draft-ietf-dots-use-cases-06
> Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-ietf-dots-use-cases-06
> Diff:           
> https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-use-cases-06
>
> Abstract:
>    The DDoS Open Threat Signaling (DOTS) effort is intended to provide 
> a
>    protocol that facilitates interoperability between multivendor
>    solutions/services.  This document presents use cases to evaluate 
> the
>    interactions expected between the DOTS components as well as DOTS
>    messaging exchanges.  The purpose of describing use cases is to
>    identify the interacting DOTS components, how they collaborate and
>    what are the types of information to be exchanged.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: <[email-masked]>
Date: Tue, 4 Jul 2017 05:30:38 +0000

Hi Roland, all,

When checking the diff, I'm surprised to see many items (including nits and so on) that were fixed in -05 reappear in this new version. 

It seems that you started the revision on an older version. IMO, this is not helpful. 

I'm afraid that we need to revert back to -05. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Roland Dobbins
> Envoyé : lundi 3 juillet 2017 22:26
> À : dots
> Objet : [Dots] Fwd: New Version Notification for draft-ietf-dots-use-
> cases-06.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Dobbins, Roland" <[email-masked]>
Date: Tue, 4 Jul 2017 06:58:01 +0000

> On Jul 4, 2017, at 12:30, "[email-masked]" <[email-masked]> wrote:
> 

Please provide a list of the things you've spotted & we'll get them fixed directly, thanks!

---

From: <[email-masked]>
Date: Tue, 4 Jul 2017 07:11:53 +0000

Roland, 

Actually, these are all the issues spotted -04 and fixed in -05. The required changes are available here:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-dots-use-cases-05.txt  

Thank you.

Cheers,
Med

> De : Dobbins, Roland [mailto:[email-masked]]
> Envoyé : mardi 4 juillet 2017 08:58
> À : BOUCADAIR Mohamed IMT/OLN
> Cc : dots
> Objet : Re: [Dots] Fwd: New Version Notification for draft-ietf-dots-use-
> cases-06.txt
> 
> 
> > When checking the diff, I'm surprised to see many items (including nits
> and so on) that were fixed in -05 reappear in this new version.
>

---

From: "Dobbins, Roland" <[email-masked]>
Date: Tue, 4 Jul 2017 08:14:18 +0000

> On Jul 4, 2017, at 14:11, "[email-masked]" <[email-masked]> wrote:
> 
> The required changes are available here:

We'll get the relevant changes fixed - note that the changes to the substance of the use-cases in both the interdomain & intradomain sections in -06 are intentional.

---

From: <[email-masked]>
Date: Tue, 4 Jul 2017 08:47:40 +0000

Re-,

I suspect that some of the changes are intentional.

I do like the new Section 3.1.8 but I'm not sure to understand the rationale behind all of the other NEW sections. For example:

* I would not categorize "End-customer operating an application or service with ...", "End-customer operating a CPE network infrastructure ...", and "End-customer with an out-of-band smartphone application" as DOTS use cases. Those are variation of DOTS client deployment within a network that makes use of the DOTS service.  

* Further, how it is relevant to the discussion whether the DOTS client is embedded on a smartphone or a "normal" host?

* "End-customer with a single upstream transit provider", "End-customer with multiple upstream transit providers ...", and "End-customer with multiple upstream transit providers, but only a single upstream transit .." are all variations of one single DOTS use case: a network invoking DOTS service from one or multiple upstream providers. 

I would personally maintain the structure in -05 + add the new section 3.1.8 + add privacy discussion induced by the procedure in section 3.1.8. 

Cheers,
Med

> Envoyé : mardi 4 juillet 2017 10:14
> We'll get the relevant changes fixed - note that the changes to the
> substance of the use-cases in both the interdomain & intradomain sections
> in -06 are intentional.
>