Subject: [Dots] Multihoming & Requirements I-D

From: <[email-masked]>
Date: Fri, 21 Jul 2017 06:43:15 +0000

Dear all,

As discussed during the DOTS session in Prague (and confirmed in the many side meetings I had after the multi-homing presentation), there is an agreement that multi-homing is key for DOTS architecture.

I'm initiating this thread so that we can figure out collectively how to include that item to the DOTS requirements I-D.

Cheers,
Med

---

From: "Roland Dobbins" <[email-masked]>
Date: Fri, 21 Jul 2017 09:22:50 +0200

On 21 Jul 2017, at 8:43, [email-masked] wrote:

> I'm initiating this thread so that we can figure out collectively how 
> to include that item to the DOTS requirements I-D.

AFAICT, the only consideration is to ensure bidirectional routability 
per sound network engineering practices - i.e., nothing DOTS-specific.

We've always assumed that multi-homing would be present in many 
environments in which DOTS will be used.  There is nothing in the DOTS 
architecture which precludes its use in multi-homing environments.  So, 
apart from emphasizing that sound network engineering practices be 
utilized, it's unclear why this is being treated as some exceptional 
problem we haven't considered, when in fact we've been aware of it and 
supported multi-homed environments from the outset of the DOTS effort.

Please keep in mind that proprietary DOTS analogues have been in 
production use for many years, and so there is a considerable degree of 
real-world experience and expertise in using signaling mechanisms to 
initiate DDoS mitigation, both from upstream transit providers and 
topologically-distant MSSPs.  Several of the active DOTS contributors 
have hands-on experience in such environments.

-----------------------------------
Roland Dobbins <[email-masked]>

---

From: <[email-masked]>
Date: Fri, 21 Jul 2017 07:39:02 +0000

Hi Roland, 

Thank you for sharing your thoughts. 

Please see inline.

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de Roland Dobbins
> Envoyé : vendredi 21 juillet 2017 09:23
> À : [email-masked]
> Objet : Re: [Dots] Multihoming & Requirements I-D
> 

[Med] That's one aspect, but as discussed in the draft this is not the only aspect. I agree the DOTS protocol is the same, but how DOTS associations are maintained, how servers are selected and how requests are placed are additional considerations to take into account. 

> architecture which precludes its use in multi-homing environments.

[Med] The problem is that if you just run a dots client/gateway which is conform to the DOTS architecture specification, DDoS mitigation may fail. I cited many examples in my prez; no need to go through that list here. 

  So,
> supported multi-homed environments from the outset of the DOTS effort.

[Med] Please read the draft. The goal is to provide a set of guidance for DOTS clients/gateways when multihomed.   

> have hands-on experience in such environments.

[Med] What I'm hearing from those with that experience (including some of your colleagues) is that there are specifics to multihoming that need to be covered. 

> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Teague, Nik" <[email-masked]>
Date: Fri, 21 Jul 2017 08:05:34 +0000

Sent from my iPhone

> On 21 Jul 2017, at 09:39, "[email-masked]" <[email-masked]> wrote:
> 
> The goal is to provide a set of guidance for DOTS clients/gateways when multihomed.   

I think this may be key point here - I think the issue of multihoming may be more a question for implementors vs the protocol itself but have no objections to clarifying text.

I would like to understand if there are any suggested updates to the architecture and requirements drafts that you feel would address the concern?

Thanks,

-Nik

---

From: "Roland Dobbins" <[email-masked]>
Date: Fri, 21 Jul 2017 10:06:20 +0200

On 21 Jul 2017, at 10:05, Teague, Nik wrote:

> I think this may be key point here - I think the issue of multihoming 
> may be more a question for implementors vs the protocol itself but 
> have no objections to clarifying text.

Concur.

---

From: "Xialiang (Frank)" <[email-masked]>
Date: Fri, 21 Jul 2017 08:08:02 +0000

Agree!

> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of Teague, Nik
> Sent: Friday, July 21, 2017 10:06 AM
> To: [email-masked]
> Cc: Roland Dobbins; [email-masked]
> Subject: Re: [Dots] Multihoming & Requirements I-D
> 
> 
> 
> Sent from my iPhone
> 
> I think this may be key point here - I think the issue of multihoming may be
> more a question for implementors vs the protocol itself but have no objections
> to clarifying text.
> 
> I would like to understand if there are any suggested updates to the
> architecture and requirements drafts that you feel would address the concern?
> 
> Thanks,
> 
> -Nik