Subject: [Dots] Default port for DOTS signal channel

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 27 Oct 2017 08:34:49 +0000

Hi all,

The DOTS signal channel draft is currently using the default port 5684 (used by (D)TLS secured CoAP), based on the discussions in the interim WG meeting to handle scenarios where DOTS gateway and IOT gateway could be co-located and for network devices to enforce policies (e.g. QoS) for DOTS signal channel differently, DOTS signal channel needs a different port.

If there are no objections from the WG, I plan to update the draft to use a new port assigned by the IANA from the port number registry.

Further, If the WG agrees, and with the WG chairs and Area Directors help a new port number can be temporarily assigned by the IANA. The same approach was followed by DPRIVE WG for DNS-over-(D)TLS drafts to get a new port, after the drafts were adopted by the WG and implemented (see https://www.ietf.org/mail-archive/web/dns-privacy/current/msg00981.html and https://www.ietf.org/mail-archive/web/dns-privacy/current/msg00922.html).

-Tiru

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 27 Oct 2017 10:50:56 -0400

Sounds good to me.

-- Flemming

On 10/27/17 4:34 AM, Konda, Tirumaleswar Reddy wrote:
>
> Hi all,
>
> The DOTS signal channel draft is currently using the default port 5684 
> (used by (D)TLS secured CoAP), based on the discussions in the interim 
> WG meeting to handle scenarios where DOTS gateway and IOT gateway 
> could be co-located and for network devices to enforce policies (e.g. 
> QoS) for DOTS signal channel differently, DOTS signal channel needs a 
> different port.
>
> If there are no objections from the WG, I plan to update the draft to 
> use a new port assigned by the IANA from the port number registry.
>
> Further, If the WG agrees, and with the WG chairs and Area Directors 
> help a new port number can be temporarily assigned by the IANA. The 
> same approach was followed by DPRIVE WG for DNS-over-(D)TLS drafts to 
> get a new port, after the drafts were adopted by the WG and 
> implemented (see 
> https://www.ietf.org/mail-archive/web/dns-privacy/current/msg00981.html 
> and 
> https://www.ietf.org/mail-archive/web/dns-privacy/current/msg00922.html).
>
> -Tiru
>
>
>
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Mortensen, Andrew" <[email-masked]>
Date: Fri, 27 Oct 2017 17:57:58 +0000

On Oct 27, 2017, at 10:50 AM, Flemming Andreasen <[email-masked]<mailto:[email-masked]>> wrote:

Sounds good to me.

Likewise. I’m still in favor of using 4646, if we can get it.

andrew

-Tiru

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 30 Oct 2017 07:51:05 +0000

Thanks Flemming and Andrew for the feedback, will address this issue in the next revision.

-Tiru

From: Mortensen, Andrew [mailto:[email-masked]]
Sent: Friday, October 27, 2017 11:28 PM
To: Flemming Andreasen <[email-masked]>
Cc: Konda, Tirumaleswar Reddy <[email-masked]>; [email-masked]
Subject: Re: [Dots] Default port for DOTS signal channel

Sounds good to me.

andrew

-Tiru

Dots mailing list