Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-06.txt

From: [email-masked]
Date: Fri, 27 Oct 2017 00:20:46 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-06.txt
	Pages           : 58
	Date            : 2017-10-27

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.  A companion
   document defines the DOTS data channel, a separate reliable
   communication layer for DOTS management and configuration.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-06
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 27 Oct 2017 07:31:28 +0000

This revision https://tools.ietf.org/html/draft-ietf-dots-signal-channel-06 and https://tools.ietf.org/html/draft-ietf-dots-data-channel-06 addresses various comments from Jon, 
especially related to the usage of 'client-identifier'.

-Tiru

> -----Original Message-----
> From: Dots [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, October 27, 2017 12:51 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-06.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: kaname nishizuka <[email-masked]>
Date: Tue, 31 Oct 2017 15:57:44 +0900

Hi Tiru,

I've read through -06 version and noticed some things.

1. CBOR mapping notation of "alt-server", "alt-server-record", "addr", "ttl" are missing on Fig.21 and 10.2.2.

2. session-id in DELETE request has been removed from -06 version.
I'm afraid it is already mentioned. Was there a discussion on this?
I'm happy if you gave me a pointer.

thank you,
Kaname

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Tue, 31 Oct 2017 08:46:24 +0000

Thanks kaname for the review. Please see inline

> From: kaname nishizuka [mailto:[email-masked]]
> Sent: Tuesday, October 31, 2017 12:28 PM
> To: Konda, Tirumaleswar Reddy <[email-masked]>;
> [email-masked]
> Subject: Re: [Dots] I-D Action: draft-ietf-dots-signal-channel-06.txt
> 
> Hi Tiru,
> 

Fixed.

> I'm afraid it is already mentioned. Was there a discussion on this?

Yes, it was removed because DELETE would delete the current configuration and the DOTS server resets the DOTS signal channel session configuration
back to the default values. 

-Tiru

> > This revision
> > https://tools.ietf.org/html/draft-ietf-dots-signal-channel-06 and
> https://tools.ietf.org/html/draft-ietf-dots-data-channel-06 addresses various
> comments from Jon, especially related to the usage of 'client-identifier'.
> >
> > -Tiru
> >
> >>          Title           : Distributed Denial-of-Service Open Threat Signaling
> (DOTS)
> >> Signal Channel
> >> Please note that it may take a couple of minutes from the time of
> >> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >>