Subject: [Dots] signal-mitigate and alias parameters

From: "Jon Shallow" <[email-masked]>
Date: Tue, 28 Nov 2017 15:18:31 -0000

I know that this is trivial, but uri and fqdn parameters are not prefixed
with target- as in

   module: ietf-dots-signal

       +--rw mitigation-scope

          +--rw client-identifier*   binary

          +--rw scope* [mitigation-id]

             +--rw mitigation-id        int32

             +--rw target-ip*           inet:ip-address

             +--rw target-prefix*       inet:ip-prefix

             +--rw target-port-range* [lower-port upper-port]

             |  +--rw lower-port    inet:port-number

             |  +--rw upper-port    inet:port-number

             +--rw target-protocol*     uint8

             +--rw fqdn*                inet:domain-name

             +--rw uri*                 inet:uri

             +--rw alias-name*          string

             +--rw lifetime?            int32

And 

   module: ietf-dots-data-channel-identifier

       +--rw identifier

          +--rw client-identifier*   binary

          +--rw alias* [alias-name]

             +--rw alias-name           string

             +--rw target-ip*           inet:ip-address

             +--rw target-prefix*       inet:ip-prefix

             +--rw target-port-range* [lower-port upper-port]

             |  +--rw lower-port    inet:port-number

             |  +--rw upper-port    inet:port-number

             +--rw target-protocol*     uint8

             +--rw fqdn*                inet:domain-name

             +--rw uri*                 inet:uri

Does it not make sense to add in the target-  for fqdn and uri for
consistency ?

- and update the CBOR mapping!

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Wed, 29 Nov 2017 06:20:40 +0000

Yes, fixed; updated drafts are uploaded to github.

-Tiru

From: Dots [mailto:[email-masked]] On Behalf Of Jon Shallow
Sent: Tuesday, November 28, 2017 8:49 PM
To: [email-masked]
Subject: [Dots] signal-mitigate and alias parameters

I know that this is trivial, but uri and fqdn parameters are not prefixed with target- as in

   module: ietf-dots-signal
       +--rw mitigation-scope

And

Does it not make sense to add in the target-  for fqdn and uri for consistency ?
- and update the CBOR mapping!

Regards

Jon