Subject: [Dots] -08/-09 use case feedback

From: Roman Danyliw <[email-masked]>
Date: Tue, 14 Nov 2017 04:03:21 +0000

Hello!

(wearing no hat)
I like the direction that the updated text in -08/-09 has been taking in organizing the use cases to emphasize the differences and reducing (or at least acknowledging) the overlap in the use cases.  I believe we should press this editorial reorganization further.  From the existing uses cases, they appear to be "parameterized" around who asks for mitigation help, who accepts/services these mitigation requests and the interconnectivity between the two.

In broad strokes, I would propose an alternative organizational structure around these concepts.  

** Create a new Section 3.1 named "Mitigation Requestors/DOTS clients", to summarize the various clients that would request mitigation help using content from Section 3.1.1.1 (IDMS), 3.1.3.1 (integrated client), 3.1.3.3 (CPE), 3.1.3.3 (smartphone app), 3.1.2.2 (MSSP as client), and 3.2.3 (orchestrator) (irrespective of whether they are single vs. multi-homed; inter vs. intra domain; etc).
	
** Next, create a new Section 3.2 named "Mitigator/DOTS servers", to summarize the kinds of "organizations" (?) that provide mitigation for requestors using content from Sections 3.1.1/3.1.2/3.1.3 (transit provider) and 3.1.2 (MSSPs).

** Next, create a new Section 3.3 named "Topologies", to summarize how requestors/mitigators are connected using content from 3.1.1 (single homed transit), 3.1.2 (multiple homed transit), 3.1.3 (not all upstream transit offer mitigation help), and 3.1.4 (MSSP).

** Finally, create a few examples that compose the concepts introduced in these sections with great specificity.  For example, the text in Section 3.1.1 is a composition of "IDMS+single homed" and helpfully provides a lot detail that concretely explains a mitigation in action.  Section 3.1, 2, and 3 would be relatively lightweight.

When reviewing the intra-domain use cases (Section 3.2), their descriptions do not cleanly fit with the above alternate organizational structure but also aren't currently documented in the same way as the inter-domain use cases (Section 3.1).  Per the Section 3.2.1 (suppression of outbound DDOS traffic from broadband) or 3.2.2 (home network) use cases, are there new client or server types? Is there an additional topology?  Communication pattern?  Or perhaps these use cases are just more detailed examples akin the details in Section 3.1.1?

Roman

---

From: "Dobbins, Roland" <[email-masked]>
Date: Tue, 14 Nov 2017 04:24:58 +0000

On Nov 14, 2017, at 11:03, Roman Danyliw <[email-masked]<mailto:[email-masked]>> wrote:

Or perhaps these use cases are just more detailed examples akin the details in Section 3.1.1?

They're largely more detailed examples, which are important in terms of a) showing DOTS implementors how it can be used in practice; b) showing operational folks the same thing, with additional 'externalities' which nevertheless are important; & c) educating non-specialists as to why DOTS is important.

Thanks for the detailed feedback!

-----------------------------------
Roland Dobbins <[email-masked]<mailto:[email-masked]>>