Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-09.txt

From: [email-masked]
Date: Tue, 28 Nov 2017 01:08:29 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-09.txt
	Pages           : 64
	Date            : 2017-11-28

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel";

   o  "| 3.00 | Alternate server | [RFCXXXX] |"

   o  reference: RFC XXXX

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-09
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Tue, 28 Nov 2017 09:17:57 +0000

Hi all, 

We tried to reorganize the content of the draft for a better readability. We also fixed many nits and checked the consistency of the overall document. 

The only pending issue so far is how to handle conflicts among dots clients. 

Please review and share your comments. 

Cheers,
Med

> -----Message d'origine-----
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : mardi 28 novembre 2017 10:08
> À : [email-masked]
> Cc : [email-masked]
> Objet : I-D Action: draft-ietf-dots-signal-channel-09.txt
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Jon Shallow" <[email-masked]>
Date: Tue, 28 Nov 2017 10:38:43 -0000

I like the reformatting and use of mitigation instead of signal in the
appropriate places.

Nits

Table 2:
"DOTS client an withdraw" should be "DOTS client can withdraw"

Figure 12:
It would be good to add in the option If-Match in the example - i.e.
      Header: PUT (Code=0.03)
      Uri-Host: "host"
      Uri-Path: ".well-known"
      Uri-Path: "dots"
      Uri-Path: "version"
      Uri-Path: "mitigate"
      Content-Format: "application/cbor"
      If-Match:
      {
       "mitigation-scope": {

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 28 November 2017 09:18
To: [email-masked]
Subject: Re: [Dots] I-D Action: draft-ietf-dots-signal-channel-09.txt

Hi all, 

We tried to reorganize the content of the draft for a better readability. We
also fixed many nits and checked the consistency of the overall document. 

Cheers,
Med

> [email-masked] Envoyé : mardi 28 novembre 2017 10:08 À : 
> [email-masked] Cc : [email-masked] Objet : I-D Action: 
> draft-ietf-dots-signal-channel-09.txt
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_______________________________________________
Dots mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dots

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Tue, 28 Nov 2017 10:59:36 +0000

Thanks Jon, fixed both Nits (uploaded revision to github). 

-Tiru

> From: Dots [mailto:[email-masked]] On Behalf Of Jon Shallow
> Sent: Tuesday, November 28, 2017 4:09 PM
> To: [email-masked]; [email-masked]
> From: Dots [mailto: [email-masked]] On Behalf Of ietf-supjps-
> [email-masked]

---

From: Nesredien Suleiman <[email-masked]>
Date: Wed, 29 Nov 2017 08:58:27 +0000 (UTC)

Hello There,First I would like to express my appreciation to everyone who is contributing on this document. I am forwarding my minor comments as follows:   
   - Though most of the readers of the document and members of this mailing list are experts but there could be some readers who may not be that expert so I believe it would be better if some acronyms and abbreviations are written in full form on their first usage as it is done for others such as DDoS. On Page 4 on the Network diagram there is an acronym CPE
   - It would have been good if the network diagram is explained a bit.
   - On Page 4 last paragraph at third line, there is grammatical error on the phrase "Operated by an domain" I believe it should be "Operated by a domain".
   - At section 4.2 CoAP URIs, Table 1 is not sited in the document.
Best regards,Nesredien

    On Tuesday, November 28, 2017, 2:00:35 PM GMT+3, Konda, Tirumaleswar Reddy <[email-masked]> wrote:  

-Tiru

---

From: <[email-masked]>
Date: Wed, 29 Nov 2017 10:24:40 +0000

Hi Nesredien,

Thank you for the review.

Will be fixed in the next iteration of the draft : https://github.com/dotswg/dots-signal-channel/pull/9/files.

Cheers,
Med

De : Nesredien Suleiman [mailto:[email-masked]]
Envoyé : mercredi 29 novembre 2017 09:58
À : Jon Shallow; BOUCADAIR Mohamed IMT/OLN; [email-masked]; Konda, Tirumaleswar Reddy
Objet : Re: [Dots] I-D Action: draft-ietf-dots-signal-channel-09.txt

Hello There,
First I would like to express my appreciation to everyone who is contributing on this document. I am forwarding my minor comments as follows:

  *   Though most of the readers of the document and members of this mailing list are experts but there could be some readers who may not be that expert so I believe it would be better if some acronyms and abbreviations are written in full form on their first usage as it is done for others such as DDoS. On Page 4 on the Network diagram there is an acronym CPE
  *   It would have been good if the network diagram is explained a bit.
  *   On Page 4 last paragraph at third line, there is grammatical error on the phrase "Operated by an domain" I believe it should be "Operated by a domain".
  *   At section 4.2 CoAP URIs, Table 1 is not sited in the document.
Best regards,
Nesredien

On Tuesday, November 28, 2017, 2:00:35 PM GMT+3, Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>> wrote:

-Tiru

> From: Dots [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jon Shallow
> To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of ietf-supjps-
> [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> > De : I-D-Announce [mailto:[email-masked]<mailto:[email-masked]>] De la part de
> > [email-masked]<mailto:[email-masked]> Envoyé : mardi 28 novembre 2017 10:08 À :
> > [email-masked]<mailto:[email-masked]> Cc : [email-masked]<mailto:[email-masked]> Objet : I-D Action:
> > [email-masked]<mailto:[email-masked]>
> > Internet-Draft directories: http://www.ietf.org/shadow.html <http://www.ietf.org/shadow.html%20> or
> [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots