Subject: [Dots] DOTS requirement draft questions and comments

From: "dongyue (D)" <[email-masked]>
Date: Mon, 4 Dec 2017 05:40:54 +0000

Here are a few questions/comments on the dots-requirement-07:

*         SIG-003: It says 'Peer DOTS agents SHOULD regularly send heartbeats to each other while a mitigation request is active'. But I think the heartbeats should be send once the DOTS session has been established, no matter if a request is active or not.

*         SIG-003: it mentioned in the second paragraph that ' a DOTS server might want to delay or cease heartbeat exchanges when an active DOTS client has not requested mitigation, in order to control load'. Firstly, 'delay' is a kind of time shift, it will not reduce the load, I recommend to replace 'delay' with 'reduce the heartbeat frequency' or 'increase the heartbeat interval'. Secondly, I am not clear why DOTS server want to cease heartbeat? In this case, if the heartbeat has been ceased, the mitigation will be automatically triggered!

*         SEC-004: In the first paragraph, the status is not a message from DOTS client, I recommend it to be 'status request'

Kind Regards,
Yue

---

From: "Mortensen, Andrew" <[email-masked]>
Date: Tue, 5 Dec 2017 16:05:39 +0000

Thanks for your comments. See my responses inline.

andrew

On Dec 4, 2017, at 12:40 AM, dongyue (D) <[email-masked]<mailto:[email-masked]>> wrote:

•         SIG-003: It says ‘Peer DOTS agents SHOULD regularly send heartbeats to each other while a mitigation request is active’. But I think the heartbeats should be send once the DOTS session has been established, no matter if a request is active or not.

The current form of this requirement is the outcome of discussions following IETF 99, in which it became apparent that a zero heartbeat mode was desirable. Please see:

<https://datatracker.ietf.org/meeting/99/materials/slides-99-dots-dots-hackathon-report/>

Specifically, the slide titled “Lessons learned (3/3)”: “Zero heartbeat mode should be allowed”.

•         SIG-003: it mentioned in the second paragraph that ‘ a DOTS server might want to delay or cease heartbeat exchanges when an active DOTS client has not requested mitigation, in order to control load’. Firstly, ‘delay’ is a kind of time shift, it will not reduce the load, I recommend to replace ‘delay’ with ‘reduce the heartbeat frequency’ or ‘increase the heartbeat interval’.

We can replace the “delay” term.

Secondly, I am not clear why DOTS server want to cease heartbeat? In this case, if the heartbeat has been ceased, the mitigation will be automatically triggered!

Triggering mitigation on loss of heartbeat is one possible mode of deployment. It is not the only mechanism for requesting mitigation. At least as described in the DOTS architecture, it's also based on the loss of heartbeat from the client, not the server.

•         SEC-004: In the first paragraph, the status is not a message from DOTS client, I recommend it to be ‘status request’

I don’t think that change improves the clarity of that paragraph. Compare the current form:

“DOTS servers MUST authorize all messages from DOTS clients which pertain to…status.”

with the change you’re proposing:

“DOTS servers MUST authorize all messages from DOTS clients which pertain to…status requests.”

To me, the change has the effect of requiring authorization of all messages *about* status requests, as opposed to messages about status.

---

From: "dongyue (D)" <[email-masked]>
Date: Wed, 6 Dec 2017 00:38:10 +0000

Thanks for your reply!

Kind Regards,
Yue

发件人: Mortensen, Andrew [mailto:[email-masked]]
发送时间: 2017年12月6日 0:06
收件人: dongyue (D) <[email-masked]>
抄送: dots <[email-masked]>
主题: Re: [Dots] DOTS requirement draft questions and comments

andrew