Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-13.txt

From: [email-masked]
Date: Thu, 14 Dec 2017 07:08:39 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-13.txt
	Pages           : 77
	Date            : 2017-12-14

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration
   purposes.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel";

   o  "| 3.00 | Alternate server | [RFCXXXX] |"

   o  reference: RFC XXXX

   o  This RFC

   Please update TBD statements with the port number to be assigned to
   DOTS Signal Channel Protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-13
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Thu, 14 Dec 2017 15:21:25 +0000

Hi all, 

A new version is out!

The main changes are as follows:
- Integrate the detailed comments from Christian. Many thanks to him!
- Double check the normative language.
- Add NEW text to discuss considerations related to the presence of translators
- Remove target-ip because it is redundant with target-prefix
- Update the text to indicate the required behavior for inserting/removing client-identifier by gateways
- Update the text to clearly specify the error codes to be returned
- Add a new parameter called "config-interval" to force a dots client to retrieve new config from the server. This is particularly useful for a DOTS server that want to instruct a client to reduce the frequency of heartbeat or even to cease them.
- heartbeat-interval can now be set to '0'
- Update the YANG module
- Add a pointer to the mechanisms required to prevent replay attack when TLS1.3 0-RTT is in use.

As usual, feel free to review and share comments.

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : jeudi 14 décembre 2017 16:09
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-signal-channel-13.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: <[email-masked]>
Date: Fri, 15 Dec 2017 07:14:31 +0000

Hi all, 

There is an error in -13 about CBOR major key for acl-name. The required change to fix it is as follows:

OLD:
   | Parameter name       | CBOR key       | CBOR major type of value |
   +----------------------+----------------+--------------------------+
   | acl-name             | 42             | 2                        |

NEW:
   | Parameter name       | CBOR key       | CBOR major type of value |
   +----------------------+----------------+--------------------------+
   | acl-name             | 42             | 3                        |

Cheers,
Med

> De : Dots [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : jeudi 14 décembre 2017 16:21
> À : [email-masked]
> Cc : JACQUENET Christian IMT/OLN
> Objet : [Dots] TR: I-D Action: draft-ietf-dots-signal-channel-13.txt
> 
> Hi all,
> 
> A new version is out!
> 
> - Add a new parameter called "config-interval" to force a dots client to
> retrieve new config from the server. This is particularly useful for a
> DOTS server that want to instruct a client to reduce the frequency of
> heartbeat or even to cease them.

---

From: "Jon Shallow" <[email-masked]>
Date: Mon, 18 Dec 2017 15:04:45 -0000

Hi Med,

I am struggling to get my mind around 'config-interval' and the practical
use of it as it adds in delays to changing heartbeat values.

Please see my comments in the discussion "[Dots] Signal Channel Heartbeats"
I have just started.

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 15 December 2017 07:15
To: [email-masked]
Cc: JACQUENET Christian IMT/OLN
Subject: Re: [Dots] TR: I-D Action: draft-ietf-dots-signal-channel-13.txt

Hi all, 

There is an error in -13 about CBOR major key for acl-name. The required
change to fix it is as follows:

OLD:

NEW:

Cheers,
Med

> [email-masked] Envoyé : jeudi 14 décembre 2017 16:21 À : 
> [email-masked] Cc : JACQUENET Christian IMT/OLN Objet : [Dots] TR: I-D 
> Action: draft-ietf-dots-signal-channel-13.txt
> 
> Hi all,
> 
> A new version is out!
> 
> - Update the text to indicate the required behavior for 
> inserting/removing client-identifier by gateways
> - Add a new parameter called "config-interval" to force a dots client 
> to retrieve new config from the server. This is particularly useful 
> for a DOTS server that want to instruct a client to reduce the 
> frequency of heartbeat or even to cease them.
> - Add a pointer to the mechanisms required to prevent replay attack 
> when
> TLS1.3 0-RTT is in use.
> 
> > [email-masked] Envoyé : jeudi 14 décembre 2017 16:09 À : 
> > [email-masked] Cc : [email-masked] Objet : [Dots] I-D Action: 
> > draft-ietf-dots-signal-channel-13.txt
> >
> >
> > Please note that it may take a couple of minutes from the time of 
> > submission until the htmlized version and diff are available at 
> > tools.ietf.org.
> >