Subject: [Dots] DOTS gateway loop handling

From: "Jon Shallow" <[email-masked]>
Date: Fri, 22 Dec 2017 09:22:36 -0000

Hi WG,

While there never should be a loop in DOTS traffic going via DOTS gateways,
if there is a mis-configuration a request can end up getting bounced between
a set of (not necessarily adjacent) DOTS gateways.

We need to make sure that this loop is broken - possibly by using a
mechanism similar to TTL in IP packets.

If we agree that loops need to get broken, this "feature" needs to get added
into both the signal and data channels.

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 22 Dec 2017 10:24:03 +0000

Good point, both drafts can use a mechanism similar to the one discussed in https://tools.ietf.org/html/rfc7332#section-5 (Max-forwards header).

-Tiru

From: Dots [mailto:[email-masked]] On Behalf Of Jon Shallow
Sent: Friday, December 22, 2017 2:53 PM
To: [email-masked]
Subject: [Dots] DOTS gateway loop handling

Hi WG,

While there never should be a loop in DOTS traffic going via DOTS gateways, if there is a mis-configuration a request can end up getting bounced between a set of (not necessarily adjacent) DOTS gateways.

We need to make sure that this loop is broken - possibly by using a mechanism similar to TTL in IP packets.

If we agree that loops need to get broken, this "feature" needs to get added into both the signal and data channels.

Regards

Jon

---

From: "Jon Shallow" <[email-masked]>
Date: Fri, 22 Dec 2017 10:30:20 -0000

Hi Tiru,

I'm not sure that we can necessarily support this as a Header, but certainly
as a parameter in the CBOR / JSON

I think the most likely scenario for this loop to happen is if DNS is not
working as expected.

Regards

Jon

From: Dots [mailto: [email-masked]] On Behalf Of Konda, Tirumaleswar
Reddy
Sent: 22 December 2017 10:24
To: Jon Shallow; [email-masked]
Subject: Re: [Dots] DOTS gateway loop handling

Good point, both drafts can use a mechanism similar to the one discussed in
https://tools.ietf.org/html/rfc7332#section-5 (Max-forwards header).

-Tiru

Hi WG,

Regards

Jon

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 22 Dec 2017 10:32:20 +0000

Yes, I meant as CBOR and JSON parameters.

-Tiru

From: Jon Shallow [mailto:[email-masked]]
Sent: Friday, December 22, 2017 4:00 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>; [email-masked]
Subject: RE: [Dots] DOTS gateway loop handling

Hi Tiru,

I'm not sure that we can necessarily support this as a Header, but certainly as a parameter in the CBOR / JSON

I think the most likely scenario for this loop to happen is if DNS is not working as expected.

Regards

Jon

From: Dots [mailto: [email-masked]<mailto:[email-masked]>] On Behalf Of Konda, Tirumaleswar Reddy
Sent: 22 December 2017 10:24
To: Jon Shallow; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dots] DOTS gateway loop handling

-Tiru

From: Dots [mailto:[email-masked]] On Behalf Of Jon Shallow
Sent: Friday, December 22, 2017 2:53 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Dots] DOTS gateway loop handling

Hi WG,

Regards

Jon