Subject: [Dots] I-D Action: draft-ietf-dots-data-channel-10.txt

From: [email-masked]
Date: Fri, 08 Dec 2017 07:58:16 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Data Channel
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Kaname Nishizuka
                          Liang Xia
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-data-channel-10.txt
	Pages           : 30
	Date            : 2017-12-08

Abstract:
   The document specifies a Distributed Denial-of-Service Open Threat
   Signaling (DOTS) data channel used for bulk exchange of data not
   easily or appropriately communicated through the DOTS signal channel
   under attack conditions.

   This is a companion document to the DOTS signal channel
   specification.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Data Channel";

   o  reference: RFC XXXX

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-data-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-data-channel-10
https://datatracker.ietf.org/doc/html/draft-ietf-dots-data-channel-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-data-channel-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Fri, 8 Dec 2017 16:02:34 +0000

Hi all, 

The main change in this new version is to merge the two yang modules into one single modules. Some nits and text reorganization were also implemented. 

Please review and share your comments. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : vendredi 8 décembre 2017 16:58
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-data-channel-10.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: Nesredien Suleiman <[email-masked]>
Date: Sat, 9 Dec 2017 11:50:14 +0000 (UTC)

Hello Med,I read the document and I found some of these
·        Page , Last Paragraph - thephrase "The server can respond to this request with either with a successor failure response " would be better if it is written as "The servercan respond to this request with either a success or failure response".

·        Page 7, Section 5.2, on thelast bullet - does "dropping or rate- limiting unwanted traffic"include black-listed traffics if so, how will the black-listed traffics be rate-limited?

·        Section 6.1, I don't knowif I missed something from previous versions but I just wanted to know thereason why the "Client-identifier" taken as optional attribute whereas the "alias-name" attribute a compulsory attribute.
Peace to all,Nesredien
    On Friday, December 8, 2017, 7:02:42 PM GMT+3, <[email-masked]> wrote:  
 
 Hi all, 

Cheers,
Med

---

From: <[email-masked]>
Date: Mon, 11 Dec 2017 06:45:29 +0000

Hi Nesredien,

Thank you for the review.

Please see inline.

Cheers,
Med

De : Nesredien Suleiman [mailto:[email-masked]]
Envoyé : samedi 9 décembre 2017 12:50
À : [email-masked]; BOUCADAIR Mohamed IMT/OLN
Objet : Re: [Dots] I-D Action: draft-ietf-dots-data-channel-10.txt

Hello Med,
I read the document and I found some of these

•         Page , Last Paragraph - the phrase "The server can respond to this request with either with a success or failure response " would be better if it is written as "The server can respond to this request with either a success or failure response".

[Med] Fixed.

•         Page 7, Section 5.2, on the last bullet - does "dropping or rate- limiting unwanted traffic" include black-listed traffics if so, how will the black-listed traffics be rate-limited?

[Med] ACLs can be used to instruct the server to blacklist some traffic that match some conditions. Also, ACLs can be used to rate-limt some traffic. How those policies are encored at the server’s side is implementation/deployment specific. For example,

-    a dots data channel message can trigger BGP messages with flow spec NLRIs to be advertised in the upstream domain.

-    a dots data channel message can trigger NETCONF messages to enforce policies on the appropriate network devices.

•         Section 6.1, I don't know if I missed something from previous versions but I just wanted to know the reason why the "Client-identifier" taken as optional attribute where as the "alias-name" attribute a compulsory attribute.

[Med] client-identifier is optional because a dots client does not need to convey an extra identifier in its messages destined to an upstream dots server because identification takes place during authentication. Likewise, a client-side gateway (that is, a dots gateway located in the client’s domain) must not leak information about internal dots clients (for privacy reasons). The only case where client-identifier is needed, is where a server-side gateway is located on-path. In such case, a server-side gateway inserts it to help the server select the appropriate policy to be enforced for the client.
Peace to all,
Nesredien

On Friday, December 8, 2017, 7:02:42 PM GMT+3, <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Cheers,
Med

> De : Dots [mailto:[email-masked]<mailto:[email-masked]>] De la part de internet-
> [email-masked]<mailto:[email-masked]>
> À : [email-masked]<mailto:[email-masked]>
> Cc : [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Dots mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dots