Subject: [Dots] I-D Action: draft-ietf-dots-signal-channel-11.txt

From: [email-masked]
Date: Wed, 06 Dec 2017 04:30:52 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the DDoS Open Threat Signaling WG of the IETF.

        Title           : Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel
        Authors         : Tirumaleswar Reddy
                          Mohamed Boucadair
                          Prashanth Patil
                          Andrew Mortensen
                          Nik Teague
	Filename        : draft-ietf-dots-signal-channel-11.txt
	Pages           : 74
	Date            : 2017-12-06

Abstract:
   This document specifies the DOTS signal channel, a protocol for
   signaling the need for protection against Distributed Denial-of-
   Service (DDoS) attacks to a server capable of enabling network
   traffic mitigation on behalf of the requesting client.

   A companion document defines the DOTS data channel, a separate
   reliable communication layer for DOTS management and configuration.

Editorial Note (To be removed by RFC Editor)

   Please update these statements with the RFC number to be assigned to
   this document:

   o  "This version of this YANG module is part of RFC XXXX;"

   o  "RFC XXXX: Distributed Denial-of-Service Open Threat Signaling
      (DOTS) Signal Channel";

   o  "| 3.00 | Alternate server | [RFCXXXX] |"

   o  reference: RFC XXXX

   o  This RFC

   Please update TBD statements with the port number to be assigned to
   DOTS Signal Channel Protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dots-signal-channel/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dots-signal-channel-11
https://datatracker.ietf.org/doc/html/draft-ietf-dots-signal-channel-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dots-signal-channel-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 6 Dec 2017 12:39:28 +0000

Hi all, 

The changes in the new version are as follows: 
- add conflict-scope
- clarify the usage of retry-timer
- merge the two YANG modules in a single one
- clarify the behavior when a request is received with a lifetime set to 0
- clarify that multiple mitigations are not allowed in a single PUT
- As for assigning 4646 as a strongly recommended port number
- some text reordering, edits, and fixing nits

We don't have any pending issue in our list. 

Please review and comment. 

Cheers,
Med

> -----Message d'origine-----
> De : Dots [mailto:[email-masked]] De la part de internet-
> [email-masked]
> Envoyé : mercredi 6 décembre 2017 13:31
> À : [email-masked]
> Cc : [email-masked]
> Objet : [Dots] I-D Action: draft-ietf-dots-signal-channel-11.txt
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots

---

From: "Jon Shallow" <[email-masked]>
Date: Wed, 6 Dec 2017 17:50:53 -0000

Hi Med,

Some minor things on a quick scan through.

4.5.2 ack_timeout needs correcting to ack-timeout

5.2 - exchanegd needs correcting to exchanged

7.1 additionaly needs correcting to additionally

9.4 structrue needs correcting to structure

9.4.1 target_ip needs correcting to target-ip for consistency

9.4.2 There is inconsistence in the naming format of the Parameter Name:
with ", not ", with space, not space (and should we be using upper-case in
parameters such as MinValue?)

conflict-scope is not in the CBOR Mappings in Table 4.  Can I ask that it be
put at the end of the table, so not messing up interoperability between DOTS
Clients/Servers based on different draft versions?

Regards

Jon

-----Original Message-----
From: Dots [mailto: [email-masked]] On Behalf Of
[email-masked]
Sent: 06 December 2017 12:39
To: [email-masked]
Subject: Re: [Dots] I-D Action: draft-ietf-dots-signal-channel-11.txt

Hi all, 

Cheers,
Med

> [email-masked] Envoyé : mercredi 6 décembre 2017 13:31 À : 
> [email-masked] Cc : [email-masked] Objet : [Dots] I-D Action: 
> draft-ietf-dots-signal-channel-11.txt
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
>

---

From: <[email-masked]>
Date: Thu, 7 Dec 2017 08:54:25 +0000

Hi Jon, 

Thank you for reviewing. 

Please see inline. 

Cheers,
Med

> De : Jon Shallow [mailto:[email-masked]]
> Envoyé : mercredi 6 décembre 2017 18:51
> À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
> Objet : RE: [Dots] I-D Action: draft-ietf-dots-signal-channel-11.txt
> 
> Hi Med,
> 

[Med] All fixed. 

> parameters such as MinValue?)

[Med] Agree. Fixed.

> Clients/Servers based on different draft versions?

[Med] Happily. A new version with these fixes will be online soon.