Subject: [drinks] Quick comments on draft-ietf-drinks-usecases-requirements-00

From: David Schwartz <[email-masked]>
Date: Mon, 27 Jul 2009 14:17:47 +0300

Sorry for the late comments on this - only had time to read this now :(

Page 7: RN is not defined in definitions section (although I know what it is :))
Page 7: Does routing group cover service types as well? 
Page 8: A TN is associated with one or more DGs? isn't it the other way around? multiple TNs may be associated with a DG. Otherwise how can you find a DG from a TN?
Page 9: Can't RN reside on the other side of the DG as well? I mean can't RN be part of SED as well?
Page 10: UC2 (upload instead of download)
Page 10: UC3 NRT should only override live (not future)
Page 11: UC4 How is this different than just specifying data-recipient-group of "self"
Page 11: UC6 why delete and not inactive? "inactive" gives you insight to who 'used" to own the number
Page 12:  UC12 need to discuss splitting up of ranges (e.g. due to NP for example)
Page 13:  UC15a similar but in reverse - I want to request your data, if you approve - need to add me to data recipient group
Page 14: UC16 need to combine the two sources of data (e.g. get an extension Route Header)
Page 14: missing UC for SSP stepping on number space of other SSP
Page 14: Why is the TN and RN data requirements only a SHOULD?
Page 14: Missing the requirement for grouping of destinations within a data recipient group
Page 15: FREQ2 I find the R.T and N.R.T a misnomer. It should really be individual vs bulk. The time aspect applies to both (e.g. you can defer a bulk registration as well)
Page 15: General comment - FREQ3 should be broken out to multiple REQs.
Page 15: FREQ3 are you reassigning "groupings" of PIs? if not, what do you mean by "one or more"?
Page 15: FREQ3 association and disassociation of a "Default Routing Group" with a Data Recipient - don't you mean Data Recipient Group?
Page 15: FREQ3 How is primary provider vs transit indicated? what is the mechanism for authentication of this? This is a good requirement but imho needs much flushing out
Page 15: FREQ7 which UC is this referencing? What is the difference between the sub-identities? different ingress/egress IPs? please explain
Page 16: FREQ9 is there a NXDOMAIN type option as well? it seems from here that I must return an answer
Page 16: FREQ11 should be split into two or three REQs
Page 16: FREQ11 How is the data object owner determined? You spoke before of transit providers vs CoRs so I assume that you assign a data object owner only to CoR - how than does transit provider provision?

D.

---

From: "Cartwright, Kenneth" <[email-masked]>
Date: Mon, 27 Jul 2009 09:35:34 -0400

Needless to say, these are all good comments and it is good to see some traffic on the mailling list.  We'll work to discuss these and update the documents after IETF meetings allow.

Ken

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of David Schwartz [[email-masked]]
Sent: Monday, July 27, 2009 7:17 AM
To: [email-masked]
Subject: [drinks] Quick comments on     draft-ietf-drinks-usecases-requirements-00

D.
_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.