Subject: [drinks] The needs for some protocols in the drinks charter

From: "Jean-Francois Mule" <[email-masked]>
Date: Thu, 17 Dec 2009 11:12:08 -0700

This is my view of why there is a need for protocols that some entities
can use to provision data into registries that are deployed and in use
today for billions of transactions in SMS-MMS, VoIP and other
applications.

In DRINKS, I thought we had a consensus on the way to view the use
cases:
	a) operator to registry provisioning
	b) registry to downstream caching servers used for LUF
resolution (sometimes called ENUM servers), with optionally LRF
resolution for the sub-set of folks that think this is important
	c) registry to registry exchanges

One view of the world says: we don't need all this, let's use DNS and
zone file transfers, we will be done.  This certainly works in some
contexts.
Another view based on real deployments and running code says: there are
many entities that rely on those registries for real-time communications
over IP today in wireless, wireline, enterprises.  In both Dublin and
Stockholm, we had folks from several registry companies and "resolution
server" companies express support and views inline with this.

Then we described use cases and requirements, got some requirements on
the data modeling and the protocol options.
We have several examples of registry communications based a) b) and c),
sometimes across registries.

Ok, work did not happen between August and November. But does that mean
we are ready to say: nobody needs this work done?

Jean-Francois.

---

From: "Guyton, Deborah A" <[email-masked]>
Date: Thu, 17 Dec 2009 14:46:44 -0500

I'd like to express support to continue the work on defining some standards for provisioning registries and then interfaces for distribution of the information to address servers to support IP calls and other services.

A  number of us have been working on this for over a year through contributions, the requirements design team, and then the protocol design team. I understand that there are potentially a number of different architectures out there and not all carriers are moving ahead as fast as anticipated due to other higher priority items.  However, we began this work as initial implementations are happening and being planned and we are anticipating the need that will exist soon.

I believe a lot of good work has been done. There is always room for additional contributions and adjustments to move us toward some standards we could begin with.  Perhaps with initial implementations, these may need to be revisited, or updated. But I believe there are a few basis concepts we can agree on and define some initial standards.

I think we hit a bump in the road when so  many of us could not attend the meeting in Hiroshima.  Perhaps it will be easier to get to Anaheim.  Maybe we should have a virtual meeting, agree on updated milestones, decide on some basics on direction, and get the work moving again.
My thoughts,
Debbie Guyton

---

From: "Maharishi, Manjul" <[email-masked]>
Date: Fri, 18 Dec 2009 13:42:22 -0500

I echo these remarks, and Debbie's comments from yesterday.

I also would like to express support for continuing this effort, and we are already having several scenarios and use cases which would benefit from standardized interface across the industry.

We had made some good progress, and it will be a pity if that was just left to rot/die. Agreed that there were some conflicting views, but that is understandable.

Manjul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Mule
Sent: Thursday, December 17, 2009 1:12 PM
To: IETF DRINKS WG
Subject: [drinks] The needs for some protocols in the drinks charter

This is my view of why there is a need for protocols that some entities can use to provision data into registries that are deployed and in use today for billions of transactions in SMS-MMS, VoIP and other applications.

In DRINKS, I thought we had a consensus on the way to view the use
cases:
        a) operator to registry provisioning
        b) registry to downstream caching servers used for LUF resolution (sometimes called ENUM servers), with optionally LRF resolution for the sub-set of folks that think this is important
        c) registry to registry exchanges

One view of the world says: we don't need all this, let's use DNS and zone file transfers, we will be done.  This certainly works in some contexts.
Another view based on real deployments and running code says: there are many entities that rely on those registries for real-time communications over IP today in wireless, wireline, enterprises.  In both Dublin and Stockholm, we had folks from several registry companies and "resolution server" companies express support and views inline with this.

Then we described use cases and requirements, got some requirements on the data modeling and the protocol options.
We have several examples of registry communications based a) b) and c), sometimes across registries.

Ok, work did not happen between August and November. But does that mean we are ready to say: nobody needs this work done?

Jean-Francois.

_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 18 Dec 2009 16:49:52 -0500

So what is the plan to progress the work? 

What milestones are people willing to agree to? What documents and when? 

The fact that we did not meet in Hiroshima is irrelevant. All work in the
IETF is ultimately done on the list meetings are "opportunities" to resolve
issues.

>  From: [email-masked] [mailto:[email-masked]] On
>  Behalf Of Maharishi, Manjul
>  Sent: Friday, December 18, 2009 1:42 PM
>  To: Jean-Francois Mule; IETF DRINKS WG
>  Subject: Re: [drinks] The needs for some protocols in the drinks
>  charter
>  
>  I also would like to express support for continuing this effort, and
>  we are already having several scenarios and use cases which would
>  benefit from standardized interface across the industry.
>  
>  We had made some good progress, and it will be a pity if that was just
>  left to rot/die. Agreed that there were some conflicting views, but
>  that is understandable.
>  
>  
>  Manjul
>  
>  
>  This is my view of why there is a need for protocols that some
>  entities can use to provision data into registries that are deployed
>  and in use today for billions of transactions in SMS-MMS, VoIP and
>  other applications.
>  
>  Another view based on real deployments and running code says: there
>  are many entities that rely on those registries for real-time
>  communications over IP today in wireless, wireline, enterprises.  In
>  both Dublin and Stockholm, we had folks from several registry
>  companies and "resolution server" companies express support and views
>  inline with this.
>  
>  Ok, work did not happen between August and November. But does that
>  mean we are ready to say: nobody needs this work done?
>  
>  Jean-Francois.
>  
>  are not the intended recipient, please contact the sender by reply e-
>  mail and destroy all copies of the original message.
>

---

From: "Cartwright, Kenneth" <[email-masked]>
Date: Fri, 18 Dec 2009 17:10:06 -0500

Right, the industry continues to progress forward, with more and more examples of inter-registry/inter-organization/inter-dataSource data exchanges, each of which having its own protocol, and its own scheme for identifying the addresses responsible/owning organization and/or the AOR (LUF), and its own scheme for identifying the route(s) to reach that responsible organization or AOR (LRF), etc.  This results in (and has resulted in) a series of one-off integrations being required between all of these registries/organizations/dataSources.  So standardization in this area is needed.

Sorry for the lack of progress over the past few months, but other priorities have temporarily won out.

Ken

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Maharishi, Manjul
Sent: Friday, December 18, 2009 1:42 PM
To: Jean-Francois Mule; IETF DRINKS WG
Subject: Re: [drinks] The needs for some protocols in the drinks charter

Manjul

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jean-Francois Mule
Sent: Thursday, December 17, 2009 1:12 PM
To: IETF DRINKS WG
Subject: [drinks] The needs for some protocols in the drinks charter

Jean-Francois.