Subject: [drinks] Questions/Corrections SPPP

From: "Mickael MARRACHE, Samuel MELLOUL" <[email-masked]>
Date: Tue, 8 Mar 2011 17:05:35 +0200

Hey,

Some questions and text corrections:

   1- What is the purpose of the AddDestGrp request, in the case that the
specified destination group already exists? If the destination group already
exists, there is only a possibility for the client to change the registrar.
Is it the purpose? (page 26)

   2- How to know that a querying registrar has the authority to view a
particular destination group? (page 27) By comparing it to the destination
group’s registrant?

   3- What is the purpose of the GetDestGrp request, in the case that the
specified ObjKeyType objects list is not empty? The querying organization
specifies the ObjKeyType objects corresponding to destination groups, so the
querying organization knows the registrant and name of each queried
destination groups. Does the querying organization need to know the
registrar, creation date and modification date of each destination group?
Or, maybe, a querying organization wants to know if it has the authority to
view a particular destination group ? (page 27)

   4- (p. 31) What does the default value ‘true’ for the “rn” element of
RNType mean? (It is not defined in the draft)

*Text Corrections :*

*
*

(p.26) AddDestGrpRqsttype -> AddDestGrpRqstType

 (p.27) getDestGrpsRqst -> GetDestGrpsRqst

 (p.28) PubIDType -> PubIdType (three times), rantId -> rant (twice), Public
Identity -> Public Identifier (three times)

(p.29) PubIDType -> PubIdType, rantId -> rant

 (p.30) PubIDType -> PubIdType, rantId -> rant

 (p.31) rantId -> rant

 (p.32) rantId -> rant

---

From: "Cartwright, Ken" <[email-masked]>
Date: Tue, 8 Mar 2011 10:29:37 -0500

Hello,

1)       The Dest Goup object is a very simple one.  There is currently no use-case that would necessitate modifying a Dest Group object itself.  Given that the identity/uniqueKey of a Dest Group is the combination of its "name" and its rarId, neither of those elements can be changed.  Changing either of those would mean that you are instead creating a different one.
2)       Please refer to the Security Considerations section of the most recent version of the document that lists the Authorization policies that each SPPP implementation must define.
3)       If the client passes in one or more Dest Group object keys to the GetDestGroups operation then the server should return the DestGroup objects that correspond to this object keys.  And because the Dest Group object is simple, the only additional attributes that are in a DestGroup object, that are not in its key, are its created date, last modified date, and rarId.
4)       Good question.  I do not know.  I believe that that default value should probably not be there.  Syed?

Ken

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mickael MARRACHE, Samuel MELLOUL
Sent: Tuesday, March 08, 2011 10:06 AM
To: [email-masked]
Subject: [drinks] Questions/Corrections SPPP

Hey,

   1- What is the purpose of the AddDestGrp request, in the case that the specified destination group already exists? If the destination group already exists, there is only a possibility for the client to change the registrar. Is it the purpose? (page 26)

   2- How to know that a querying registrar has the authority to view a particular destination group? (page 27) By comparing it to the destination group's registrant?

   3- What is the purpose of the GetDestGrp request, in the case that the specified ObjKeyType objects list is not empty? The querying organization specifies the ObjKeyType objects corresponding to destination groups, so the querying organization knows the registrant and name of each queried destination groups. Does the querying organization need to know the registrar, creation date and modification date of each destination group? Or, maybe, a querying organization wants to know if it has the authority to view a particular destination group ? (page 27)

   4- (p. 31) What does the default value 'true' for the "rn" element of RNType mean? (It is not defined in the draft)

Text Corrections :

(p.28) PubIDType -> PubIdType (three times), rantId -> rant (twice), Public Identity -> Public Identifier (three times)

(p.31) rantId -> rant

(p.32) rantId -> rant

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

---

From: "Ali, Syed Wasim" <[email-masked]>
Date: Tue, 8 Mar 2011 11:30:35 -0500

4- (p. 31) What does the default value ‘true’ for the “rn” element of RNType mean? (It is not defined in the draft)

[Syed] This is perhaps a typo from the past changes. Given that the data type is string, the default value is clearly out of place. We shall fix it for the next draft release.

Thanks for pointing this out.

-Syed

From: "Cartwright, Ken" <[email-masked]<mailto:[email-masked]>>
Date: Tue, 8 Mar 2011 10:29:37 -0500
To: "Mickael MARRACHE, Samuel MELLOUL" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [drinks] Questions/Corrections SPPP

Hello,

1)       The Dest Goup object is a very simple one.  There is currently no use-case that would necessitate modifying a Dest Group object itself.  Given that the identity/uniqueKey of a Dest Group is the combination of its “name” and its rarId, neither of those elements can be changed.  Changing either of those would mean that you are instead creating a different one.
2)       Please refer to the Security Considerations section of the most recent version of the document that lists the Authorization policies that each SPPP implementation must define.
3)       If the client passes in one or more Dest Group object keys to the GetDestGroups operation then the server should return the DestGroup objects that correspond to this object keys.  And because the Dest Group object is simple, the only additional attributes that are in a DestGroup object, that are not in its key, are its created date, last modified date, and rarId.
4)       Good question.  I do not know.  I believe that that default value should probably not be there.  Syed?

Ken

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Mickael MARRACHE, Samuel MELLOUL
Sent: Tuesday, March 08, 2011 10:06 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [drinks] Questions/Corrections SPPP

Hey,

   2- How to know that a querying registrar has the authority to view a particular destination group? (page 27) By comparing it to the destination group’s registrant?

   4- (p. 31) What does the default value ‘true’ for the “rn” element of RNType mean? (It is not defined in the draft)

Text Corrections :

(p.31) rantId -> rant

(p.32) rantId -> rant

---

From: "Cartwright, Ken" <[email-masked]>
Date: Tue, 8 Mar 2011 13:29:21 -0500

Sorry, I have a typo below.  "is the combination of its "name" and its rarId" should instead say "is the combination of its "name" and its rantId"

Ken

________________________________
From: Cartwright, Ken
Sent: Tuesday, March 08, 2011 10:30 AM
To: 'Mickael MARRACHE, Samuel MELLOUL'; [email-masked]
Subject: RE: [drinks] Questions/Corrections SPPP

Hello,

Ken

Hey,

Text Corrections :

(p.31) rantId -> rant

(p.32) rantId -> rant