Subject: [drinks] Questions SPPP

From: Mickael MARRACHE <[email-masked]>
Date: Thu, 5 May 2011 22:25:18 +0300

Hey,

1) Can a telephone number be associated directly to route records and
associated to a destination group too? If no, I think it's better to precise
it.

2) Which attributes a client can change using an update request on a
telephone number object? Can he change the rant, the dgName and the
telephone number (primary key attributes)? If there are some attributes that
can't be changed, I think it's better to precise it too.

Thanks

---

From: "Cartwright, Ken" <[email-masked]>
Date: Thu, 5 May 2011 16:08:08 -0400

Hello,

1)       The protocol allows it.
2)       Changing an object's _identity_ (i.e. the attributes of an object that uniquely identify it) does not really make sense within the context of SPPP.  So the protocol does not have the data structres to support that.  So for each object type it is not possible to use SPPP to change the properties of an object that _identify_ it.  For example there is no protocol construct that enables changing the "tn" attribute of a TNType, because the "tn" attribute is used (along with the dgName and rantId) to identify the specific TNType object instance.  So no need to state that fact.

Ken
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mickael MARRACHE
Sent: Thursday, May 05, 2011 3:25 PM
To: [email-masked]
Subject: [drinks] Questions SPPP

Hey,

1) Can a telephone number be associated directly to route records and associated to a destination group too? If no, I think it's better to precise it.

2) Which attributes a client can change using an update request on a telephone number object? Can he change the rant, the dgName and the telephone number (primary key attributes)? If there are some attributes that can't be changed, I think it's better to precise it too.

Thanks

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.