Subject: [drinks] Questions SPPP

From: Mickael MARRACHE <[email-masked]>
Date: Wed, 4 May 2011 16:35:35 +0300

Hey,

Some questions/suggestions:

1) Implementation difficulties due to multiple use of 'ext' element with
inheritance (for example BasicObjType and RteGrpOfferType).

2) Why did you remove the rarId element of BasicObjType? I think we have to
use a registrar ID to differentiate between proprietary of SEDs and
operation caller?

---

From: "Cartwright, Ken" <[email-masked]>
Date: Wed, 4 May 2011 09:55:45 -0400

Hello,

Thanks for your comments:

1)       Yes.  Very good point.  The name of the ext element in the base type should not be the same name of the ext element in the concrete type.  Please go ahead and change the name in your local XSD so that you can move forward and we will put this on the "To-Do" list for the document.
2)       We removed the rarId element because there is no concrete use-case that requires it to be in the protocol, and having it in there creates some additional work and some potential interoperability challenges for some of the authors.  However, it is certainly true that any server implementation of SPPP will need to _internally_ maintain an identifier of the registrar that created each object.  That identifier would, at a minimum, end up being used for authorization and reporting.

Ken
________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mickael MARRACHE
Sent: Wednesday, May 04, 2011 9:36 AM
To: [email-masked]
Subject: [drinks] Questions SPPP

Hey,

1) Implementation difficulties due to multiple use of 'ext' element with inheritance (for example BasicObjType and RteGrpOfferType).

2) Why did you remove the rarId element of BasicObjType? I think we have to use a registrar ID to differentiate between proprietary of SEDs and operation caller?

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.