Subject: [drinks] Questions SPPP

From: Mickael MARRACHE <[email-masked]>
Date: Thu, 5 May 2011 21:17:48 +0300

Hey,

It is specified: "A telephone number is provisioned using the TNType, an
extension of
                       PubIDType. Each TNType object is uniquely identified
by the
                       combination of its tn element, and the unique key of
its parent
                       Destination Group (dgName and rantId)."(page 29)

How a telephone number (TNType) is identified in the case it is directly
associated to route records? I guess with registrant ID and tn? If yes, for
a given registrant, there can't be two telephone number associated with two
different sets of route records? Is that a problem?

---

From: "Cartwright, Ken" <[email-masked]>
Date: Thu, 5 May 2011 14:53:43 -0400

Hi Mickael,

Having two TNTypes that reside within different DestGroups and that contain the same telephone number does not create a problem, in fact the protocol was designed, in part, to support that requirement.  The spec statement "In other words, a given telephone number string may exist within one or more Destination Groups, but must not exist more than once within a Destination Group."

Your point about the spec failing to explicitly state how to uniquely identify a TNType object that does not reside in a Destination Group, is a valid one.  We can add a sentence that speaks to that.  But your assumption about how to do it is accurate, use the combination of the TN string and the rantID.

Ken

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mickael MARRACHE
Sent: Thursday, May 05, 2011 2:18 PM
To: [email-masked]
Subject: [drinks] Questions SPPP

Hey,

It is specified: "A telephone number is provisioned using the TNType, an extension of
                       PubIDType. Each TNType object is uniquely identified by the
                       combination of its tn element, and the unique key of its parent
                       Destination Group (dgName and rantId)."(page 29)

How a telephone number (TNType) is identified in the case it is directly associated to route records? I guess with registrant ID and tn? If yes, for a given registrant, there can't be two telephone number associated with two different sets of route records? Is that a problem?

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

---

From: Mickael MARRACHE <[email-masked]>
Date: Thu, 5 May 2011 22:00:53 +0300

My question was about the second point, "how to uniquely identify a TNType
object that does not reside in a Destination Group". If my assumption is
valid, what about the question "If yes, for a given registrant, there can't
be two telephone number associated with two different sets of route records?
Is that a problem?"

On Thu, May 5, 2011 at 9:53 PM, Cartwright, Ken <[email-masked]>wrote:

>  Hi Mickael,
>
>
>
> Having two TNTypes that reside within different DestGroups and that contain
> the same telephone number does not create a problem, in fact the protocol
> was designed, in part, to support that requirement.  The spec statement “In
> other words, a given telephone number string may exist within one or more
> Destination Groups, but must not exist more than once within a Destination
> Group.”
>
>
>
> Your point about the spec failing to explicitly state how to uniquely
> identify a TNType object that does not reside in a Destination Group, is a
> valid one.  We can add a sentence that speaks to that.  But your assumption
> about how to do it is accurate, use the combination of the TN string and the
> rantID.
>
>
>
> Ken
>
>
>  ------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *Mickael MARRACHE
> *Sent:* Thursday, May 05, 2011 2:18 PM
> *To:* [email-masked]
> *Subject:* [drinks] Questions SPPP
>
>
>
> Hey,
>
> ------------------------------
> are not the intended recipient, please contact the sender by reply e-mail
> and destroy all copies of the original message.
>
>

---

From: "Cartwright, Ken" <[email-masked]>
Date: Thu, 5 May 2011 15:56:53 -0400

Well, I'd not quite state it that way.  A given telephone number _can_ be associated with two separate sets of Route Records by having two TNType objects and those two objects are in different Dest Groups.  But of course for a TNType that does not reside in a destination group, there is no way to associate it with two different sets of Route Records.  The protocol does not support that feature.

Ken

________________________________
From: Mickael MARRACHE [mailto:[email-masked]]
Sent: Thursday, May 05, 2011 3:01 PM
To: Cartwright, Ken; [email-masked]
Subject: Re: [drinks] Questions SPPP

My question was about the second point, "how to uniquely identify a TNType object that does not reside in a Destination Group". If my assumption is valid, what about the question "If yes, for a given registrant, there can't be two telephone number associated with two different sets of route records? Is that a problem?"

On Thu, May 5, 2011 at 9:53 PM, Cartwright, Ken <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mickael,

Ken

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mickael MARRACHE
Sent: Thursday, May 05, 2011 2:18 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [drinks] Questions SPPP

Hey,