Subject: [drinks] Suggestion SPPP

From: Mickael MARRACHE <[email-masked]>
Date: Mon, 16 May 2011 16:00:31 +0300

The draft says:

Route Records: When a route record is deleted any references
between that route record and any route group must be removed by
the SPPP implementation as part of fulfilling the deletion
request.

But there may be a link between route records and telephone numbers too. So,
when a route record is deleted, if there is a telephone number which
references directly this route record, the reference has to be deleted. But
there is a problem.
If this telephone number is not associated to a destination group and this
references only this route record, we get a telephone number which is not
associated to a destination group and not associated to route records, so it
must be deleted too?

P.S: I didn't receive a response for the question : Is a telephone number
the only public identifier which can be associated directly to route
records?

---

From: "Cartwright, Ken" <[email-masked]>
Date: Mon, 16 May 2011 10:00:30 -0400

Hi Michael,

The TN should not be deleted in this case.  And yes, you are correct, under those circumstances, that TN will not have any Route Recs associated with it.  And there is no problem with this.

And the answer to your second question is Yes.

Ken

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mickael MARRACHE
Sent: Monday, May 16, 2011 9:01 AM
To: [email-masked]
Subject: [drinks] Suggestion SPPP

The draft says:

But there may be a link between route records and telephone numbers too. So, when a route record is deleted, if there is a telephone number which references directly this route record, the reference has to be deleted. But there is a problem.
If this telephone number is not associated to a destination group and this references only this route record, we get a telephone number which is not associated to a destination group and not associated to route records, so it must be deleted too?

P.S: I didn't receive a response for the question : Is a telephone number the only public identifier which can be associated directly to route records?

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.