Subject: [drinks] String sizes and SPPP

From: Dean Willis <[email-masked]>
Date: Wed, 15 Jun 2011 22:38:42 -0500

I'm looking at implementing an SPPP server with a MySQL backend. The obvious
approaches to an SQL schema cap the string lengths at some fixed boundary.

The protocol spec doesn't seem to have any bounds on various string
identifiers.

What might be reasonable numbers for the various identifier lengths?

-- 
Dean Willis

---

From: "Jeremy Barkan \(Digitalshtick\)" <[email-masked]>
Date: Thu, 16 Jun 2011 09:36:05 +0300

It would be helpful to have some validation criteria for all of the data
fields in the protocol - and these should be then implemented in the Schema.

This would mean - string lengths, integer sizes and so on

Jeremy Barkan

CTO

Digitalshtick

Tel: +972 2 6728069

Mobile: +972 54 6321603

Skype: jeremy_barkan

 <http://www.digitalshtick.com/> www.digitalshtick.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dean Willis
Sent: 16 June 2011 06:39
To: [email-masked]
Subject: [drinks] String sizes and SPPP

-- 

Dean Willis