Subject: [drinks] I-D Action: draft-ietf-drinks-sppp-over-soap-04.txt

From: [email-masked]
Date: Wed, 06 Jul 2011 10:51:04 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Data for Reachability of Inter/tra-NetworK SIP Working Group of the IETF.

	Title           : SPPP Over SOAP and HTTP
	Author(s)       : Kenneth Cartwright
	Filename        : draft-ietf-drinks-sppp-over-soap-04.txt
	Pages           : 16
	Date            : 2011-07-06

   The Session Peering Provisioning Protocol (SPPP) is an XML protocol
   that exists to enable the provisioning of session establishment data
   into Session Data Registries or SIP Service Provider data stores.
   Sending XML data structures over Simple Object Access Protocol (SOAP)
   and HTTP(s) is a widely used, de-facto standard for messaging between
   elements of provisioning systems.  Therefore the combination of SOAP
   and HTTP(s) as a transport for SPPP is a natural fit.  The obvious
   benefits include leveraging existing industry expertise, leveraging
   existing standards, and a higher probability that existing
   provisioning systems can be more easily integrated with this
   protocol.  This document describes the specification for transporting
   SPPP XML structures over SOAP and HTTP(s).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-drinks-sppp-over-soap-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-drinks-sppp-over-soap-04.txt

---

From: "Cartwright, Ken" <[email-masked]>
Date: Wed, 6 Jul 2011 13:59:41 -0400

I've submitted the following update to the SPPP transport document to address the comments received from WG LC.  Those comments were as follows, and the changes I made...

1.       Section 1: Introduction: The opening para states that "SPPP is best supported by ....". It might be helpful to state the rationale why these "features" are necessary for SPPP. However, this is more of a nit than a necessity - as the expectation is that whoever is reading this document is familiar with SPPP and its needs.

KJC:  Added a sentence or two about the rationale, which partially reflects what was in the use case document and the protocol document.

2.       Section 3:, 3rd para: "Document Literal Wrapped style...<snip...<snip>...is generally regarded as an optimal approach that....". It will be good to provide some reference(s) that support this. Not sure if it is acceptable practice to have any non-standard bodies URLs be listed in the reference section (other standards organizations documents are ok - such as ITU-T etc).

KJC:  Given that this is a best practice, there was not a single authoritative reference to be used.  So what I did was describe what the phrase "Document Literal Wrapped" means.

3.       Section 3, page 6 - last sentence: SOAP and WSDL are referenced, but not present in the Reference section.

KJC:  Added the references.

4.       Section 4, page 7 - last sentence: HTTP is reference, but not present in the Reference section.

KJC: Added the reference.

5.       (nit) Section 7.1 - last sentence of first para: Typo - "Thes" should be "These".

KJC: Fixed

6.       (nit) Section 7.2 - last sentence of second para: Typo - "reasonabl" should be "reasonable".

KJC: Fixed.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, July 06, 2011 1:51 PM
To: [email-masked]
Cc: [email-masked]
Subject: [drinks] I-D Action: draft-ietf-drinks-sppp-over-soap-04.txt

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-drinks-sppp-over-soap-04.txt
_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.