Subject: [drinks] FW: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

From: Sumanth Channabasappa <[email-masked]>
Date: Fri, 23 Sep 2011 12:57:51 -0600

I am forwarding this as an FYI. If you are interested in this discussion, please check the rai discussion list. See: https://www.ietf.org/mailman/listinfo/rai for archives and subscription.

- S

From: [email-masked] On Behalf Of PFAUTZ, PENN L
To: [email-masked]
Subject: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

Following up on the discussion in dispatch at IETF 81 (www.ietf.org/proceedings/81/minutes/dispatch.txt<http://www.ietf.org/proceedings/81/minutes/dispatch.txt>) I'd like to get some discussion of   draft-pfautz-service-provider-identifier-urn-01 going.
The draft proposed IANA registration of a service provider ID (SPID) which would have the following characteristics:
-      Numeric ID, at least 8 digits long
-      Fixed length
-      Available to any type of entity
-      Entities able to obtain multiple identifiers.
-       Some range of identifiers reserved for internal usage
-      Open registration by IANA

The minutes concluded:

-      WG is in support of creating a URN for this.
-      Document(s) likely to be AD sponsored.
-      Discussion should move to RAI area list (as opposed to DRINKS or DISPATCH).

The outstanding issues seemed to be
1. Is a new resource assignment necessary for the URN or could an existing one, Private Enterprise Numbers or ITADs be used with a URN defined to provide a fixed length parameter as requested in the I-D?

2. Assuming a fixed length parameter will be used, what's the right length?

The I-D proposed a new resource, partly because the existing ones were intended for other purposes and already had many registrations. I'd also note that PENs suggest a sub-delegation approach to assigning multiple SPIDs to an entity (an entity gets one PEN assignment and can assign values hierarchically below that (e.g. AT&T has PEN 74, and would assign 74.1, 74.2, etc). Because at least some of the service providers wanted to use SPID to prefix E.164 numbers and others want to incorporate SPID in a domain name, this would present issues.

Penn Pfautz
AT&T Access Management
+1-732-420-4962

---

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Fri, 23 Sep 2011 18:59:40 +0000

Thanks Sumanth.  And if folks think this SPID would be a useful thing to have, please weigh in accordingly.

Penn Pfautz
AT&T Access Management
+1-732-420-4962
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sumanth Channabasappa
Sent: Friday, September 23, 2011 2:58 PM
To: [email-masked]
Subject: [drinks] FW: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

- S

The minutes concluded:

Penn Pfautz
AT&T Access Management
+1-732-420-4962

---

From: "Richard Shockey" <[email-masked]>
Date: Sat, 24 Sep 2011 20:26:34 -0400

Please weigh in.  NOW!  It's important.   

It's no real problem to create a new namespace in IANA and this certainly
fits the definition.

You will all see the usual chatter about why you need to create a new name
space. Why doesn't ITAD's work etc but the business case for doing this
should be self evident and we will never be able to kill off Class 5
networks until something like this is in place.

Needless to say I totally support Penn's draft and DRINKS will be a
immediate beneficiary of this class of identifier.  This work has the
support of all of the global international carriers typically represented by
i3Forum etc but even speaking in my role as SIP Forum Chairman we totally
support this work. 

We have all seen how SPID's and Alt-SPIDs have made all IP  interconnection
easier in the North American market. This draft takes that concept to the
next logical step.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
PFAUTZ, PENN L
Sent: Friday, September 23, 2011 3:00 PM
To: Sumanth Channabasappa; [email-masked]
Subject: Re: [drinks] FW: [RAI] Global Service Provider ID -
draft-pfautz-service-provider-identifier-urn-01

Thanks Sumanth.  And if folks think this SPID would be a useful thing to
have, please weigh in accordingly.

Penn Pfautz

AT&T Access Management

+1-732-420-4962

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sumanth Channabasappa
Sent: Friday, September 23, 2011 2:58 PM
To: [email-masked]
Subject: [drinks] FW: [RAI] Global Service Provider ID -
draft-pfautz-service-provider-identifier-urn-01

I am forwarding this as an FYI. If you are interested in this discussion,
please check the rai discussion list. See:
https://www.ietf.org/mailman/listinfo/rai for archives and subscription.

- S

From: [email-masked] On Behalf Of PFAUTZ, PENN L
To: [email-masked]
Subject: [RAI] Global Service Provider ID -
draft-pfautz-service-provider-identifier-urn-01

Following up on the discussion in dispatch at IETF 81
(www.ietf.org/proceedings/81/minutes/dispatch.txt) I'd like to get some
discussion of   draft-pfautz-service-provider-identifier-urn-01 going.

The draft proposed IANA registration of a service provider ID (SPID) which
would have the following characteristics:

-      Fixed length 

The minutes concluded:

-      Discussion should move to RAI area list (as opposed to DRINKS or
DISPATCH). 

1. Is a new resource assignment necessary for the URN or could an existing
one, Private Enterprise Numbers or ITADs be used with a URN defined to
provide a fixed length parameter as requested in the I-D?

The I-D proposed a new resource, partly because the existing ones were
intended for other purposes and already had many registrations. I'd also
note that PENs suggest a sub-delegation approach to assigning multiple SPIDs
to an entity (an entity gets one PEN assignment and can assign values
hierarchically below that (e.g. AT&T has PEN 74, and would assign 74.1,
74.2, etc). Because at least some of the service providers wanted to use
SPID to prefix E.164 numbers and others want to incorporate SPID in a domain
name, this would present issues. 

Penn Pfautz

AT&T Access Management

+1-732-420-4962

---

From: <[email-masked]>
Date: Mon, 26 Sep 2011 15:36:48 +0200

Dear Penn,

Apologies if this is already raised but  having a quick review of your draft, it seems to me all the requirements you listed are met by the ITAD number for VoIP service providers:

   o  They SHOULD be globally unique
   o  They SHOULD be numeric, at least 8 digits long
   o  They SHOULD be fixed length
   o  they SHOULD be available to any type of entity
   o  Entities SHOULD be able to obtain mulitple identifiers.
   o  Some range of identifiers SHOULD be reserved for internal entity
      usage.

Did I missed something?

Thanks.

Cheers,
Med

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de PFAUTZ, PENN L
Envoyé : vendredi 23 septembre 2011 21:00
À : Sumanth Channabasappa; [email-masked]
Objet : Re: [drinks] FW: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

Penn Pfautz
AT&T Access Management
+1-732-420-4962

- S

The minutes concluded:

Penn Pfautz
AT&T Access Management
+1-732-420-4962

---

From: Sumanth Channabasappa <[email-masked]>
Date: Mon, 26 Sep 2011 07:39:27 -0600

Folks,

The fwd was meant as an FYI, please provide comments on the RAI reflector where this discussion is happening.

Sumanth -- as co-chair

On Sep 26, 2011, at 7:36 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Dear Penn,

Did I missed something?

Thanks.

Cheers,
Med

________________________________
De : [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] De la part de PFAUTZ, PENN L
Envoyé : vendredi 23 septembre 2011 21:00
À : Sumanth Channabasappa; <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Objet : Re: [drinks] FW: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

Penn Pfautz
AT&T Access Management
+1-732-420-4962
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Sumanth Channabasappa
Sent: Friday, September 23, 2011 2:58 PM
To: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Subject: [drinks] FW: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

I am forwarding this as an FYI. If you are interested in this discussion, please check the rai discussion list. See: <https://www.ietf.org/mailman/listinfo/rai> https://www.ietf.org/mailman/listinfo/rai for archives and subscription.

- S

From: [email-masked]<mailto:[email-masked]> On Behalf Of PFAUTZ, PENN L
To: <mailto:[email-masked]> [email-masked]<mailto:[email-masked]>
Subject: [RAI] Global Service Provider ID - draft-pfautz-service-provider-identifier-urn-01

Following up on the discussion in dispatch at IETF 81 (<http://www.ietf.org/proceedings/81/minutes/dispatch.txt>www.ietf.org/proceedings/81/minutes/dispatch.txt<http://www.ietf.org/proceedings/81/minutes/dispatch.txt>) I’d like to get some discussion of   draft-pfautz-service-provider-identifier-urn-01 going.
The draft proposed IANA registration of a service provider ID (SPID) which would have the following characteristics:
–      Numeric ID, at least 8 digits long
–      Fixed length
–      Available to any type of entity
–      Entities able to obtain multiple identifiers.
–       Some range of identifiers reserved for internal usage
–      Open registration by IANA

The minutes concluded:

–      WG is in support of creating a URN for this.
–      Document(s) likely to be AD sponsored.
–      Discussion should move to RAI area list (as opposed to DRINKS or DISPATCH).

2. Assuming a fixed length parameter will be used, what’s the right length?

The I-D proposed a new resource, partly because the existing ones were intended for other purposes and already had many registrations. I’d also note that PENs suggest a sub-delegation approach to assigning multiple SPIDs to an entity (an entity gets one PEN assignment and can assign values hierarchically below that (e.g. AT&T has PEN 74, and would assign 74.1, 74.2, etc). Because at least some of the service providers wanted to use SPID to prefix E.164 numbers and others want to incorporate SPID in a domain name, this would present issues.

Penn Pfautz
AT&T Access Management
+1-732-420-4962