Subject: [drinks] Implications of re-adding rar in spprov-11

From: Dean Willis <[email-masked]>
Date: Wed, 9 Nov 2011 16:34:46 -0600

The discussion around Organization in 3.1 Protocol Data Model may be
inconsistent with reintroduction of "rar" into the schema:

   o  Organization:
      An Organization is an entity that may fulfill the role of a
      registrant or a peering organization.  All SPPP objects are
      associated with an organization identifier to identify each
      object's registrant, while tracking the identity of the registrar
      that provisioned each SPPP object is left as a matter of policy
      for an SPPP implementation.

If rar is in the object schema, tracking it may not be optional. We
noted during the OpenSPP work that we were having a hard time modeling
a number of use cases without tracking the rar.

I suggest replacing "while tracking..." with "and a registrar
identifier to identify the registrar that provisioned the object."

--

Dean

---

From: "Cartwright, Ken" <[email-masked]>
Date: Thu, 10 Nov 2011 09:33:29 -0500

That sentace is a holdover from when we removed rar from the schema.  It needs to be changed now that we have added it back in.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dean Willis
Sent: Wednesday, November 09, 2011 5:35 PM
To: [email-masked]
Subject: [drinks] Implications of re-adding rar in spprov-11

The discussion around Organization in 3.1 Protocol Data Model may be inconsistent with reintroduction of "rar" into the schema:

   o  Organization:

If rar is in the object schema, tracking it may not be optional. We noted during the OpenSPP work that we were having a hard time modeling a number of use cases without tracking the rar.

I suggest replacing "while tracking..." with "and a registrar identifier to identify the registrar that provisioned the object."

--

Dean

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.