Subject: [drinks] FW: I-D Action: draft-ietf-drinks-spp-framework-01.txt

From: "Bhatia, Vikas" <[email-masked]>
Date: Mon, 12 Mar 2012 14:43:52 -0400

Hi All,

New versions of the draft documents for the SPP Framework and SPP Protocol over SOAP have been submitted today.

Following are the set of changes to the documents. Action Item (AI) numbers are listed (wherever applicable). These AIs were identified in the last Interim and subsequent weekly design meetings.

===Start - List of Changes===

SPP Framework document
----------------------
AI-1/ Addressed data model diagram inconsistencies - Diagram has been significantly revamped per the discussions and comments
        David's comments:
        * remove extensions
        * add missing arrows (TN and RR)
        * add [0..n] on relevant arrows

        Other changes:
        * Added the new URI type of Public Identifier (refer AI-3 below)
        * Added Egress Route into the diagram

AI-3/ Non-numeric PI (URIPubIdType) and related text has been added.
AI-5/ Removed priority from RteRec base type
AI-6/ Also added "isInSvc" flag on RteRec base type
AI-7/ Move up "ttl" field to base RteRec type

SPP Protocol over SOAP document
--------------------------------
AI-13a In the response, returned an error with the maximum (Response code 2001).
AI-13c/ Removed definition of transaction id type as it is already listed in framework document.
AI-14/ Expanded element name "dtlResult" to "detailResult" to make it consistent with element "overallResult".
AI-15/ Defined a type "MsgType" to add max length to result message text.
AI-19/ Clarifed attributes of ObjKeyType on how they identify uniqueness and added an example as well.

-Corrected the numbering of Result Codes (like some result codes were starting with 2103 instead of 2100 etc).
-Introduced an enumeration "ResultCodeValType" to define all the result codes. This ensures that server can only send one of the result codes defined in the schema. In previous version(s), it was loosely defined to take in any integer.

General
-------
-Corrected some editorial nits (spell checks, consistent use of terminology etc.).
-Moved "ObjKeyTypeEnum" from framework to protocol document (thought protocol document was an appropriate places for it since it is only used in the SPP Protocol over SOAP schema).
-A-11/ Review Security Cons section (All) - The change I did was to add the text proposed by Scott in the SPP Protocol over SOAP document (and added Scott's name to acknowledgements).

===End - List of Changes===

Thanks,
Vikas

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, March 12, 2012 2:19 PM
To: [email-masked]
Cc: [email-masked]
Subject: [drinks] I-D Action: draft-ietf-drinks-spp-framework-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Data for Reachability of Inter/tra-NetworK SIP Working Group of the IETF.

        Title           : Session Peering Provisioning Framework (SPPF)
        Author(s)       : Kenneth Cartwright
                          Syed Wasim Ali
                          Alexander Mayrhofer
                          Vikas Bhatia
        Filename        : draft-ietf-drinks-spp-framework-01.txt
        Pages           : 59
        Date            : 2012-03-12

   This document specifies the data model and the overall structure for
   a framework to provision session establishment data into Session Data
   Registries and SIP Service Provider data stores.  The framework is
   called the Session Peering Provisioning Framework (SPPF).  The
   provisioned data is typically used by network elements for session
   peering.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-drinks-spp-framework-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-drinks-spp-framework-01.txt

_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

Subject: [drinks] I-D Action: draft-ietf-drinks-spp-protocol-over-soap-01.txt
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Date: Mon, 12 Mar 2012 14:23:24 -0400
List-Id: IETF DRINKS WG <drinks.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Data for Reachability of Inter/tra-NetworK SIP Working Group of the IETF.

	Title           : Session Peering Provisioning (SPP) Protocol over SOAP
	Author(s)       : Kenneth Cartwright
                          Vikas Bhatia
	Filename        : draft-ietf-drinks-spp-protocol-over-soap-01.txt
	Pages           : 91
	Date            : 2012-03-12

   The Session Peering Provisioning Framework (SPPF) is an XML framework
   that exists to enable the provisioning of session establishment data
   into Session Data Registries or SIP Service Provider data stores.
   Sending XML data structures over Simple Object Access Protocol (SOAP)
   and HTTP(s) is a widely used, de-facto standard for messaging between
   elements of provisioning systems.  Therefore the combination of SOAP
   and HTTP(s) as a transport protocol for SPPF is a natural fit.  The
   obvious benefits include leveraging existing industry expertise,
   leveraging existing standards, and a higher probability that existing
   provisioning systems can be more easily integrated with this
   protocol.  This document describes the specification for transporting
   SPPF XML structures over SOAP and HTTP(s).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-drinks-spp-protocol-over-soap-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-drinks-spp-protocol-over-soap-01.txt

_______________________________________________
drinks mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/drinks

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 12 Mar 2012 19:11:12 +0000

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Bhatia, Vikas
> Sent: Monday, March 12, 2012 2:44 PM
> To: [email-masked]
> Subject: [drinks] FW: I-D Action: draft-ietf-drinks-spp-framework-
> 01.txt
> 
> Hi All,
> 
> New versions of the draft documents for the SPP Framework and SPP
> Protocol over SOAP have been submitted today.
> 
> Following are the set of changes to the documents. Action Item (AI)
> numbers are listed (wherever applicable). These AIs were identified in
> the last Interim and subsequent weekly design meetings.

My comments have been completely addressed - thanks!

Scott