Subject: [drinks] DRAFT minutes of the 2013-05-16 conference call.

From: Alexander Mayrhofer <[email-masked]>
Date: Tue, 21 May 2013 10:20:19 +0000

DRINKS design team conference call
===========================

2013-05-16, 08:30 - 09:00am Pacific Time

Participants
--------------

  - Mickael Marrache
  - Dean Willis
  - Alex Mayrhofer
  - David Schwartz
  - Syed Ali
  - Vikas Bhatia

AI
---

1/ (All) Post PROs and CONs regarding DGname as component of PI Key Type to mailing list  (if not yet posted)
2/ (Design Team) Make informed decision based on full information

Minutes
----------

1) clarification that cardinality mistake in diagram is solved - will be changed  (Figure 2 - Relation between PI and DG)

2) discussion about whether DGname should be part of the publickeytype.

Vikas: What new information came to table that we didn't have before?
David: Implementation work brought this up.
Alex (individual): Having optional attribute as key component sounds illogical (although understand that NULL values can be key components)
Vikas: What do we gain when we remove it?
David: Implementation is much easier.
Dean: Simplification might subsequently lead to more deployment?

Vikas: two options - again, what new has come to light to change this former decision?
Dean: Optional keys & hibernation in DB are complex..
Vikas: We need more arguments than just "this is complex"
David: Only Counter-argument he hears is "let's not change it" - Can someone come up with a use case why this is needen, What the advantage is to leave it in besides avoiding a change?
Vikas: Argument is not inertia, but what is the new information?
David: new info is implementation experience.
David: Optional parameter as key component is not the way to do data modesl. 
Vikas: Depends on the case.

Alex (as chair): 
Conclusion: No concensus yet. We Need more information - Please post PROs and CONs to the list, 
so that we can make an informed decision, hopefully over the course of the next week

Call concludes.

---

From: Sumanth Channabasappa <[email-masked]>
Date: Wed, 22 May 2013 22:26:58 +0000

Folks,

Can you please post your thoughts around the pros and cons as you seem
them so that we can resolve this topic? It will be useful to have this (on
the list) before we have another design team call. See below for details.

Thanks!
- S (as the co-chair)

On 5/21/13 4:20 AM, "Alexander Mayrhofer" <[email-masked]>
wrote:

>1) clarification that cardinality mistake in diagram is solved - will be
>changed  (Figure 2 - Relation between PI and DG)
>
>Alex (individual): Having optional attribute as key component sounds
>illogical (although understand that NULL values can be key components)
>David: Only Counter-argument he hears is "let's not change it" - Can
>someone come up with a use case why this is needen, What the advantage is
>to leave it in besides avoiding a change?
>_______________________________________________
>drinks mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/drinks
>