Subject: Re: [drinks] [IANA #803729] Expert Review for draft-ietf-drinks-spp-protocol-over-soap-07

From: Alexander Mayrhofer <[email-masked]>
Date: Wed, 4 Feb 2015 08:31:22 +0000

(author hat on)

Pearl,

please find my responses to Graham's questions below:

> [...]
> I do have a couple of questions:
> 
> (a) the XML appears to use at least two new URNs:
> 
> xmlns:sppfb="urn:ietf:params:xml:ns:sppf:base:1"
> xmlns:sppfs="urn:ietf:params:xml:ns:sppf:soap:1"
>
> but only registers one:
> 
> urn:ietf:params:xml:ns:sppf:soap:1
> 
> It's probably fine - I think the other is registered in
> https://tools.ietf.org/html/draft-ietf-drinks-spp-framework-09#section-11.1.
> Will these documents be going forward together? A little more explanation
> and cross-reference might conceivably be helpful (e.g. that the WSDL
> definition uses these new URNs, and where the other one is defined).

This is correct - the registration of the other namespace is requested in the Framework document. And, yes, the intention is that both documents move forward together, since they are tightly coupled anyways. 

We will add explanation and cross-reference to the document together in either a new revision of the document or an RFC Editor Note - my proposal for such text would be to add a new paragraph in Section 12 (IANA Considerations), saying:

Note that the WSDL Specification also makes use of the "urn:ietf:params:xml:ns:sppf:base:1" XML Namespace URN, which is defined in [SPPF].

> (b) it's not clear from the registration what the URN is being registered *as*.
> From context, I think it is as an *XML namespace*, but I think it could be
> clearer (both XML Namespaces and XML Schemas are mentioned in the
> accompanying text).

Again, we will address this together with other changes to the document, my proposal is to change the first paragraph of Section 12 into:

This document uses URNs to describe XML Namespaces and XML Schemas.
 According to [RFC3688], IANA is requested to perform  registration of the following URN in the 
 IANA XML Namespace Registry:

(plus add the following Line to the front of the registration request)

Registration request for the SPPF SOAP XML namespace:

Hope that clarifies the questions?
thanks,
Alex

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Mon, 09 Feb 2015 17:44:37 +0000

Hi all,

Graham has reviewed the below comments and has no further question.

Thanks,
~pl

On Wed Feb 04 08:31:51 2015, [email-masked] wrote:
> This is correct - the registration of the other namespace is requested
> in the Framework document. And, yes, the intention is that both
> documents move forward together, since they are tightly coupled
> anyways.
> 
> We will add explanation and cross-reference to the document together
> in either a new revision of the document or an RFC Editor Note - my
> proposal for such text would be to add a new paragraph in Section 12
> (IANA Considerations), saying:
> 
> Note that the WSDL Specification also makes use of the
> "urn:ietf:params:xml:ns:sppf:base:1" XML Namespace URN, which is
> defined in [SPPF].
> 
> Again, we will address this together with other changes to the
> document, my proposal is to change the first paragraph of Section 12
> into:
>