Subject: [eap] Missing subsection 5.x on Experimental Type

From: [email-masked] (Henrik Levkowetz)
Date: Fri, 25 Apr 2003 11:36:56 +0200

Submitter name: Henrik Levkowetz
Submitter email address: [email-masked]
Date first submitted: April 25, 2003
Document: EAP-02.c
Comment type: E
Priority: 1
Section: 5
Rationale/Explanation of issue:

Going over the draft to compile a list of changes compared with rfc 2284,
I've noticed that we lack a subsection to section 5 which says something
about type 255, Experimental use. What about:

	5.8 Experimental
		
	   Description
		
		The Experimental Type has no fixed format or content. It is
		intended for use when experimenting with new EAP types. This type
		MUST NOT be used for regular deployment of draft features.
		
	   Type
		
		255
		
	   Type-Data
		
		Undefined

	Henrik

-- 
  Basic research is what I'm doing when I don't know what I'm doing. 
    -- Wernher von Braun

---

From: [email-masked] (Jari Arkko)
Date: Fri, 25 Apr 2003 16:23:02 +0300

Ok, but some details inline:

> 		MUST NOT be used for regular deployment of draft features.

The last part of the sentence sounds a bit strange. How about something
like "This type is intended for experimental and testing purposes. No
guarantee is made for interoperability between peers using this type,
as outlined in [IANA-EXP]."

[IANA-EXP]     T. Narten, "Assigning Experimental and Testing Numbers
                Considered Useful", IETF Work in Progress.

---

From: [email-masked] (Henrik Levkowetz)
Date: Fri, 25 Apr 2003 15:40:08 +0200

On Fri, 25 Apr 2003 16:23:02 +0300

>                 Considered Useful", IETF Work in Progress.

Ok, changing the last sentence. Yes, I considered refering to this draft,
but decided not to as this can stand pretty much on it's own.

	Henrik

-- 
  The dinosaurs became extinct because they 
  didn't have a space program. - Larry Niven 

  And if we become extinct because we don't have 
  a space program, it'll serve us right! - AC Clark