Subject: [eap] WG last call issue: EAP-04 Section 2.2: EAP multiplexing model requriements

From: [email-masked] (Henrik Levkowetz)
Date: Tue, 17 Jun 2003 21:34:57 +0200

Submitter name: Henrik Levkowetz
Submitter email address: [email-masked]
Date first submitted: June 17, 2003
Document: EAP-04
Comment type: T
Priority: 1
Section: 2.2 EAP multiplexing model
Rationale/Explanation of issue:

The draft says:

   "Since EAP authentication methods may wish to access the Identity, the
   Identity Request and Response can be assumed to be accessible to
   authentication methods (Types 4 or greater) in addition to the
   Identity method.  The Identity Type is discussed in Section 5.1."

There's a requirement on an implementation here, I think.
Maybe we should say that the Identity Request and Response
SHOULD or MUST be made accessible to authentication methods?

---

From: [email-masked] (Jari Arkko)
Date: Wed, 18 Jun 2003 23:00:57 +0300

> SHOULD or MUST be made accessible to authentication methods?

Yes. ... esponse SHOULD be accessible to ....?

--Jari