Subject: [eap] Issue 164: conflicting implementation note

From: [email-masked] (Joseph Salowey)
Date: Tue, 29 Jul 2003 22:21:57 -0700

The implementation note in section 5.1 seems to conflict with text in
section 2[3]

Submitter name: Joe Salowey 
Submitter email address: [email-masked] 
Date first submitted: 7/29/2003
Reference: 
Document: RFC2284bis
Comment type: T
Priority: S
Section: 5.1
Rationale/Explanation of issue: 

In section 2 [3] there is the following text
"After a suitable number of
       retransmissions, the authenticator SHOULD end the EAP
       conversation.  The authenticator MUST NOT send a Success or
       Failure packet when retransmitting or when it fails to get a
       response from the peer."

In section 5.1 there is the following text in the implementation note:

"It is suggested that the Identity Request be
         retried a minimum of 3 times before terminating the
         authentication phase with a Failure reply."

This seems contradictory.

Requested change: 

Section 5.1 

"It is suggested that the Identity Request be
         retried a minimum of 3 times before terminating the
         authentication."

---

From: [email-masked] (Jari Arkko)
Date: Wed, 30 Jul 2003 20:17:07 +0300

> This seems contradictory.

Yes.

>          retried a minimum of 3 times before terminating the

Right. Thanks for observing this!

--Jari