Subject: [eap] Announcing: draft-moskowitz-eap-auth-model-00.txt

From: Bernard Aboba <[email-masked]>
Date: Thu, 7 Aug 2003 11:29:08 -0700 (PDT)

To: IETF-Announce: ;
Subject: I-D ACTION:draft-moskowitz-eap-auth-model-00.txt
From: [email-masked]
Date: Thu, 07 Aug 2003 07:52:50 -0400
Reply-to: [email-masked]
Sender: [email-masked]

--------------------------------------------------------------------------------

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: An Authentication Functional Layering Model
	Author(s)	: R. Moskowitz
	Filename	: draft-moskowitz-eap-auth-model-00.txt
	Pages		: 11
	Date		: 2003-8-6

There is considerable confusion surrounding authentication styles
and the nature of the resulting trust.  This paper is an attempt to
develop categories of authentication methods and present examples of
each.  In so doing, it develops an Authentication Functional
Layering Model.  It will look at the components of authentication,
the flows, channels, algorithms, and entities.  The taxonomy
presented here is new; it has been created to facilitate discussion
and understanding.  Only two-party authentications are presented
here.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-moskowitz-eap-auth-model-00.txt

To remove yourself from the IETF Announcement list, send a message to
ietf-announce-request with the word unsubscribe in the body of the
message.

Internet-Drafts are also available by anonymous FTP. Login with the
username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-moskowitz-eap-auth-model-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-moskowitz-eap-auth-model-00.txt".

NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

<ftp://ftp.ietf.org/internet-drafts/draft-moskowitz-eap-auth-model-00.txt>

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 08 Aug 2003 12:30:17 -0400

>Sender: [email-masked]

Thank you, Bernard in beating me to posting this ID here.

Please, I welcome comments on content.

I know it can use some editorial clean up, and in the end lots of references.

There are multiple driving forces for this paper.  Perhaps a very important 
one will be for the next update to 802.1x via the new LinkSec taskgroup in 
802.1.

I also hope that it will result in discussion about how EAP works over the 
'rgiht' flows, and about authentication algorithms that we need and do not 
have.

Bernard has me on the hook for a paper on Security Associations, so the 
part in this ID on SAs, may get move into a larger context.

Robert Moskowitz
ICSAlabs/A Division of TruSecure Corporation
Security Interest EMail: [email-masked]

---

From: David Jablon <[email-masked]>
Date: Sun, 10 Aug 2003 16:17:39 -0400

Bob,

The tiny section of draft-moskowitz-eap-auth-model-00.txt that mentions
passwords could be interpreted (perversely) to imply that they should
be treated as similar to MAC addresses.

You may also want to coordinate with Eric Rescorla's draft, of which I've
just become aware, in which he too attempts to categorize authentication
technologies.

I have separate concerns about each of these drafts, and I think it makes sense
to discuss them in a common appropriate forum.  I'm not sure what that forum is,
but without such a forum, I think both will suffer from a lack of appropriate attention.

-- David

At 12:30 PM 8/8/03 -0400, Robert Moskowitz wrote:
>There are multiple driving forces for this paper.  Perhaps a very important one will be for the next update to 802.1x via the new LinkSec taskgroup in 802.1.
>
>I also hope that it will result in discussion about how EAP works over the 'rgiht' flows, and about authentication algorithms that we need and do not have.
>
>Bernard has me on the hook for a paper on Security Associations, so the part in this ID on SAs, may get move into a larger context.
>
>
>
>Robert Moskowitz

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 11 Aug 2003 08:24:26 -0400

>be treated as similar to MAC addresses.

I have been thinking of your comment while I was driving up into the 
Catskills for visiting day to the farm my son is working on.  You are right 
about the unintended impression and I will address that.

>just become aware, in which he too attempts to categorize authentication

I have also learned about Eric's ID and have submitted comments to him and 
the IAB.  His draft is doing something much different than mine, though.

>but without such a forum, I think both will suffer from a lack of 

Understand.  And there is more here that I feel needs to be written (and 
Bernard got me to commit to one on Security Associations at the 802 
plenary...).

Don't have an answer.  Perhaps someone should ask Bellovin or Housley.

Robert Moskowitz