Subject: [eap] Test Vector - Annex A - draft-haverinen-ppext-eap-sim-12.txt

From: Pascal Urien <[email-masked]>
Date: Tue, 13 Jan 2004 13:58:06 +0100

Hi Everybody,

    I have written a C code that checks the test vectors expressed in annexe A
    of the draft-haverinen-pppext-eap-sim-12.txt document.

    I found the following typographic error,  in A.8 Re-Authentication, page 68
    the last byte (6f)  of the identity value is missing.

    Source code is available at http://www.chez.com/urienp/eapsim.zip
    (for visual C tool). A small lib (eapsim.lib) contains all needed 
cryptographic procedures.

    Test results are dumped in the file result.txt.

Pascal.

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: <[email-masked]>
Date: Tue, 13 Jan 2004 15:27:28 +0200

Pascal,

Thanks for the test code. 

We have found a couple of other issues in the test vectors, 
and we'll update the test vectors in the next draft revision.
The fixes are:
- wrong Identifier field in EAP-Success
- last byte of EAP-Response/Identifier for re-authentication is missing,
as you noted
- in EAP-Request/SIM/Reauthentication, AT_PADDING should be omitted because
the plaintext is a multiple of 16 bytes
- MSK and EMSK are derived incorrectly in re-authentication.
K_aut and K_encr are not derived, so the key stream begins directly 
with MSK bytes.
- EAP Success in re-authentication uses a different Identifier than
in full authentication, so we cannot say the EAP Success packet
is similar as in full authentication 

Best regards,
Henry

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Pascal Urien
> Sent: 13 January, 2004 14:58
> To: [email-masked]
> Subject: [eap] Test Vector - Annex A -
> draft-haverinen-ppext-eap-sim-12.txt
> 
> 
> Hi Everybody,
>