Subject: RE: [Sipping-emergency] Emergency Scenarios Document

From: "McCalmont, Patti" <[email-masked]>
Date: Tue, 27 May 2003 10:54:29 -0500

Section 3.3

> In the legacy network ....mapping database.

The term "mapping database is used a few times within the document. Is mapping database trying to refer to a selective routing database that is used to determine how to route the call based on the location of the caller to the PSAP? If so, a better term would be location database or selective routing database (term used in US/Canada. Or, is it trying to refer to the phone number to location information, Automatic Location Identification (ALI) database, or both? Some clarification is needed.
   
      For PBX operation, an additional issue is that telephone number 
      assignments are under control of the private network operator.  PBXs 
      without direct-inward-dialing (DID) introduce an additional 
      challenge.  Typically, the calling number is used as a unique 
      reference to identify the caller's location.

Without CAMA or PRI connections for emergency calls, those PBX locations cannot convey the caller's identity (even with DID). What is typically used is the Billing Number or Main Directory number for the PBX when they don't have the CAMA/PRI. There may need some clarification as connections required in order to provide the DID stations or is that what was trying to be said with "administrative arrangements"? 

      A special arrangement at the switch serving the ECC allows the 
      emergency operator to hold open the voice path back to the caller as 
      long as necessary, even if the caller goes on-hook.  It should be 
      noted that this functionality is not supported for ISDN. Thus, the 
      operator can also ring the caller's line in this situation or others 
      where it might be necessary. 

Call Hold applies globally to Basic 911 and is an option for Enhanced 9-1-1 so which type of "legacy network" is described in this section. If Enhanced 9-1-1, then Call Hold (as stated later) is an optional feature.

	Henning wrote: I would qualify this as "In analog switches, ....". Most switches today 
	are effectively ISDN (or equivalent), so this feature is likely only 
	available to a tiny fraction of end systems.

Most switches today are digital so I don't like the term "analog switches". It would be better to talk about the interfaces into the switch as being analog or digital (ISDN).

Section 4.3.1
>       There is still the problem of distinguishing between voice and text 
>       emergency calls.  If the user enters an actual emergency number, that 
>       can be the one that serves the user's needs.  If the configuration is 
>       by DHCP or SIP registrar, it may be that selection of the appropriate 
>       number is based on pre-configuration of the SIP phone as voice or 
>       text bas

	Henning wrote: Unless I'm really off my rocker, the number is the same for TDD calls. 
	See http://www.nena.org/PR_Pubs/9-1-1QandA.htm for evidence.

He is correct. It's the equipment at the PSAP that detects the call as TDD nothing in how the user dials.

Patti McCalmont	

_______________________________________________
Sipping-emergency mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-emergency
_______________________________________________
Sipping-emergency mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sipping-emergency

---

From: Tom Taylor <[email-masked]>
Date: Tue, 27 May 2003 12:47:08 -0400

I'll be replying to Henning's comments, but since this note is relatively short I'll
address it first.

McCalmont, Patti wrote:
> The term "mapping database is used a few times within the document. Is mapping
> database trying to refer to a selective routing database that is used to
> determine how to route the call based on the location of the caller to the PSAP?
> If so, a better term would be location database or selective routing database
> (term used in US/Canada. Or, is it trying to refer to the phone number to
> location information, Automatic Location Identification (ALI) database, or both?
> Some clarification is needed.
[PTT]  I'll clarify.  In North American terms I'm referring to the ALI database.

> 
> For PBX operation, an additional issue is that telephone number assignments are
> under control of the private network operator.  PBXs without
> direct-inward-dialing (DID) introduce an additional challenge.  Typically, the
> calling number is used as a unique reference to identify the caller's location.
> 
> Without CAMA or PRI connections for emergency calls, those PBX locations cannot
> convey the caller's identity (even with DID). What is typically used is the
> Billing Number or Main Directory number for the PBX when they don't have the
> CAMA/PRI. There may need some clarification as connections required in order to
> provide the DID stations or is that what was trying to be said with
> "administrative arrangements"?
[PTT] I seem to have gotten this wrong, as you and Henning point out.  I'll have to 
extend the discussion.
> 
> 
> A special arrangement at the switch serving the ECC allows the emergency operator
> to hold open the voice path back to the caller as long as necessary, even if the
> caller goes on-hook.  It should be noted that this functionality is not supported
> for ISDN. Thus, the operator can also ring the caller's line in this situation or
> others where it might be necessary.
> 
> Call Hold applies globally to Basic 911 and is an option for Enhanced 9-1-1 so
> which type of "legacy network" is described in this section. If Enhanced 9-1-1,
> then Call Hold (as stated later) is an optional feature.
> 
> Henning wrote: I would qualify this as "In analog switches, ....". Most switches
> today are effectively ISDN (or equivalent), so this feature is likely only 
> Most switches today are digital so I don't like the term "analog switches". It
> would be better to talk about the interfaces into the switch as being analog or
> digital (ISDN).

[PTT] Yes, that's right.  In North America, there aren't many ISDN lines, but in 
Europe there are.  In both places, most switches are digital.
> 
> 
> Section 4.3.1
> 
>> There is still the problem of distinguishing between voice and text emergency
>> calls.  If the user enters an actual emergency number, that can be the one that
>> serves the user's needs.  If the configuration is by DHCP or SIP registrar, it
>> may be that selection of the appropriate number is based on pre-configuration
>> of the SIP phone as voice or text bas
> 
> 
> Henning wrote: Unless I'm really off my rocker, the number is the same for TDD
> calls. See http://www.nena.org/PR_Pubs/9-1-1QandA.htm for evidence.
> 

[PTT] That's in North America.  It's different in Australia.  I suppose I should 
modify the discussion to make it clear that the requirement is only present in some 
countries.

> 
> Patti McCalmont
> 
> _______________________________________________ Sipping-emergency mailing list 
> _______________________________________________ Sipping-emergency mailing list