Subject: Re: [Ecrit] PSAP callback

From: Christer Holmberg <[email-masked]>
Date: Sat, 23 Jul 2011 17:55:17 +0200

Hi Martin,

Thanks for your comments! Unfortunately, due to summer vacations etc, it took a while for me to reply. Sorry for that. 

Comments inline.

>The idea that I recall being floated is very similar to the 
>one I see proposed here.  That used a GRUU but no explicit 
>tag. This is subtly different and I can't see a reason why 
>it is better.
> 
>This could be a very simple thing to specify.  Adding the tag 
>could actually make it harder. 	

I am not religious regarding the protocol mechanism. The important thing is having *A* mechanism that:

1. Ensures that the PSAP callback call reaches the same device that made the associated emergency call; and

2. Identities that the call is a PSAP callback call.

Also, in order to prevent fraud, the callback indicator would need to be asserted by the network.

Regarding the suggestion to use GRUU, I assume a UA, before making the emergency call (eCALL), would perform an "emergency registration" (eREG), in order to retieve the "emergency gruu" (eGRUU).

One question is: if the UA deregisters the eREG after the eCALL, would the callback call still reach the UA?

Regards,

Christer

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 24 Jul 2011 01:04:35 +0800

> thing is having *A* mechanism that:

I'm not religious.

> made the associated emergency call; and

Right.

> 2. Identities that the call is a PSAP callback call.

You need to be clearer here: identifies to whom?  It would be relatively easy to identify to the UA, but less easy for a proxy that has no prior interaction with the call.

> be asserted by the network.

Specifically what sort of fraud?  Callbacks are usually charged as normal, so the only potential problem here is circumvention of normal call screening (redirection to voice mail, and so on), and then only when those sorts of policies are suppressed.

It's entirely possible that callbacks will be treated like normal calls.  Then I see very little reason to spend additional effort in special markings.

> Regarding the suggestion to use GRUU, I assume a UA, before making the 
> emergency call (eCALL), would perform an "emergency registration"
> (eREG), in order to retieve the "emergency gruu" (eGRUU).

That's possible.  It's also possible to simply register a pseudo-instance so that you get an extra GRUU (eGRUU) that you only use for emergency calls.  If that extra GRUU is only used for emergency calls, then all calls directed to it are probably callbacks.

You can then associate special policy (suppress some call screening) for calls directed to that particular GRUU, but I'm not aware of any burning need to do so.

> the callback call still reach the UA?

Does it matter?

Cheers,
Martin

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 23 Jul 2011 19:42:22 +0200

Hi, 

>You need to be clearer here: identifies to whom?  It would be 
>relatively easy to identify to the UA, but less easy for a 
>proxy that has no prior interaction with the call.

The home network.

>>Also, in order to prevent fraud, the callback indicator 
>>would need to be asserted by the network.
> 
>Specifically what sort of fraud?  Callbacks are usually 
>charged as normal, so the only potential problem here is 
>circumvention of normal call screening (redirection to voice 
>mail, and so on), and then only when those sorts of policies 
>are suppressed.
> 
>It's entirely possible that callbacks will be treated like 
>normal calls.  Then I see very little reason to spend 
>additional effort in special markings.

Sure, they CAN be treated as normal calls. But, it should also be possible for the home network to give special treatment the them. At least from an IMS perspective that typically would mean bypassing of services, but I assume that would apply also to other environments.
 
>>Regarding the suggestion to use GRUU, I assume a UA, before 
>>making the emergency call (eCALL), would perform an "emergency registration"
>That's possible.  It's also possible to simply register a 
>pseudo-instance so that you get an extra GRUU (eGRUU) that 
>you only use for emergency calls.  If that extra GRUU is only 
>used for emergency calls, then all calls directed to it are 
>probably callbacks.
> 
>You can then associate special policy (suppress some call 
>screening) for calls directed to that particular GRUU, but 
>I'm not aware of any burning need to do so.

We can look at the usage of GRUU.

What I want to get a decission on now is whether ECRIT it willing to work on a solution that takes the "home network callback identification" into consideration.

>>One question is: if the UA deregisters the eREG after the 
>>eCALL, would the callback call still reach the UA?
> 
>Does it matter?

What do you mean? The callback call should reach the UA, shouldn't it? :)

Regards,

Christer

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 24 Jul 2011 18:34:02 +0800

On 2011-07-23 at 13:42:22, Christer Holmberg wrote:
> >You need to be clearer here: identifies to whom?  ...
> 
> The home network.

Right, assuming that a home network proxy saw the original call is not going to work.

As far as a call marking, the question for me becomes whether the call marking is explicit or negotiated.  An explicit indicator might be easier, but I'd like to find a solution that required as few implementation warts as possible.

> Sure, they CAN be treated as normal calls. But, it should also be 
> possible for the home network to give special treatment the them. At 
> least from an IMS perspective that typically would mean bypassing of 
> services, but I assume that would apply also to other environments.

And this is the dangerous part, I see.  Allowing arbitrary calls to be marked would open up the possibility of abuse.  Unless you ensured that only PSAPs (and their agents) could mark such calls.

> What I want to get a decission on now is whether ECRIT it willing to 
> work on a solution that takes the "home network callback 
> identification" into consideration.

It's a reasonable goal.  But consider the option where no specific marking is made, and the UE is instead required to inform the home network that a particular GRUU is in fact an "eGRUU".  Or, the UE doesn't say so directly, and instead requests specific call handling policy for a particular GRUU.

The answer is all tied up in whether it is desirable for the home network to be able to unilaterally apply policy.

> >>One question is: if the UA deregisters the eREG after the eCALL,
> would
> >>the callback call still reach the UA?
> >
> >Does it matter?
> 

Of course, but there are so many reasons why a callback could fail already.  It certainly isn't an inviolable axiom.  Is there any reason why you wouldn't say "Deregistration: don't do that." ?

I'd say that it would be more likely that a user turns off their phone than an implementer would allow deregistration, particularly if a specification expressly prohibited it.

--Martin

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 24 Jul 2011 22:08:55 +0200

Hi Martin, 

>call is not going to work.

Correct. The original call might not have traversed the home network.

>As far as a call marking, the question for me becomes whether 
>the call marking is explicit or negotiated.  An explicit 
>indicator might be easier, but I'd like to find a solution 
>that required as few implementation warts as possible.

I agree.

>>possible for the home network to give special treatment the 
>>them. At least from an IMS perspective that typically would mean 
>>bypassing of services, but I assume that would apply also to other environments.
> 
>And this is the dangerous part, I see. Allowing arbitrary 
>calls to be marked would open up the possibility of abuse.  
>Unless you ensured that only PSAPs (and their agents) could 
>mark such calls.

Yes. That's why such marking would have to be asserted.

>>What I want to get a decission on now is whether ECRIT it 
>>willing to work on a solution that takes the "home network callback 
>It's a reasonable goal. But consider the option where no 
>specific marking is made, and the UE is instead required to 
>inform the home network that a particular GRUU is in fact an 
>"eGRUU". Or, the UE doesn't say so directly, and instead 
>requests specific call handling policy for a particular GRUU.
> 
>The answer is all tied up in whether it is desirable for the 
>home network to be able to unilaterally apply policy.
> 
>Of course, but there are so many reasons why a callback could 
>fail already. It certainly isn't an inviolable axiom.  Is 
>there any reason why you wouldn't say "Deregistration: don't 
>do that." ?
> 
>I'd say that it would be more likely that a user turns off 
>their phone than an implementer would allow deregistration, 
>particularly if a specification expressly prohibited it.
 
I guess it depends on whether you have a dedicated emergency registration or not. In such cases I think it's quite normal that you would un-register after you've finished the call

Of course, you could wait for some time before you unregister.

Regards,

Christer