Subject: [Ecrit] Device Identity in PIDF-LO (from draft-ietf-ecrit-data-only-ea-01 and SIP Location Conveyance)

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 7 Jul 2011 11:27:37 +0300

Hi James, 

the example in draft-ietf-ecrit-data-only-ea-01 uses the device id in the PIDF-LO:

   <?xml version="1.0" encoding="UTF-8"?>
      <presence xmlns="urn:ietf:params:xml:ns:pidf"
          xmlns:gp="urn:ietf:params:xml:ns:pidf:geopriv10"
          xmlns:cl="urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr"
          xmlns:gml="http://www.opengis.net/gml"
          entity="pres:[email-masked]">
        <tuple id="12345">
         <dm:device id="sensor1">
          <gp:geopriv>
            <gp:location-info>
              <gml:location>
                <gml:Point srsName="urn:ogc:def:crs:EPSG::4326">
                  <gml:pos>32.86726 -97.16054</gml:pos>
                </gml:Point>
               </gml:location>
            </gp:location-info>
            <gp:usage-rules>
              <gp:retransmission-allowed>yes
              </gp:retransmission-allowed>
              <gp:retention-expiry>2010-07-30T20:00:00Z
              </gp:retention-expiry>
            </gp:usage-rules>
            <gp:method>802.11</gp:method>
           </gp:geopriv>
***          <dm:deviceID>mac:1234567890ab</dm:deviceID> ***
          <dm:timestamp>2010-07-28T20:57:29Z</dm:timestamp>
         </dm:device>
        </tuple>
      </presence>

The example was copied from SIP Location Conveyance and modified slightly. 

Now, Martin indicated that this usage of the deviceID requires the definition of the mac: URI scheme. James noted that this mac: URI scheme approach dated back to the time when we worked on the HELD identity extension but in the end a different approach was chosen (namely using separate XML elements). 

So, for me the question is now what to put in there. I could just omit this example altogether but how do we put a MAC address as a device id into a PIDF-LO then. 

Ciao
Hannes

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 07 Jul 2011 15:00:04 -0500

>The example was copied from SIP Location Conveyance and modified slightly.

thanks for including the example and where the mods were done.

>Now, Martin indicated that this usage of the deviceID requires the 
>definition of the mac: URI scheme.

sounds about right, but...

>James noted that this mac: URI scheme approach dated back to the 
>time when we worked on the HELD identity extension but in the end a 
>different approach was chosen (namely using separate XML elements).

... just because the HELD identity work went in another direction, 
does that mean you can't use a mac: URI? There's gotta be one defined 
already as a deviceID within the presence docs. I think I remember 
RFC 3856 referring to it when discussing layer 2 devices like cellphones.

>So, for me the question is now what to put in there. I could just 
>omit this example altogether but how do we put a MAC address as a 
>device id into a PIDF-LO then.

I think this is already defined as a part of presence, but just 
because it was discussed in one of those RFCs doesn't mean it was 
defined there.

James

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 7 Jul 2011 23:13:20 +0300

On Jul 7, 2011, at 11:00 PM, James M. Polk wrote:

> , does that mean you can't use a mac: URI? There's gotta be one defined already as a deviceID within the presence docs. I think I remember RFC 3856 referring to it when discussing layer 2 devices like cellphones.

It would be great if someone has defined a URI scheme for this purpose already. I have not seen it. 
If we have to define one fine as well.

---

From: "Winterbottom, James" <[email-masked]>
Date: Fri, 8 Jul 2011 06:34:40 +0800

I don't believe that there is one already defined.
The Presence Data Model document is the first place that I saw this used and I couldn't find one defined then and that is why an earlier version of the identity extensions document defined one. As far as I recall, Cullen was one of the people that suggested getting a mac URI scheme would be nearly impossible to get through the IESG and suggested that we use the UUID scheme defined in RFC4122 instead.

Cheers
James

James Winterbottom
Global Product Manager
CommScope GeoLENs
IP Location Product Portfolio
Email: [email-masked]
Phone: +61-2-42-212938
Mobile: +61-447-773-560

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hannes Tschofenig
> Sent: Friday, 8 July 2011 6:13 AM
> To: James M. Polk
> Cc: [email-masked]
> Subject: Re: [Ecrit] Device Identity in PIDF-LO (from draft-ietf-ecrit-
> data-only-ea-01 and SIP Location Conveyance)
> 
> 
> > , does that mean you can't use a mac: URI? There's gotta be one defined
> already as a deviceID within the presence docs. I think I remember RFC
> 3856 referring to it when discussing layer 2 devices like cellphones.
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 11 Jul 2011 08:57:20 +0800

On 2011-07-08 at 06:13:20, Hannes Tschofenig wrote:
> > , does that mean you can't use a mac: URI? There's gotta be one
> defined already as a deviceID within the presence docs. I think I 
> remember RFC 3856 referring to it when discussing layer 2 devices like 
> cellphones.

It wasn't 3856, it was 4474.  And that has some invalid examples.  But then, there are plenty of those about.
 
> If we have to define one fine as well.

I did a little asking around on that point.  The short answer: "woe to he who tries to register a URI scheme".

There are all sorts of problems to overcome if you define the new scheme.  MAC, EUI-48, vs. EUI-64; urn:mac:... or just mac:...; URI parameters y/n; ...

Easier to avoid the problem altogether.  It's only an example.  Fix the example.

--Martin