Subject: [Ecrit] draft-tschofenig-ecrit-xmpp-es-00.txt comments

From: Gunnar Hellström <[email-masked]>
Date: Wed, 14 Mar 2012 07:14:27 +0100

Hannes and all,
It is good that this draft is published.

Whatever architecture is decided for handling of XMPP in emergency 
services, conversion outside or bring it in, it is important to collect 
information on what factors shall be considered and what problems to solve.

I have made some mainly editorial comments that I send in a changemarked 
copy to you, Hannes.

Here, I just want to comment that I suggest to include a section about 
session handling as well.

A starting proposal:
---------------------------------------------------------------------------------------------------------------

4.9  <http://tools.ietf.org/html/draft-tschofenig-ecrit-xmpp-es-00#section-4.8>   Sessions  versus Messaging in  EmergencyCommunication

Emergency case handling  is currently handled in sessions by the call takers.
In most cases it is most efficient if the same call taker can handle the call
and  any subsequent calls back, so that the detailed knowledge of the case is maintained.  

XMPP messaging sessions are often not ended by any specific signaling indicating
the end of a session.  This causes a need to artificially create an end of a session,
  so that human and technical resources can be released.

It also creates a need to keep messages together in the session evenwhen the user
  is  travelling  and moves between PSAP areas during the session.

There is thus a need to create a method for a pseudo-session management of XMPP messages,
  influencing the routing and linking to emergency case.          

__________________________________________________________________________

/Gunnar

[email-masked] skrev 2012-03-05 21:16:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
> 	Title           : Emergency Services Functionality with the Extensible Messaging and Presence Protocol (XMPP)
> 	Author(s)       : Hannes Tschofenig
> 	Filename        : draft-tschofenig-ecrit-xmpp-es-00.txt
> 	Pages           : 17
> 	Date            : 2012-03-05
>
>     The Extensible Messaging and Presence Protocol (XMPP) is a technology
>     that enjoys widespread deployment in the instant messaging
>     application domain.  While many features for XMPP had been
>     standardized in the IETF as well as in the XMPP Standards Foundation
>     emergency services functionality was not part of it.
>
>     This document aims to initiate a discussion about the necessary
>     emergency services functionality for XMPP.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-tschofenig-ecrit-xmpp-es-00.txt

---

From: Bernard Aboba <[email-masked]>
Date: Sat, 17 Mar 2012 11:54:00 -0700

One question I have is whether we are talking about XMPP Instant Messaging, or MUC (XEP-045) or some mixture of both. The draft currently doesn't mention MUC, but one can imagine a per-incident chat room.  

There are several ways that MUC could be used.  For example, contact between the user and PSAP might be via IM,;  however, caller and dispatcher messages could also be forwarded to an MUC within the PSAP where police, fire and medical could provide information to the dispatcher.  Alternatively, the caller might actually be placed into a per-incident MUC. 

Date: Wed, 14 Mar 2012 07:14:27 +0100
From: [email-masked]
To: [email-masked]; [email-masked]
Subject: [Ecrit] draft-tschofenig-ecrit-xmpp-es-00.txt   comments

    

    Hannes and all,

    Whatever architecture is decided for handling of XMPP in emergency
    services, conversion outside or bring it in, it is important to
    collect information on what factors shall be considered and what
    problems to solve. 

    I have made some mainly editorial comments that I send in a
    changemarked copy to you, Hannes.

    Here, I just want to comment that I suggest to include a section
    about session handling as well.

    A starting proposal:

    
    4.9  Sessions versus Messaging in Emergency Communication
     
    It also creates a need to keep messages together in the session even when the user

    

    

    /Gunnar

  

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit