Subject: [Ecrit] -additional-data-04

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 17 Jul 2012 11:54:12 -0400

http://tools.ietf.org/html/draft-ietf-ecrit-additional-data-04

New release has changes as requested by Matt Serra (from NENA) and some edits for the discussion Martin Thomson and I had on how to have one Call-Info URI with multiple MIME types.  I think the benefits of the MIME are slim and the overhead is not worth it, but I did the link. I also added a registry of block types to make the job of the client (PSAP) easier.

On the NENA updates, I started making the change requested to handle what they called "data provider" but it looked to ugly to me.  I did it a different way: I add a type of provider called "subcontractor" and added two elements: the "Principal" (the service provider who the subcontractor is contracted to and "Priority" (who should be contacted first, the subcontractor or the principal).  I think this is a better way to solve the problem which generalized to more cases than the specific backwards compatible mechanism proposed.

I think that this document is ready for work group last call.

Brian

---

From: Randall Gellens <[email-masked]>
Date: Wed, 25 Jul 2012 18:50:23 -0700

Hi Brian,

Did you look at the edits I suggested back in November, submitted 
against -02?  When I asked you in March about it since they weren't 
reflected in -03, you said you'd missed them by accident.  It doesn't 
look like you considered them in -04, so I'd like to know if this was 
deliberate or accidental (in which case an -05 might be a good idea 
prior to WGLC).

At 11:54 AM -0400 7/17/12, Brian Rosen wrote:

>  New release has changes as requested by Matt Serra (from NENA) and 
> some edits for the discussion Martin Thomson and I had on how to 
> have one Call-Info URI with multiple MIME types.  I think the 
> benefits of the MIME are slim and the overhead is not worth it, but 
> I did the link. I also added a registry of block types to make the 
> job of the client (PSAP) easier.
>
>  On the NENA updates, I started making the change requested to 
> handle what they called "data provider" but it looked to ugly to 
> me.  I did it a different way: I add a type of provider called 
> "subcontractor" and added two elements: the "Principal" (the 
> service provider who the subcontractor is contracted to and 
> "Priority" (who should be contacted first, the subcontractor or the 
> principal).  I think this is a better way to solve the problem 
> which generalized to more cases than the specific backwards 
> compatible mechanism proposed.
>
>  _______________________________________________
>  Ecrit mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/ecrit

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Genetics explains why you look like your father, and if you don't,
why you should.