Subject: [Ecrit] comment field in additional-data

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 9 Aug 2012 11:42:18 -0400

Would there be any objection to adding a field in the service provider info block for a comment?
I'm asking because we found a backwards compatibility issue in NENA, but I think it's generally useful.  There are always a couple of things it may be helpful to tell the call taker (human).  I'd put cautionary text in that suggests using an extension mechanism to pass actual data intended to be consumed by an automaton.  This is just for free text to be displayed to a call taker or other PSAP staff.

---

From: Matt Serra <[email-masked]>
Date: Thu, 9 Aug 2012 16:28:19 -0500

Brian - 

No objection, but a question:

We mentioned possibly putting this field into the PIDF instead.  Did we arrive on putting this into the Add'l Call Data to keep the PIDF "clean" assuming it has no alternate use outside of 9-1-1?

I suspect the driver is also based on whether the "Comment" is related to the address, or the provider/service as well.

Thanks.

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 9 Aug 2012 18:30:47 -0400

Well, I think we want entities other than an access network to be able to use a comment, so the latter of your two answers is what I would say.

If there is a comment in additional-data, I don't think we need another in PIDF.

Brian

On Aug 9, 2012, at 5:28 PM, Matt Serra <[email-masked]> wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Randall Gellens <[email-masked]>
Date: Thu, 30 Aug 2012 11:52:08 -0700

Would a comment in the service provider block and a comment in the 
PIDF be directed at different uses? Likely I'm misunderstanding one, 
the other, or both.  I read Brian's note on adding a comment to the 
service provider block as a way for a service provider to add 
free-form information to, for example, the contact info for the 
service provider ("For non-emergency requests, call the listed 
administrative number and ask for Marge; if it's an emergency, call 
the listed mobile number").  A comment in the PIDF-LO would be a way 
to make a remark regarding the location.

At 6:30 PM -0400 8/9/12, Brian Rosen wrote:

>  Well, I think we want entities other than an access network to be 
> able to use a comment, so the latter of your two answers is what I 
> would say.
>
>>  We mentioned possibly putting this field into the PIDF instead. 
>> Did we arrive on putting this into the Add'l Call Data to keep the 
>> PIDF "clean" assuming it has no alternate use outside of 9-1-1?
>>
>>  I suspect the driver is also based on whether the "Comment" is 
>> related to the address, or the provider/service as well.
>>
>>  Thanks.
>>
>>  I'm asking because we found a backwards compatibility issue in 
>> NENA, but I think it's generally useful.  There are always a 
>> couple of things it may be helpful to tell the call taker (human). 
>> I'd put cautionary text in that suggests using an extension 
>> mechanism to pass actual data intended to be consumed by an 
>> automaton.  This is just for free text to be displayed to a call 
>> taker or other PSAP staff.
>>
>>
>>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Boling's postulate:
    If you're feeling good, don't worry.  You'll get over it.

---

From: "Delaine Arnold ENP" <[email-masked]>
Date: Thu, 30 Aug 2012 15:21:53 -0400

PIDF-LO already has a LOC (Additional Location Information).  Why won't that
work?

Thank you,
Delaine
---------------------------------------
Delaine M. Arnold, ENP
NENA Data Structures Sub-Committee Chair
Voice:  813-960-1698
Cell:     813-928-1692
Email:  [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Randall Gellens
Sent: Thursday, August 30, 2012 2:52 PM
To: Rosen, Brian; Matt Serra
Cc: Rosen, Brian; [email-masked] Org
Subject: Re: [Ecrit] comment field in additional-data

Would a comment in the service provider block and a comment in the PIDF be
directed at different uses? Likely I'm misunderstanding one, the other, or
both.  I read Brian's note on adding a comment to the service provider block
as a way for a service provider to add free-form information to, for
example, the contact info for the service provider ("For non-emergency
requests, call the listed administrative number and ask for Marge; if it's
an emergency, call the listed mobile number").  A comment in the PIDF-LO
would be a way to make a remark regarding the location.

At 6:30 PM -0400 8/9/12, Brian Rosen wrote:

>>  I'm asking because we found a backwards compatibility issue in NENA, 
>> but I think it's generally useful.  There are always a couple of 
>> things it may be helpful to tell the call taker (human).
>> I'd put cautionary text in that suggests using an extension mechanism 
>> to pass actual data intended to be consumed by an automaton.  This is 
>> just for free text to be displayed to a call taker or other PSAP 
>> staff.
>>
>>
>>

-------------- Randomly selected tag: --------------- Boling's postulate:

---

From: Matt Serra <[email-masked]>
Date: Thu, 30 Aug 2012 16:31:25 -0500

I'll respond, as I think I'm responsible for the confusion.

Brian proposes that this new "Comment" field appear ONLY within the Additional-Data Service Provider Block and NOT within the PIDF.  This way, anyone can populate the "Comment" field.  If it were in the PIDF, only access networks could populate the new "Comment" field.

I think this field should only be used to provide incremental comments about the Service Provider, or the Services Provided, and NOT about the location.  It would be better to carry information about the location in a separate Call-Info header having the Purpose parameter set to 'emergencyLocationData' (at least this is what is documented in the NENA i3 specification).

Matt.

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: Thursday, August 30, 2012 2:52 PM
To: Rosen, Brian; Matt Serra
Cc: Rosen, Brian; [email-masked] Org
Subject: Re: [Ecrit] comment field in additional-data

Would a comment in the service provider block and a comment in the PIDF be directed at different uses? Likely I'm misunderstanding one, the other, or both.  I read Brian's note on adding a comment to the service provider block as a way for a service provider to add free-form information to, for example, the contact info for the service provider ("For non-emergency requests, call the listed administrative number and ask for Marge; if it's an emergency, call the listed mobile number").  A comment in the PIDF-LO would be a way to make a remark regarding the location.

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 30 Aug 2012 18:19:33 -0400

Please let's not get additional location data confused with this.

The request is for free text from a service provider in the path of an emergency call, or in the case of a PIDF, the author of a PIDF.  

"Additional Location Data" is defined by NENA as information specific to a location (not a PIDF, but the location the PIDF represents).  It has things like floor plans, tenant/building owner contact data, elevator status, ..  It probably could use a comment field, but it's an entirely separate data structure, not defined in this document.

Brian

---

From: Matt Serra <[email-masked]>
Date: Thu, 30 Aug 2012 20:59:43 -0500

Agreed.  I was trying to address Randall's remark about using a comment in the PIDF to "to make a remark regarding location" - which is best left to Brian's definition of Additional Location Data.