Subject: [Ecrit] PSAP Callback Draft

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 18 Oct 2012 11:49:10 +0300

Hi all, 

Christer and I had put the new text into the (not-yet-submitted) draft. Here is the current snapshot:
https://github.com/hannestschofenig/tschofenig-ids/blob/master/psap-callback/draft-ietf-ecrit-psap-callback-06.txt

Feedback we can be incorporated before the submission deadline. 

Ciao
Hannes

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 18 Oct 2012 13:05:10 -0400

Hannes, Christer, ecrit wg,

Robert, Adam and I have been discussing how best to handle the updating 
of the Priority header to include a new value. Ideally there would 
already be an IANA registry with defined procedures for adding new 
values. But there isn't.

So we have two alternatives:

1) Simply mark this draft as an update to 3261. Provide ABNF that 
extends the syntax of the Priority header. (As your planned draft does.)

2) Make an update to 3261 that establishes a new IANA registry for 
Priority header field values, and populate it with all the values 
included in 3261. Set the rules for adding new values to that registry. 
Then set your new draft to follow those rules to add the new value to 
the registry.

The 2nd way is clearly more work, but it is the "cleaner" way to do it. 
Robert has concerns that if we don't do that, and go with (1), then we 
will have some difficulty getting it through IESG.

So we would prefer to do (2). Adam already put together a draft of a 
draft to do the revision to 3261. We can have that ready to submit when 
submissions are opened up again the first day in Atlanta. It is quite a 
straightforward thing to do so we expect we can have it approved and 
ready for the IESG soon enough that it won't slow your work up. Once 
that draft is filed you will be able to reference it in your draft so 
they can be wrapped up in parallel.

Is ecrit ok with that direction?

	Thanks,
	Paul (as sipcore co-chair)

On 10/18/12 4:49 AM, Hannes Tschofenig wrote:
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 18 Oct 2012 20:31:27 +0300

I am curious why you need a separate draft just to create an additional 
registry. We still have "space left" in the current PSAP callback draft...

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Oct 2012 18:14:04 +0000

Hi,

I am ok with (2). Does anyone have a problem with taking such approach (we obviously still need to sort out the details)?

Now, regarding the documentation.

As Hannes also asked, do we really need a separate draft in order to create the registry? I don't really care if we create a separate draft or not, but I would like to have a decision soon. I don't think we need to spend f2f time in Atlanta to discuss the documentation.

But, separate draft or not, we can still work on the procedure text that I suggested. So, please read and comment :)

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 18. lokakuuta 2012 20:05
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Ecrit] PSAP Callback Draft

Robert, Adam and I have been discussing how best to handle the updating of the Priority header to include a new value. Ideally there would already be an IANA registry with defined procedures for adding new values. But there isn't.

1) Simply mark this draft as an update to 3261. Provide ABNF that extends the syntax of the Priority header. (As your planned draft does.)

2) Make an update to 3261 that establishes a new IANA registry for Priority header field values, and populate it with all the values included in 3261. Set the rules for adding new values to that registry. 
Then set your new draft to follow those rules to add the new value to the registry.

The 2nd way is clearly more work, but it is the "cleaner" way to do it. 
Robert has concerns that if we don't do that, and go with (1), then we will have some difficulty getting it through IESG.

So we would prefer to do (2). Adam already put together a draft of a draft to do the revision to 3261. We can have that ready to submit when submissions are opened up again the first day in Atlanta. It is quite a straightforward thing to do so we expect we can have it approved and ready for the IESG soon enough that it won't slow your work up. Once that draft is filed you will be able to reference it in your draft so they can be wrapped up in parallel.

	Thanks,

On 10/18/12 4:49 AM, Hannes Tschofenig wrote:
> https://github.com/hannestschofenig/tschofenig-ids/blob/master/psap-ca
> llback/draft-ietf-ecrit-psap-callback-06.txt
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 18 Oct 2012 14:32:28 -0400

> registry. We still have "space left" in the current PSAP callback draft...

Oh, I thought it was "full". :-)

We did discuss putting all the stuff to establish the IANA registry and 
grandfather the existing values into your draft. We just think that 
seems like a poor organization. (Sort of a layering violation.)
We also aren't out of RFC numbers yet. :-)

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 18 Oct 2012 20:22:09 +0000

Hi,

So, just to clarify: Adam is working on a draft which will create the IANA registry for Priority header field values, and the psap-callback draft will then define and register a new header field value into that registry?

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 18. lokakuuta 2012 21:32
To: Hannes Tschofenig
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ecrit] PSAP Callback Draft

On 10/18/12 1:31 PM, Hannes Tschofenig wrote:
> I am curious why you need a separate draft just to create an 
> additional registry. We still have "space left" in the current PSAP callback draft...

We did discuss putting all the stuff to establish the IANA registry and grandfather the existing values into your draft. We just think that seems like a poor organization. (Sort of a layering violation.) We also aren't out of RFC numbers yet. :-)

	Thanks,
	Paul

>> Robert, Adam and I have been discussing how best to handle the 
>> updating of the Priority header to include a new value. Ideally there 
>> would already be an IANA registry with defined procedures for adding 
>> new values. But there isn't.
>>
>> Robert has concerns that if we don't do that, and go with (1), then 
>> we will have some difficulty getting it through IESG.
>>
>> draft to do the revision to 3261. We can have that ready to submit 
>> when submissions are opened up again the first day in Atlanta. It is 
>> quite a straightforward thing to do so we expect we can have it 
>> approved and ready for the IESG soon enough that it won't slow your 
>> work up. Once that draft is filed you will be able to reference it in 
>> your draft so they can be wrapped up in parallel.
>>
>>> https://github.com/hannestschofenig/tschofenig-ids/blob/master/psap-
>>> callback/draft-ietf-ecrit-psap-callback-06.txt
>>>
>>>
>>>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 18 Oct 2012 21:26:22 -0400

> So, just to clarify: Adam is working on a draft which will create the IANA registry for Priority header field values, and the psap-callback draft will then define and register a new header field va…

Yes!

	Thanks,
	Paul

---

From: Marc Linsner <[email-masked]>
Date: Fri, 19 Oct 2012 08:42:30 -0400

Paul,

So do we have a commitment to progress both drafts expeditiously??  (Or at
least in lockstep so PSAP-Callback doesn't sit in the RFC Editor blackhole
due to dependencies)

Thanks,

-Marc-

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Thursday, October 18, 2012 9:26 PM
To: Christer Holmberg <[email-masked]>
Cc: "[email-masked]" <[email-masked]>,
"[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [Ecrit] PSAP Callback Draft

>> So, just to clarify: Adam is working on a draft which will create the
>>IANA registry for Priority header field values, and the psap-callback
>>draft will then define and register a new header field value into that
>>registry?
>
>Yes!
>
>	Thanks,
>	Paul
>
>> Regards,
>>
>> Christer
>>
>>seems like a poor organization. (Sort of a layering violation.) We also
>>aren't out of RFC numbers yet. :-)
>>
>> 	Thanks,
>> 	Paul
>>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 19 Oct 2012 11:38:52 -0400

> least in lockstep so PSAP-Callback doesn't sit in the RFC Editor blackhole

Yes, that is the plan.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 19 Oct 2012 19:01:02 +0000

Hi,

I support moving ahead with two drafts. 

Because, that means we can keep the psap-callback draft in ECRIT, while I assume the Privacy registry draft will be produced in SIPCORE.

Assuming, of course, that SIPCORE will agree to produce such draft. I hope such agreement can come asap.

Regards,

Christer

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: 19. lokakuuta 2012 18:39
To: Marc Linsner
Cc: Christer Holmberg; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ecrit] PSAP Callback Draft

On 10/19/12 8:42 AM, Marc Linsner wrote:
> Paul,
>
> So do we have a commitment to progress both drafts expeditiously??  
> (Or at least in lockstep so PSAP-Callback doesn't sit in the RFC 
> Editor blackhole due to dependencies)

Yes, that is the plan.

	Thanks,
	Paul

>>> So, just to clarify: Adam is working on a draft which will create 
>>> the IANA registry for Priority header field values, and the 
>>> psap-callback draft will then define and register a new header field 
>>> value into that registry?
>>
>> Yes!
>>
>> 	Thanks,
>> 	Paul
>>
>>> Regards,
>>>
>>> Christer
>>>
>>> We did discuss putting all the stuff to establish the IANA registry 
>>> and grandfather the existing values into your draft. We just think 
>>> that seems like a poor organization. (Sort of a layering violation.) 
>>>>> updating of the Priority header to include a new value. Ideally 
>>>>> there would already be an IANA registry with defined procedures 
>>>>> for adding new values. But there isn't.
>>>>>
>>>>> Robert has concerns that if we don't do that, and go with (1), 
>>>>> then we will have some difficulty getting it through IESG.
>>>>>
>>>>> So we would prefer to do (2). Adam already put together a draft of 
>>>>> a draft to do the revision to 3261. We can have that ready to 
>>>>> submit when submissions are opened up again the first day in 
>>>>> Atlanta. It is quite a straightforward thing to do so we expect we 
>>>>> can have it approved and ready for the IESG soon enough that it 
>>>>> won't slow your work up. Once that draft is filed you will be able 
>>>>> to reference it in your draft so they can be wrapped up in parallel.
>>>>>
>>>>>> https://github.com/hannestschofenig/tschofenig-ids/blob/master/ps
>>>>>> ap- callback/draft-ietf-ecrit-psap-callback-06.txt
>>>>>>
>>>>>>
>>>>>>

---

From: James Polk <[email-masked]>
Date: Fri, 19 Oct 2012 14:46:44 -0500

At 02:01 PM 10/19/2012, Christer Holmberg wrote:

>Because, that means we can keep the psap-callback draft in ECRIT, 
>while I assume the Privacy

s/privacy/priority

>registry draft will be produced in SIPCORE.
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 19 Oct 2012 21:47:35 +0000

Correct :)

Regards,

Christer 

-----Original Message-----
From: James Polk [mailto:[email-masked]] 
Sent: 19. lokakuuta 2012 22:47
To: Christer Holmberg; 'Paul Kyzivat'; Marc Linsner
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ecrit] PSAP Callback Draft

At 02:01 PM 10/19/2012, Christer Holmberg wrote:

>Because, that means we can keep the psap-callback draft in ECRIT, while 
>I assume the Privacy

s/privacy/priority

> >>> psap-callback draft will then define and register a new header 
> >>> field value into that registry?
> >>
> >> Yes!
> >>
> >>      Thanks,
> >>      Paul
> >>
> >>> Regards,
> >>>
> >>> Christer
> >>>
> >>> We did discuss putting all the stuff to establish the IANA 
> >>> registry and grandfather the existing values into your draft. We 
> >>> just think that seems like a poor organization. (Sort of a 
> >>> layering violation.) We also aren't out of RFC numbers yet. :-)
> >>>
> >>>     Thanks,
> >>>     Paul
> >>>
> >>>>> 1) Simply mark this draft as an update to 3261. Provide ABNF 
> >>>>> that extends the syntax of the Priority header. (As your planned 
> >>>>> draft
> >>>>> does.)
> >>>>>
> >>>>> 2) Make an update to 3261 that establishes a new IANA registry 
> >>>>> for Priority header field values, and populate it with all the 
> >>>>> values included in 3261. Set the rules for adding new values to 
> >>>>> that registry.
> >>>>> So we would prefer to do (2). Adam already put together a draft 
> >>>>> of a draft to do the revision to 3261. We can have that ready to 
> >>>>> Atlanta. It is quite a straightforward thing to do so we expect 
> >>>>> we can have it approved and ready for the IESG soon enough that 
> >>>>> it won't slow your work up. Once that draft is filed you will be 
> >>>>> able to reference it in your draft so they can be wrapped up in parallel.
> >>>>>
> >>>>>> Christer and I had put the new text into the 
> >>>>>> (not-yet-submitted) draft. Here is the current snapshot:

---

From: Adam Roach <[email-masked]>
Date: Fri, 19 Oct 2012 14:27:29 -0500

> So, just to clarify: Adam is working on a draft which will create the IANA registry for Priority header field values, and the psap-callback draft will then define and register a new header field va…

That's the plan. I have one ready, and will be submitting it Monday of 
the IETF meeting, in order to start the ball rolling in SIPCORE as soon 
as possible.

/a