Subject: Re: [Ecrit] PSAP Callback Draft

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Fri, 19 Oct 2012 15:57:54 +0300

Experience tells me to put the stuff in one document. Just think about Phone BCP...

Sent from my Windows Phone

-----Original Message-----
From: ext Marc Linsner
Sent: 10/19/2012 3:42 PM
To: Paul Kyzivat; Christer Holmberg
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Ecrit] PSAP Callback Draft

Paul,

So do we have a commitment to progress both drafts expeditiously??  (Or at
least in lockstep so PSAP-Callback doesn't sit in the RFC Editor blackhole
due to dependencies)

Thanks,

-Marc-

-----Original Message-----
From: Paul Kyzivat <[email-masked]>
Date: Thursday, October 18, 2012 9:26 PM
To: Christer Holmberg <[email-masked]>
Cc: "[email-masked]" <[email-masked]>,
"[email-masked]" <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [Ecrit] PSAP Callback Draft

>On 10/18/12 4:22 PM, Christer Holmberg wrote:
>>
>> Hi,
>>
>> So, just to clarify: Adam is working on a draft which will create the
>>IANA registry for Priority header field values, and the psap-callback
>>draft will then define and register a new header field value into that
>>registry?
>
>Yes!
>
>	Thanks,
>	Paul
>
>> Regards,
>>
>> Christer
>>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>>Of Paul Kyzivat
>> Sent: 18. lokakuuta 2012 21:32
>> To: Hannes Tschofenig
>> Cc: [email-masked]; [email-masked];
>>[email-masked]
>> Subject: Re: [Ecrit] PSAP Callback Draft
>>
>> On 10/18/12 1:31 PM, Hannes Tschofenig wrote:
>>> I am curious why you need a separate draft just to create an
>>> additional registry. We still have "space left" in the current PSAP
>>>callback draft...
>>
>> Oh, I thought it was "full". :-)
>>
>> We did discuss putting all the stuff to establish the IANA registry and
>>grandfather the existing values into your draft. We just think that
>>seems like a poor organization. (Sort of a layering violation.) We also
>>aren't out of RFC numbers yet. :-)
>>
>> 	Thanks,
>> 	Paul
>>
>>> On 10/18/2012 08:05 PM, Paul Kyzivat wrote:
>>>> Hannes, Christer, ecrit wg,
>>>>
>>>> Robert, Adam and I have been discussing how best to handle the
>>>> updating of the Priority header to include a new value. Ideally there
>>>> would already be an IANA registry with defined procedures for adding
>>>> new values. But there isn't.
>>>>
>>>> So we have two alternatives:
>>>>
>>>> 1) Simply mark this draft as an update to 3261. Provide ABNF that
>>>> extends the syntax of the Priority header. (As your planned draft
>>>> does.)
>>>>
>>>> 2) Make an update to 3261 that establishes a new IANA registry for
>>>> Priority header field values, and populate it with all the values
>>>> included in 3261. Set the rules for adding new values to that
>>>>registry.
>>>> Then set your new draft to follow those rules to add the new value to
>>>> the registry.
>>>>
>>>> The 2nd way is clearly more work, but it is the "cleaner" way to do
>>>>it.
>>>> Robert has concerns that if we don't do that, and go with (1), then
>>>> we will have some difficulty getting it through IESG.
>>>>
>>>> So we would prefer to do (2). Adam already put together a draft of a
>>>> draft to do the revision to 3261. We can have that ready to submit
>>>> when submissions are opened up again the first day in Atlanta. It is
>>>> quite a straightforward thing to do so we expect we can have it
>>>> approved and ready for the IESG soon enough that it won't slow your
>>>> work up. Once that draft is filed you will be able to reference it in
>>>> your draft so they can be wrapped up in parallel.
>>>>
>>>> Is ecrit ok with that direction?
>>>>
>>>>       Thanks,
>>>>       Paul (as sipcore co-chair)
>>>>
>>>> On 10/18/12 4:49 AM, Hannes Tschofenig wrote:
>>>>> Hi all,
>>>>>
>>>>> Christer and I had put the new text into the (not-yet-submitted)
>>>>> draft. Here is the current snapshot:
>>>>> https://github.com/hannestschofenig/tschofenig-ids/blob/master/psap-
>>>>> callback/draft-ietf-ecrit-psap-callback-06.txt
>>>>>
>>>>>
>>>>>
>>>>> Feedback we can be incorporated before the submission deadline.
>>>>>
>>>>> Ciao
>>>>> Hannes
>>>>>
>>>>> _______________________________________________
>>>>> Ecrit mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/ecrit
>>>>>
>>>>
>>>> _______________________________________________
>>>> Ecrit mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/ecrit
>>>
>>>
>>
>> _______________________________________________
>> Ecrit mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ecrit
>>
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Adam Roach <[email-masked]>
Date: Fri, 19 Oct 2012 14:25:48 -0500

[speaking as SIPCORE chair]

Hannes:

I understand the concern -- but the counter is that fixing what appears 
to be a bug in the core SIP spec* seems a bit out of charter for ECRIT. 
I'm not entirely certain you'd have review from the SIP community at 
large for creation of the registry, and I think that such visibility is 
necessary.

The SIPCORE document would be a very short one. The only issue that is 
likely (in my personal opinion) to generate significant discussion is 
IANA registration policy. Given that SIPCORE doesn't have a ton on its 
plate right now, I'm pretty comfortable that we can get such a document 
pubreq'd fast enough that it won't get in the way of ECRIT's document 
being published.

/a

* To wit: I consider it a bug that we have defined a clear extension 
point in the protocol without also defining a registry for values.

On 10/19/12 7:57 AM, Tschofenig, Hannes (NSN - FI/Espoo) wrote:
> ------------------------------------------------------------------------
> From: ext Marc Linsner
> Sent: 10/19/2012 3:42 PM