Subject: [Ecrit] Establishing a "Priority" header field registry

From: Adam Roach <[email-masked]>
Date: Tue, 06 Nov 2012 10:53:41 -0500

[as an individual]

The document draft-ietf-ecrit-psap-callback has identified a desire to 
add a new value to the "Priority" header field for SIP. While RFC 3261 
clearly intended the values in this header field to be extensible, it 
did not define a registry of such values.

To address this oversight, I have put together a small draft that 
defines such a registry and populates it with the values defined by RFC 
3261. Because this is a correction to the core SIP specification, it is 
my belief that it falls within the charter of the SIPCORE working group.

The only real open issue, in my opinion, is the IANA registration policy 
that should apply to new "Priority" header field values. To avoid 
blocking any work in ECRIT, we need to move this work (or something 
equivalent) forward very quickly. If you have any interest in the topic, 
please review and comment with some urgency.

http://www.ietf.org/id/draft-roach-sipcore-priority-00.txt

[The following request is being made in my WG chair role]
As this is a SIPCORE matter, please discuss it on the SIPCORE list 
rather than the ECRIT list.

Thanks!

/a

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 6 Nov 2012 13:22:19 -0500

I support this work.  I agree with Christer about a registration template.  While it is obvious what is requested, I think it's better to have it.

I am happy with "IETF Review" as the management policy.

Brian

On Nov 6, 2012, at 10:53 AM, Adam Roach <[email-masked]> wrote:

> [as an individual]
> 
> The document draft-ietf-ecrit-psap-callback has identified a desire to add a new value to the "Priority" header field for SIP. While RFC 3261 clearly intended the values in this header field to be extensible, it did not define a registry of such values.
> 
> To address this oversight, I have put together a small draft that defines such a registry and populates it with the values defined by RFC 3261. Because this is a correction to the core SIP specification, it is my belief that it falls within the charter of the SIPCORE working group.
> 
> The only real open issue, in my opinion, is the IANA registration policy that should apply to new "Priority" header field values. To avoid blocking any work in ECRIT, we need to move this work (or something equivalent) forward very quickly. If you have any interest in the topic, please review and comment with some urgency.
> 
> As this is a SIPCORE matter, please discuss it on the SIPCORE list rather than the ECRIT list.
> 
> Thanks!
> 
> /a
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: James Polk <[email-masked]>
Date: Tue, 06 Nov 2012 22:05:20 -0600

I support this work

James

At 12:22 PM 11/6/2012, Rosen, Brian wrote:
>I support this work.  I agree with Christer about a registration 
>template.  While it is obvious what is requested, I think it's 
>better to have it.
>
> > The document draft-ietf-ecrit-psap-callback has identified a 
> desire to add a new value to the "Priority" header field for SIP. 
> While RFC 3261 clearly intended the values in this header field to 
> be extensible, it did not define a registry of such values.
> >
> defines such a registry and populates it with the values defined by 
> RFC 3261. Because this is a correction to the core SIP 
> specification, it is my belief that it falls within the charter of 
> the SIPCORE working group.
> >
> > The only real open issue, in my opinion, is the IANA registration 
> policy that should apply to new "Priority" header field values. To 
> avoid blocking any work in ECRIT, we need to move this work (or 
> something equivalent) forward very quickly. If you have any 
> interest in the topic, please review and comment with some urgency.
> >
>Ecrit mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ecrit

---

From: Janet P Gunn <[email-masked]>
Date: Wed, 7 Nov 2012 09:07:50 -0500

I also support this work
Janet

This is a PRIVATE message. If you are not the intended recipient, please 
delete without copying and kindly advise us by e-mail of the mistake in 
delivery. NOTE: Regardless of content, this e-mail shall not operate to 
bind CSC to any order or other contract unless pursuant to explicit 
written agreement or government initiative expressly permitting the use of 
e-mail for such purpose.

From:   James Polk <[email-masked]>
To:     "Rosen, Brian" <[email-masked]>, "[email-masked]" 
<[email-masked]>
Cc:     "[email-masked]" <[email-masked]>
Date:   11/06/2012 11:05 PM
Subject:        Re: [Ecrit] [sipcore] Establishing a "Priority" header 
field registry
Sent by:        [email-masked]

I support this work

James