Subject: [Ecrit] 'emergency-callback' instead of 'psap-callback' ??

From: Shida Schubert <[email-masked]>
Date: Thu, 8 Nov 2012 16:25:48 +0900

Just found out two days ago that we may need to implement 
what ever that comes out of this.. 

 "psap" seems to be a very regional specific name, it definitely 
doesn't mean anything in Japan and probably in many other 
countries in the world.. 

 Considering this may need to be implemented in Countries where 
"PSAP" has no meaning, can we come up with more generic name 
that is acceptable around the world like "emergency-callback"??

  Regards
   Shida

On Oct 16, 2012, at 8:57 PM, Christer Holmberg wrote:

> Hi,
>  
> I drafted some initial text regarding the new SIP Priority header field ’psap-callback’ value.
>  
> Feel free to comment :)
>  
> -----------------------
>  
> X.            PSAP Callback Indicator.
>  
> X.1          General
>  
> This section defines a new header field value, "psap-callback", for the SIP Priority header field [RFC3261].
> The value is used by a SIP entity to inform downstream entities that the request is associated with a PSAP callback
> SIP session.
>  
> x.2          Usage
>  
> SIP entities that receive the header field value within an initial request for a SIP session, or within a standalone
> SIP request, can, depending on local policies, apply PSAP callback specific procedures for the session or request.
>  
> PSAP callback specific procedures might be applied both by network entities and by the callee. The specific procedures
> are outside the scope of this document, but typically include bypassing services and barring procedures.
>  
> x.3          Syntax
>  
> x.3.1      General
>  
>    This Section defines the ABNF for the new SIP Priority header field value, "psap-callback".
>  
> x.3.2      ABNF
>  
> priority-value  /=  "psap-callback"
>  
> -----------------------
>  
> Regards,
>  
> Christer
>  
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: James Polk <[email-masked]>
Date: Thu, 08 Nov 2012 09:31:24 -0600

While I appreciate your intent, I need to fall back to the idea that 
there are many many different types of emergencies, and many of them 
are based on the perspective of the person having the emergency, and 
not by how a local, regional or national determines what is and what 
is not an emergency.

While I understand that 'psap' might not be know, 'emergency' or 
'emergency-<anything>' is just too broad and can be either misused or 
misunderstood.

For example, is the fact that I really need to make a point to 
someone who just hung up on my fall into the 'emergency-callback' 
realm we're specifying in ECRIT? I don't believe so, especially if 
that someone is my ex-spouse, who has a restraining order against me 
(she doesn't, but I'm just using that as an example.

I could use a ex-boyfriend or ex-girlfriend example, or a 
(unreasonable) daughter/son example, or a boss/subordinate example, 
or even a telemarketer example that everyone probably can relate to.

I mean, we're talking about turning off DNR and call forward services 
that I probably otherwise want to have enabled in nearly or every 
case except the 911/112 case.

my 2.25 cents (before taxation - which is coming soon)

James

At 01:25 AM 11/8/2012, Shida Schubert wrote:

>>I drafted some initial text regarding the new SIP Priority header 
>>field 'psap-callback' value.
>>
>>Feel free to comment :)
>>
>>-----------------------
>>
>>The value is used by a SIP entity to inform downstream entities 
>>that the request is associated with a PSAP callback
>>SIP session.
>>
>>x.2          Usage
>>
>>SIP entities that receive the header field value within an initial 
>>request for a SIP session, or within a standalone
>>SIP request, can, depending on local policies, apply PSAP callback 
>>specific procedures for the session or request.
>>
>>PSAP callback specific procedures might be applied both by network 
>>entities and by the callee. The specific procedures
>>are outside the scope of this document, but typically include 
>>bypassing services and barring procedures.
>>
>>x.3          Syntax
>>
>>x.3.1      General
>>
>><mailto:[email-masked]>[email-masked]

---

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 8 Nov 2012 23:37:51 +0800

I don't understand how having psap-callback addresses the examples below since if the ex can mark her call as emergency-callback she can just as easily mark it as psap-callback.
The term PSAP certainly isn't universal though its understanding is certainly growing.
I think that Shida's proposal is perfectly reasonable and would be my preferred option.

Cheers
James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James Polk
Sent: Friday, 9 November 2012 2:31 AM
To: Shida Schubert; [email-masked]
Subject: Re: [Ecrit] 'emergency-callback' instead of 'psap-callback' ??

While I appreciate your intent, I need to fall back to the idea that there are many many different types of emergencies, and many of them are based on the perspective of the person having the emergency, and not by how a local, regional or national determines what is and what is not an emergency.

While I understand that 'psap' might not be know, 'emergency' or 'emergency-<anything>' is just too broad and can be either misused or misunderstood.

For example, is the fact that I really need to make a point to someone who just hung up on my fall into the 'emergency-callback' 
realm we're specifying in ECRIT? I don't believe so, especially if that someone is my ex-spouse, who has a restraining order against me (she doesn't, but I'm just using that as an example.

I could use a ex-boyfriend or ex-girlfriend example, or a
(unreasonable) daughter/son example, or a boss/subordinate example, or even a telemarketer example that everyone probably can relate to.

I mean, we're talking about turning off DNR and call forward services that I probably otherwise want to have enabled in nearly or every case except the 911/112 case.

James

At 01:25 AM 11/8/2012, Shida Schubert wrote:

>  Just found out two days ago that we may need to implement what ever 
>that comes out of this..
>
>doesn't mean anything in Japan and probably in many other countries in 
>the world..
>
>  Considering this may need to be implemented in Countries where "PSAP" 
>has no meaning, can we come up with more generic name that is 
>acceptable around the world like "emergency-callback"??
>
>   Regards
>    Shida
>
>>The value is used by a SIP entity to inform downstream entities that 
>>the request is associated with a PSAP callback SIP session.
>>
>>x.2          Usage
>>
>>request for a SIP session, or within a standalone SIP request, can, 
>>depending on local policies, apply PSAP callback specific procedures 
>>for the session or request.
>>
>>entities and by the callee. The specific procedures are outside the 
>>scope of this document, but typically include bypassing services and 
>>barring procedures.
>>
>>x.3          Syntax
>>
>>x.3.1      General
>>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 8 Nov 2012 16:01:48 +0000

Hi,

Some time ago, there was a concensus call for the value on the list, and "psap-callback" was chosen. 

Regards,

Christer 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Winterbottom, James
Sent: 8. marraskuuta 2012 17:38
To: James Polk; Shida Schubert; [email-masked]
Subject: Re: [Ecrit] 'emergency-callback' instead of 'psap-callback' ??

Cheers
James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of James Polk
Sent: Friday, 9 November 2012 2:31 AM
To: Shida Schubert; [email-masked]
Subject: Re: [Ecrit] 'emergency-callback' instead of 'psap-callback' ??

James

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 8 Nov 2012 17:06:27 +0100

I would prefer to just stick with what we have currently agreed, and just make sure we have adequately defined the term PSAP to encompass other countries emergency call architectures to encompass it where the use is appropriate, and certainly to exclude examples as proposed by James Polk.

Regards

Keith

> Sent: 08 November 2012 15:38
> I don't understand how having psap-callback addresses the examples below
> since if the ex can mark her call as emergency-callback she can just as
> easily mark it as psap-callback.
> While I appreciate your intent, I need to fall back to the idea that there
> are many many different types of emergencies, and many of them are based
> on the perspective of the person having the emergency, and not by how a
> local, regional or national determines what is and what is not an
> emergency.
> 
> For example, is the fact that I really need to make a point to someone who
> just hung up on my fall into the 'emergency-callback'
> realm we're specifying in ECRIT? I don't believe so, especially if that
> someone is my ex-spouse, who has a restraining order against me (she
> doesn't, but I'm just using that as an example.
> 
> (unreasonable) daughter/son example, or a boss/subordinate example, or
> even a telemarketer example that everyone probably can relate to.
> 
> I mean, we're talking about turning off DNR and call forward services that
> I probably otherwise want to have enabled in nearly or every case except
> the 911/112 case.
>