Subject: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

From: Christer Holmberg <[email-masked]>
Date: Fri, 15 Feb 2013 08:33:16 +0000

Hi,

As previously discussed, some existing emergency services might be offered in one specific country only, and RFC 5031 currently does not allow registering country specific service URNs.

We have submitted a draft, draft-holmberg-ecrit-country-emg-urn-00.txt, which suggests a solution, by defining a dedicated URN sub-service, with a relaxed registration policy, for country specific emergency services.

Such URN would look something like: urn:service:sos.country-specific.<two letter country code>.<identifier assigned by PSAP>

Feel free to comment :)

I would also like to request agenda in Orlando to discuss this.

Regards,

Christer

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 15 Feb 2013 12:04:29 +0200

Christer, I may misunderstand your writeup. 

We already have certain service URNs that are applicable only to certain countries. As an example pick mountain rescue (urn:service:sos.mountain). 

Karl Heinz later defined an extension that allows you to list the available service URNs in a specific region, see  
http://tools.ietf.org/html/rfc6197

You may want to do is to register a new Service URN for spy reporting, GAULA (anti-kidnapping), etc.

Ciao
Hannes

On Feb 15, 2013, at 10:33 AM, Christer Holmberg wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Ivo Sedlacek <[email-masked]>
Date: Fri, 15 Feb 2013 10:58:57 +0000

Hello,

The mountain rescue emergency service is offered at least in Austria (Alpine rescue) and Ireland (The Mountain and Cave Rescue) according to http://en.wikipedia.org/wiki/Emergency_telephone_number and in Poland (ratownictwo morskie i górskie) according to http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410

Thus, RFC5031 criteria for registration (see below) are satisfied for the mountain rescue emergency service.

------------------

   The 'sos' service type describes emergency services requiring an

   immediate response, typically offered by various branches of the

   government or other public institutions.  Additional sub-services can

   be added after expert review and must be of general public interest

   and have a similar emergency nature.  The expert is designated by the

   ECRIT working group, its successor, or, in their absence, the IESG.

   >>The expert review should only approve emergency services that are

   offered widely and in different countries, with approximately the

   same caller expectation in terms of services rendered. << The 'sos'

   service is not meant to invoke general government, public

   information, counseling, or social services.

------------------

However,

- the "Reporting spies" emergency service is offered in South Korea only and thus would not pass the RFC5031 criteria above.

- the "GAULA (anti-kidnapping)" emergency service is offered in Colombia only and thus would not pass the RFC5031 criteria above.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: 15. února 2013 11:04
To: Christer Holmberg
Cc: [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Ciao

Hannes

> [email-masked]<mailto:[email-masked]>

Ecrit mailing list

[email-masked]<mailto:[email-masked]>

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 15 Feb 2013 18:10:41 +0200

Hi Ivo, 

you are correct that there are restrictions on what you can register under the sos tree. The idea was that it focuses on the emergency services rescue functionality and not on other functionality that do not have the emergency services nature (such as pizza delivery) or are otherwise entirely different. 

If you believe it does not belong under the sos tree for the indicated reasons then it may make sense to register it under a different label. 

Ciao
Hannes

On Feb 15, 2013, at 12:58 PM, Ivo Sedlacek wrote:

> Hello,
>  
> The mountain rescue emergency service is offered at least in Austria (Alpine rescue) and Ireland (The Mountain and Cave Rescue) according tohttp://en.wikipedia.org/wiki/Emergency_telephone_number and in Poland (ratownictwo morskie i górskie) according to http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 15 Feb 2013 16:24:45 +0000

Hi Hannes,

The idea is not to create a mechanism for pizza delivery, or whatever other non-emergency-nature service - even if they would be specific to one country.

Or, do you foresee that one would call James Bond to deliver a pizza? ;)

Regards,

Christer

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: 15. helmikuuta 2013 18:11
To: Ivo Sedlacek
Cc: Hannes Tschofenig; Christer Holmberg; [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Hi Ivo, 

Ciao
Hannes

---

From: Richard Barnes <[email-masked]>
Date: Fri, 15 Feb 2013 14:40:47 -0500

I would be a little concerned about the registry growing quite large.
 Things are very number-based right now, but it's not a far stretch to
imagine UI based on available emergency services (e.g.,
http://geopriv.dreamhosters.com/web911/).  So it could be challenging for
developers if the list grew large or rapidly changing.

It seems to me that the more conservative approach would be to just update
the IANA registration policy to be slightly more liberal.

--Richard

On Fri, Feb 15, 2013 at 11:24 AM, Christer Holmberg <
[email-masked] <javascript:_e({}, 'cvml',
[email-masked]');>> wrote:

> Hi Hannes,
>
> The idea is not to create a mechanism for pizza delivery, or whatever
> other non-emergency-nature service - even if they would be specific to one
> country.
>
> From: Hannes Tschofenig [mailto:[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>
> ]
> Cc: Hannes Tschofenig; Christer Holmberg; [email-masked]<javascript:_e({}, 'cvml', [email-masked]');>
> Subject: Re: [Ecrit] Draft new:
> draft-holmberg-ecrit-country-specific-emergency-services-00
>
> Hi Ivo,
>
> you are correct that there are restrictions on what you can register under
> the sos tree. The idea was that it focuses on the emergency services rescue
> functionality and not on other functionality that do not have the emergency
> services nature (such as pizza delivery) or are otherwise entirely
> different.
>
> If you believe it does not belong under the sos tree for the indicated
> reasons then it may make sense to register it under a different label.
>
> Ciao
> Hannes
>
> > The mountain rescue emergency service is offered at least in Austria
> (Alpine rescue) and Ireland (The Mountain and Cave Rescue) according
> tohttp://en.wikipedia.org/wiki/Emergency_telephone_number and in Poland
> (ratownictwo morskie i górskie) according to
> http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410
> >
> > - the "Reporting spies" emergency service is offered in South Korea only
> and thus would not pass the RFC5031 criteria above.
> > - the "GAULA (anti-kidnapping)" emergency service is offered in Colombia
> only and thus would not pass the RFC5031 criteria above.
> >
> > Kind regards
> >
> > Ivo Sedlacek
> >
> > This Communication is Confidential. We only send and receive email on
> the basis of the terms set out at www.ericsson.com/email_disclaimer
> >
> > From: [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');> [mailto:[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>]
> On Behalf Of Hannes Tschofenig
> > Cc: [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>
> > Subject: Re: [Ecrit] Draft new:
> draft-holmberg-ecrit-country-specific-emergency-services-00
> >
> > We already have certain service URNs that are applicable only to certain
> countries. As an example pick mountain rescue (urn:service:sos.mountain).
> >
> > Karl Heinz later defined an extension that allows you to list the
> available service URNs in a specific region, see
> > > As previously discussed, some existing emergency services might be
> offered in one specific country only, and RFC 5031 currently does not allow
> registering country specific service URNs.
> > >
> > > We have submitted a draft,
> draft-holmberg-ecrit-country-emg-urn-00.txt, which suggests a solution, by
> defining a dedicated URN sub-service, with a relaxed registration policy,
> for country specific emergency services.
> > >
> > > Such URN would look something like:
> urn:service:sos.country-specific.<two letter country code>.<identifier
> assigned by PSAP>
> > >
> > > Feel free to comment :)
> > >
> > > [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>
> > [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>
> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 18 Feb 2013 14:00:27 +0000

Hello,

thank you for your mail.

> It seems to me that the more conservative approach would be to just update the IANA registration policy to be slightly more liberal.

By "slightly more liberal", do you propose that the IANA registration policy for registration of any sub-service of the service URN with the 'sos' service type would be relaxed similarly as proposed in the draft (i.e. it is sufficient if the emergency service exists in single country only)? That would be possible. 

Or do you have other proposal?

Thank you for clarification.

Kind regards

 Ivo Sedlacek

---

From: Richard Barnes <[email-masked]>
Date: Mon, 18 Feb 2013 12:27:31 -0500

Yes, I was thinking that the policy would be that an emergency service
exists in one country.  The purpose of the registry would be just be to
encourage deduplication.  So, for instance, to encourage the several
different countries that have traffic police numbers* to all use something
like "urn:service:sos.traffic".  Or, to choose a better example, once Korea
has registered "urn:service:sos.espionage", to encourage the second country
that establishes a spy reporting service to also use that URN.

Alternatively, someone could just go through the list of emergency numbers
on Wikipedia and submit one big registration for the common ones (like
traffic police).  Those would be allowable under the current policy.

--Richard

* according to wikipedia: EG, SD, CN, IN**, PK, SA, AL, AM, AZ, NZ, CO, EC
** hopefully India could be persuaded to consolidate its three different
traffic police numbers

On Mon, Feb 18, 2013 at 9:00 AM, Ivo Sedlacek <[email-masked]>wrote:

> Hello,
>
> thank you for your mail.
>
> > It seems to me that the more conservative approach would be to just
> update the IANA registration policy to be slightly more liberal.
>
> By "slightly more liberal", do you propose that the IANA registration
> policy for registration of any sub-service of the service URN with the
> 'sos' service type would be relaxed similarly as proposed in the draft
> (i.e. it is sufficient if the emergency service exists in single country
> only)? That would be possible.
>
> This Communication is Confidential. We only send and receive email on the
> basis of the terms set out at www.ericsson.com/email_disclaimer
>

---

From: John-Luc Bakker <[email-masked]>
Date: Mon, 18 Feb 2013 17:39:23 +0000

Hi,

A few observations on the contents of the Wikipedia page.
The first entry shows Algeria having one number for medical AND fire: "14".
Should there be one URN for "medical" and "fire" registered with IANA? (A second country with one number for medical AND fire, "15" in their case, is Morocco).

Also, Algeria lists:

National Gendarmerie : 1055; Counter Terrorist Unit : 1548; support for children : 3033.

So, URNs for these may also be needed. However, I question if we should derive IANA-registered URNs from any Wikipedia page (which can be edited by others that national regulators).

Kind regards,

               John-Luc

From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Barnes
Sent: Monday, February 18, 2013 11:28 AM
To: Ivo Sedlacek
Cc: [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Yes, I was thinking that the policy would be that an emergency service exists in one country.  The purpose of the registry would be just be to encourage deduplication.  So, for instance, to encourage the several different countries that have traffic police numbers* to all use something like "urn:service:sos.traffic".  Or, to choose a better example, once Korea has registered "urn:service:sos.espionage", to encourage the second country that establishes a spy reporting service to also use that URN.

Alternatively, someone could just go through the list of emergency numbers on Wikipedia and submit one big registration for the common ones (like traffic police).  Those would be allowable under the current policy.

--Richard

* according to wikipedia: EG, SD, CN, IN**, PK, SA, AL, AM, AZ, NZ, CO, EC
** hopefully India could be persuaded to consolidate its three different traffic police numbers

On Mon, Feb 18, 2013 at 9:00 AM, Ivo Sedlacek <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

thank you for your mail.

Kind regards

 Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 18 Feb 2013 12:56:06 -0500

Hi John-Luc,

We actually already have separate URNs for medical and fire --
"urn:service:sos.ambulance"
and "urn:service:sos.fire" [1].  So that's not an issue.  LoST can map them
to the same or different numbers depending on the jurisdiction.  There is
also a "counseling" URN for children, "urn:service:counseling.children".

It might make sense to define new URNs for "national gendarmerie" /
"national police", and possibly "counter terrorism", since it seems that
those exist in several countries.

But in general, this is the sort of exercise that people should go through
for the various countries.

--Richard

[1] <
http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xml

On Mon, Feb 18, 2013 at 12:39 PM, John-Luc Bakker <[email-masked]> wrote:

>  Hi,****
>
> ** **
>
> A few observations on the contents of the Wikipedia page.****
>
> The first entry shows Algeria having one number for medical AND fire:
> “14”. ****
>
> Should there be one URN for “medical” and “fire” registered with IANA? (A
> second country with one number for medical AND fire, “15” in their case, is
> Morocco).****
>
> ** **
>
> Also, Algeria lists:****
>
> ** **
>
> National Gendarmerie : *1055*; Counter Terrorist Unit : *1548*; support
> for children : *3033*.****
>
> ** **
>
> So, URNs for these may also be needed. However, I question if we should
> derive IANA-registered URNs from any Wikipedia page (which can be edited by
> others that national regulators). ****
>
> ** **
>
> Kind regards,****
>
> ** **
>
>                John-Luc****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Richard Barnes
> *Sent:* Monday, February 18, 2013 11:28 AM
> *To:* Ivo Sedlacek
>
> *Cc:* [email-masked]
> *Subject:* Re: [Ecrit] Draft new:
> draft-holmberg-ecrit-country-specific-emergency-services-00****
>
> ** **
>
> that establishes a spy reporting service to also use that URN.****
>
> ** **
>
> traffic police).  Those would be allowable under the current policy.****
>
> ** **
>
> --Richard ****
>
> ** **
>
> ****
> traffic police numbers****
>
> ** **
>
> On Mon, Feb 18, 2013 at 9:00 AM, Ivo Sedlacek <[email-masked]>
> wrote:****
>
> Hello,
>
> thank you for your mail.****
>
>
> update the IANA registration policy to be slightly more liberal.****
>
> Thank you for clarification.****
>
>
> Kind regards
>
>  Ivo Sedlacek
>
> basis of the terms set out at www.ericsson.com/email_disclaimer****
>
> ** **
> This transmission (including any attachments) may contain confidential
> information, privileged material (including material protected by the
> solicitor-client or other applicable privileges), or constitute non-public
> information. Any use of this information by anyone other than the intended
> recipient is prohibited. If you have received this transmission in error,
> please immediately reply to the sender and delete this information from
> your system. Use, dissemination, distribution, or reproduction of this
> transmission by unintended recipients is not authorized and may be
> unlawful.
>

---

From: John-Luc Bakker <[email-masked]>
Date: Mon, 18 Feb 2013 18:26:59 +0000

Hi,

"urn:service:counseling.children" may be more suited for a non-emergency response (e.g. children requesting counseling because of a broken heart), whereas other examples exist where clearly a more urgent, more coordinated, local response is needed, perhaps identified by the following new URN "urn:service:sos.children".

Regards,

               John-Luc

From: Richard Barnes [mailto:[email-masked]]
Sent: Monday, February 18, 2013 11:56 AM
To: John-Luc Bakker
Cc: Ivo Sedlacek; [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Hi John-Luc,

We actually already have separate URNs for medical and fire -- "urn:service:sos.ambulance" and "urn:service:sos.fire" [1].  So that's not an issue.  LoST can map them to the same or different numbers depending on the jurisdiction.  There is also a "counseling" URN for children, "urn:service:counseling.children".

It might make sense to define new URNs for "national gendarmerie" / "national police", and possibly "counter terrorism", since it seems that those exist in several countries.

But in general, this is the sort of exercise that people should go through for the various countries.

--Richard

[1] <http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xml>

On Mon, Feb 18, 2013 at 12:39 PM, John-Luc Bakker <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Also, Algeria lists:

Kind regards,

               John-Luc

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Richard Barnes
Sent: Monday, February 18, 2013 11:28 AM
To: Ivo Sedlacek

Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

--Richard

thank you for your mail.

Kind regards

 Ivo Sedlacek

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 19 Feb 2013 02:03:48 +0100

To try and put things in context, I think there are four "problems" with the existing sos URN values. draft-holmberg-ecrit-country-specific-emergency-services-00 attempts to solve only one of these.

1)         There are a number of emergency services that exist in multiple countries where a sos subtype is not defined. My view is that we probably should define values for:
            -           traffic emergency
            -           child protection emergency (this is not the same as child counselling). For example Italy, among others, has such a value where an immediate response is required.
            Obviously before we can define these (and in addition to fulfilling the IANA registration requirements), we need to come up definitions of what these really mean.

2)         There are a number of emergency services that exist in a single country. Ideally, for use in networks where service URNs are used, these should have some form of service URN defined. This is what draft-holmberg-ecrit-country-specific-emergency-services-00 seeks to resolve.

3)         There are a number of countries where a number of distinct police forces exist. For any given location, these tend to be defined on a range of areas of jurisdiction, e.g. national versus municipal. This has been discussed on the list over the end of last year, and there seemed to be some consensus on defining a range of subtypes for subtype "police". Obviously it will not be possible to cover every variation with this, and we probably need to limit ourselves to values that serve in multiple countries, in the same way the higher level subtypes do.

4)                   There are a number of cases were PSAPs cover multiple subtypes. Where service URNs are being used in isolation, this is not an issue. However where service URNs are being created from dialled digits, a particular local service number in the telephony numbering plan could well map to two or more potential subtypes. Yes, in these cases we could ignore generating a subtype altogether, but some countries find it desirable to obtain all the information available from the user. Thus it would be useful to be able to say sos.fire+medical in these scenarios.

Note that all these issues fall under the "sos" definition of emergency service.

Regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Richard Barnes
Sent: 18 February 2013 17:56
To: John-Luc Bakker
Cc: [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Hi John-Luc,

--Richard

Also, Algeria lists:

Kind regards,

               John-Luc

--Richard

thank you for your mail.

Kind regards

 Ivo Sedlacek

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 19 Feb 2013 19:59:52 +0000

Hello,

> Yes, I was thinking that the policy would be that an emergency service exists in one country.

If the WG decides this is the best way forward, it would be OK for me.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>
From: Richard Barnes [mailto:[email-masked]]
Sent: 18. února 2013 18:28
To: Ivo Sedlacek
Cc: Christer Holmberg; Hannes Tschofenig; [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

--Richard

thank you for your mail.

Kind regards

 Ivo Sedlacek

---

From: John-Luc Bakker <[email-masked]>
Date: Tue, 19 Feb 2013 21:23:31 +0000

Hi all,

If we consider "urn:service:sos.espionage", and assume that in some jurisdiction the reporting of espionage is not seen as a specific "sos" sub service, i.e. not requiring an immediate response, then note that RFC 5031 includes:

  For any given service URN, service-identifiers can be removed

  right-to-left; the resulting URN is still valid, referring to

  a more generic service.

So, that would reduce "urn:service:sos.espionage" to "urn:service:sos". For this URN, RFC 5031 includes:

   urn:service:sos  The generic 'sos' service reaches a public safety
      answering point (PSAP), which in turn dispatches aid appropriate
      to the emergency.  It encompasses all of the services listed
      below.

Would this mean that in that jurisdiction PSAPs would get a higher load due to the fact that the IANA registry includes  "urn:service:sos.espionage", even though in that jurisdiction this is not considered an emergency?

For UAs that support and adhere to LOST, this may not be an issue as the UE should not have mapped the service identifier to "urn:service:sos.espionage". It would nevertheless be useful if the network is able to reject such requests due to the regulatory requirements in place in the jurisdiction.

Regards,

               John-Luc

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ivo Sedlacek
Sent: Tuesday, February 19, 2013 2:00 PM
To: Richard Barnes
Cc: [email-masked]
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-country-specific-emergency-services-00

Hello,

Kind regards

Ivo Sedlacek

Cc: Christer Holmberg; Hannes Tschofenig; [email-masked]<mailto:[email-masked]>

--Richard

thank you for your mail.

Kind regards

 Ivo Sedlacek