Subject: Re: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 3 Apr 2013 14:07:27 +0000

The way this is currently drafted does not in my view present the problem correctly.

It implies that the user wants an identical service, but that the endpoints (PSAPs) are somehow themselves addressed by different organisations. If the user wants an identical service then the URNs should not need to be distinctive.

Rather I think the problem is that we have a miscellaneous bunch of subservices which we do not wish to explicitly identify. Within any specific area, it is well known that some are associated with say a national organisation, and some with a local organisation. Thus for the police emergency call example used before, it would be well known that murder required the national police force, but burglary required the local police force. Therefore rather than identify a subtype for each crime, we use a label that represents the wider organisation or the more local organisation.

Regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dan Mongrain
Sent: 25 March 2013 13:28
To: [email-masked]
Subject: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

I submitted version 00 of my draft that documents Service Coverage Scope in Service URN.  I decided to call it Service Coverage Scope instead of Jurisdiction Scope only because it could be used to specify a service that is not government provided.  For example, I want to find a restaurant and I am looking for the neighbourhood pizza joint (not a national chain).  I would then specify Service URN "urn:service:restaurant.pizza.A5" (whatever the standard for restaurant Service URN would look like).  On the other hand, if I want the national pizza chain, I would specify "urn:service:restaurant.pizza.country".  I though of creating a .international Service Area Scope but decided to hold off and get comments first, especially since this is not necessary for Public Safety.  The is the Interpol that would fit the requirement for .international but they do not accept emergency calls (as far as I know).  I also did not include .A6 (street level) as I am not sure it makes sense, but again, willing to add as it costs nothing to do so.

This is my first Internet draft so please be indulgent.

Thanx,
Dan

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: March-25-13 9:15 AM
To: MONGRAIN Daniel
Subject: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

A new version of I-D, draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
has been successfully submitted by Daniel Mongrain and posted to the
IETF repository.

Filename:        draft-mongrain-ecrit-service-coverage-scope-urn
Revision:        00
Title:           Service Coverage Scope for Service URN
Creation date:   2013-03-25
Group:           Individual Submission
Number of pages: 6
URL:             http://www.ietf.org/internet-drafts/draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
Status:          http://datatracker.ietf.org/doc/draft-mongrain-ecrit-service-coverage-scope-urn
Htmlized:        http://tools.ietf.org/html/draft-mongrain-ecrit-service-coverage-scope-urn-00

Abstract:
   This document specifies a mechanism to specify a Service Coverage
   Scope in a Service URN [RFC5031] when multiple providers provide the
   same service for the same location.

The IETF Secretariat

---

From: MONGRAIN Daniel <[email-masked]>
Date: Wed, 3 Apr 2013 14:57:47 +0000

This is not necessarily true in the US.  While 9-1-1 is the well-known number to be used to report an emergency, lots of state police advertise that they can be called to report the same emergency.  They have advertised speed dial numbers (for example, *CSP for Colorado State Police or *ISP for Idaho State Police) that are to be used to call for assistance when on a mobile phone (see http://www.kansashighwaypatrol.org/about/state_contact.html).  Even if it was to report a traffic emergency, different police forces handle the emergency dependant on where the accident occurs (state police on freeways, local police on city streets).  Here in the city of Ottawa in Canada, there are three police forces that handle traffic: city police on city streets, Ontario Provincial Police for the freeway and Royal Canadian Mounted Police for federal parkways!  Good thing is that the only number to reach them all is 9-1-1, PSAP call taker transfers the call.  But just on the other side of the river in the province of Québec, QPP advertises *4141 for emergencies (in addition to 9-1-1 which goes to city police).

I am sure that in some countries service demarcation is clear between police forces, in the US the lines are quite blurry.  But I am happy to modify the text of the draft to make it more clear.

Thanx,
Dan

____________________________________________________
Dan Mongrain, eng.
Senior Systems Engineer, Public Safety
FREQUENTIS USA Inc.

9017 Red Branch Road, Suite 102 Columbia Maryland 21045
Phone   +1-301-657-8001
Mobile   +1-819-744-0491
Fax       +1-301-657-8002
Web      www.frequentis.com/usa<http://www.frequentis.com/Internet/>
E-Mail    [email-masked]<mailto:[email-masked]>

Incorporated in the State of Maryland
EIN: 52-2178926 CAGE Code: 1XKR9
____________________________________________________
Confidentiality Notice: This email message, including any attachments, is for the sole use of the intended recipient(s) and contains confidential and privileged information. Any unauthorized review, use, disclosure or distribution is prohibited. If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message and associated attachments.

From: DRAGE, Keith (Keith) [mailto:[email-masked]]
Sent: April-03-13 10:07 AM
To: Dan Mongrain; [email-masked]
Subject: RE: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Regards

Keith

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Dan Mongrain
Sent: 25 March 2013 13:28
To: [email-masked]<mailto:[email-masked]>
Subject: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Thanx,
Dan
-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: March-25-13 9:15 AM
To: MONGRAIN Daniel
Subject: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Abstract:

The IETF Secretariat

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 9 Apr 2013 17:21:12 +0000

The draft states:

   For some given location, there may be multiple providers that supply

   the same given service.

However, in case of the Czech republic, the responsibility and the services of municipal police and of the national police are similar but not completely same. E.g. municipal police does not handle murder cases.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>
From: [email-masked] [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: 3. dubna 2013 7:07
To: Dan Mongrain; [email-masked]
Subject: Re: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Regards

Keith

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Dan Mongrain

Thanx,
Dan
-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: March-25-13 9:15 AM
To: MONGRAIN Daniel
Subject: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Abstract:

The IETF Secretariat

---

From: Martin Thomson <[email-masked]>
Date: Tue, 9 Apr 2013 10:30:26 -0700

On 9 April 2013 10:21, Ivo Sedlacek <[email-masked]> wrote:
> However, in case of the Czech republic, the responsibility and the services
> of municipal police and of the national police are similar but not
> completely same. E.g. municipal police does not handle murder cases.

That interesting, but is it relevant?  e.g., would it be a problem if
I contacted municipal police to report a murder?

Keep in mind that we are talking about emergency contact, not debating
the finer points of jurisdiction.  If it is acceptable (and
manageable) for murders to be reported to the local municipality, then
a new URN might be unnecessary.

If it is relevant, as is the case with matters of jurisdiction in some
parts of the US (see example of local police v. highway patrol on a
highway overpass), then it behooves us to provide a way for the
distinction to be made by the person reporting the emergency.  A new
URN might be needed to allow for the distinction to be made.  (That
has usability issues, but that's not a problem that can be solved with
engineering.)

---

From: MONGRAIN Daniel <[email-masked]>
Date: Tue, 9 Apr 2013 17:50:56 +0000

In the case of reporting a murder in the Czech republic, we would create a service URN of urn:service:sos.police.murder (only if such calls are considered emergency calls) as the subservice distinction is important.  Routing of the call would then point to the national police.  The Service Coverage Scope draft addresses the case where there are two separate service providers that provide the same service.

With the wording "some given location" and "there may be" I am specifying that the application is not universal.  Usage of Service Coverage Scope is only acceptable in areas where such a case exists.

Thanx,
Dan

From: Ivo Sedlacek [mailto:[email-masked]]
Sent: April-09-13 1:21 PM
To: DRAGE, Keith (Keith); Dan Mongrain; [email-masked]
Subject: RE: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

The draft states:

   the same given service.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of DRAGE, Keith (Keith)
Sent: 3. dubna 2013 7:07
To: Dan Mongrain; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Regards

Keith

Thanx,
Dan
-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: March-25-13 9:15 AM
To: MONGRAIN Daniel
Subject: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

Abstract:

The IETF Secretariat

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Apr 2013 02:13:58 +0800

As a bystander, I'm curious what UI is anticipated that makes use of the 
large number of these different service urns that are being proposed?

If I'm a native in the Czech republic, do I have a special number that I 
call to report murders? (A number that is then translated by the phone 
to the urn.)

If I happen to be visiting the Czech republic from the US and I see a 
murder, how do *I* know how to report it?

	Thanks,
	Paul

On 4/10/13 1:50 AM, MONGRAIN Daniel wrote:
> In the case of reporting a murder in the Czech republic, we would create
> a service URN of urn:service:sos.police.murder (only if such calls are
> considered emergency calls) as the subservice distinction is important.
> Routing of the call would then point to the national police.  The
> Service Coverage Scope draft addresses the case where there are two
> separate service providers that provide the same service.
>
> With the wording “some given location” and “there may be” I am
> specifying that the application is not universal.  Usage of Service
> Coverage Scope is only acceptable in areas where such a case exists.
>
> Thanx,
>
> Dan
>
> *Dan Mongrain, eng.**
> *Senior Systems Engineer, Public Safety
> FREQUENTIS USA Inc.
>
> Webwww.frequentis.com/usa <http://www.frequentis.com/Internet/>
> E-Mail [email-masked] <mailto:[email-masked]>
>
> *Confidentiality Notice:*This email message, including any attachments,
> is for the sole use of the intended recipient(s) and contains
> confidential and privileged information. Any unauthorized review, use,
> disclosure or distribution is prohibited. If you are not the intended
> recipient, please contact the sender by reply email and destroy all
> copies of the originalmessage and associated attachments.
>
> *From:*Ivo Sedlacek [mailto:[email-masked]]
> *Sent:* April-09-13 1:21 PM
> *To:* DRAGE, Keith (Keith); Dan Mongrain; [email-masked]
> *Subject:* RE: [Ecrit] Fwd: FW: New Version Notification for
> draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
>
> The draft states:
>
> However, in case of the Czech republic, the responsibility and the
> services of municipal police and of the national police are similar but
> not completely same. E.g. municipal police does not handle murder cases.
>
> Kind regards
>
> Ivo Sedlacek
>
> This Communication is Confidential. We only send and receive email on
> the basis of the terms set out at www.ericsson.com/email_disclaimer
> <http://www.ericsson.com/email_disclaimer>
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] <mailto:[mailto:[email-masked]]>
> *On Behalf Of *DRAGE, Keith (Keith)
> *Sent:* 3. dubna 2013 7:07
> *To:* Dan Mongrain; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [Ecrit] Fwd: FW: New Version Notification for
> draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
>
> It implies that the user wants an identical service, but that the
> endpoints (PSAPs) are somehow themselves addressed by different
> organisations. If the user wants an identical service then the URNs
> should not need to be distinctive.
>
> Rather I think the problem is that we have a miscellaneous bunch of
> subservices which we do not wish to explicitly identify. Within any
> specific area, it is well known that some are associated with say a
> national organisation, and some with a local organisation. Thus for the
> police emergency call example used before, it would be well known that
> murder required the national police force, but burglary required the
> local police force. Therefore rather than identify a subtype for each
> crime, we use a label that represents the wider organisation or the more
> local organisation.
>
> Regards
>
> Keith
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Dan Mongrain
> *Sent:* 25 March 2013 13:28
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [Ecrit] Fwd: FW: New Version Notification for
> draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
>
> I submitted version 00 of my draft that documents Service Coverage Scope
> in Service URN.  I decided to call it Service Coverage Scope instead of
> Jurisdiction Scope only because it could be used to specify a service
> that is not government provided.  For example, I want to find a
> restaurant and I am looking for the neighbourhood pizza joint (not a
> national chain).  I would then specify Service URN
> "urn:service:restaurant.pizza.A5" (whatever the standard for restaurant
> Service URN would look like).  On the other hand, if I want the national
> pizza chain, I would specify "urn:service:restaurant.pizza.country".  I
> though of creating a .international Service Area Scope but decided to
> hold off and get comments first, especially since this is not necessary
> for Public Safety.  The is the Interpol that would fit the requirement
> for .international but they do not accept emergency calls (as far as I
> know).  I also did not include .A6 (street level) as I am not sure it
> makes sense, but again, willing to add as it costs nothing to do so.
>
> From: [email-masked] <mailto:[email-masked]>
> [mailto:[email-masked] <mailto:[email-masked]>]
> Subject: New Version Notification for
> draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-mongrain-ecrit-service-coverage-scope-urn-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-mongrain-ecrit-service-coverage-scope-urn
> Htmlized:
> http://tools.ietf.org/html/draft-mongrain-ecrit-service-coverage-scope-urn-00
>
>
> Abstract:
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 9 Apr 2013 14:30:16 -0400

Let's use a case more familiar to you:

Have you been on an highway that has a sign that says

"State Police patrol this highway, call *77"

"*77" is the dial string.  The service boundary is the road.  It leads to a specific responder agency, distinct from local police.

Brian

On Apr 9, 2013, at 2:13 PM, Paul Kyzivat <[email-masked]> wrote:

> As a bystander, I'm curious what UI is anticipated that makes use of the large number of these different service urns that are being proposed?
> 
> If I'm a native in the Czech republic, do I have a special number that I call to report murders? (A number that is then translated by the phone to the urn.)
> 
> If I happen to be visiting the Czech republic from the US and I see a murder, how do *I* know how to report it?
> 
> 	Thanks,
> 	Paul
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 9 Apr 2013 18:37:30 +0000

> That interesting, but is it relevant?  e.g., would it be a problem if I contacted municipal police to report a murder?

In Czech republic, municipal police will need to transfer the murder report to the national police. It will result in delay of any action.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer

---

From: MONGRAIN Daniel <[email-masked]>
Date: Tue, 9 Apr 2013 18:47:43 +0000

When a device enters an area, it can always interrogate the LoST service with a listServicesByLocation request which will return the list of services available for the given location.  Since not all services are available at all locations, then it can be expected that the list of services received should be very manageable.  The UI of the device could have an emergency call page/menu/whatever which displays the available emergency services for the location of the device.  The user would then pick the most appropriate service for the circumstances.

The list of possible services returned is finite as service URN must be documented in either an RFC or IANA registry, including a description of the service.  The device's manufacturer could have pre-provisioned the device with user-friendly icons and descriptions for all of the different service URNs that could be returned so the user would see not service URNs but a user-friendly interface (if there is a user-friendly icon for murder, that is).  As the device enters different jurisdictions, the device lists of emergency services changes to reflect the services available in that area.

Another way can be that the device is statically configured to show some/all emergency services.  The user selects a service and the device makes a findService request to the LoST service.  In the case that service is not available for the given location, the LoST service can always return another service that should  do the same.  Maybe more overwhelming to the user to show all services but may still be usable.  But definitely the first mechanism is preferable.

Thanx,
Dan

9017 Red Branch Road, Suite 102 Columbia Maryland 21045
Phone   +1-301-657-8001
Mobile   +1-819-744-0491
Fax       +1-301-657-8002
Web      www.frequentis.com/usa
E-Mail    [email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: April-09-13 2:14 PM
To: [email-masked]
Subject: Re: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

	Thanks,
	Paul

On 4/10/13 1:50 AM, MONGRAIN Daniel wrote:
> With the wording "some given location" and "there may be" I am

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 9 Apr 2013 19:08:06 +0000

Hello,

> As a bystander, I'm curious what UI is anticipated that makes use of the large number of these different service urns that are being proposed?

Normally, the UE selects the emergency service by dialling a number and the dialled digits get translated to emergency URN without human involvement. There may be other UI implementation thought.

> If I'm a native in the Czech republic, do I have a special number that I call to report murders? (A number that is then translated by the phone to the urn.)

There is a number for the national police = 158.
There is a number for the municipal police = 156.

> If I happen to be visiting the Czech republic from the US and I see a murder, how do *I* know how to report it?

Assuming a 3GPP compliant mobile phone is used then the roamed-to users can use:
1) globally valid numbers 112 and 911 -> this translates to urn:service:sos. This would be delivered to default PSAP.
2) any number for police emergency service  which is configured in the (U)SIM card (whatever valid in your own country) -> translates to urn:service:sos.police. In Czech republic, this would be delivered to PSAP of national police.
3) any number for police emergency service  which is provided by the Czech republic provider serving the UE (= 158) -> - translates to urn:service:sos.police. In Czech republic, this would be delivered to PSAP of national police.
4) 156 -> this is translated in network to the URN registered by IANA for the municipal police.

Kind regards

Ivo Sedlacek

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Apr 2013 03:11:36 +0800

> "*77" is the dial string.  The service boundary is the road.  It leads to a specific responder agency, distinct from local police.

I understand that case. (I also suspect that it doesn't work very well - 
how many people will notice the sign and know when to use *77 instead of 
911.)

I guess there could also be billboards around town announcing "Call *789 
if you witness a murder. But the more of these there are the less likely 
it is that callers will know to use them. Less is better.

	Thanks,
	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 10 Apr 2013 03:18:12 +0800

This is more what I was expecting to hear.
Is this actually being done anywhere?
Would be be legal. (Its my impression that emergency call buttons on 
phones are discouraged in the US.)
Can it be done so it works no matter where I take my phone?

I know it is not our place to specify the UI for this functionality. But 
it is easy to define things that almost guarantee poor UIs.
So IMO it is helpful to at least consider that reasonable UA is feasible.

	Thanks,
	Paul

---

From: MONGRAIN Daniel <[email-masked]>
Date: Tue, 9 Apr 2013 19:29:37 +0000

The emergency call button is discouraged because of the pocket dial issue (some phones allow an emergency number to be dialled if  you hold the button long enough even in the case of the keypad/screen being locked).  I do not think there is any regulations regarding easing the calling of emergency assistance as long as inadvertent dialling is reduced to a minimum/impossible.  An ecrit compliant device that interrogates LoST and intelligently displays available services is feasible in my mind.  Such a device would work wherever ecrit support is deployed. 

Dan

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: April-09-13 3:18 PM
To: MONGRAIN Daniel
Cc: [email-masked]
Subject: Re: [Ecrit] Fwd: FW: New Version Notification for draft-mongrain-ecrit-service-coverage-scope-urn-00.txt

	Thanks,
	Paul