Subject: [Ecrit] draft-ietf-ecrit-additional-data-10: service provider subscontractor

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 31 Jul 2013 17:08:02 +0000

I have several comments around items related to service provider subcontractor.
--------------------
3.1.4.  Type of Data Provider
Token: Service Provider Subcontractor
Comment 9: This is a fuzzy concept to me. I really don't understand what this is. Which to me suggests it's ambiguous as to how or when to use it.
Comment 10: Can a Service Provider Subcontractor only be a "Service Provider (Calling or Origination telecom SP), or can it also be one of the other types?, If it can be one of the other types, which value is to be used? Meaning of this Type element seems a bit overloaded to me.

Token: Expert Advice Provider        
Comment 11: Who does this provide advice to?
-----------------------
3.1.8.  Subcontractor Principal 

   Data  Element:  Subcontractor Principal

   XML Element:  <SubcontratorPrincipal>

   Description:  If the data provider is a subcontractor to another
      provider such as an access infrastructure provider or telematics
      provider, this element contains the DataProviderString of the
      service provider to indicate which provider the subcontractor is
      working for.  This data is required if the Data Provider type is
      subcontractor .

Comment 12: This element is not in xml in Section 6.1
Comment 13: There's no Use provided for this element.
Comment 14: As commented above, I think the info that the type field is trying to convey is overloaded, by trying to also convey subcontracting.  But also, I'm not really understanding this subcontractor concept. Is this anything like a wholesale relationship (ISP provides access by wholesaling the service of an access network provider)?
Comment 15: Does the last sentence of Description belong in a Use statement?
--------------------------
3.1.9.  Subcontractor Priority 

   Data Element:  Subcontractor Priority

   Use:  Required

Comment 16: This element is not in xml in Section 6.1
Comment 17: Is this really Required, or is it Conditional (on SubcontractorPrincipal being provided, or some other condition)?

---

From: Gunnar Hellstrom <[email-masked]>
Date: Wed, 31 Jul 2013 20:41:18 +0200

Barbara and Hannes,

The service provider topic was up for discussion between April 30 and 
May 6, under the subject "draft-ietf-ecrit-additional-data-07".
I do not think the discussions and proposals at that time led to any 
modifications to the draft.

I also have a feeling that the specification is "overloaded" in this 
area, but I would like to see comments from people closer to operations 
about the usefulness of the values and subdivisions in the service 
provider area.
Please review also these earlier comments together with Barbara's new.

Regards
Gunnar

On 2013-07-31 19:08, STARK, BARBARA H wrote:
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit