Subject: [Ecrit] Service URNs for specialized law enforcement and similar services

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 29 Jul 2013 13:28:59 -0400

We discussed at length today how to provide URNs for direct access to specialized first responder services. Here are some observations:

(1) While there are some generic descriptions, such as "sheriff" or "transit police", there are numerous variations by issues handled (e.g., "special victims unit", "SWAT team", "US Postal Inspector") and geography ("county police", "state police", "university campus police", "park police", "military police"). There are no clear boundaries in some cases between types of emergency handled and geography. For example, the US Postal Inspector isn't restricted to US post offices and deals with a wide variety of crimes, from mail fraud to mailing ricin. The FCC enforcement bureau has badges and enforces, among other things, antenna safety violations anywhere in the US.

Geography often overlaps - the NJ Transit and Amtrak police both deal with the North East Corridor and Penn Station.

(2) Something we did not discuss: People often need to access "out of area" services. For example, I might want to contact transit police after I leave the train, e.g., if I saw something suspicious, want to ask about a lost item or need to follow up on an earlier issue. In particular, it must be possible to reach NJ state police even if I'm just across the border in NY and I need to be able to reach the Amtrak police when I'm on NJ Transit. This is obviously trivial with using numbers, but it would be really confusing to be connected to NJ state police if I just talked to the NY version.

(3) We also didn't really discuss why we need a URN to begin with. I see three reasons:

(a) Automated location disclosure [and location-based routing] - you can disclose location if it's below 'sos', but not with some random number. That's both good and bad, as it is not clear that location and identity disclosure are always desirable for these services. The legal status is also different.

(b) Automated discovery - I should be able to discover all emergency services that are applicable to my area, as that's really painful right now. At least in the US, numbers for these services are not widely known (every sheriff's department has their own and so does every transit police department).

(c) Fall back - you can fall back to a generic emergency service if that service doesn't handle the local area. However, that's not always appropriate. If I'm *not* on the Columbia campus and call the Columbia University police number about a lost item, I don't want to be connected to 911.

(4) Unlike 911, these numbers are often used for emergencies and "business" non-emergency issues, such as reporting a crime that took place in the past rather than just crimes in progress.

I'll follow up with some opinions, but I hope this is reasonably non-controversial.

Henning

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 30 Jul 2013 07:12:25 +0000

Hello,

the issue occurs also outside of USA.

I have given in past (see attached) the Czech republic and Poland cases of PSAPs of different police forces which offer similar, but not completely the same, services in the same location. 

The difference in offered services comes from different legal status of the police forces:
- the one established by national goverment is responsible all crimes
- the one established by municipal authorities is responsible for minor crimes

It would be good to cover those in the discussion as well.

It might be good to extend the list to state:
(5) in some countries, in a given location, there are several PSAPs of emergency services (e.g. police forces) which offer similar, but not completely the same, service. A unique URN is needed for each of them.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: 29. července 2013 19:29
To: ECRIT
Subject: [Ecrit] Service URNs for specialized law enforcement and similar services

Henning
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

Subject: [Ecrit] What is the most appropriate method for registering new sub-services of urn:service:sos
From: Ivo Sedlacek <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Thu, 13 Dec 2012 13:22:02 +0000
List-Id: <ecrit.ietf.org>

Hello,

in the Czech republic, the national regulator defined two police related emergency services:

A) emergency service provided by the national police (number 158 in the public switched telephone network); and

B) emergency service provided by the municipal police (number 156 in the public switched telephone network).

The regulation is http://aplikace.mvcr.cz/archiv2008/sbirka/2007/sb043-07.pdf which lists the numbers 156 and 158 in section 4.5. with note 2) which states "Číslo je národním číslem pro tísňové volání" (= the number is a national number for emergency calls).

Is it appropriate to register the following URNs for those services with IANA?

- urn:service:sos.police.national - The 'police.national' service refers to the police department or other law enforcement authorities of the national government.

- urn:service:sos.police.municipal - The 'police.municipal' service refers to the police department or other law enforcement authorities of the municipal authorities.

Or should those be registered with a prefix indicating that those are applicable to Czech republic only, as other countries may have similar (but not necessarily identical) services:

- urn:service:sos.police.czech.national - The 'police.czech.national' service refers to the police department or other law enforcement authorities of the national government.

- urn:service:sos.police.czech.municipal - The 'police.czech.municipal' service refers to the police department or other law enforcement authorities of municipal authorities.

I assume this question belongs to IANA, but as the expert reviewer most likely will be from the ECRIT, I am sending it here.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer