Subject: [Ecrit] country specific emergency URNs

From: "Aleksiev, Vasil" <[email-masked]>
Date: Thu, 6 Jul 2017 13:36:44 +0200

Hello,

3GPP tried to register "sos.country-specific" sub-service type with IANA and got a comment back that "country-specific" is not an emergency service. There was a discussion on the last IETF meeting on this topic and as outcome 3 ways forward presented to 3GPP CT1 - change the registration process, create an exception in the registration process or use the current process.

There were discussions how to go forward with this topic in 3GPP CT1. With the help of some of the delegates list with emergency services was prepared in order to see what exactly problems we might have with registration. You can see the list attached.

Looking to the list there are some issues which I believe cannot be solved within the current registration process. I have tried to summarize the comments and the examples that we had during our discussions in 3GPP CT1 and to start a discussion in ECRIT mailing list regarding the possible registration of these specific emergency services. Meanwhile there is a process to make the list with the emergency services bigger.

There are some conclusions seen from the list:

 1.  Each emergency service needs to have unique emergency service URN. Handling in IMS can be different than handling in CS.

Example1:

In Czech republic, there is a "Municipal police" emergency service (156) and a "Police of the Czech Republic" emergency service (158) + other emergency services.

Within the CS domain it is possible to indicate the emergency service required, but in a limited set (3GPP TS 22.101) - there is only one bit for Police in the Emergency category Information Element.

An operator in Czech republic can provide to a UE via NAS a mapping of 158 and the Police bit in the Emergency category IE. Whenever the user dials 158 in Czech republic, this causes the UE to use a CS EMERGENCY SETUP with the Emergency category IE with the Police bit set or a UE-detectable IMS emergency call setup with the Request-URI set to the urn:service:sos.police, sent within emergency PDN connection. Either the MSC or the IMS network in Czech republic route the call to the PSAP providing the "Police of the Czech Republic" emergency service.

The operator in Czech republic canNOT provide to a UE via NAS a mapping of 156 and a bit in the Emergency category Information element since:
- the "Police" bit is taken for the "Police of the Czech Republic" emergency service (which is provided by a different PSAP than the PSAP providing the "Municipal police" emergency service);
- there is no other related bit; and
- providing no bit implies a generic emergency service (which is provided by a different PSAP than the PSAP providing the "Municipal police" emergency service).

Given that the UE is not configured with 156, whenever the user dials 156 in Czech republic, this causes the UE to use a CS SETUP for 156 or a non-emergency IMS call setup for tel:156;phone-context=<phone-context<tel:156;phone-context=%3cphone-context>>.
In CS, the MSC is always in the same country as the UE so the MSC just routes the non-emergency CS domain call for 156 to the PSAP providing the "Municipal police" emergency service.
In IMS, it is not so easy since inbound-roamer would have P-CSCF abroad.
                The P-CSCF abroad sends a 380 response to the UE to inform the UE that the UE dialed an emergency number. In the 380 response, there is a Contact header field indicating the "Municipal police" emergency service.
                Based on the 380 response, the UE determines that a call to an emergency number was attempted and the UE selects whether to attempt the emergency call in CS or in IMS.
                               If in IMS, the UE establishes an emergency PDN connection, and sets up a UE-detectable IMS emergency call and sets the Request-URI to the Contact of the 380 response, i.e. the Request-URI contains a sos URN identifying the "Municipal police" emergency service. Based on the Request-URI, the IMS network in Czech republic routes the call to the PSAP providing the "Municipal police" emergency service.
                               If in CS, since the the Contact of the 380 response does not match any of urn:service:sos, urn:service:sos.police, urn:service:sos.ambulance, urn:service:sos.fire, urn:service:sos.marine, urn:service:sos.mountain, the UE sends CS SETUP for 156.

The marked text above is one reason why each emergency service needs to have a unique emergency service URN (either country specific emergency URN or an emergency URN assigned by IANA and ECRIT).

 1.  It is not possible to consolidate services which are in different nations.

Emergency service X might have a different meaning in different countries, e.g. X.A in country A and X.B in country B.

Furthermore, even if at the moment X.A and X.B would be identical, it cannot be guaranteed that national regulations of A and B would keep X.A and X.B in-line.

>From this perspective it would make sense to allow national regulators to determine their national emergency service URNs in a way that is clearly indicated as country-specific.

Assume there are several countries defining the following emergency service:

* 555 - religious/spiritual counselling

It might be difficult to ensure to people of different religious convictions that they end up with a counsellor of their need/expectation. Whilst this maybe could be solved by a designator for specific religion, the issue would for sure be seen by some countries as their decision to make (locally).

EXAMPLE 2

142- Telefonseelsorge (Telefone soul care) is defined as emergency number in Austria and is served by the Catholic and Evangelistic Churches in Austria.

106 - Mental problems hotline in Belgium has nothing to do with the Church.

988 - Helpline (domestic violence/ suicides) in Poland.

It is not possible to consolidate these emergency numbers in 3 different countries under only one urn. They provide almost the same service, but have different ways to help. These 3 numbers cannot be referred to a single URN, since public and regulator expectations towards them are different.

EXAMPLE 3

197- Terror Alert - Child Alert in France

114 - Child emergency in Italy

They cannot be under one URN since the number in France is also responsible for Terror Alert.

 1.  In some countries some counselling services are considered as emergency and in other countries they are only counselling services.

EXAMPLE 4

In Austria:

-  147 - Notrufdienst für Kinder und Jugendliche is emergency number according to the regulators/ law. While in Germany +49 800 1110333 Kinder- und Jugendtelefon is not emergency service.

IANA have registered urn:service:sos for "emergency services" and urn:sos:counceling for non-emergency services. 147 has to be mapped under the "emergency services" tree to satisfy Austrian regulatory requirements, while +49 800 1110333 has to remain under the "non-emergency services" tree. It is unclear how the ECRIT expert will handle these requests given the following description for the expert's role in 4.3 of RFC 5031:
"The expert review should take into account whether these services are offered widely and in different countries, with approximately the same caller expectation in terms of services rendered."

 1.  The local regulator may want to have the routing urns in local language or may want to have a better translation to English that what is chosen in the time of the registration.

All the examples show that emergency services have its local peculiarities in different countries and consolidating them under respective sos sub-services is difficult. In some cases consolidation is possible (the sos urns which are already registered). But in other cases it is not possible to use the current registration process and to satisfy the regulatory requirements in different countries.
I believe the examples above give arguments to use "sos.country-specific".

Best regards,
Vasil

T-Mobile International Austria GmbH
Vasil Aleksiev
SIM - Standardization & IPR Management

Rennweg 97-99, A-1030 Wien
Mobile: +43 676 8200 5145
E-Mail: [email-masked]<mailto:[email-masked]>
www.t-mobile.at<http://www.t-mobile.at>

LIFE IS FOR SHARING

__________________________________________________________________________________________
Notice: This e-mail and any attachments are confidential and may be privileged.
If you are not the intended recipient, notify the sender immediately, destroy all
copies from your system and do not disclose or use the information for any purpose.
Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte bevorrechtigtem
Schutz unterliegen. Wenn Sie nicht der beabsichtigte Adressat sind, informieren Sie
bitte den Absender unverzueglich, loeschen Sie alle Kopien von Ihrem System und
veroeffentlichen Sie oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.

Think before you print!

T-Mobile Austria GmbH
Geschaeftsfuehrung: Dr. Andreas Bierwirth (Vorsitzender), Aufsichtsrat: Dr. Rolf Nafziger (Vorsitzender)
Firmenbuch: Handelsgericht Wien, Sitz Wien, FN 171112k, UID ATU 45011703, DVR 0898295
Konto: UniCredit Bank Austria AG IBAN: AT93 1200 0528 4407 2301, BIC: BKAUATWW

T-Mobile - Das verbindet uns.
__________________________________________________________________________________________

---

From: Brian Rosen <[email-masked]>
Date: Thu, 6 Jul 2017 17:09:19 -0400

There seems to be a fundamental misunderstanding of what the values in the registry are supposed to be used for.

They are meant to be used to identify unique services.  

It’s useful to try to not have a lot of services that really are the same service having different entries, but two services that are indeed different ought to have different entries.

Also, the routing of a service can be whatever is needed; no assumption about routing is made other than the implication that the routing element will have different service URNs for different services.

With that it mind, my suggestions for the cases you cited are inline:

> On Jul 6, 2017, at 7:36 AM, Aleksiev, Vasil <[email-masked]> wrote:
> 
> Hello,
> 3GPP tried to register “sos.country-specific” sub-service type with IANA and got a comment back that “country-specific” is not an emergency service. There was a discussion on the last IETF meeting on this topic and as outcome 3 ways forward presented to 3GPP CT1 – change the registration process, create an exception in the registration process or use the current process. 
> Each emergency service needs to have unique emergency service URN. Handling in IMS can be different than handling in CS.
>  
> Example1:
>  
> Given that the UE is not configured with 156, whenever the user dials 156 in Czech republic, this causes the UE to use a CS SETUP for 156 or a non-emergency IMS call setup for tel:156;phone-context=<phone-context <tel:156;phone-context=%3cphone-context>>. 
There will be some form of “national.police” and some form of “local.police” or “municipal.police" registrations.   If needed, other police registrations can be made, but just using the two registrations for “national.police” and “local.police” and mapping 158 to “national.police’ and “156” to “local.police” would make sense here.  The routing element can still route a call marked “national.police” to the local PSAP or a call marked “national.police” to the local PSAP if it needs to.  Routing can be anything you need it to be; the name of the service doesn’t influence routing.  The system clearly can correctly route a 156 call and a 158 call on the ÇS or IMS networks, and it can clearly route a local.police and a national.police the same way.  The point here is that you have exactly two service codes (156 and 158) and you need exactly two service URNs, and there isn’t any reason at all that using “local.police” and “national.police” won’t work fine.
>  
>  
> It is not possible to consolidate services which are in different nations.
>  
I don’t agree.  While it may be the case that in some future time some country changes the generally accepted definition of a service, all that we care about is that there is a reasonable mapping available.  If we need to, when the new service is defined, it can get a new service urn if it is indeed a different service.

> It might be difficult to ensure to people of different religious convictions that they end up with a counsellor of their need/expectation. Whilst this maybe could be solved by a designator for spec…
Like police, fire and ems, if we need a service URN for “spiritualCounseling” and in some country there is “christian.spiritualCounseling” and “moslem.spiritualCounseling” where in another country there is “Catholic.spiritualCounseling” and “easternOrthodox.spiritualCounseling” then we can make registrations for each of them, because they are actually different services.
> It is not possible to consolidate these emergency numbers in 3 different countries under only one urn. They provide almost the same service, but have different ways to help. These 3 numbers cannot…
I think those are separate services and would clearly qualify for separate registrations.    While one country might have a suicide prevention service and a separate domestic violence service, there could be a question of whether a combined service is a separate service.  I would think it would be, and would qualify for a registration.  It would clearly work if 988 in Poland used the “suicidePrevention” service URN even though it combines it with domestic violence.  However, I think it’s probably best to give it a separate service URN.
> They cannot be under one URN since the number in France is also responsible for Terror Alert. 
Same as above. I think France should have a separate registration, but it would work fine if they just used “childEmergency”.
>  
> In some countries some counselling services are considered as emergency and in other countries they are only counselling services.
>  
> EXAMPLE 4
> In Austria:
So?  Do you want to map +49 800 1110333 in Germany to “childEmergency” or not?  If it’s not mapped to the service URN, then there is no problem.  If it is, then the call is not an emergency call.  The service URN is designed to work with non-emergency services.  There is no restriction on sos:counseling that it can only be used for non-emergency calls.  If it makes sense in some country to treat it as an emergency call, do it.  Nothing will break somewhere else.

>  
> IANA have registered urn:service:sos for “emergency services” and urn:sos:counceling for non-emergency services. 147 has to be mapped under the “emergency services” tree to satisfy Austrian regulatory requirements, while +49 800 1110333 has to remain under the “non-emergency services” tree. It is unclear how the ECRIT expert will handle these requests given the following description for the expert’s role in 4.3 of RFC 5031: 
> “The expert review should take into account whether these services are offered widely and in different countries, with approximately the same caller expectation in terms of services rendered.”
This is urn:service:sos.childEmergency (or something like it), not urn:service.sos or urn:sos:counceling.

>  
> The local regulator may want to have the routing urns in local language or may want to have a better translation to English that what is chosen in the time of the registration.
>  
Once again, this is a urn, not a human readable tag.  It could be X4476 and work fine.  

If there are distinct services, they should get distinct service urns.  Service urns are inexpensive and the process to get a new one is simple.  The fact that in some countries some unusual services, or service combinations exist doesn’t detract from the overall observation that in most countries, there is a common set of services that they all agree on.  Where there are distinct services, ask for a service urn and you will get one.

> I believe the examples above give arguments to use “sos.country-specific”.
I don’t agree at all

Brian

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 7 Jul 2017 23:46:38 -0400

Just to add to this: URNs are not meant to encode all kinds of policy by
name, e.g., whether a service is legally considered an emergency service or
not. They are protocol identifiers, not legal or human interface labels.
The precise content, operator and status of well-known (including
emergency) services sometimes change, without the number changing, so this
isn't a particularly new issue.

The same basic service can function quite differently in different
countries, as you know, but we still call it something similar or give it
the same number. (For example, many emergency services that have separate
numbers in European countries all use 911 in the US.)

*Thus, the only real requirement is that, within a country or other
appropriate jurisdiction, each distinct service has a unique name so that
calls can be routed appropriately.*

A secondary requirement is that a traveler should get a reasonably-close
approximation of the service if it is mapped to the same URN. For example,
it is probably better that somebody who has a speed dial button for
children's services in Austria gets the rough equivalent in Germany or
Italy, rather than having to look up the local number. In that case, a
caller really does not care one bit that it is legally an emergency service
in Austria, and not in Germany.

The notion of country-specific labels defeats this core portability design
goal of the sos URN.

Similarly, if a single number serves two different purposes in one country,
there is no harm in having two labels. Indeed, that's probably a good idea,
just in case they get split later.

I think a helpful next step, which you have already started, is to
enumerate the classes of emergency and related public services that
currently do not have a suitable URN. We can then decide what the
appropriate tree might be, recognizing that some may be a bit fuzzy (e.g.,
the child services you mentioned). The tree only matters in the case where
a particular label does not exist in a country and labels are stripped. In
some cases, the right approach may be to define related services in both
the 'sos' and 'counseling' tree.

Henning

On Thu, Jul 6, 2017 at 5:09 PM, Brian Rosen <[email-masked]> wrote:

> It’s useful to try to not have a lot of services that really are the same
> service having different entries, but two services that are indeed
> different ought to have different entries.
>
>
> Also, the routing of a service can be whatever is needed; no assumption
> about routing is made other than the implication that the routing element
> will have different service URNs for different services.
>
> 3GPP tried to register “sos.country-specific” sub-service type with IANA
> and got a comment back that “country-specific” is not an emergency service.
> There was a discussion on the last IETF meeting on this topic and as
> outcome 3 ways forward presented to 3GPP CT1 – change the registration
> process, create an exception in the registration process or use the current
> process.
> There were discussions how to go forward with this topic in 3GPP CT1. With
> the help of some of the delegates list with emergency services was prepared
> in order to see what exactly problems we might have with registration. You
> can see the list attached.
> Looking to the list there are some issues which I believe cannot be solved
> within the current registration process. I have tried to summarize the
> comments and the examples that we had during our discussions in 3GPP CT1
> and to start a discussion in ECRIT mailing list regarding the possible
> registration of these specific emergency services. Meanwhile there is a
> process to make the list with the emergency services bigger.
>    1. Each emergency service needs to have unique emergency service URN.
>    Handling in IMS can be different than handling in CS.
>
>
> Example1:
>
> In Czech republic, there is a "Municipal police" emergency service (156)
> and a "Police of the Czech Republic" emergency service (158) + other
> emergency services.
>
> Within the CS domain it is possible to indicate the emergency service
> required, but in a limited set (3GPP TS 22.101) - there is only one bit
> for Police in the Emergency category Information Element.
>
> An operator in Czech republic can provide to a UE via NAS a mapping of 158
> and the Police bit in the Emergency category IE. Whenever the user dials
> 158 in Czech republic, this causes the UE to use a CS EMERGENCY SETUP *with
> the Emergency category IE with the Police bit set* or a UE-detectable IMS
> emergency call setup* with the Request-URI set to the
> urn:service:sos.police, sent within emergency PDN connection*. *Either
> the MSC or the IMS network in Czech republic route the call to the PSAP
> providing the "Police of the Czech Republic" emergency service.*
>
> The operator in Czech republic canNOT provide to a UE via NAS a mapping of
> 156 and a bit in the Emergency category Information element since:
> - the "Police" bit is taken for the "Police of the Czech Republic"
> emergency service (which is provided by a different PSAP than the PSAP
> providing the "Municipal police" emergency service);
> - providing no bit implies a generic emergency service (which is provided
> by a different PSAP than the PSAP providing the "Municipal police"
> emergency service).
>
> Given that the UE is not configured with 156, whenever the user dials 156
> in Czech republic, this causes the UE to use a CS SETUP for 156 or a
> non-emergency IMS call setup for tel:156;phone-context=<phone-context
> <156;phone-context=%3cphone-context>>.
> In CS, the MSC is always in the same country as the UE so the MSC just
> routes the non-emergency CS domain call for 156 to the PSAP providing the
> "Municipal police" emergency service.
>                 The P-CSCF abroad sends a 380 response to the UE to inform
> the UE that the UE dialed an emergency *number*. In the 380 response, *there
> is a Contact header field indicating the "Municipal police" emergency
> service*.
>                 Based on the 380 response, the UE determines that a call
> to an emergency number was attempted and the UE selects whether to attempt
> the emergency call in CS or in IMS.
>                                If in IMS, the UE establishes an emergency
> PDN connection, and sets up a UE-detectable IMS emergency call and *sets
> the Request-URI to the Contact of the 380 response, i.e. the Request-URI
> contains a sos URN identifying the "Municipal police" emergency service.* Based
> on the Request-URI, the IMS network in Czech republic routes the call to
> the PSAP providing the "Municipal police" emergency service.
>                                If in CS, *since the the Contact of the
> 380 response does not match any of urn:service:sos, urn:service:sos.police,
> urn:service:sos.ambulance, urn:service:sos.fire, urn:service:sos.marine,
> urn:service:sos.mountain*, the UE sends CS SETUP for 156.
>
> The *marked* text above is one reason why each emergency service needs to
> have a unique emergency service URN (either country specific emergency URN
> or an emergency URN assigned by IANA and ECRIT).
>
> There will be some form of “national.police” and some form of
> “local.police” or “municipal.police" registrations.   If needed, other
> police registrations can be made, but just using the two registrations for
> “national.police” and “local.police” and mapping 158 to “national.police’
> and “156” to “local.police” would make sense here.  The routing element can
> still route a call marked “national.police” to the local PSAP or a call
> marked “national.police” to the local PSAP if it needs to.  Routing can be
> anything you need it to be; the name of the service doesn’t influence
> routing.  The system clearly can correctly route a 156 call and a 158 call
> on the ÇS or IMS networks, and it can clearly route a local.police and a
> national.police the same way.  The point here is that you have exactly two
> service codes (156 and 158) and you need exactly two service URNs, and
> there isn’t any reason at all that using “local.police” and
> “national.police” won’t work fine.
>
>
>
>
> Emergency service X might have a different meaning in different countries,
> e.g. X.A in country A and X.B in country B.
> Furthermore, even if at the moment X.A and X.B would be identical, it
> cannot be guaranteed that national regulations of A and B would keep X.A
> and X.B in-line.
> From this perspective it would make sense to allow national regulators to
> determine their national emergency service URNs in a way that is clearly
> indicated as country-specific.
>
> I don’t agree.  While it may be the case that in some future time some
> country changes the generally accepted definition of a service, all that we
> care about is that there is a reasonable mapping available.  If we need to,
> when the new service is defined, it can get a new service urn if it is
> indeed a different service.
>
> It might be difficult to ensure to people of different religious
> convictions that they end up with a counsellor of their need/expectation.
> Whilst this maybe could be solved by a designator for specific religion,
> the issue would for sure be seen by some countries as their decision to
> make (locally).
>
> Like police, fire and ems, if we need a service URN for
> “spiritualCounseling” and in some country there is “christian.spiritualCounseling”
> and “moslem.spiritualCounseling” where in another country there is
> “Catholic.spiritualCounseling” and “easternOrthodox.spiritualCounseling”
> then we can make registrations for each of them, because they are actually
> different services.
>
>
> EXAMPLE 2
> 142- Telefonseelsorge (Telefone soul care) is defined as emergency number
> in Austria and is served by the Catholic and Evangelistic Churches in
> Austria.
> It is not possible to consolidate these emergency numbers in 3 different
> countries under only one urn. They provide almost the same service, but
> have different ways to help. These 3 numbers cannot be referred to a single
> URN, since public and regulator expectations towards them are different.
>
> I think those are separate services and would clearly qualify for separate
> registrations.    While one country might have a suicide prevention service
> and a separate domestic violence service, there could be a question of
> whether a combined service is a separate service.  I would think it would
> be, and would qualify for a registration.  It would clearly work if 988 in
> Poland used the “suicidePrevention” service URN even though it combines it
> with domestic violence.  However, I think it’s probably best to give it a
> separate service URN.
>
>
> EXAMPLE 3
> Same as above. I think France should have a separate registration, but it
> would work fine if they just used “childEmergency”.
>
>
>
>    1. In some countries some counselling services are considered as
>    emergency and in other countries they are only counselling services.
>
>
> EXAMPLE 4
> In Austria:
> -  147 - Notrufdienst für Kinder und Jugendliche is emergency number
> according to the regulators/ law. While in Germany +49 800 1110333
> <+49%20800%201110333> Kinder- und Jugendtelefon is not emergency service.
>
> So?  Do you want to map +49 800 1110333 <+49%20800%201110333> in Germany
> to “childEmergency” or not?  If it’s not mapped to the service URN, then
> there is no problem.  If it is, then the call is not an emergency call.
> The service URN is designed to work with non-emergency services.  There is
> no restriction on sos:counseling that it can only be used for non-emergency
> calls.  If it makes sense in some country to treat it as an emergency call,
> do it.  Nothing will break somewhere else.
>
>
> IANA have registered urn:service:sos for “emergency services” and
> urn:sos:counceling for non-emergency services. 147 has to be mapped under
> the “emergency services” tree to satisfy Austrian regulatory requirements,
> while +49 800 1110333 <+49%20800%201110333> has to remain under the “non-emergency
> services” tree. It is unclear how the ECRIT expert will handle these
> requests given the following description for the expert’s role in 4.3 of
> RFC 5031:
> “The expert review should take into account whether these services are
> offered widely and in different countries, with approximately the same
> caller expectation in terms of services rendered.”
>
>    1. The local regulator may want to have the routing urns in local
>    language or may want to have a better translation to English that what is
>    chosen in the time of the registration.
>
>
> All the examples show that emergency services have its local peculiarities
> in different countries and consolidating them under respective sos
> sub-services is difficult. In some cases consolidation is possible (the sos
> urns which are already registered). But in other cases it is not possible
> to use the current registration process and to satisfy the regulatory
> requirements in different countries.
>
> If there are distinct services, they should get distinct service urns.
> Service urns are inexpensive and the process to get a new one is simple.
> The fact that in some countries some unusual services, or service
> combinations exist doesn’t detract from the overall observation that in
> most countries, there is a common set of services that they all agree on.
> Where there are distinct services, ask for a service urn and you will get
> one.
>
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>
>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Sat, 8 Jul 2017 17:11:40 +0000

I do not believe I quite agree.

The top level “sos” carries certain semantics including immediate response, which are quite distinct from “counselling”

So while a children’s service in one country may come under “sos” it will come under “counselling” in another.

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: 08 July 2017 04:47
To: Brian Rosen <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

Just to add to this: URNs are not meant to encode all kinds of policy by name, e.g., whether a service is legally considered an emergency service or not. They are protocol identifiers, not legal or human interface labels. The precise content, operator and status of well-known (including emergency) services sometimes change, without the number changing, so this isn't a particularly new issue.

The same basic service can function quite differently in different countries, as you know, but we still call it something similar or give it the same number. (For example, many emergency services that have separate numbers in European countries all use 911 in the US.)

Thus, the only real requirement is that, within a country or other appropriate jurisdiction, each distinct service has a unique name so that calls can be routed appropriately.

A secondary requirement is that a traveler should get a reasonably-close approximation of the service if it is mapped to the same URN. For example, it is probably better that somebody who has a speed dial button for children's services in Austria gets the rough equivalent in Germany or Italy, rather than having to look up the local number. In that case, a caller really does not care one bit that it is legally an emergency service in Austria, and not in Germany.

The notion of country-specific labels defeats this core portability design goal of the sos URN.

Similarly, if a single number serves two different purposes in one country, there is no harm in having two labels. Indeed, that's probably a good idea, just in case they get split later.

I think a helpful next step, which you have already started, is to enumerate the classes of emergency and related public services that currently do not have a suitable URN. We can then decide what the appropriate tree might be, recognizing that some may be a bit fuzzy (e.g., the child services you mentioned). The tree only matters in the case where a particular label does not exist in a country and labels are stripped. In some cases, the right approach may be to define related services in both the 'sos' and 'counseling' tree.

Henning

On Thu, Jul 6, 2017 at 5:09 PM, Brian Rosen <[email-masked]<mailto:[email-masked]>> wrote:
There seems to be a fundamental misunderstanding of what the values in the registry are supposed to be used for.

On Jul 6, 2017, at 7:36 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Example1:

EXAMPLE 2

EXAMPLE 3

EXAMPLE 4
In Austria:
-  147 - Notrufdienst für Kinder und Jugendliche is emergency number according to the regulators/ law. While in Germany +49 800 1110333<tel:+49%20800%201110333> Kinder- und Jugendtelefon is not emergency service.
So?  Do you want to map +49 800 1110333<tel:+49%20800%201110333> in Germany to “childEmergency” or not?  If it’s not mapped to the service URN, then there is no problem.  If it is, then the call is not an emergency call.  The service URN is designed to work with non-emergency services.  There is no restriction on sos:counseling that it can only be used for non-emergency calls.  If it makes sense in some country to treat it as an emergency call, do it.  Nothing will break somewhere else.

IANA have registered urn:service:sos for “emergency services” and urn:sos:counceling for non-emergency services. 147 has to be mapped under the “emergency services” tree to satisfy Austrian regulatory requirements, while +49 800 1110333<tel:+49%20800%201110333> has to remain under the “non-emergency services” tree. It is unclear how the ECRIT expert will handle these requests given the following description for the expert’s role in 4.3 of RFC 5031:
“The expert review should take into account whether these services are offered widely and in different countries, with approximately the same caller expectation in terms of services rendered.”
This is urn:service:sos.childEmergency (or something like it), not urn:service.sos or urn:sos:counceling.

Brian

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 8 Jul 2017 18:41:38 -0400

Keith,

like I mentioned, if there is a perception that this matters in response
and recognizing the trade-offs (suddenly, a service in country A fails in
country B, even though users would perceive the replacement service to be
sufficiently close), there's no reason not to create child services under
both sos and counseling categories, as they are presumably substantially
different in that case (one sends a child protection service worker, the
other provides telephone counseling on how to deal with bullying, say). As
long as each country is clear on the mapping, there's no real problem.

I think the best path forward is to enumerate the non-traditional (i.e.,
beyond fire, police and ambulance) services in each country and see what
the best set of labels would be, keeping the two objectives in mind (MUST
avoid collisions in each country, SHOULD facilitate traveller use).

Thus, I think we're not really disagreeing...

Henning

On Sat, Jul 8, 2017 at 1:11 PM, Drage, Keith (Nokia - GB) <
[email-masked]> wrote:

> The top level “sos” carries certain semantics including immediate
> response, which are quite distinct from “counselling”
>
>
>
> *From:* Ecrit [mailto:[email-masked]] *On Behalf Of *Henning
> Schulzrinne
> *Sent:* 08 July 2017 04:47
> *To:* Brian Rosen <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Ecrit] country specific emergency URNs
>
>
>
> Similarly, if a single number serves two different purposes in one
> country, there is no harm in having two labels. Indeed, that's probably a
> good idea, just in case they get split later.
>
>
>
> emergency call setup *with the Request-URI set to the

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Mon, 10 Jul 2017 11:31:33 +0200

Hi to all,

In my first bullet regarding unique emergency URN I have given the example with differences between IMS and CS and to show that emergency numbers are handled differently and also to show the roaming treatment. For every emergency number defined by regulator it is needed to have sos domain. Sos triggers the respective routing with emergency category and this is different from the CS treatment where some numbers currently are not handled as emergency and detected as such on a later stage. I am glad to understand that this is also the view of ECRIT and for every emergency service defined by local law there shall be sos definition.

In my second bullet regarding difficulties of consolidating services in different nations I have given examples of 142 – Telefonseelsorge (telephone soul care), 106 – Mental problems hotline. Just looking to the names - the services look quite similar, so how these two services will be named under sos? Sos.soulcare and sos.mentalhealth?
197 – Terror Alert – Child Alert in France – I suppose the name shall be sos.terror-child? I think somebody from France should explain the specifics regarding this emergency service.
114- Child emergency in Italy – here is easy – sos.children.

In my third bullet regarding counselling services in one country considered as emergency in other I have given examples of 147 and +498001110333. I suppose 147 (emergency service for children and youth) shall be sos.children-and-youth. The service does not have the same name as 114- child emergency in Italy. +498001110333 shall be counseling.children.

In my fourth bullet regarding the will of the local regulator – I fully agree that the urns may even look like sos.1, sos.2, sos.3, sos.4 … But the problem might be that the local regulator does not think so. Till now in Austria there is no law regarding routing of IMS emergency calls, but when it is written it could be written inside that urns shall be sos.telefonseelsorge, sos.kinder.147.

I see a problem with that I am not authorized to make registrations regarding emergency URNs – I am not representing the regulator or the other operators in the respective countries.
Of course I could try to define sos.children and I agree that this will be enough, but if the regulator later decides that this is not ok?

Best regards,

Vasil

Von: Ecrit [mailto:[email-masked]] Im Auftrag von Henning Schulzrinne
Gesendet: Sonntag, 09. Juli 2017 00:42
An: Drage, Keith (Nokia - GB) <[email-masked]>
Cc: [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

Keith,

like I mentioned, if there is a perception that this matters in response and recognizing the trade-offs (suddenly, a service in country A fails in country B, even though users would perceive the replacement service to be sufficiently close), there's no reason not to create child services under both sos and counseling categories, as they are presumably substantially different in that case (one sends a child protection service worker, the other provides telephone counseling on how to deal with bullying, say). As long as each country is clear on the mapping, there's no real problem.

I think the best path forward is to enumerate the non-traditional (i.e., beyond fire, police and ambulance) services in each country and see what the best set of labels would be, keeping the two objectives in mind (MUST avoid collisions in each country, SHOULD facilitate traveller use).

Henning

On Sat, Jul 8, 2017 at 1:11 PM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
I do not believe I quite agree.

Keith

From: Ecrit [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Henning Schulzrinne
Sent: 08 July 2017 04:47
To: Brian Rosen <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] country specific emergency URNs

Henning

Hello,

Example1:

EXAMPLE 2

EXAMPLE 3

EXAMPLE 4
In Austria:

Brian

Think before you print!

T-Mobile Austria GmbH

T-Mobile – Das verbindet uns.
__________________________________________________________________________________________

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 10 Jul 2017 08:45:02 -0400

We can't predict what unknown third parties, such as regulators, will do,
but since registrations of sos URNs is not a high-effort project, we can
always go back and try again. I think it is incumbent upon standards
organizations to explain that these are "mechanical" protocol constants,
not user interface elements.

The most productive way forward would be to enumerate the services by
description (and, for concreteness, the [short code] number and country)
and whether these services are meant as emergency services (i.e., a vehicle
with flashing lights get dispatched) or as counseling (i.e., somebody
provides advice or information over the phone, with no expectation that
anything or anyone is dispatched to your location). That way, we can
collectively judge which ones are sufficiently similar and avoid any
collisions, as well as judge whether a hierarchical label is useful. As I
mentioned, the goal is collision avoidance within a country and rough
categorization, without worrying about fine details. (After all, we don't
get too concerned for 112/911 of how each country or region organizes their
fire brigades and whether dispatch is done across services, integrated or
separated by service.)

>From your note, it is clear that we're lacking an authoritative description
in some cases. For example, I admit that I don't understand the 197 service
(why would children call in terrorism alerts?). I'm afraid in some cases,
nuance or substance has been lost in translation (literally, in some cases).

Since you seem to have a good list of emergency services, maybe you can get
this started and others can chime in. Again, I wouldn't worry about the
labels at this point as that is probably more of a distraction.

In some cases, I think it would be helpful to have somebody with local
knowledge contribute, possibly after consulting with local authorities.

Henning

On Mon, Jul 10, 2017 at 5:31 AM, Aleksiev, Vasil <[email-masked]
> wrote:

> Hi to all,
>
>
>
> In my first bullet regarding unique emergency URN I have given the example
> with differences between IMS and CS and to show that emergency numbers are
> handled differently and also to show the roaming treatment. For every
> emergency number defined by regulator it is needed to have sos domain. Sos
> triggers the respective routing with emergency category and this is
> different from the CS treatment where some numbers currently are not
> handled as emergency and detected as such on a later stage. I am glad to
> understand that this is also the view of ECRIT and for every emergency
> service defined by local law there shall be sos definition.
>
>
>
> In my second bullet regarding difficulties of consolidating services in
> different nations I have given examples of 142 – Telefonseelsorge
> (telephone soul care), 106 – Mental problems hotline. Just looking to the
> names - the services look quite similar, so how these two services will be
> named under sos? Sos.soulcare and sos.mentalhealth?
>
> 197 – Terror Alert – Child Alert in France – I suppose the name shall be
> sos.terror-child? I think somebody from France should explain the specifics
> regarding this emergency service.
>
> In my third bullet regarding counselling services in one country
> considered as emergency in other I have given examples of 147 and
> +498001110333 <+49%20800%201110333>. I suppose 147 (emergency service for
> children and youth) shall be sos.children-and-youth. The service does not
> have the same name as 114- child emergency in Italy. +498001110333
> <+49%20800%201110333> shall be counseling.children.
>
>
>
> In my fourth bullet regarding the will of the local regulator – I fully
> agree that the urns may even look like sos.1, sos.2, sos.3, sos.4 … But the
> problem might be that the local regulator does not think so. Till now in
> Austria there is no law regarding routing of IMS emergency calls, but when
> it is written it could be written inside that urns shall be
> sos.telefonseelsorge, sos.kinder.147.
>
>
>
> I see a problem with that I am not authorized to make registrations
> regarding emergency URNs – I am not representing the regulator or the other
> operators in the respective countries.
>
> Of course I could try to define sos.children and I agree that this will be
> enough, but if the regulator later decides that this is not ok?
>
>
>
> Best regards,
>
>
>
> Vasil
>
>
>

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Tue, 11 Jul 2017 10:35:57 +0200

Hello,
I do not agree with your interpretation of emergency services. In one country only the local authority can define what are the emergency services. Since there is law saying that 147 Telefonseelsorge is emergency service, it shall be treated as such. Regarding the vehicle with flashing lights dispatched – you cannot guarantee for that the respective operator on 147 will not send the police for example via its own channel if this is needed. So in my understanding the approach shall be based on local law. Regarding the benefits in routing of having all the emergency services in one country under sos subspace I have given examples already. In the file that I have send I have added only the emergency services for Austria with the respective link to the written law. The same is done from other 3GPP CT1 delegates who have given the info regarding the other countries in the file. Ecrit experts can check the links and read the respective law requirements written in the languages of the respective country.
Regarding 197 service, the original name of the service of the name in French is: Alerte attentat – Alerte enlèvement from the provided link with written law. So I suppose this is a little bit different meaning from what is written as translation – according to Google it is more regarding alert abduction and attack. It was filled in the file from Orange delegate in 3GPP CT1, so I suppose more explanation from her will follow. If there is Ecrit expert speaking French, he can also help.
The list is present already – done with help of 3GPP CT1 delegates from the respective countries, but only some countries in Europe present there. It is seen from the list that consolidation between different countries is not so simple and it cannot be done without reading the law of the respective country on the respective language.
I consider talking with regulator not so easy – it has to be done via the official channels. I expect the regulator, when wants to start a new service, to have a meeting with all the operators present in one country and to discuss the details about. On such meeting every operator can state its opinion and discuss the requirements and possibilities. The requirements for the solution will be finalised and then the regulator can publish the respective law. Gathering such meeting is not in mine authorities. The result of talking only with some of the attending parties in process will be only speculation regarding a future decision. I am also not sure if this is the process in every country.
That is why 3GPP CT1 tried to register country specific emergency URN as a simple solution for countries where the emergency services are different from the common ones.

Best regards,

Vasil

Von: Henning Schulzrinne [mailto:[email-masked]]
Gesendet: Montag, 10. Juli 2017 14:45
An: Aleksiev, Vasil <[email-masked]>
Cc: [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

We can't predict what unknown third parties, such as regulators, will do, but since registrations of sos URNs is not a high-effort project, we can always go back and try again. I think it is incumbent upon standards organizations to explain that these are "mechanical" protocol constants, not user interface elements.

The most productive way forward would be to enumerate the services by description (and, for concreteness, the [short code] number and country) and whether these services are meant as emergency services (i.e., a vehicle with flashing lights get dispatched) or as counseling (i.e., somebody provides advice or information over the phone, with no expectation that anything or anyone is dispatched to your location). That way, we can collectively judge which ones are sufficiently similar and avoid any collisions, as well as judge whether a hierarchical label is useful. As I mentioned, the goal is collision avoidance within a country and rough categorization, without worrying about fine details. (After all, we don't get too concerned for 112/911 of how each country or region organizes their fire brigades and whether dispatch is done across services, integrated or separated by service.)

From your note, it is clear that we're lacking an authoritative description in some cases. For example, I admit that I don't understand the 197 service (why would children call in terrorism alerts?). I'm afraid in some cases, nuance or substance has been lost in translation (literally, in some cases).

Since you seem to have a good list of emergency services, maybe you can get this started and others can chime in. Again, I wouldn't worry about the labels at this point as that is probably more of a distraction.

In some cases, I think it would be helpful to have somebody with local knowledge contribute, possibly after consulting with local authorities.

Henning

On Mon, Jul 10, 2017 at 5:31 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Hi to all,

In my third bullet regarding counselling services in one country considered as emergency in other I have given examples of 147 and +498001110333<tel:+49%20800%201110333>. I suppose 147 (emergency service for children and youth) shall be sos.children-and-youth. The service does not have the same name as 114- child emergency in Italy. +498001110333<tel:+49%20800%201110333> shall be counseling.children.

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

---

From: Procopio Roberto <[email-masked]>
Date: Tue, 11 Jul 2017 10:00:08 +0000

Dear All,

I share the points raised by Vasil. In some of the emails below I red that a way forward could be to identify a reasonable mapping between an emergency service and the related sos urns. I don’t think that this is a good way forward. The reason is that this way forward requires a consolidation of emergency service requirements among different countries and this requires a deep understanding of the emergency services definition in each country.

Simply looking at the emergency services collected in the table shared by Vasil, it can be understood that services having the same name can have different requirements in different countries. This mistmatch generates problems in the emergency service operation as showed in the example raised by Vasil (e.g. roaming, borders). If we look at future possible deployments of mobile networks, we can also find other scenarios (such as cross-national MVNO) where is crucial to identify exactly one specific emergency service in one country.

Therefore in my opinion is very important to guarantee the flexibility in the naming definition of the sos urns. As Vasil said, this flexibility was one of the reasons behind the proposal of the country specific emergency URN.

BR
Roberto

Da: Ecrit [mailto:[email-masked]] Per conto di Aleksiev, Vasil
Inviato: martedì 11 luglio 2017 10:36
A: Henning Schulzrinne
Cc: [email-masked]
Oggetto: Re: [Ecrit] country specific emergency URNs

Hello,

Best regards,

Vasil

An: Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>>

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 11 Jul 2017 06:59:22 -0400

For cross-national MVNOs, routing to a service that does not exist in the
country you are visiting is not helpful (or even possible). Thus, if you
define a country-specific service that exists only in, say, Italy, and then
visit Austria, the call will have to fail. In the SOS model, you get a
close approximation, which seems much more user friendly.

As I have stated repeatedly, and you seem to continue to ignore, is that
the label is an internal protocol label where the only requirement is that
there is a unique 1-1 mapping within one country from number to label. This
requirement exist even if you create country-specific labels unless your
"label" is sos:fr.147, i.e., you directly encode the number. This is
clearly a bad idea.

I disagree that this requires a "consolidation of emergency service
requirements". It requires a listing of services, which I have again asked
for again and again.

As I have also tried to explain several times, we only have to make sure
two things are true:

(1) The description is precise enough so that it is clear in each country
whether it matches an existing service. If a newly-discovered service does
not seem to match an existing one, a new label is created. The description
does not have to be a legal one or cover every aspect of operation (which
changes over time anyway). In all the cases we have discussed, this seems
relatively straightforward.

(2) Within each country, all existing numbers have to map to unique URNs.

It is very difficult to make progress if you (and your colleagues) insist
that something is not possible, but then make it impossible to make
progress by not providing the necessary information. It would be most
helpful if you could engage constructively rather than insisting on a
solution that violates the spirit and design principles of the architecture.

I continue to look forward to starting the list of services we should
discuss.

Henning

On Tue, Jul 11, 2017 at 6:00 AM, Procopio Roberto <
[email-masked]> wrote:

> Dear All,
>
>
>
> I share the points raised by Vasil. In some of the emails below I red that
> a way forward could be to identify a reasonable mapping between an
> emergency service and the related sos urns. I don’t think that this is a
> good way forward. The reason is that this way forward requires a
> consolidation of emergency service requirements among different countries
> and this requires a deep understanding of the emergency services definition
> in each country.
>
>
>
> Simply looking at the emergency services collected in the table shared by
> Vasil, it can be understood that services having the same name can have
> different requirements in different countries. This mistmatch generates
> problems in the emergency service operation as showed in the example raised
> by Vasil (e.g. roaming, borders). If we look at future possible deployments
> of mobile networks, we can also find other scenarios (such as
> cross-national MVNO) where is crucial to identify exactly one specific
> emergency service in one country.
>
>
>
> Therefore in my opinion is very important to guarantee the flexibility in
> the naming definition of the sos urns. As Vasil said, this flexibility was
> one of the reasons behind the proposal of the country specific emergency
> URN.
>
>
>
> BR
>
> Roberto
>
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 11 Jul 2017 07:33:19 -0400

You mention a list (or lists) that you and others have compiled. Can you
point at it (or attach the documents or presentations) as I'm afraid I
don't have a good place to look?

One of the advantages that we have on this mailing list is that we can
indeed draw on the expertise of a wide variety of international experts.

I also don't understand your comment regarding 147. I thought we had agreed
that if a service exists as an emergency service, it will be added as an
SOS URN, even if there's already a counseling version that's somewhat
similar. Again, the user expectation should guide this since the goal is to
fall back to something that the user isn't (too) surprised by if the
service does not exist.

For France, the law seems to be at
https://www.legifrance.gouv.fr/affichTexte.do?cidTexte=JORFTEXT000030973250

Interestingly, the link (via Google Translate) offers the following helpful
advice:
"Finally, without calling into question the need of the Ministry of the
Interior, the majority of contributions reminds us of the inefficiency and
the risk of confusion associated with the multiplication of emergency
numbers. Some operators reiterate the request made by the French Telecom
Federation during the previous consultation of a reflection on the
rationalization of emergency numbers."

>From what I can tell, 197 is a number that combines two services, namely
for citizens calling in information about an attack or a child abduction.
The number is only activated after an incident and is otherwise dormant. In
the US, we call them "tip lines" (although they are used for crimes in
general, not just the two special cases). See
http://www.secourisme.net/spip.php?breve412&lang=fr

Henning

On Tue, Jul 11, 2017 at 4:35 AM, Aleksiev, Vasil <[email-masked]

> Hello,
>
> I do not agree with your interpretation of emergency services. In one
> country only the local authority can define what are the emergency
> services. Since there is law saying that 147 Telefonseelsorge is emergency
> service, it shall be treated as such. Regarding the vehicle with flashing
> lights dispatched – you cannot guarantee for that the respective operator
> on 147 will not send the police for example via its own channel if this is
> needed. So in my understanding the approach shall be based on local law.
> Regarding the benefits in routing of having all the emergency services in
> one country under sos subspace I have given examples already. In the file
> that I have send I have added only the emergency services for Austria with
> the respective link to the written law. The same is done from other 3GPP
> CT1 delegates who have given the info regarding the other countries in the
> file. Ecrit experts can check the links and read the respective law
> requirements written in the languages of the respective country.
>
> Regarding 197 service, the original name of the service of the name in
> French is: Alerte attentat – Alerte enlèvement from the provided link with
> written law. So I suppose this is a little bit different meaning from what
> is written as translation – according to Google it is more regarding alert
> abduction and attack. It was filled in the file from Orange delegate in
> 3GPP CT1, so I suppose more explanation from her will follow. If there is
> Ecrit expert speaking French, he can also help.
>
> The list is present already – done with help of 3GPP CT1 delegates from
> the respective countries, but only some countries in Europe present there.
> It is seen from the list that consolidation between different countries is
> not so simple and it cannot be done without reading the law of the
> respective country on the respective language.
>
> I consider talking with regulator not so easy – it has to be done via the
> official channels. I expect the regulator, when wants to start a new
> service, to have a meeting with all the operators present in one country
> and to discuss the details about. On such meeting every operator can state
> its opinion and discuss the requirements and possibilities. The
> requirements for the solution will be finalised and then the regulator can
> publish the respective law. Gathering such meeting is not in mine
> authorities. The result of talking only with some of the attending parties
> in process will be only speculation regarding a future decision. I am also
> not sure if this is the process in every country.
>
> That is why 3GPP CT1 tried to register country specific emergency URN as a
> simple solution for countries where the emergency services are different
> from the common ones.
>
>
>
> Best regards,
>
>
>
> Vasil
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Jul 2017 11:48:53 +0000

Hi Henning,

>You mention a list (or lists) that you and others have compiled. Can you point at it (or attach the documents or presentations) as I'm afraid I don't have a good place to look?

The list was attached in an e-mail sent to this list, by Vasil, Thursday 6th.

Regards,

Christer

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Tue, 11 Jul 2017 15:43:08 +0200

Hi Henning,
I am sending the list attached. Sorry for not adding it in every email. It was present in the first mail that I have sent. It was prepared from 3GPP CT1 delegates as a list of emergency services in the respective countries according to current law – links to the law texts is also provided. Unfortunately we do not have more knowledge regarding other countries.
I gave the example with 147 again regarding not typical emergency service making sure that there is common understanding. Only the local law has the authority to say what services are emergency and all parties involved shall take this for granted and treat every aspect of the service as emergency including the sos registration.

I have tried to use google translate for the French document and it seems to be what you describe. But it is better somebody knowing French language to say more about it. Even if this service is activated under special circumstances it is still expected to have treatment as emergency call and it shall be under sos subspace.

According to the current law if subscriber from Telekom Italia goes to Austria and taking in mind emergency numbers in Italy dials 113 (Police) from phone with IMS registration, such call shall be stopped since 113 is not existing number in Austria. Dialling the number is leading and dialling of not existing number cannot route the call to emergency service.

Best regards,

Vasil

Von: Henning Schulzrinne [mailto:[email-masked]]
Gesendet: Dienstag, 11. Juli 2017 13:33
An: Aleksiev, Vasil <[email-masked]>
Cc: [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

One of the advantages that we have on this mailing list is that we can indeed draw on the expertise of a wide variety of international experts.

I also don't understand your comment regarding 147. I thought we had agreed that if a service exists as an emergency service, it will be added as an SOS URN, even if there's already a counseling version that's somewhat similar. Again, the user expectation should guide this since the goal is to fall back to something that the user isn't (too) surprised by if the service does not exist.

Interestingly, the link (via Google Translate) offers the following helpful advice:
"Finally, without calling into question the need of the Ministry of the Interior, the majority of contributions reminds us of the inefficiency and the risk of confusion associated with the multiplication of emergency numbers. Some operators reiterate the request made by the French Telecom Federation during the previous consultation of a reflection on the rationalization of emergency numbers."
From what I can tell, 197 is a number that combines two services, namely for citizens calling in information about an attack or a child abduction. The number is only activated after an incident and is otherwise dormant. In the US, we call them "tip lines" (although they are used for crimes in general, not just the two special cases). See
http://www.secourisme.net/spip.php?breve412&lang=fr

Henning

On Tue, Jul 11, 2017 at 4:35 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

---

From: Brian Rosen <[email-masked]>
Date: Tue, 11 Jul 2017 09:57:11 -0400

Henning provided the answer to this issue:
1. We make a list of all known services, and create registrations for them.  Your list from CT1 will be very helpful to do this
2. A country makes its own determination of which existing registrations match its services, and uses those registrations for services that it determines match
3. If there is a service in a country that does not match, it requests a new registration.  As this involves a designated expert reviewer, there may be some questions back and forth about why an existing registration is not acceptable, but if it is actually a different service, then there is a reasonable expectation the new registration will be allowed.

As Henning and I have observed, the only requirement is that there be a unique mapping between the service number and a registration.  The name of the service doesn’t matter.  It’s helpful if the service matches the description in the registration, but, strictly speaking, it doesn’t have to, it only needs to be unique from other services in that country.

Brian

> On Jul 11, 2017, at 9:43 AM, Aleksiev, Vasil <[email-masked]> wrote:
> 
> Hi Henning,
> https://www.legifrance.gouv.fr/affichTexte.do?cidTexte=JORFTEXT000030973250 <https://www.legifrance.gouv.fr/affichTexte.do?cidTexte=JORFTEXT000030973250>
>  
> http://www.secourisme.net/spip.php?breve412&lang=fr <http://www.secourisme.net/spip.php?breve412&lang=fr>
>  
> Henning
>  
> On Tue, Jul 11, 2017 at 4:35 AM, Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>> wrote:
> Hello,
> <Emergency-numbers-v1.6.xlsx>_______________________________________________
> Ecrit mailing list
> [email-masked]

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 11 Jul 2017 18:31:31 -0400

Vasil,

my apologies for missing the attachment. This is indeed quite helpful. I
have started to collect those and some other numbers at

https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing

I've "pencilled in" some tentative names in red mainly to make sure that
there are no in-country duplications.

There are a number of to-do countries, but so far, I've noticed a few that
are likely to be easy (well-defined), with some tentative names:

sos.child-protection (for emergency services that deal with child abuse)
sos.child-missing (for missing or abducted children)
sos.water (for water utility-related emergencies, similar to sos.gas)
sos.electric (for electricity-related emergencies)

No particular preference on whether to label the children-related ones

sos.children.protection
sos.children.missing

I'll raise a few others separately to avoid mixing threads.

Henning

On Tue, Jul 11, 2017 at 9:43 AM, Aleksiev, Vasil <[email-masked]

> Hi Henning,
>
> I am sending the list attached. Sorry for not adding it in every email. It
> was present in the first mail that I have sent. It was prepared from 3GPP
> CT1 delegates as a list of emergency services in the respective countries
> according to current law – links to the law texts is also provided.
> Unfortunately we do not have more knowledge regarding other countries.
>
> I gave the example with 147 again regarding not typical emergency service
> making sure that there is common understanding. Only the local law has the
> authority to say what services are emergency and all parties involved shall
> take this for granted and treat every aspect of the service as emergency
> including the sos registration.
>
>
>
> I have tried to use google translate for the French document and it seems
> to be what you describe. But it is better somebody knowing French language
> to say more about it. Even if this service is activated under special
> circumstances it is still expected to have treatment as emergency call and
> it shall be under sos subspace.
>
>
>
> According to the current law if subscriber from Telekom Italia goes to
> Austria and taking in mind emergency numbers in Italy dials 113 (Police)
> from phone with IMS registration, such call shall be stopped since 113 is
> not existing number in Austria. Dialling the number is leading and dialling
> of not existing number cannot route the call to emergency service.
>
>
>
> Best regards,
>
>
>
> Vasil
>
>
>
>
>
>
>
>
>
>
>
> *Von:* Henning Schulzrinne [mailto:[email-masked]]
> *Gesendet:* Dienstag, 11. Juli 2017 13:33
> *An:* Aleksiev, Vasil <[email-masked]>
> *Cc:* [email-masked]
> *Betreff:* Re: [Ecrit] country specific emergency URNs
>
>
>
> I also don't understand your comment regarding 147. I thought we had
> agreed that if a service exists as an emergency service, it will be added
> as an SOS URN, even if there's already a counseling version that's somewhat
> On Tue, Jul 11, 2017 at 4:35 AM, Aleksiev, Vasil <
> [email-masked]> wrote:
>
> Hello,
>

---

From: <[email-masked]>
Date: Wed, 12 Jul 2017 06:44:06 +0000

Hi,

Concerning the 197 service in France for Terror Alert – Child Alert, it is a single number for 2 very different purposes: the abduction alert AND the terrorist attack alert.
There is a single number because it is related to a dedicated procedures that can be launched including radio and TV programs interruption for alerting people and other national security procedures.

Best regards,
Marianne

De : Ecrit [mailto:[email-masked]] De la part de Aleksiev, Vasil
Envoyé : mardi 11 juillet 2017 10:36
À : Henning Schulzrinne
Cc : [email-masked]
Objet : Re: [Ecrit] country specific emergency URNs

Hello,

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Wed, 12 Jul 2017 15:36:09 +0200

Hi Henning,
I have looked at the list and noticed that you have also entered the other numbers for Austria, which are not emergency numbers. They shall not be under sos. This is what I see as other problem – there are services which you call for help - the respective service or vehicle is dispatched, but since they are not defined as emergency according to the law, they shall not be under sos domain.
For Austria you can also see in the law document (https://www.bmvit.gv.at/telekommunikation/recht/aut/rtrverordnung/downloads/kem_vo/2009212.pdf ) that the non-emergency services are:

130 Landeswarnzentralen (Country warning centre) – used in cases of storms, floods, different crisis, disaster control.
120, 123 Pannendienste – Roadside assistance.
1484-x Krankentransporte – ambulance services – only regional service.
116000 Hotline für vermiste Kinder – hotline for missinig children.
116111 Hotline für Hilfe suchender Kinder - hotline for searched (wanted) children.
116123 Hotline zur Lebenshilfe – hotline for support.
111 Telefonströrungsannahmestellen – Registering technical problems with telecommunication services.
118 Telefonauskunftsdienste – Telephone information services.

Some of them can be registered under counselling. Obviously road assistance and disaster line are not counselling services  - they can be defined under new domain – for example help.road.

Interesting is that 147 is emergency service, so it shall be sos.children, but 116000 shall be counselling.child.missing or help.child.missing. 116111 – help.child.wanted, 116123 – counselling.life (combination of mental-health and suicide). 1484-x help.ambulance. 111 – help.telecom, 118 – help.info.

The number which you have entered in the table of your file 01/406 43 43 and 0800/133133 are not present in the law document so they shall not at all be present in your file. The number starting with 01 is a normal number in Vienna, 0800 is a free phone service according to the law.

Best regards,

Vasil

Von: Henning Schulzrinne [mailto:[email-masked]]
Gesendet: Mittwoch, 12. Juli 2017 00:32
An: Aleksiev, Vasil <[email-masked]>
Cc: [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil,

my apologies for missing the attachment. This is indeed quite helpful. I have started to collect those and some other numbers at

I've "pencilled in" some tentative names in red mainly to make sure that there are no in-country duplications.

There are a number of to-do countries, but so far, I've noticed a few that are likely to be easy (well-defined), with some tentative names:

sos.children.protection
sos.children.missing

Henning

On Tue, Jul 11, 2017 at 9:43 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Hi Henning,
I am sending the list attached. Sorry for not adding it in every email. It was present in the first mail that I have sent. It was prepared from 3GPP CT1 delegates as a list of emergency services in the respective countries according to current law – links to the law texts is also provided. Unfortunately we do not have more knowledge regarding other countries.
I gave the example with 147 again regarding not typical emergency service making sure that there is common understanding. Only the local law has the authority to say what services are emergency and all parties involved shall take this for granted and treat every aspect of the service as emergency including the sos registration.

Best regards,

Vasil

Von: Henning Schulzrinne [mailto:[email-masked]<mailto:[email-masked]>]

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: Brian Rosen <[email-masked]>
Date: Wed, 12 Jul 2017 09:46:15 -0400

Vasil

Once again, the name has no significance as long as it is unique.  We use the names as suggestive for the service to aid the service providers, regulators and public safety authorities in setting up the systems, but the urn name is not used by anything other than computer software during an emergency.

If one country has a service for an ambulance service that is considered an emergency service, but in another country it is not considered an emergency service, we can, and should still use the service in the sos tree for the non-emergency service.  On the other hand, if there was a country that had two ambulance services, one that was used for emergency transport and another that was used for non-emergency transport, then we would need two URNs, because we have distinct services and need different URNs.  

Brian

> On Jul 12, 2017, at 9:36 AM, Aleksiev, Vasil <[email-masked]> wrote:
> 
> Hi Henning,
> For Austria you can also see in the law document (https://www.bmvit.gv.at/telekommunikation/recht/aut/rtrverordnung/downloads/kem_vo/2009212.pdf <https://www.bmvit.gv.at/telekommunikation/recht/aut/rtrverordnung/downloads/kem_vo/2009212.pdf> ) that the non-emergency services are:
>  
> Interesting is that 147 is emergency service, so it shall be sos.children, but 116000 shall be counselling.child.missing or help.child.missing. 116111 – help.child.wanted, 116123 – counselling.life (combination of mental-health and suicide). 1484-x help.ambulance. 111 – help.telecom, 118 – help.info <http://help.info/>.
>  
> Von: Henning Schulzrinne [mailto:[email-masked] <mailto:[email-masked]>] 
> An: Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing <https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing>
>  
> On Tue, Jul 11, 2017 at 9:43 AM, Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Henning,
> Von: Henning Schulzrinne [mailto:[email-masked] <mailto:[email-masked]>] 
> An: Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> __________________________________________________________________________________________ _______________________________________________
> Ecrit mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Jul 2017 14:28:51 +0000

Hi,

>If one country has a service for an ambulance service that is considered an emergency service, but in another country it is not considered an emergency service, we can, and should still use the service in the sos tree for the non-emergency service.

Section 4.2 of RFC 5031 says:

   "The 'sos' service type describes emergency services requiring an
   immediate response, typically offered by various branches of the
   government or other public institutions."

So, at least the ‘sos’ part of the name DOES have significance, doesn’t it?

Regards,

Christer

On Jul 12, 2017, at 9:36 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:

Hi Henning,

Interesting is that 147 is emergency service, so it shall be sos.children, but 116000 shall be counselling.child.missing or help.child.missing. 116111 – help.child.wanted, 116123 – counselling.life (combination of mental-health and suicide). 1484-x help.ambulance. 111 – help.telecom, 118 – help.info<http://help.info/>.

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Wed, 12 Jul 2017 16:49:16 +0200

Hi Brian,
A service URN with a top-level service type of "sos" is used only when the user intends to establish an emergency call. The emergency call will be treated with priority in the network. For non-emergency numbers in one country sos shall not be used since priority there is not needed.

Best regards,

Vasil

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Mittwoch, 12. Juli 2017 15:46
An: Aleksiev, Vasil <[email-masked]>
Cc: Henning Schulzrinne <[email-masked]>; [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil

Brian

Hi Henning,

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Jul 2017 11:19:26 -0400

Christer,

The description tries to capture the nature of the service ("immediate
response"), not the legal status within a country. For example, it does not
opine on whether carriers are required, by law or regulation, to support
such a code, how such calls are charged, or whether the vehicle providing
the service is allowed to use flashing blue lights and sirens.

I'm confused as to why this discussion matters. Is there some reason any
legal distinctions need to be reflected in a protocol label? Do you have a
particular case in mind where this matters?

I think we are all trying to keep this relatively simple, so I think it
helps if we can focus on the technical issues.

Henning

On Wed, Jul 12, 2017 at 10:28 AM, Christer Holmberg <
[email-masked]> wrote:

> Hi,
>
> >Once again, the name has no significance as long as it is unique.  We use
> the names as suggestive for the service to aid the service providers,
> regulators and public safety authorities in setting up the systems, but the
> urn name is not used by anything other than computer software during an
> emergency.
> >
> >If one country has a service for an ambulance service that is considered
> an emergency service, but in another country it is not considered an
> emergency service, we can, and should still use the service in the sos tree
> for the non-emergency service.
>
> I have looked at the list and noticed that you have also entered the other
> numbers for Austria, which are not emergency numbers. They shall not be
> under sos. This is what I see as other problem – there are services which
> you call for help - the respective service or vehicle is dispatched, but
> since they are not defined as emergency according to the law, they shall
> not be under sos domain.
> For Austria you can also see in the law document (https://www.bmvit.gv.at/
> telekommunikation/recht/aut/rtrverordnung/downloads/kem_vo/2009212.pdf )
> that the non-emergency services are:
>
> 130 Landeswarnzentralen (Country warning centre) – used in cases of
> storms, floods, different crisis, disaster control.
> Some of them can be registered under counselling. Obviously road
> assistance and disaster line are not counselling services  - they can be
> defined under new domain – for example help.road.
>
> Interesting is that 147 is emergency service, so it shall be sos.children,
> but 116000 shall be counselling.child.missing or help.child.missing. 116111
> – help.child.wanted, 116123 – counselling.life (combination of
> mental-health and suicide). 1484-x help.ambulance. 111 – help.telecom, 118 –
>  help.info.
>
> The number which you have entered in the table of your file 01/406 43 43
> and 0800/133133 are not present in the law document so they shall not at
> all be present in your file. The number starting with 01 is a normal number
> in Vienna, 0800 is a free phone service according to the law.
>
> Best regards,
>
> Vasil
>
>
> *Von:* Henning Schulzrinne [mailto:[email-masked]
> <[email-masked]>]
> *Gesendet:* Mittwoch, 12. Juli 2017 00:32
> On Tue, Jul 11, 2017 at 9:43 AM, Aleksiev, Vasil <

---

From: Brian Rosen <[email-masked]>
Date: Wed, 12 Jul 2017 11:21:21 -0400

Vasil

There is NO SIGNIFICANCE to the name.  It can be “flowers” and work the same.

Whether you treat the call as an emergency call (priority, etc) cannot be determined by the urn NAME.

It might be determined by looking at the URN and comparing it to a list of URNs that should be treated specially, but you can’t infer that just because the urn starts with sos that it is an emergency call, or that if starts with “flower” that it isn’t an emergency call. 

The name has no significance.

Brian

> On Jul 12, 2017, at 10:49 AM, Aleksiev, Vasil <[email-masked]> wrote:
> 
> Hi Brian,
> Von: Brian Rosen [mailto:[email-masked] <mailto:[email-masked]>] 
> An: Aleksiev, Vasil <Vasi <mailto:[email-masked]>[email-masked] <mailto:[email-masked]>>
> Cc: Henning Schulzrinne <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> On Jul 12, 2017, at 9:36 AM, Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Henning,

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Wed, 12 Jul 2017 15:27:25 +0000

Yes, but the name is “sos.flowers”, not “flowers”.

Further, if the receiving entity does not understand “sos.flowers” it will be treated as “sos”, and therefore any usage should correspond with the semantics of “sos”.

Failure to do this will mean calls that are not emergency calls (thereby not requiring immediate response) will be sent to the PSAP, and at least certain regulators and emergency service providers get very upset with this happening.

So any subtype meaning, in my view, must also complement the semantics of “sos”, rather than just replace it.

Regards

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: 12 July 2017 16:21
To: Aleksiev, Vasil <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

Vasil

Brian

On Jul 12, 2017, at 10:49 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:

Hi Brian,

Best regards,

Vasil

Von: Brian Rosen [mailto:[email-masked]]
Gesendet: Mittwoch, 12. Juli 2017 15:46
An: Aleksiev, Vasil <Vasi<mailto:[email-masked]>[email-masked]<mailto:[email-masked]>>
Cc: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil

Brian

Hi Henning,

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Jul 2017 11:29:22 -0400

Vasil,

the service URN does not prescribe any network priority treatment. Indeed,
at least in the US, landline 911 calls are treated exactly the same as
regular calls, e.g., during network congestion. (We have the SIP RPH
mechanism for prioritizing call treatment, but it's not used for civilian
emergency calls.)

I suspect this is try for many of the non-112 calls today. I very much
doubt that marine emergency calls in Finland or 1-800 calls to the poison
control center in the US (and the equivalent set of numbers in Germany,
say) receive any priority treatment in the network.

Again, I think it helps make progress if we do not overload labels with
policy.

Naturally, any country or carrier is free to use any label, including the
URN, to signify any treatment local law and regulation permits or requires.
But the label does not *require* or imply such network treatment.

I admit I'm thoroughly confused by this discussion. Where did the priority
issue suddenly come from? It's not in any ECRIT document that I'm aware of.

Henning

On Wed, Jul 12, 2017 at 10:49 AM, Aleksiev, Vasil <
[email-masked]> wrote:

> Hi Brian,
>
> A service URN with a top-level service type of "sos" is used only when the
> user intends to establish an emergency call. The emergency call will be
> treated with priority in the network. For non-emergency numbers in one
> country sos shall not be used since priority there is not needed.
>
>
>
> Best regards,
>
>
>
> Vasil
>
>
>
>
>
> *Von:* Brian Rosen [mailto:[email-masked]]
> *Gesendet:* Mittwoch, 12. Juli 2017 15:46
> *Cc:* Henning Schulzrinne <[email-masked]>; [email-masked]
> for the non-emergency service.  On the other hand, if there was a country
> that had two ambulance services, one that was used for emergency transport
> and another that was used for non-emergency transport, then we would need
> two URNs, because we have distinct services and need different URNs.
>
>
>
> Brian
>
>
>
>
>

---

From: Brian Rosen <[email-masked]>
Date: Wed, 12 Jul 2017 11:51:13 -0400

No, I meant “flowers” like “flowers.ambulance”.

We do in fact want the name to be suggestive of  the function, mostly so that provisioning is easier.  However, if there was a flowers.ambulance, it should work EXACTLY the same as if it was sos.ambulance, counseling.ambulance or non-government-non-emergencyservices.ambulance or sos.a15b23.

The name has NO SIGNIFICANCE.  It’s just a token.  We compare against it in LoST, but we don’t infer anything in the name.

No one other than network and sap provisioning/operations people ever type them or see them.  Callers and call takers NEVER see them.

Brian

> On Jul 12, 2017, at 11:27 AM, Drage, Keith (Nokia - GB) <[email-masked]> wrote:
> 
> On Jul 12, 2017, at 10:49 AM, Aleksiev, Vasil <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Hi Brian,

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Jul 2017 11:55:15 -0400

I think Brian has already answered most of these. The confusion arises
since you take a lawyer view of what an emergency number is (I'm not even
sure what this means in practice - required routing by carriers? free of
charge?).

The 'sos' label is a conceptual label that is simply used to organize terms
and reflect common understandings.

For example, poison control often uses regular or toll-free numbers, but
poison control numbers are routinely listed as "emergency numbers".

To take an Austrian example: The LPD lists a bunch of numbers at

http://www.polizei.gv.at/alle/notrufe.aspx

as "Notruf- und Notfallnummern", including such numbers as 147 that are
clearly not traditional flashing-lights emergency services, or numbers like
Frauennotruf: 01/71 71 9, which isn't on your list.

Thus, official Austrian entities have a far more intuitive understanding of
the term.

The 'sos' label is a routing label. If a country doesn't want to use the
URN mechanism for certain numbers, they can decide not to. I'm trying to
collect a set of labels that cover services that are currently or are
likely to use such a geographic routing system. In many cases, these
services go to a single national call center and don't use geography at
all, and won't use any ECRIT functionality. In that case, the URN will
never be used. A bit of wasted effort, but no real harm that I can see.

Thus, among the services you describe that were not on your original
spreadsheet, should any of them be included in my list, whether under 'sos'
or not? The ones to be included are services that are likely to use
ECRIT-style location-based routing. Thus, services like directory service
or phone repair services are likely not of immediate concern unless you
believe that whoever provides those would like to use service URNs.

130 is an interesting one. It did not appear on your list, but similar
services seem to be found elsewhere. When would I call it instead of 112,
122 (fire) or 144 (rescue)? I found it listed as maritime rescue at
http://kaernten.bergrettung.at/de/notruf

Henning

On Wed, Jul 12, 2017 at 9:36 AM, Aleksiev, Vasil <[email-masked]

> mental-health and suicide). 1484-x help.ambulance. 111 – help.telecom, 118
> – help.info.
>
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Jul 2017 12:10:41 -0400

I agree that the naming should be chosen so that the routing behavior in
case of non-support is sensible. (After all, this was one reason for the
hierarchy.)

This can be a bit of a judgement call, but carriers have three options when
they find a non-supported label:

* route to the "next one up". I think in the US, there's probably a bias to
routing emergencies to 911, e.g., if a label sos.poison were to show up.
This should rarely happen - after all, there's no local short code for
this, so the only likely valid (non-buggy) case would be a roaming
international user who dials the home emergency number which gets
translated to a locally-not-supported service.

* explicitly route to some kind of IVR (e.g., for sos.gas in the US: "The
number you have dialed is not supported in your local area. If this is a
true emergency, dial 911. To report gas leaks, call your local utility.
Good luck finding a phone book.")

* fast busy or "no such number" recording or the SIP equivalent. Probably
the worst option.

Henning

On Wed, Jul 12, 2017 at 11:27 AM, Drage, Keith (Nokia - GB) <
[email-masked]> wrote:

> Further, if the receiving entity does not understand “sos.flowers” it will
> be treated as “sos”, and therefore any usage should correspond with the
> semantics of “sos”.
>
>
>
> Failure to do this will mean calls that are not emergency calls (thereby
> not requiring immediate response) will be sent to the PSAP, and at least
> certain regulators and emergency service providers get very upset with this
> happening.
>
>
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Jul 2017 12:22:57 -0400

Marianne,

thanks for the background. If I understand this correctly, it is used for
people to call in tips ("I have seen the child that is missing", "I saw a
vehicle that matches the description on TV yesterday"), not to request help
("I am injured and need an ambulance", "The person on TV is pointing a gun
at people outside my window").

I read that a single number was created since the number is only activated
on demand, in response to a high-profile incident such as a terror attack
or a likely-abducted child (similar to the case when an "amber alert" is
issued in the US) and it was seen as unlikely that both types of events
would occur at the same time, as they are (thankfully) somewhat rare.

Is my understanding correct?

Thus, I have labeled it as a "tip line" since that's the common English
term for such services. I have not tried to make it more specific since
there's currently no other (ECRIT) service in France that's similar. I
assume that local police have tip lines for regular crimes, but they are
just regular local phone numbers, and thus of no collision concern here.

If there's a better name, please suggest.

Henning

On Wed, Jul 12, 2017 at 2:44 AM, <[email-masked]> wrote:

> Hi,
>
>
>
> Concerning the 197 service in France for Terror Alert – Child Alert, it
> is a single number for 2 very different purposes: the abduction alert AND
> the terrorist attack alert.
>
> There is a single number because it is related to a dedicated procedures
> that can be launched including radio and TV programs interruption for
> alerting people and other national security procedures.
>
>
>
> Best regards,
>
> Marianne
>
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 12 Jul 2017 19:38:20 +0000

Hi,

>We do in fact want the name to be suggestive of  the function, mostly so that provisioning is easier.  However, if there was a flowers.ambulance, it should >work EXACTLY the same as if it was sos.ambulance, counseling.ambulance or non-government-non-emergencyservices.ambulance or sos.a15b23.
>
>The name has NO SIGNIFICANCE.  It’s just a token.

If that is true, we do we separate the sub-services to begin with? Why do we define sub-service specific registration procedures (even though they happen to be identical for the existing sub-services?

RFC 5031 defines semantics for the sos sub-service, and at least my understanding is that sos is to be used for emergency services, and nothing else. Where is it said that it is ok to use sos also for non-emergency services, and to use non-sos for emergency services?

If we start using non-sos for emergency services, and sos for non-emergency services, I think we will end up in a mess…

Regards,

Christer

On Jul 12, 2017, at 11:27 AM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Regards

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: 12 July 2017 16:21
To: Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] country specific emergency URNs

Vasil

Brian

Hi Brian,

Best regards,

Vasil

Vasil

Brian

Hi Henning,

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: Brian Rosen <[email-masked]>
Date: Wed, 12 Jul 2017 15:57:33 -0400

> If that is true, we do we separate the sub-services to begin with? Why do we define sub-service specific registration procedures (even though they happen to be identical for the existing sub-servic…
Because we would like the name to be suggestive of the function so that provisioning and debugging is easier.  That really is why we did it that way.  Using a GUID would have worked.

>  
> RFC 5031 defines semantics for the sos sub-service, and at least my understanding is that sos is to be used for emergency services, and nothing else.
There is no limit expressed, or implied, that sos is restricted to “flashing lights” emergencies.  It’s suggestive of emergency, but not exclusively used that way.  The counter example was the non-emergency ambulance service.  Using sos.ambulance for a non emergency ambulance service, unless a country has both an emergency and a non-emergency ambulance service that needs urns, is appropriate I think.  I don’t think it would be wrong to create a non-emergency ambulance registration, but I also don’t think we need to.

> Where is it said that it is ok to use sos also for non-emergency services, and to use non-sos for emergency services?
There is no MUST language at all.  Anything is acceptable, although the expert review gets to offer an opinion, and take it to the list if needed.  The review is merely supposed to make sure the service is distinct from an existing registration.  Registrations are cheap.

> If we start using non-sos for emergency services, and sos for non-emergency services, I think we will end up in a mess…
The above example is how I think we don’t get into a mess.  I don’t think there is a good reason to create an ambulance service that isn’t in the sos tree unless we have an incidence of two services and we need to differentiate.  Even if the ambulance service in a country is not considered an emergency service, using sos.ambulance for it is fine in my opinion.

---

From: Gunnar Hellström <[email-masked]>
Date: Thu, 13 Jul 2017 07:51:50 +0200

> There is no MUST language at all.  Anything is acceptable, although the expert review gets to offer an opinion, and take it to the list if needed.  The review is merely supposed to make sure the se…
I agree with Christer that this reasoning would create a mess. There is 
must language in RFC 5031. The idea is that resources working with 
emergencies shall be able to handle them rapidly and efficiently without 
having them placed in queues merged with non-emergency calls.

RFC 5031 says about sos and the sub-services :
"The 'sos' service type describes emergency services requiring an
immediate response, typically offered by various branches of the 
government or other public institutions. Additional sub-services can be 
added after expert review and must be of general public interest and 
have a similar emergency nature."

I think that is clear enough to avoid using sos subservices for services 
not requiring an immediate response.

English might lack a simple word for the non-emergency ambulance 
service. In Swedish, we call it "sjuktransport"
  and the German word is "krankentransport". Maybe that is why you feel 
it would be hard to find a good term in English for the registration of 
the non-emergency ambulance service and got into the reasoning in this 
thread.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Jul 2017 06:38:29 +0000

Hi,

>>RFC 5031 defines semantics for the sos sub-service, and at least my
>>understanding is that sos is to be used for emergency services, and
>>nothing else.
>
>There is no limit expressed, or implied, that sos is restricted to
>³flashing lights² emergencies.  It¹s suggestive of emergency, but not
>exclusively used that way.
>The counter example was the non-emergency ambulance service.  Using
>sos.ambulance for a non emergency ambulance service, unless a country has
>both an emergency and a
>non-emergency ambulance service that needs urns, is appropriate I think.
>I don¹t think it would be wrong to create a non-emergency ambulance
>registration, but I also don¹t think we
>need to.

I think we should have separate URNs for emergency and non-emergency
services - no matter if the emg and non-emg services are provided in the
same country or in different countries.

>There is no MUST language at all.  Anything is acceptable, although the
>expert review gets to offer an opinion, and take it to the list if
>needed. 
>
>The review is merely supposed to make sure the service is distinct from
>an existing registration.  Registrations are cheap.

Not if we are going to have list discussions about the name whenever a URN
is to be registered. It would prolong the registration and, depending on
who participate in such discussions, the outcome would be very
inconsistent.

So, I strongly think that if the service is an emergency service, we use
sos. If the service is not an emergency service, we don¹t use sos.

And, *URNs* are cheap, so we are not going to ³run out of them² if we use
different ones for emergency services and non-emergency services.

>>If we start using non-sos for emergency services, and sos for
>>non-emergency services, I think we will end up in a messŠ
>
>The above example is how I think we don¹t get into a mess.  I don¹t think
>there is a good reason to create an ambulance service that isn¹t in the
>sos tree unless 
>we have an incidence of two services and we need to differentiate.  Even
>if the ambulance service in a country is not considered an emergency
>service, using sos.ambulance for it is fine in my opinion.

I have a different opinion :)

Regards,

Christer

---

From: Georg Mayer <[email-masked]>
Date: Thu, 13 Jul 2017 09:32:21 +0200

Hello,

coming late to this discussion, just a few comments.

1) if the name holds no meaning but should be suggestive, then the most
suggestive name I could think of e.g. in Austria would simply be the
number that you call today. But then we are back at square one again, as
I guess the idea (once at least) was to avoid numbers.
What I want to say: if the name really does  not hold any
meaning/semantics, then it will be hard to deny anybody to register any
URN-name for a specific service.

2) In the counseling example (just taken as an example) I think the
situation is really much more complicated. You just don't want to hand
out a URN that says christian.counseling - I can see even problems
within single countries. You will end up with a long looong list of very
specific services and it will be hard to keep the overview.
It might be easier to just have them country specific, then things a
clearer.

Again, semantics plays a role here and people read it from the URN.

3) Compiling the list - that's an effort that will most likely never
end. And it is also something that seemingly nobody wants to do - its
much more work then just putting together all the numbers and the
person/organization which then merges  the different services will for
sure be criticized from different sides.
In my opinion the national legislations should take responsibility on
this and we should not try to negotiate between them. We should give
them a vehicle that allows them to easily register their related services.

In any way, I don't think that from 3GPP side we can come up with a full
list. It might be that GSMA can start such an initiative, but regardless
of who is doing this, it would create an enormous overhead, which in my
eyes is unnecessary.

Cheers,
Georg

On 2017-07-12 21:57, Brian Rosen wrote:
>> If that is true, we do we separate the sub-services to begin with? Why
>> do we define sub-service specific registration procedures (even though
>> they happen to be identical for the existing sub-services?
> Because we would like the name to be suggestive of the function so that
> provisioning and debugging is easier.  That really is why we did it that
> way.  Using a GUID would have worked.
> 
>>  
> “flashing lights” emergencies.  It’s suggestive of emergency, but not
> exclusively used that way.  The counter example was the non-emergency
> ambulance service.  Using sos.ambulance for a non emergency ambulance
> service, unless a country has both an emergency and a non-emergency
> ambulance service that needs urns, is appropriate I think.  I don’t
> think it would be wrong to create a non-emergency ambulance
> registration, but I also don’t think we need to.
> 
>> Where is it said that it is ok to use sos also for non-emergency
>> services, and to use non-sos for emergency services?
> needed.  The review is merely supposed to make sure the service is
> distinct from an existing registration.  Registrations are cheap.
> 
>>  
>> non-emergency services, I think we will end up in a mess…
> The above example is how I think we don’t get into a mess.  I don’t
> think there is a good reason to create an ambulance service that isn’t
> in the sos tree unless we have an incidence of two services and we need
> to differentiate.  Even if the ambulance service in a country is not
> considered an emergency service, using sos.ambulance for it is fine in
> my opinion.
> 
> 
>>  
> 
> 
> 

-- 
Georg Mayer
3GPP CT Chairman
HUAWEI Technologies
Mobile: +43 699 1900 5758

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Thu, 13 Jul 2017 09:54:04 +0200

Brian,
you continue to say that name has no significance. I have a suggestion, why not to have all the services sos.1, sos.2, sos.3, sos.4 till 10 for example. Since nobody will read it why to use police, ambulance, flowers. It will be simple and nobody will argue about names. Since we are discussing names they have significance. I agree that these are just names and simple much, but there are more things behind.
RFC 5031 has stated that sos tree is for emergency calls, then other standards organizations are using this. According to 3GPP specifications using sos implies emergency service which goes with the respective using of priority in initiating, routing, serving the call. So if you now allow using sos tree for non-emergency calls it will cause a lot of problems.

Best regards,

Vasil

Gesendet: Mittwoch, 12. Juli 2017 17:21

Vasil

Brian

Hi Brian,

Best regards,

Vasil

Vasil

Brian

Hi Henning,

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 13 Jul 2017 09:36:37 +0000

Hi,

My assumption has been that sos is used for emergency services, and that has also been the assumption of other people (representing other SDOs, etc) I have talked to. So, I really think we should stick to that. It makes no harm.

When it comes to naming significance in general, I do agree that the name itself is just a “string”. But, whenever we defines names in general (header field names, parameter names etc) we typically want them to be descriptive. However, I have not seen any suggestion that we should move away from that approach.

Regards,

Christer

From: Ecrit <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 13 July 2017 at 10:54
To: Brian Rosen <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ecrit] country specific emergency URNs

Brian,

Best regards,

Vasil

Vasil

Brian

Hi Brian,

Best regards,

Vasil

Vasil

Brian

Hi Henning,

Best regards,

Vasil

Vasil,

sos.children.protection
sos.children.missing

Henning

Best regards,

Vasil

Henning

Best regards,

Vasil

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

Think before you print!

T-Mobile Austria GmbH

---

From: James Winterbottom <[email-masked]>
Date: Thu, 13 Jul 2017 19:55:33 +1000

This brings one to ponder whether a different set of top-level domains might be more appropriate for non-time-sensitive social services?

Perhaps urn:socialservice:xxx
Where there is no default tree climb beyond xxx

Cheers
James

Sent from my iPhone

> On 9 Jul 2017, at 3:11 am, Drage, Keith (Nokia - GB) <[email-masked]> wrote:
> 
> Given that the UE is not configured with 156, whenever the user dials 156 in Czech republic, this causes the UE to use a CS SETUP for 156 or a non-emergency IMS call setup for tel:156;phone-context=<phone-context>.

---

From: "Aleksiev, Vasil" <[email-masked]>
Date: Thu, 13 Jul 2017 13:04:30 +0200

Henning,
In one country always there is a regulator commission which is monitoring the telecom carriers. The regulator issues rules in written form and monitors if all the carriers are following it. If the written rules are not followed, the regulator issues the respective penalties. So every mobile or fixed operator looks into the written rules and takes care of it. In this sense the telecom operators are only caring what is the regulator definition of emergency calls. That is why we have created a file with links to the respective documents, which are issued by the regulators in the respective countries (in form of law). In such document there is definition for emergency calls and list is present with the numbers considered as emergency in the country. The definition usually includes serving the calls with priority, providing location of the subscribers, providing possibility for call back.
One operator uses such mechanisms only for numbers defined as emergency by the law. Of course every organisation is free to define its own emergency number for some reasons, but the operators do not have an obligation to take care of this and route such numbers as normal calls.
I think there is no reason to search in google for every possible emergency number which nobody is routing as emergency according to the regulators requirements.

BR Vasil

Von: Henning Schulzrinne [mailto:[email-masked]]
Gesendet: Mittwoch, 12. Juli 2017 17:29
An: Aleksiev, Vasil <[email-masked]>
Cc: Brian Rosen <[email-masked]>; [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil,

the service URN does not prescribe any network priority treatment. Indeed, at least in the US, landline 911 calls are treated exactly the same as regular calls, e.g., during network congestion. (We have the SIP RPH mechanism for prioritizing call treatment, but it's not used for civilian emergency calls.)

I suspect this is try for many of the non-112 calls today. I very much doubt that marine emergency calls in Finland or 1-800 calls to the poison control center in the US (and the equivalent set of numbers in Germany, say) receive any priority treatment in the network.

Again, I think it helps make progress if we do not overload labels with policy.

Naturally, any country or carrier is free to use any label, including the URN, to signify any treatment local law and regulation permits or requires. But the label does not require or imply such network treatment.

I admit I'm thoroughly confused by this discussion. Where did the priority issue suddenly come from? It's not in any ECRIT document that I'm aware of.

Henning

On Wed, Jul 12, 2017 at 10:49 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Hi Brian,
A service URN with a top-level service type of "sos" is used only when the user intends to establish an emergency call. The emergency call will be treated with priority in the network. For non-emergency numbers in one country sos shall not be used since priority there is not needed.

Best regards,

Vasil

Von: Brian Rosen [mailto:[email-masked]<mailto:[email-masked]>]
Gesendet: Mittwoch, 12. Juli 2017 15:46
An: Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>>
Cc: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil

Brian

Think before you print!

T-Mobile Austria GmbH

---

From: Brian Rosen <[email-masked]>
Date: Thu, 13 Jul 2017 09:23:25 -0400

> immediate response, typically offered by various branches of the government or other public institutions. Additional sub-services can be added after expert review and must be of general public interest and have a similar emergency nature."
> 
There is no MUST in that text.  It’s not normative.  The “must” in “must be of general public interest” is not normative, or it would have said “MUST be of general public interest”.  It’s advice to the expert reviewer.

OTOH, registrations are cheap and if there is even a significant minority who think it’s advisable to separate the real emergency services from non-emergency services, then I’m fine with doing that.  I’m just trying to make sure the name itself is not significant; we get into lots of trouble when we try to make components of a URI significant.

---

From: Brian Rosen <[email-masked]>
Date: Thu, 13 Jul 2017 09:24:26 -0400

As in my prior message to Gunnar, I’m convinced; let’s have non-emergency services, including one for ambulance.

Brian
> On Jul 13, 2017, at 2:38 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
> 
> 
>> łflashing lights˛ emergencies.  Itąs suggestive of emergency, but not
>> I donąt think it would be wrong to create a non-emergency ambulance
>> registration, but I also donąt think we
>> need to.
> 
> sos. If the service is not an emergency service, we donąt use sos.
> 
> And, *URNs* are cheap, so we are not going to łrun out of them˛ if we use
>> The above example is how I think we donąt get into a mess.  I donąt think
>> there is a good reason to create an ambulance service that isnąt in the
>> sos tree unless

---

From: John-Luc Bakker <[email-masked]>
Date: Thu, 13 Jul 2017 14:47:16 +0000

Vasil makes a key point: countries determine the emergency services provided within the country and the countries assign the number. So far, countries have not been required to consult with foreign organizations. Countries may choose to allocate the same number allocated by other countries, however calls may still be routed to PSAPs offering primarily different emergency services: take for example 112 in Europe. Some countries route calls to 112 to police, while others route them to ambulance (in these countries a dedicated emergency number for police may exist (which should bind to the police URN)). Countries have full jurisdiction over their number plans and rules that prescribe how calls to certain numbers shall be treated/routed.

The only policy they have in common is perhaps the  immediacy of the response. This lines up with the “sos” label (RFC 5031):

   The 'sos' service type describes emergency services requiring an
   immediate response, typically offered by various branches of the
   government or other public institutions.

The binding of number to URN is country specific. Additional policies beyond the immediacy of the response are country specific. The specific list of services for which immediacy of the response is required are country specific (some services treated as emergency in, say Austria, are not required to be treated as emergency in many other countries).

Requiring regulators to engage in discussions on ECRIT or awareness of IANA registration processes just for SIP emergency calls seems not practical and confusing, at a minimum.

Since so much falls solely within the jurisdiction of countries/regulators, this calls into question the need for having a detailed/exhaustive registry beyond identifying some basic, more or less universal services. Beyond this, it is really up to the needs of the public in the country in question.

From: Ecrit [mailto:[email-masked]] On Behalf Of Aleksiev, Vasil
Sent: Thursday, July 13, 2017 6:05 AM
To: Henning Schulzrinne <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

Henning,

BR Vasil

Cc: Brian Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Vasil,

Henning

Best regards,

Vasil

Vasil

Brian

Think before you print!

T-Mobile Austria GmbH

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Jul 2017 12:04:40 -0400

I suspect, despite differences at the margins, we have general agreement on
a few points:

* Service URNs are meant to reflect reasonable, common understanding of the
service and lead to reasonable fall-back behavior if the specific service
is not supported. For example, if there's a service URN sos.fire.wildfire,
the behavior is as expected: if it doesn't exist, forwarding the call to
whoever handles sos.fire is probably right.

* We already have the 'counseling' tree for non-emergency advice services.
We seem to converge on having a non-emergency services tree (or possibly
more than one) that reflect services that yield a response (more than
talk), but are not considered emergency services.

* URNs don't encode policy (e.g., priority) or law.

* We have a light-weight process for adding URNs on an as-needed basis. I
suspect this discussion will yield a slew of new registrations that will
cover most ECRIT-using services (and many that never will), but we don't
need to strive for completeness now.

As I have mentioned, I have made an effort, now updated, to collect the
emergency and similar widely-known services for almost all of the OECD
countries at

*https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing
<https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing>*

If you see any mistakes or significant omissions, please let me know.

I'm hoping that the list can help avoid pointless discussions about
services that could exist, but don't actually do. Also, as mentioned, we
don't need to encode every possible widely-known service unless it is
likely to use ECRIT-style (service URN + LoST) resolution. Thus, for the
time being, we don't have to worry about, say, phone repair,
call-before-you-dig, directory services, talking clock services, weather,
traffic (511 in the US) or dial-a-prayer services, even though they may all
have short code numbers.

Henning

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Jul 2017 12:10:56 -0400

ISTM that one beneficial effect of creating this general 
(non-nation-specific) enumeration of services is to provide a gentle way 
of encouraging countries to adopt consistent service definitions. Just 
the small effort of deciding whether one of the existing names will work 
for your service, or whether a new name is needed, can be a nudge toward 
consistency.

This seems important when people and their phones are roaming across 
countries.

	Thanks,
	Paul

On 7/13/17 10:47 AM, John-Luc Bakker wrote:
> Vasil makes a key point: countries determine the emergency services 
> provided within the country and the countries assign the number. *So 
> far, countries have not been required to consult with foreign 
> organizations.* Countries may choose to allocate the same number 
> allocated by other countries, however calls may still be routed to PSAPs 
> offering primarily different emergency services: take for example 112 in 
> Europe. Some countries route calls to 112 to police, while others route 
> them to ambulance (in these countries a dedicated emergency number for 
> police may exist (which should bind to the police URN)). Countries have 
> full jurisdiction over their number plans and rules that prescribe how 
> calls to certain numbers shall be treated/routed.
> 
> The only policy they have in common is perhaps the  immediacy of the 
> response. This lines up with the “sos” label (RFC 5031):
> 
> The binding of number to URN is country specific. Additional policies 
> beyond the immediacy of the response are country specific. The specific 
> list of services for which immediacy of the response is required are 
> country specific (some services treated as emergency in, say Austria, 
> are not required to be treated as emergency in many other countries).
> 
> Requiring regulators to engage in discussions on ECRIT or awareness of 
> IANA registration processes just for SIP emergency calls seems not 
> practical and confusing, at a minimum.
> 
> Since so much falls solely within the jurisdiction of 
> countries/regulators, this calls into question the need for having a 
> detailed/exhaustive registry beyond identifying some basic, more or less 
> universal services. Beyond this, it is really up to the needs of the 
> public in the country in question.
> 
> *From:*Ecrit [mailto:[email-masked]] *On Behalf Of *Aleksiev, Vasil
> *Sent:* Thursday, July 13, 2017 6:05 AM
> *To:* Henning Schulzrinne <[email-masked]>
> *Cc:* [email-masked]
> In one country always there is a regulator commission which is 
> monitoring the telecom carriers. The regulator issues rules in written 
> form and monitors if all the carriers are following it. If the written 
> rules are not followed, the regulator issues the respective penalties. 
> So every mobile or fixed operator looks into the written rules and takes 
> care of it. In this sense the telecom operators are only caring what is 
> the regulator definition of emergency calls. That is why we have created 
> a file with links to the respective documents, which are issued by the 
> regulators in the respective countries (in form of law). In such 
> document there is definition for emergency calls and list is present 
> with the numbers considered as emergency in the country. The definition 
> usually includes serving the calls with priority, providing location of 
> the subscribers, providing possibility for call back.
> 
> One operator uses such mechanisms only for numbers defined as emergency 
> by the law. Of course every organisation is free to define its own 
> emergency number for some reasons, but the operators do not have an 
> obligation to take care of this and route such numbers as normal calls.
> 
> I think there is no reason to search in google for every possible 
> emergency number which nobody is routing as emergency according to the 
> regulators requirements.
> 
> BR Vasil
> 
> *Von:*Henning Schulzrinne [mailto:[email-masked]]
> *Gesendet:* Mittwoch, 12. Juli 2017 17:29
> *An:* Aleksiev, Vasil <[email-masked] 
> <mailto:[email-masked]>>
> *Cc:* Brian Rosen <[email-masked] <mailto:[email-masked]>>; 
> [email-masked] <mailto:[email-masked]>
> the service URN does not prescribe any network priority treatment. 
> Indeed, at least in the US, landline 911 calls are treated exactly the 
> same as regular calls, e.g., during network congestion. (We have the SIP 
> RPH mechanism for prioritizing call treatment, but it's not used for 
> civilian emergency calls.)
> 
> doubt that marine emergency calls in Finland or 1-800 calls to the 
> poison control center in the US (and the equivalent set of numbers in 
> Germany, say) receive any priority treatment in the network.
> 
> Naturally, any country or carrier is free to use any label, including 
> the URN, to signify any treatment local law and regulation permits or 
> requires. But the label does not /require/ or imply such network treatment.
> 
> I admit I'm thoroughly confused by this discussion. Where did the 
> priority issue suddenly come from? It's not in any ECRIT document that 
> I'm aware of.
> 
> Henning
> 
> On Wed, Jul 12, 2017 at 10:49 AM, Aleksiev, Vasil 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi Brian,
> 
>     A service URN with a top-level service type of "sos" is used only
>     when the user intends to establish an emergency call. The emergency
>     call will be treated with priority in the network. For non-emergency
>     numbers in one country sos shall not be used since priority there is
>     not needed.
> 
>     Best regards,
> 
>     Vasil
> 
>     *Von:*Brian Rosen [mailto:[email-masked] <mailto:[email-masked]>]
>     *An:* Aleksiev, Vasil <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* Henning Schulzrinne <[email-masked]
>     <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>     Once again, the name has no significance as long as it is unique. 
>     We use the names as suggestive for the service to aid the service
>     providers, regulators and public safety authorities in setting up
>     the systems, but the urn name is not used by anything other than
>     computer software during an emergency.
> 
>     If one country has a service for an ambulance service that is
>     considered an emergency service, but in another country it is not
>     considered an emergency service, we can, and should still use the
>     service in the sos tree for the non-emergency service.  On the other
>     hand, if there was a country that had two ambulance services, one
>     that was used for emergency transport and another that was used for
>     non-emergency transport, then we would need two URNs, because we
>     have distinct services and need different URNs.
> 
>     Brian
> 
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Jul 2017 12:23:00 -0400

Vasil,

I assume you don't know that I have worked for a large telecom regulator
for the past seven years, so grant me that I am somewhat familiar with this
territory. (As usual, anything I say here is my personal opinion, etc.)

This is much more complicated than you make it, unfortunately. To give you
a US example:

911 was put into operation in 1968; it was only legally designated a
national emergency number in 1999 (see
https://www.gpo.gov/fdsys/pkg/PLAW-106publ81/pdf/PLAW-106publ81.pdf).

Similarly, over time, obligations for interconnected VoIP carriers changed
for handling 911. This didn't change the nature of 911, how carriers
treated the number, the technology or consumer expectations.

Secondly, we probably agree that there are numbers that are routinely
treated as emergency numbers in practice. I gave an Austrian example of a
listing of "Notrufnummern" that goes significantly beyond whatever list is
encoded in some legislation. I'm not saying that all of these should be
'sos' (indeed, several should not), but it shows that even official
government web sites have a more fluid definition, based on consumer
expectations and common sense, of what constitutes an emergency number.

Another example: I don't think anybody wants to convert sos.poison, an
existing RFC 5031 registration, to something else. But there is no law (in
the US) that designates the poison control number as an emergency number.

There is a general good-engineering practice of not encoding policy into
protocol (or identifiers), as you want to change policy without changing
protocols.

But I don't think these abstract philosophical discussions are getting us
anywhere. Please take a look at the specific engineering proposals in

and provide comments or alternatives. I think that will get us further than
these abstract discussions.

Henning

On Thu, Jul 13, 2017 at 7:04 AM, Aleksiev, Vasil <[email-masked]

> Henning,
>
> In one country always there is a regulator commission which is monitoring
> the telecom carriers. The regulator issues rules in written form and
> monitors if all the carriers are following it. If the written rules are not
> followed, the regulator issues the respective penalties. So every mobile or
> fixed operator looks into the written rules and takes care of it. In this
> sense the telecom operators are only caring what is the regulator
> definition of emergency calls. That is why we have created a file with
> links to the respective documents, which are issued by the regulators in
> the respective countries (in form of law). In such document there is
> definition for emergency calls and list is present with the numbers
> considered as emergency in the country. The definition usually includes
> serving the calls with priority, providing location of the subscribers,
> providing possibility for call back.
>
> One operator uses such mechanisms only for numbers defined as emergency by
> the law. Of course every organisation is free to define its own emergency
> number for some reasons, but the operators do not have an obligation to
> take care of this and route such numbers as normal calls.
>
> *Cc:* Brian Rosen <[email-masked]>; [email-masked]

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Jul 2017 12:31:02 -0400

Beyond the attempt to designate 112 as the European emergency number,
there's actually a larger effort for other services, under 116 xxx:

https://ec.europa.eu/digital-single-market/en/116-helplines

The 'missing children' one seems most successful in term of widespread
adoption.

I think EENA has been trying to fight for reducing the number of distinct
emergency service numbers. This is the same incentive that led US cities to
use 311 instead of a plethora of service-specific numbers, as it was seen
as more effective to have a single number sort out who the caller should
talk to rather than the phone book "blue pages" approach where the caller
had to reverse-engineer the government org chart.

Henning

On Thu, Jul 13, 2017 at 12:10 PM, Paul Kyzivat <[email-masked]>
wrote:

> (non-nation-specific) enumeration of services is to provide a gentle way of
> encouraging countries to adopt consistent service definitions. Just the
> small effort of deciding whether one of the existing names will work for
> your service, or whether a new name is needed, can be a nudge toward
> consistency.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Jul 2017 12:39:52 -0400

With the widespread adoption of smart phones, is there any effort to 
improving the UI for requesting services? For instance, a GUI with a 
menu? (Such a thing probably wouldn't want to display URNs, it might 
follow the general URN hierarchy.)

On 7/13/17 12:31 PM, Henning Schulzrinne wrote:
> I think EENA has been trying to fight for reducing the number of 
> distinct emergency service numbers. This is the same incentive that led 
> US cities to use 311 instead of a plethora of service-specific numbers, 
> as it was seen as more effective to have a single number sort out who 
> the caller should talk to rather than the phone book "blue pages" 
> approach where the caller had to reverse-engineer the government org chart.
> 
> Henning
> 
> On Thu, Jul 13, 2017 at 12:10 PM, Paul Kyzivat <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     (non-nation-specific) enumeration of services is to provide a gentle
>     way of encouraging countries to adopt consistent service
>     definitions. Just the small effort of deciding whether one of the
>     existing names will work for your service, or whether a new name is
>     needed, can be a nudge toward consistency.
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Jul 2017 14:20:00 -0400

Yes, I suspect there will be either pre-populated address book entries or
icons.

So that Brian doesn't get a heart attack: Any icon would need to require
user confirmation, as in "are you sure you wanted to call poison control?"

The real future is Google Home or Amazon Echo, however. "You seem to be
arguing with your spouse. Should I connect you to [counseling.rmarriage]?"

On Thu, Jul 13, 2017 at 12:39 PM, Paul Kyzivat <[email-masked]>
wrote:

> improving the UI for requesting services? For instance, a GUI with a menu?
> (Such a thing probably wouldn't want to display URNs, it might follow the
> general URN hierarchy.)
>
>

---

From: John-Luc Bakker <[email-masked]>
Date: Thu, 13 Jul 2017 18:22:24 +0000

All though I don’t work for a regulator, I can imagine that service definition is not driven by the URN. Identifying the branch of government actually paying for the day-to-day operations is likely to have an influence. That's why even Europe's 112 may map to different URNs in the different countries of Europe.

I am not sure it is up to IETF to limit the types of emergency services countries may wish to develop or to further complicate defining these emergency services.

A limited set of emergency service types have been available via circuit switched (TS 22.101) [police, fire, ambulance, mountain, sea]. This restriction has not limited the creativity of regulators around the world. It has limited the applicability of the CS EMERGENCY SETUP message (the CS EMERGENCY SETUP message has to include one of the types above). It would seem that at a minimum the 5 types above need to be encoded in URNs (and RFC 5031 does that).

There is no global organization (not the UN) chartered to align emergency services. If experience on CS is a guide, leaving it up to regulators to define various country specific emergency services types (under the "sos" label) is a prudent way forward. I am not aware of a desire by regulators to align emergency service types globally.

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Thursday, July 13, 2017 11:11 AM
To: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

ISTM that one beneficial effect of creating this general
(non-nation-specific) enumeration of services is to provide a gentle way of encouraging countries to adopt consistent service definitions. Just the small effort of deciding whether one of the existing names will work for your service, or whether a new name is needed, can be a nudge toward consistency.

This seems important when people and their phones are roaming across countries.

	Thanks,
	Paul

On 7/13/17 10:47 AM, John-Luc Bakker wrote:
> allocated by other countries, however calls may still be routed to 
> PSAPs offering primarily different emergency services: take for 
> example 112 in Europe. Some countries route calls to 112 to police, 
> while others route them to ambulance (in these countries a dedicated 
> emergency number for police may exist (which should bind to the police 
> URN)). Countries have full jurisdiction over their number plans and 
> rules that prescribe how calls to certain numbers shall be treated/routed.
> 
> beyond the immediacy of the response are country specific. The 
> specific list of services for which immediacy of the response is 
> required are country specific (some services treated as emergency in, 
> say Austria, are not required to be treated as emergency in many other countries).
> 
> detailed/exhaustive registry beyond identifying some basic, more or 
> less universal services. Beyond this, it is really up to the needs of 
> the public in the country in question.
> 
> So every mobile or fixed operator looks into the written rules and 
> takes care of it. In this sense the telecom operators are only caring 
> what is the regulator definition of emergency calls. That is why we 
> have created a file with links to the respective documents, which are 
> issued by the regulators in the respective countries (in form of law). 
> In such document there is definition for emergency calls and list is 
> present with the numbers considered as emergency in the country. The 
> definition usually includes serving the calls with priority, providing 
> location of the subscribers, providing possibility for call back.
> 
> One operator uses such mechanisms only for numbers defined as 
> emergency by the law. Of course every organisation is free to define 
> its own emergency number for some reasons, but the operators do not 
> have an obligation to take care of this and route such numbers as normal calls.
> 
> same as regular calls, e.g., during network congestion. (We have the 
> SIP RPH mechanism for prioritizing call treatment, but it's not used 
> for civilian emergency calls.)
> 
> If you are not the intended recipient, notify the sender immediately, 
> destroy all copies from your system and do not disclose or use the 
> information for any purpose.
> Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte 
> bevorrechtigtem Schutz unterliegen. Wenn Sie nicht der beabsichtigte 
> Adressat sind, informieren Sie bitte den Absender unverzueglich, 
> loeschen Sie alle Kopien von Ihrem System und veroeffentlichen Sie 
> oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.
> 
> Think before you print!
> 
> T-Mobile Austria GmbH

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 13 Jul 2017 14:40:33 -0400

I don't expect this to change. Regulators and other entities say something
like "implement a national lost-children service using 116 000". They don't
specify protocols, URNs, IP addresses, port numbers or other details, and
don't need to. This is very similar to, say, mobile services, where a
regulator may auction spectrum and impose service conditions ("serve 95% of
the population within 5 years"). They don't show up at 3GPP defining the
radio access network modulation parameters or the protocol constants in
DIAMETER.

Thus, this requires no "negotiation".

This would be different if the IETF were to say "lost children services
need to use the phone number 123 and will get lower priority than 112
calls". Clearly, that steps into territory that regulators do care about
since it affects the user interface and experience. Service URNs, as we
have beaten to death on this thread, are not visible to users and do not
affect user experience. (Leaving aside fall-back corner cases.)

Henning

On Thu, Jul 13, 2017 at 10:47 AM, John-Luc Bakker <[email-masked]>
wrote:

> provided within the country and the countries assign the number. *So far,
> countries have not been required to consult with foreign organizations.*
> Countries may choose to allocate the same number allocated by other
> countries, however calls may still be routed to PSAPs offering primarily
> different emergency services: take for example 112 in Europe. Some
> countries route calls to 112 to police, while others route them to
> ambulance (in these countries a dedicated emergency number for police may
> exist (which should bind to the police URN)). Countries have full
> jurisdiction over their number plans and rules that prescribe how calls to
> certain numbers shall be treated/routed.
>
>
>
> country specific (some services treated as emergency in, say Austria, are
> not required to be treated as emergency in many other countries).
>
>
>
> universal services. Beyond this, it is really up to the needs of the public
> in the country in question.
>
>
>
> *From:* Ecrit [mailto:[email-masked]] *On Behalf Of *Aleksiev,
> Vasil
> destroy all
> bevorrechtigtem

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 15 Jul 2017 08:20:25 +0000

Hi,

>As in my prior message to Gunnar, I’m convinced; let’s have non-emergency services, >including one for ambulance.

Great.

The question then is whether we should update RFC 5031, to make it more clear.

Regards,

Christer

>> sos.ambulance for a non emergency ambulance service, unless a country 
>> has both an emergency and a non-emergency ambulance service that 
>> needs urns, is appropriate I think.
>> registration, but I also donąt think we need to.
> 
> services - no matter if the emg and non-emg services are provided in 
> the same country or in different countries.
> 
>> There is no MUST language at all.  Anything is acceptable, although 
>> the expert review gets to offer an opinion, and take it to the list 
>> if needed.
>> 
>> The review is merely supposed to make sure the service is distinct 
>> from an existing registration.  Registrations are cheap.
> 
> Not if we are going to have list discussions about the name whenever a 
> URN is to be registered. It would prolong the registration and, 
> depending on who participate in such discussions, the outcome would be 
> very inconsistent.
> 
> So, I strongly think that if the service is an emergency service, we 
> use sos. If the service is not an emergency service, we donąt use sos.
> 
> And, *URNs* are cheap, so we are not going to łrun out of them˛ if we 
> use different ones for emergency services and non-emergency services.
> 
> 
>> The above example is how I think we donąt get into a mess.  I donąt 
>> think there is a good reason to create an ambulance service that 
>> isnąt in the sos tree unless we have an incidence of two services and 
>> we need to differentiate.  Even if the ambulance service in a country 
>> is not considered an emergency service, using sos.ambulance for it is 
>> fine in my opinion.
>

---

From: Brian Rosen <[email-masked]>
Date: Sat, 15 Jul 2017 10:02:29 -0400

I have a draft in progress:
https://tools.ietf.org/html/draft-rosen-ecrit-service-urn-subregistries-00 <https://tools.ietf.org/html/draft-rosen-ecrit-service-urn-subregistries-00>

Henning and I are going to add subtrees for several kinds of services, and we can include the non-emergency services in that.

It is informational - in only asks IANA to create sub registries, and does not update 5031.  I don’t think we need to update 5031 if we do that.

Brian

> On Jul 15, 2017, at 4:20 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Wed, 19 Jul 2017 23:09:45 +0000

For the UK, I would note that 0800 111 999 is not handled by the regulator or the telecommunications networks as an emergency number. For a real emergency, one would still be expected to dial 999 / 112 and request fire and/or police depending on the nature of the issue. The reached secondary answer point in the UK may then call in other services as appropriate, which could include a gas response. This additional call is again not formally an emergency call.

(One would expect the fire service and the police to be required for a real gas immediate response emergency to protect life. The gas service only has the capability of removing the source of the gas, and has not direct capability of calling in emergency services except by making an emergency call themselves)

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: 13 July 2017 17:05
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

I suspect, despite differences at the margins, we have general agreement on a few points:

* Service URNs are meant to reflect reasonable, common understanding of the service and lead to reasonable fall-back behavior if the specific service is not supported. For example, if there's a service URN sos.fire.wildfire, the behavior is as expected: if it doesn't exist, forwarding the call to whoever handles sos.fire is probably right.

* We already have the 'counseling' tree for non-emergency advice services. We seem to converge on having a non-emergency services tree (or possibly more than one) that reflect services that yield a response (more than talk), but are not considered emergency services.

* We have a light-weight process for adding URNs on an as-needed basis. I suspect this discussion will yield a slew of new registrations that will cover most ECRIT-using services (and many that never will), but we don't need to strive for completeness now.

As I have mentioned, I have made an effort, now updated, to collect the emergency and similar widely-known services for almost all of the OECD countries at

I'm hoping that the list can help avoid pointless discussions about services that could exist, but don't actually do. Also, as mentioned, we don't need to encode every possible widely-known service unless it is likely to use ECRIT-style (service URN + LoST) resolution. Thus, for the time being, we don't have to worry about, say, phone repair, call-before-you-dig, directory services, talking clock services, weather, traffic (511 in the US) or dial-a-prayer services, even though they may all have short code numbers.

Henning

On Thu, Jul 13, 2017 at 2:38 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Regards,

Christer

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Thu, 20 Jul 2017 00:11:53 +0000

I suspect there is one normative statement we should make (emphasise). That is that any usage of a type and subtypes MUST meet the semantics of the type and the subtypes and not just the subtype.

Thus it must be made more explicit that if I use “sos”, I want an immediate response, and if I use “ambulance” with it, I want an ambulance with immediate response. Failure to do this will mean that those responders that validly remove subtypes they do not need to understand will receive erroneous emergency calls.

Keith

From: Brian Rosen [mailto:[email-masked]]
Sent: 15 July 2017 15:02
To: Christer Holmberg <[email-masked]>
Cc: Drage, Keith (Nokia - GB) <[email-masked]>; [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

I have a draft in progress:
https://tools.ietf.org/html/draft-rosen-ecrit-service-urn-subregistries-00

Brian

On Jul 15, 2017, at 4:20 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Great.

Regards,

Christer

On Jul 13, 2017, at 2:38 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Christer

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 24 Jul 2017 11:54:50 +0000

Hello,

my view:

1) an operator deploying a SIP based mobile network needs sos URNs for every emergency service defined in the country of the SIP based mobile network. Those SIP based mobile networks are being deployed today so the sos URNs are needed *NOW* as those sos URNs is used in those SIP based networks for internal routing (even if PSAPs are still using circuit switched technology).

2) it is regulator's decision on what emergency services are offered in a country.

3) if a service is defined as an emergency service by a regulator of a country, there has to be a unique (within the country) sos URN for it.

4) it is regulator's decision on what sos URN to use to indicate an emergency service.

                NOTE: without such decision, operator can guess an sos URN for a service. However, if guessing is incorrect, the operator will need to re-configure the SIP based mobile network (and that one reason for defining sos URNs relying solely on country identification and emergency number identification).

5) so far regulators are not used to make decisions described in 4).

6) it is decision of a regulator of a country A and a regulator of a country B, whether an emergency service X offered in country A is the same as an emergency service Y offered in country B.

7) so far regulators are not used to make decisions described in 6).

8) imagine that a number (e.g. 123) is specified by a regulator for a particular emergency service.

                Let's assume that someone would register a sos URN with a descriptive sublabel for this emergency service and this sos URN would be used in networks.

                Now what to do if the regulator extends the scope of the service associated with this number (i.e. 123)?

                Would someone need to register a new sos URN (with sublabel reflecting the extended scope) and the networks would need to be reconfigured to stop using the old sos URN and start using the new sos URN?

So, I support Vasil's and Roberto's suggestion to specify a sos URN containing country identifier and emergency number (e.g. urn:service:sos.country-specific.<country ID>.<emergency number> or possibly urn:service:sos.country-specific-<country ID>-<emergency number>). Such sos URN will never be used by the UE (with exception of INVITE request triggered by 3xx response), only within the networks.

All the above probably looks unreasonable or over-engineering from US perspective where 911 is the only emergency number. However, that's how it is in real world in other continents and technology needs to support the real world there too (and trying to force changes there will not be successful).

Kind regards

Ivo Sedlacek

PS: Sorry for commenting late - I was enjoying holidays.

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 24 Jul 2017 14:40:57 -0400

I don't know what first-hand experience with regulators you've had, but
from having worked at a well-known one since 2010, this isn't quite mine.
>From my experience, at the staff level, they are well aware of the relevant
organizations (NENA in North America, EENA in Europe), know and are in
regular contact with many of the relevant standards organizations (e.g.,
ATIS in the US, 3GPP or IETF), they attend related meetings and staff are
happy to talk to outside experts. It does require some outreach,
particularly if there has been no prior contact in a particular topic area.
On the European side, I suspect that EENA would be happy to help with
making contact.

Thus, I find the argument that regulators are, to re-cast your argument a
bit, just too clueless and disconnected to care or be educated a bit
presumptuous. From what I can tell, most regulators haven't paid a whole
lot of attention to NG911/NG112 details since they haven't been actionable
until fairly recently.

You are essentially advocating to just use the (short code) numbers. If
that's all you want, there's no reason to bother with sos URNs at all.
Needless to say, I think that's a bad idea.

Henning

On Mon, Jul 24, 2017 at 7:54 AM, Ivo Sedlacek <[email-masked]>
wrote:

> Hello,
>
>
>
> my view:
>
>
>
> 1) an operator deploying a SIP based mobile network needs sos URNs for
> every emergency service defined in the country of the SIP based mobile
> network. Those SIP based mobile networks are being deployed today so the
> sos URNs are needed *NOW* as those sos URNs is used in those SIP based
> networks for internal routing (even if PSAPs are still using circuit
> switched technology).
>
>
>
> 3) if a service is defined as an emergency service by a regulator of a
> country, there has to be a unique (within the country) sos URN for it.
>
>
>
>                 NOTE: without such decision, operator can guess an sos URN
> for a service. However, if guessing is incorrect, the operator will need to
> re-configure the SIP based mobile network (and that one reason for defining
> sos URNs relying solely on country identification and emergency number
> identification).
>
>
>
> 6) it is decision of a regulator of a country A and a regulator of a
> country B, whether an emergency service X offered in country A is the same
> as an emergency service Y offered in country B.
>
>
>
>                 Let's assume that someone would register a sos URN with a
> descriptive sublabel for this emergency service and this sos URN would be
> used in networks.
>
>                 Now what to do if the regulator extends the scope of the
> service associated with this number (i.e. 123)?
>
>                 Would someone need to register a new sos URN (with
> sublabel reflecting the extended scope) and the networks would need to be
> reconfigured to stop using the old sos URN and start using the new sos URN?
>
>
>
> So, I support Vasil's and Roberto's suggestion to specify a sos URN
> containing country identifier and emergency number (e.g.
> urn:service:sos.country-specific.<country ID>.<emergency number> or
> possibly urn:service:sos.country-specific-<country ID>-<emergency
> number>). Such sos URN will never be used by the UE (with exception of
> INVITE request triggered by 3xx response), only within the networks.
>
>
>
> All the above probably looks unreasonable or over-engineering from US
> perspective where 911 is the only emergency number. However, that's how it
> is in real world in other continents and technology needs to support the
> real world there too (and trying to force changes there will not be
> successful).
>
>
>
> Kind regards
>
>
>
> Ivo Sedlacek
>
>
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 25 Jul 2017 06:03:30 +0000

Hello,

can you indicate any *regulation* which defines which emergency URN to use for an emergency service (outside of the usual police, ambulance and fire fighters)?

Kind regards

Ivo

From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, July 24, 2017 8:41 PM
To: Ivo Sedlacek <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

I don't know what first-hand experience with regulators you've had, but from having worked at a well-known one since 2010, this isn't quite mine. From my experience, at the staff level, they are well aware of the relevant organizations (NENA in North America, EENA in Europe), know and are in regular contact with many of the relevant standards organizations (e.g., ATIS in the US, 3GPP or IETF), they attend related meetings and staff are happy to talk to outside experts. It does require some outreach, particularly if there has been no prior contact in a particular topic area. On the European side, I suspect that EENA would be happy to help with making contact.

Thus, I find the argument that regulators are, to re-cast your argument a bit, just too clueless and disconnected to care or be educated a bit presumptuous. From what I can tell, most regulators haven't paid a whole lot of attention to NG911/NG112 details since they haven't been actionable until fairly recently.

You are essentially advocating to just use the (short code) numbers. If that's all you want, there's no reason to bother with sos URNs at all. Needless to say, I think that's a bad idea.

Henning

On Mon, Jul 24, 2017 at 7:54 AM, Ivo Sedlacek <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

my view:

Kind regards

Ivo Sedlacek

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 25 Jul 2017 07:37:38 -0400

Ivo,

not right now - because there wasn't the need. Indeed, in many countries,
such internal details are left to the technical standards that are cited by
reference, if needed. After all, no regulation currently describes the
ECRIT protocols, either.

Henning

On Tue, Jul 25, 2017 at 2:03 AM, Ivo Sedlacek <[email-masked]>
wrote:

> Hello,
>
>
>
> can you indicate any *regulation* which defines which emergency URN to use
> for an emergency service (outside of the usual police, ambulance and fire
> fighters)?
>
>
>
> Kind regards
>
>
>
> Ivo
>
>
>
>
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 25 Jul 2017 12:40:45 +0000

Henning,

Do you agree that:
- *today*, most regulators do not indicate what sos URNs to use for emergency services; and
- *today*, operators of 3GPP SIP based mobile networks need the sos URNs for the emergency services (for emergency call routing in their 3GPP SIP based mobile networks)?

Kind regards

Ivo Sedlacek

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 25 Jul 2017 08:50:43 -0400

> - *today*, most regulators do not indicate what sos URNs to use for

None do, as far as I know. Neither do they specify whether SIP is to be
used over TCP or UDP, or SIP is used at all, among a myriad of other
details.

> - *today*, operators of 3GPP SIP based mobile networks need the sos URNs
> for the emergency services (for emergency call routing in their 3GPP SIP
> based mobile networks)?
>

Yes. And they should decide whether regulators, in a specific country, care
about SOS URNs or see that as a low-level engineering detail that is
invisible to the public.

None of this has anything to do with the discussion of whether to create,
essentially, SOS URNs that are phone numbers.

I haven't heard a substantive argument on this; rather, this is all about
the perceived mental state or ability of regulators, which seems like a
rather peculiar way of designing identifiers and protocols.

I have made a specific set of proposals that provide URNs, sos and
otherwise, for all EENA-identified services and other, non-emergency ones,
that are listed as widely-available services. Rather than speculating about
regulators, it might be more productive to see if they meet the identified
needs and to identify gaps. I look forward to your feedback.

Henning

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 25 Jul 2017 13:25:22 +0000

> None of this has anything to do with the discussion of whether to create, essentially, SOS URNs that are phone numbers.

It has.

Several operators indicated that they do not feel authorized to make a registration for emergency-services-without-an-assigned-sos-URN (Vasil: I see a problem with that I am not authorized to make registrations regarding emergency URNs – I am not representing the regulator or the other operators in the respective countries. and Roberto: I share the points raised by Vasil.) and that a decision needs to be made by the regulator (Vasil: I consider talking with regulator not so easy – it has to be done via the official channels. I expect the regulator, when wants to start a new service, to have a meeting with all the operators present in one country and to discuss the details about. On such meeting every operator can state its opinion and discuss the requirements and possibilities. The requirements for the solution will be finalised and then the regulator can publish the respective law. Gathering such meeting is not in mine authorities. The result of talking only with some of the attending parties in process will be only speculation regarding a future decision. I am also not sure if this is the process in every country.).

That's why the operators want to stick to what is defined by in the regulations (i.e. emergency numbers) and enable its usage for addressing within 3GPP SIP based mobile networks.

Kind regards

Ivo Sedlacek

From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Tuesday, July 25, 2017 2:51 PM
To: Ivo Sedlacek <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

On Tue, Jul 25, 2017 at 8:40 AM, Ivo Sedlacek <[email-masked]<mailto:[email-masked]>> wrote:
Henning,

Do you agree that:

None do, as far as I know. Neither do they specify whether SIP is to be used over TCP or UDP, or SIP is used at all, among a myriad of other details.

Yes. And they should decide whether regulators, in a specific country, care about SOS URNs or see that as a low-level engineering detail that is invisible to the public.

None of this has anything to do with the discussion of whether to create, essentially, SOS URNs that are phone numbers.

I haven't heard a substantive argument on this; rather, this is all about the perceived mental state or ability of regulators, which seems like a rather peculiar way of designing identifiers and protocols.

I have made a specific set of proposals that provide URNs, sos and otherwise, for all EENA-identified services and other, non-emergency ones, that are listed as widely-available services. Rather than speculating about regulators, it might be more productive to see if they meet the identified needs and to identify gaps. I look forward to your feedback.

Henning

Kind regards

Ivo Sedlacek

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 25 Jul 2017 11:01:13 -0400

None of you seem to have actually talked to a living, real "regulator" (in
reality, likely a staff person).

You argue that the RFC 5031 model should be abandoned, by assertion. I'm
not sure that trying to make technical arguments is going to convince you
or even first-hand experience of somebody who works for a regulator, so I
don't think continuing this discussion is particularly productive.

Henning

On Tue, Jul 25, 2017 at 9:25 AM, Ivo Sedlacek <[email-masked]>
wrote:

> > None of this has anything to do with the discussion of whether to
> create, essentially, SOS URNs that are phone numbers.
>
>
>
> It has.
>
>
>
> Several operators indicated that they do not feel authorized to make a
> registration for emergency-services-without-an-assigned-sos-URN (Vasil: I
> see a problem with that I am not authorized to make registrations regarding
> emergency URNs – I am not representing the regulator or the other operators
> in the respective countries. and Roberto: I share the points raised by
> Vasil.) and that a decision needs to be made by the regulator (Vasil: I
> consider talking with regulator not so easy – it has to be done via the
> not sure if this is the process in every country.).
>
>
>
> That's why the operators want to stick to what is defined by in the
> regulations (i.e. emergency numbers) and enable its usage for addressing
> within 3GPP SIP based mobile networks.
>
>
>
> Kind regards
>
>
>
> Ivo Sedlacek
>
>
>
> *From:* Henning Schulzrinne [mailto:[email-masked]]
> *Sent:* Tuesday, July 25, 2017 2:51 PM
> *To:* Ivo Sedlacek <[email-masked]>
> *Cc:* [email-masked]
> Yes. And they should decide whether regulators, in a specific country,
> care about SOS URNs or see that as a low-level engineering detail that is
> invisible to the public.
>
>
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 25 Jul 2017 15:26:35 +0000

Hello,

> You argue that the RFC 5031 model should be abandoned, by assertion. I'm not sure that trying to make technical arguments is going to convince you or even first-hand experience of somebody who works for a regulator, so I don't think continuing this discussion is particularly productive.

I argue that the operator should have a *choice* to use sos URNs based on the currently existing regulations (i.e. based on emergency numbers), until the regulator makes a formal decision on assignment of sos URNs to emergency services.

I do not argue that RFC5031 is to be abandoned.

Kind regards

Ivo Sedlacek