Subject: Re: [Ecrit] country specific emergency URNs

From: "Aleksiev, Vasil" <[email-masked]>
Date: Thu, 10 Aug 2017 18:25:54 +0200

Hi Henning,
I was on a vacation and now back. Regulators are different in every country, experience with one regulator cannot give you a view regarding the regulators in the world.
I can assure you that if a number is defined as emergency from a regulator it shall be treated as emergency. According to the Austrian text there I do not see fluid definitions. I think the regulator has the authority to decide what number is emergency and what not. So if a regulator has decided that the emergency numbers in one country shall be 10 different numbers – all of them shall be treated as emergency. CS has certain limitations – only 7 categories can be used for UE detected emergency calls. But this shall not be the case for other RATs. In this sense I do not see a reason why there shall be limitations on what service shall be treated as emergency and what not.
I also fully support Ivo´s view.

BR Vasil

Von: Henning Schulzrinne [mailto:[email-masked]]
Gesendet: Donnerstag, 13. Juli 2017 18:23
An: Aleksiev, Vasil <[email-masked]>
Cc: Brian Rosen <[email-masked]>; [email-masked]
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil,

I assume you don't know that I have worked for a large telecom regulator for the past seven years, so grant me that I am somewhat familiar with this territory. (As usual, anything I say here is my personal opinion, etc.)

This is much more complicated than you make it, unfortunately. To give you a US example:

911 was put into operation in 1968; it was only legally designated a national emergency number in 1999 (see https://www.gpo.gov/fdsys/pkg/PLAW-106publ81/pdf/PLAW-106publ81.pdf).

Similarly, over time, obligations for interconnected VoIP carriers changed for handling 911. This didn't change the nature of 911, how carriers treated the number, the technology or consumer expectations.

Secondly, we probably agree that there are numbers that are routinely treated as emergency numbers in practice. I gave an Austrian example of a listing of "Notrufnummern" that goes significantly beyond whatever list is encoded in some legislation. I'm not saying that all of these should be 'sos' (indeed, several should not), but it shows that even official government web sites have a more fluid definition, based on consumer expectations and common sense, of what constitutes an emergency number.

Another example: I don't think anybody wants to convert sos.poison, an existing RFC 5031 registration, to something else. But there is no law (in the US) that designates the poison control number as an emergency number.

There is a general good-engineering practice of not encoding policy into protocol (or identifiers), as you want to change policy without changing protocols.

But I don't think these abstract philosophical discussions are getting us anywhere. Please take a look at the specific engineering proposals in

https://docs.google.com/presentation/d/18t1siLVrPTwyYWUm8TQK7EnwC9Y4hwkYZmEa846Pzig/edit?usp=sharing

and provide comments or alternatives. I think that will get us further than these abstract discussions.

Henning

On Thu, Jul 13, 2017 at 7:04 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Henning,
In one country always there is a regulator commission which is monitoring the telecom carriers. The regulator issues rules in written form and monitors if all the carriers are following it. If the written rules are not followed, the regulator issues the respective penalties. So every mobile or fixed operator looks into the written rules and takes care of it. In this sense the telecom operators are only caring what is the regulator definition of emergency calls. That is why we have created a file with links to the respective documents, which are issued by the regulators in the respective countries (in form of law). In such document there is definition for emergency calls and list is present with the numbers considered as emergency in the country. The definition usually includes serving the calls with priority, providing location of the subscribers, providing possibility for call back.
One operator uses such mechanisms only for numbers defined as emergency by the law. Of course every organisation is free to define its own emergency number for some reasons, but the operators do not have an obligation to take care of this and route such numbers as normal calls.
I think there is no reason to search in google for every possible emergency number which nobody is routing as emergency according to the regulators requirements.

BR Vasil

Von: Henning Schulzrinne [mailto:[email-masked]<mailto:[email-masked]>]
Gesendet: Mittwoch, 12. Juli 2017 17:29
An: Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>>
Cc: Brian Rosen <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil,

the service URN does not prescribe any network priority treatment. Indeed, at least in the US, landline 911 calls are treated exactly the same as regular calls, e.g., during network congestion. (We have the SIP RPH mechanism for prioritizing call treatment, but it's not used for civilian emergency calls.)

I suspect this is try for many of the non-112 calls today. I very much doubt that marine emergency calls in Finland or 1-800 calls to the poison control center in the US (and the equivalent set of numbers in Germany, say) receive any priority treatment in the network.

Again, I think it helps make progress if we do not overload labels with policy.

Naturally, any country or carrier is free to use any label, including the URN, to signify any treatment local law and regulation permits or requires. But the label does not require or imply such network treatment.

I admit I'm thoroughly confused by this discussion. Where did the priority issue suddenly come from? It's not in any ECRIT document that I'm aware of.

Henning

On Wed, Jul 12, 2017 at 10:49 AM, Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>> wrote:
Hi Brian,
A service URN with a top-level service type of "sos" is used only when the user intends to establish an emergency call. The emergency call will be treated with priority in the network. For non-emergency numbers in one country sos shall not be used since priority there is not needed.

Best regards,

Vasil

Von: Brian Rosen [mailto:[email-masked]<mailto:[email-masked]>]
Gesendet: Mittwoch, 12. Juli 2017 15:46
An: Aleksiev, Vasil <[email-masked]<mailto:[email-masked]>>
Cc: Henning Schulzrinne <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Betreff: Re: [Ecrit] country specific emergency URNs

Vasil

Once again, the name has no significance as long as it is unique.  We use the names as suggestive for the service to aid the service providers, regulators and public safety authorities in setting up the systems, but the urn name is not used by anything other than computer software during an emergency.

If one country has a service for an ambulance service that is considered an emergency service, but in another country it is not considered an emergency service, we can, and should still use the service in the sos tree for the non-emergency service.  On the other hand, if there was a country that had two ambulance services, one that was used for emergency transport and another that was used for non-emergency transport, then we would need two URNs, because we have distinct services and need different URNs.

Brian

__________________________________________________________________________________________
Notice: This e-mail and any attachments are confidential and may be privileged.
If you are not the intended recipient, notify the sender immediately, destroy all
copies from your system and do not disclose or use the information for any purpose.
Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte bevorrechtigtem
Schutz unterliegen. Wenn Sie nicht der beabsichtigte Adressat sind, informieren Sie
bitte den Absender unverzueglich, loeschen Sie alle Kopien von Ihrem System und
veroeffentlichen Sie oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.

Think before you print!

T-Mobile Austria GmbH
Geschaeftsfuehrung: Dr. Andreas Bierwirth (Vorsitzender), Aufsichtsrat: Dr. Rolf Nafziger (Vorsitzender)
Firmenbuch: Handelsgericht Wien, Sitz Wien, FN 171112k, UID ATU 45011703, DVR 0898295
Konto: UniCredit Bank Austria AG IBAN: AT93 1200 0528 4407 2301, BIC: BKAUATWW

T-Mobile – Das verbindet uns.
__________________________________________________________________________________________

__________________________________________________________________________________________
Notice: This e-mail and any attachments are confidential and may be privileged.
If you are not the intended recipient, notify the sender immediately, destroy all
copies from your system and do not disclose or use the information for any purpose.
Diese E-Mail inklusive aller Anhaenge ist vertraulich und koennte bevorrechtigtem
Schutz unterliegen. Wenn Sie nicht der beabsichtigte Adressat sind, informieren Sie
bitte den Absender unverzueglich, loeschen Sie alle Kopien von Ihrem System und
veroeffentlichen Sie oder nutzen Sie die Information keinesfalls, gleich zu welchem Zweck.

Think before you print!

T-Mobile Austria GmbH
Geschaeftsfuehrung: Dr. Andreas Bierwirth (Vorsitzender), Aufsichtsrat: Dr. Rolf Nafziger (Vorsitzender)
Firmenbuch: Handelsgericht Wien, Sitz Wien, FN 171112k, UID ATU 45011703, DVR 0898295
Konto: UniCredit Bank Austria AG IBAN: AT93 1200 0528 4407 2301, BIC: BKAUATWW

T-Mobile – Das verbindet uns.
__________________________________________________________________________________________

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 10 Aug 2017 21:18:20 -0400

Unfortunately, you offer no evidence of your assertions and no indication
that the proposed approach that follows the SOS URI does not work. (The
approach is simple: We define SOS URIs for emergency services as needed and
as requested by regulators or other relevant entities.)

The approach is pretty straightforward and depends on the local situation:

Case 1: The regulator does not care about SOS URNs, considering this a
user-invisible network-internal matter. The local (national) carriers map
the emergency numbers in a country to a SOS URN. If there's no suitable
match, a new URN is defined, with a short registration process that we are
currently exercising. (I suspect that the US would work that way.)

Case 2: The regulator cares about SOS URNs. In that case, they are involved
in the discussion, e.g., to determine whether this is a good opportunity to
create a regionally-unified label for a similar service (to facilitate
roaming, including accidental roaming, and cross-border handling).

Obviously, it's a good idea to find out in each case whether the regulator
cares or not, but as long as each emergency number maps to a unique URN,
it's just a user-invisible label.

Organizations such as EENA can help keep informational number-to-URN lists,
if that's helpful.

You are advocating, essentially, reverting to the number-based approach
which the ECRIT working group has rejected in its earlier standards effort,
because of the known deficiencies. Thus, I'm not sure how we can make
progress beyond repeating assertions about unnamed regulators who may or
may not like certain things. If you can explain, beyond mere assertion, why
the process above would not work, maybe we can make progress.

Henning

On Thu, Aug 10, 2017 at 12:25 PM, Aleksiev, Vasil <
[email-masked]> wrote:

> Hi Henning,
>
> I was on a vacation and now back. Regulators are different in every
> country, experience with one regulator cannot give you a view regarding the
> regulators in the world.
>
> I can assure you that if a number is defined as emergency from a regulator
> it shall be treated as emergency. According to the Austrian text there I do
> not see fluid definitions. I think the regulator has the authority to
> decide what number is emergency and what not. So if a regulator has decided
> that the emergency numbers in one country shall be 10 different numbers –
> all of them shall be treated as emergency. CS has certain limitations –
> only 7 categories can be used for UE detected emergency calls. But this
> shall not be the case for other RATs. In this sense I do not see a reason
> why there shall be limitations on what service shall be treated as
> emergency and what not.
>
> *Von:* Henning Schulzrinne [mailto:[email-masked]]
> *Gesendet:* Donnerstag, 13. Juli 2017 18:23
> *An:* Aleksiev, Vasil <[email-masked]>
> *Cc:* Brian Rosen <[email-masked]>; [email-masked]
> *Betreff:* Re: [Ecrit] country specific emergency URNs
>
>
>
> Vasil,
>
>
>
> I assume you don't know that I have worked for a large telecom regulator
> for the past seven years, so grant me that I am somewhat familiar with this
> territory. (As usual, anything I say here is my personal opinion, etc.)
>
>
>
> 911 was put into operation in 1968; it was only legally designated a
> national emergency number in 1999 (see https://www.gpo.gov/
> fdsys/pkg/PLAW-106publ81/pdf/PLAW-106publ81.pdf).
>
>
>
> Similarly, over time, obligations for interconnected VoIP carriers changed
> for handling 911. This didn't change the nature of 911, how carriers
> treated the number, the technology or consumer expectations.
>
>
>
> Secondly, we probably agree that there are numbers that are routinely
> treated as emergency numbers in practice. I gave an Austrian example of a
> listing of "Notrufnummern" that goes significantly beyond whatever list is
> encoded in some legislation. I'm not saying that all of these should be
> 'sos' (indeed, several should not), but it shows that even official
> government web sites have a more fluid definition, based on consumer
> expectations and common sense, of what constitutes an emergency number.
>
>
>
> Another example: I don't think anybody wants to convert sos.poison, an
> existing RFC 5031 registration, to something else. But there is no law (in
> the US) that designates the poison control number as an emergency number.
>
>
>
> There is a general good-engineering practice of not encoding policy into
> protocol (or identifiers), as you want to change policy without changing
> protocols.
>
>
>
> But I don't think these abstract philosophical discussions are getting us
> anywhere. Please take a look at the specific engineering proposals in
>
>
>
> On Thu, Jul 13, 2017 at 7:04 AM, Aleksiev, Vasil <
> [email-masked]> wrote:
>
> Henning,
>
> In one country always there is a regulator commission which is monitoring
> the telecom carriers. The regulator issues rules in written form and
> monitors if all the carriers are following it. If the written rules are not
> followed, the regulator issues the respective penalties. So every mobile or
> fixed operator looks into the written rules and takes care of it. In this
> sense the telecom operators are only caring what is the regulator
> definition of emergency calls. That is why we have created a file with
> links to the respective documents, which are issued by the regulators in
> the respective countries (in form of law). In such document there is
> definition for emergency calls and list is present with the numbers
> considered as emergency in the country. The definition usually includes
> serving the calls with priority, providing location of the subscribers,
> providing possibility for call back.
>
> One operator uses such mechanisms only for numbers defined as emergency by
> the law. Of course every organisation is free to define its own emergency
> number for some reasons, but the operators do not have an obligation to
> take care of this and route such numbers as normal calls.
>
> I think there is no reason to search in google for every possible
> emergency number which nobody is routing as emergency according to the
> regulators requirements.
>
>
>
> BR Vasil
>
>
>
>
>
> *Von:* Henning Schulzrinne [mailto:[email-masked]]
> *Gesendet:* Mittwoch, 12. Juli 2017 17:29
> *An:* Aleksiev, Vasil <[email-masked]>
> *Cc:* Brian Rosen <[email-masked]>; [email-masked]
> *Betreff:* Re: [Ecrit] country specific emergency URNs
>
>
>
> Vasil,
>
>
>
> the service URN does not prescribe any network priority treatment. Indeed,
> at least in the US, landline 911 calls are treated exactly the same as
> regular calls, e.g., during network congestion. (We have the SIP RPH
> mechanism for prioritizing call treatment, but it's not used for civilian
> emergency calls.)
>
>
>
> I suspect this is try for many of the non-112 calls today. I very much
> doubt that marine emergency calls in Finland or 1-800 calls to the poison
> control center in the US (and the equivalent set of numbers in Germany,
> say) receive any priority treatment in the network.
>
>
>
> Naturally, any country or carrier is free to use any label, including the
> URN, to signify any treatment local law and regulation permits or requires.
> But the label does not *require* or imply such network treatment.
>
>
>
> I admit I'm thoroughly confused by this discussion. Where did the priority
> issue suddenly come from? It's not in any ECRIT document that I'm aware of.
>
> Henning
>
>
>
> On Wed, Jul 12, 2017 at 10:49 AM, Aleksiev, Vasil <
> [email-masked]> wrote:
>
> Hi Brian,
>
> A service URN with a top-level service type of "sos" is used only when the
> user intends to establish an emergency call. The emergency call will be
> treated with priority in the network. For non-emergency numbers in one
> country sos shall not be used since priority there is not needed.
>
>
>
> Best regards,
>
>
>
> Vasil
>
>
>
>
>
> *Von:* Brian Rosen [mailto:[email-masked]]
> *Gesendet:* Mittwoch, 12. Juli 2017 15:46
> *An:* Aleksiev, Vasil <[email-masked]>
> *Cc:* Henning Schulzrinne <[email-masked]>; [email-masked]
> *Betreff:* Re: [Ecrit] country specific emergency URNs
>
>
>
> Vasil
>
>
>
> Once again, the name has no significance as long as it is unique.  We use
> the names as suggestive for the service to aid the service providers,
> regulators and public safety authorities in setting up the systems, but the
> urn name is not used by anything other than computer software during an
> emergency.
>
>
>
> If one country has a service for an ambulance service that is considered
> an emergency service, but in another country it is not considered an
> emergency service, we can, and should still use the service in the sos tree
> for the non-emergency service.  On the other hand, if there was a country
> that had two ambulance services, one that was used for emergency transport
> and another that was used for non-emergency transport, then we would need
> two URNs, because we have distinct services and need different URNs.
>
>
>
> Brian
>
>
>
>
>
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Fri, 11 Aug 2017 06:54:34 +0000

Hello,

Case 1: The regulator does not care about SOS URNs, considering this a user-invisible network-internal matter. The local (national) carriers map the emergency numbers in a country to a SOS URN. If there's no suitable match, a new URN is defined, with a short registration process that we are currently exercising. (I suspect that the US would work that way.)

you still do not seem to understand the point.

The operators do not feel authorized to request definition of the new emergency service and its sos URN.

They operators feel that this is responsiblity of the regulator.

Kind regards

Ivo

---

From: Ivo Sedlacek <[email-masked]>
Date: Fri, 11 Aug 2017 10:09:18 +0000

To be clear - by referring to "the operators" below, I meant the operators which expressed the view in this discussion so far.

Kind regards

Ivo

From: Ecrit [mailto:[email-masked]] On Behalf Of Ivo Sedlacek
Sent: Friday, August 11, 2017 8:55 AM
To: Henning Schulzrinne <[email-masked]>; Aleksiev, Vasil <[email-masked]>
Cc: [email-masked]
Subject: Re: [Ecrit] country specific emergency URNs

Hello,

Kind regards

Ivo

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 11 Aug 2017 09:33:13 -0400

Carriers are not asked to "define" an emergency service or create a new
one. You are translating an existing emergency number, defined by
regulators, statute or just custom, into an internal protocol identifier
(SOS URN) invisible to users. Can you point to an actual regulation that
prevents carriers (or standards bodies) from defining protocol constants?
Again, I think we'll make more progress if we can get beyond feelings and
fears and to facts.

Henning

On Fri, Aug 11, 2017 at 6:09 AM, Ivo Sedlacek <[email-masked]>
wrote:

> To be clear - by referring to "the operators" below, I meant the operators
> which expressed the view in this discussion so far.
>
>
>
> Kind regards
>
>
>
> Ivo
>
>
>
> *From:* Ecrit [mailto:[email-masked]] *On Behalf Of *Ivo Sedlacek
> *Sent:* Friday, August 11, 2017 8:55 AM
> *To:* Henning Schulzrinne <[email-masked]>; Aleksiev, Vasil <
> [email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Ecrit] country specific emergency URNs
>
>
>
> Hello,
>
>
>