From emu-bounces@ietf.org Fri Jan 20 16:20:08 2006
Received: from localhost.cnri.reston.va.us ([127.0.0.1] helo=megatron.ietf.org)
	by megatron.ietf.org with esmtp (Exim 4.32)
	id 1F03g0-0005Z6-OW; Fri, 20 Jan 2006 16:20:08 -0500
Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
	by megatron.ietf.org with esmtp (Exim 4.32)
	id 1F03fv-0005X4-SF; Fri, 20 Jan 2006 16:20:03 -0500
Received: from ietf-mx.ietf.org (ietf-mx [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id QAA24988;
	Fri, 20 Jan 2006 16:18:35 -0500 (EST)
Received: from [132.151.6.50] (helo=newodin.ietf.org)
	by ietf-mx.ietf.org with esmtp (Exim 4.43)
	id 1F03oj-00057l-OL; Fri, 20 Jan 2006 16:29:10 -0500
Received: from mlee by newodin.ietf.org with local (Exim 4.43)
	id 1F03fu-0002A9-1h; Fri, 20 Jan 2006 16:20:02 -0500
Content-Type: text/plain
Mime-Version: 1.0
To: ietf-announce@ietf.org
From: IESG Secretary <iesg-secretary@ietf.org>
Message-Id: <E1F03fu-0002A9-1h@newodin.ietf.org>
Date: Fri, 20 Jan 2006 16:20:02 -0500
X-Spam-Score: 0.0 (/)
X-Scan-Signature: 10d3e4e3c32e363f129e380e644649be
Cc: emu@ietf.org
Subject: [Emu] WG Action: EAP Method Update (emu) 
X-BeenThere: emu@ietf.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: "EAP Methods Update \(EMU\)" <emu.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/emu>,
	<mailto:emu-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www1.ietf.org/pipermail/emu>
List-Post: <mailto:emu@ietf.org>
List-Help: <mailto:emu-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/emu>,
	<mailto:emu-request@ietf.org?subject=subscribe>
Sender: emu-bounces@ietf.org
Errors-To: emu-bounces@ietf.org

A new IETF working group has been formed in the Security Area. For additional
information, please contact the Area Directors or the WG Chairs.

+++

EAP Method Update (emu)
========================

Current Status: Active Working Group

Chairs:
Jari Arkko <jari.arkko@piuha.net>
Joe Salowey <jsalowey@cisco.com>

Security Area Director(s):
Russ Housley <housley@vigilsec.com>
Sam Hartman <hartmans-ietf@mit.edu>

Security Area Advisor:
Sam Hartman <hartmans-ietf@mit.edu>

Mailing Lists: 
General Discussion: emu@ietf.org
To Subscribe: https://www1.ietf.org/mailman/listinfo/emu
Archive: http://www.ietf.org/mail-archive/web/emu/current/index.html


Description of Working Group:

The Extensible Authentication Protocol (EAP) [RFC 3748] is a network
access authentication framework used in the PPP, 802.11, 802.16, VPN,
PANA, and in some functions in 3G networks. EAP itself is a simple
protocol and actual authentication happens in EAP methods.

Over 40 different EAP methods exist. Most of this methods are
proprietary methods and only a few methods are documented in RFCs. The
lack of documented, open specifications is a deployment and
interoperability problem. In addition, none of the EAP methods in the
standards track implement features such as key derivation that are
required for many modern applications. This poses a problem for, among
other things, the selection of a mandatory to implement EAP method in
new network access technologies. For example, no standards track
methods meet new requirements such as those posed in RFC 4017, which
documents IEEE 802.11 requirements for EAP methods.

This group is chartered to work on the following types of mechanisms to
meet RFC 3748 and RFC 4017 requirements:

- An update to RFC 2716 to bring EAP-TLS into standards track, clarify
specification, interoperability, and implementation issues gathered over
the years, and update the document to meet the requirements of RFC 3748,
RFC 4017, and EAP keying framework documents. Backwards compatibility with 
RFC 2716 is a requirement.

- Enhanced functionality to enable a TLS-based EAP method to support
authentication methods beyond certificates, channel bindings and other
optional functions required in RFC 4017. So as to enable RFC 2716bis to
focus solely on clarifications to the existing protocol, this effort
will be handled in a separate document. Depending on an analysis of the
behavior of existing implementations, it is possible that this effort
may be able to use the existing EAP-TLS type code, or it may need to be
handled via assignment of a new EAP Type Code.

- A mechanism based on strong shared secrets that meets RFC 3748 and RFC
4017 requirements. This mechanism should strive to be simple and
compact for implementation in resource constrained environments.

- A mechanism meeting RFC 3748 and RFC 4017 requirements that makes use
of existing password databases such as AAA databases. The implementation
should strive to be usable in resource constrained environments.

In order to facilitate the development of the shared secret and password
based methods design teams will be formed. The design teams should take
into consideration existing methods including mechanisms based on
EAP-TLS such as TLS-PSK.

Milestones:
Feb 2006 Form design team to work on strong shared secret mechanism
Mar 2006 Submit 2716bis I-D
Jun 2006 Submit first draft of enhanced EAP-TLS I-D
Jul 2006 Form password based mechanism design team
Jul 2006 Submit first draft of shared secret mechanism I-D
Aug 2006 Submit 2716bis draft to IESG for Proposed Standard
Nov 2006 Submit 2716bis draft to IESG for draft standard
Dec 2006 Submit first draft password based method I-D
Jan 2007 Submit Strong Shared Secret Mechanism to IESG
Jan 2007 Submit enhanced EAP-TLS to IESG
Aug 2007 Submit password Based Mechanism to IESG

_______________________________________________
Emu mailing list
Emu@ietf.org
https://www1.ietf.org/mailman/listinfo/emu



From emu-bounces@ietf.org Mon Jan 30 00:16:09 2006
Received: from localhost.cnri.reston.va.us ([127.0.0.1] helo=megatron.ietf.org)
	by megatron.ietf.org with esmtp (Exim 4.32)
	id 1F3ROb-0004An-Eq; Mon, 30 Jan 2006 00:16:09 -0500
Received: from odin.ietf.org ([132.151.1.176] helo=ietf.org)
	by megatron.ietf.org with esmtp (Exim 4.32) id 1F3ROa-0004AV-DL
	for emu@megatron.ietf.org; Mon, 30 Jan 2006 00:16:08 -0500
Received: from ietf-mx.ietf.org (ietf-mx [132.151.6.1])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id AAA26819
	for <emu@ietf.org>; Mon, 30 Jan 2006 00:14:23 -0500 (EST)
Received: from sj-iport-3-in.cisco.com ([171.71.176.72]
	helo=sj-iport-3.cisco.com) by ietf-mx.ietf.org with esmtp (Exim 4.43)
	id 1F3RZ7-0007df-8J for emu@ietf.org; Mon, 30 Jan 2006 00:27:02 -0500
Received: from sj-core-1.cisco.com ([171.71.177.237])
	by sj-iport-3.cisco.com with ESMTP; 29 Jan 2006 21:15:48 -0800
X-IronPort-AV: i="4.01,232,1136188800"; 
	d="scan'208"; a="398114026:sNHT29110472"
Received: from E2K-SEA-XCH2.sea-alpha.cisco.com (e2k-sea-xch2.cisco.com
	[10.93.132.68])
	by sj-core-1.cisco.com (8.12.10/8.12.6) with ESMTP id k0U5FlKT021489
	for <emu@ietf.org>; Sun, 29 Jan 2006 21:15:48 -0800 (PST)
X-MimeOLE: Produced By Microsoft Exchange V6.0.6249.0
content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: text/plain;
	charset="US-ASCII"
Content-Transfer-Encoding: quoted-printable
Date: Sun, 29 Jan 2006 21:22:18 -0800
Message-ID: <7210B31550AC934A8637D6619739CE69068C1CEA@e2k-sea-xch2.sea-alpha.cisco.com>
Thread-Topic: EMU PSK Method work Item
Thread-Index: AcYlXDoZs2MvzSipTNCJ0jye+pJm3w==
From: "Salowey, Joe" <jsalowey@cisco.com>
To: <emu@ietf.org>
X-Spam-Score: 0.0 (/)
X-Scan-Signature: 798b2e660f1819ae38035ac1d8d5e3ab
Content-Transfer-Encoding: quoted-printable
Subject: [Emu] EMU PSK Method work Item
X-BeenThere: emu@ietf.org
X-Mailman-Version: 2.1.5
Precedence: list
List-Id: "EAP Methods Update \(EMU\)" <emu.ietf.org>
List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/emu>,
	<mailto:emu-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www1.ietf.org/pipermail/emu>
List-Post: <mailto:emu@ietf.org>
List-Help: <mailto:emu-request@ietf.org?subject=help>
List-Subscribe: <https://www1.ietf.org/mailman/listinfo/emu>,
	<mailto:emu-request@ietf.org?subject=subscribe>
Sender: emu-bounces@ietf.org
Errors-To: emu-bounces@ietf.org

The first work item on the EMU charter is to start work on a shared
secret EAP method.  The item on the charter is:

"A mechanism based on strong shared secrets that meets RFC 3748 and
RFC 4017 requirements. This mechanism should strive to be simple and
compact for implementation in resource constrained environments."

The emphasis here is to create a simple, secure mechanism to support pre
shared secret keys.  Support for optional enhancements may be considered
in the design as long as it does not bog down the progress of the work
item.  Current work in this area which should be considered in the
design including:

EAP-PAX - draft-clancy-eap-pax-06.txt
EAP-PSK - draft-bersani-eap-psk-09.txt
EAP-SAKE - draft-vanderveen-eap-sake-00.txt
EAP-IKEv2 - draft-eronen-ipsec-ikev2-eap-auth-04.txt
TLS-PSK - RFC4279

Please send email to the chairs if you are interested in participating
as a contributor on the shared secret method design team along with a
description of your experience.

_______________________________________________
Emu mailing list
Emu@ietf.org
https://www1.ietf.org/mailman/listinfo/emu



