Subject: RE: [Enum] ENUM Requirements

From: [email-masked]
Date: Tue, 30 Nov 1999 14:25:35 -0600

> Are 1 800 numbers or the UK version of toll free legitimate 
> e164 numbers or is this national numbering plan specific. 
> I agree these numbers are essential to resolve but what 
> other classes of numbers must resolve as well... 900 ?

Freephone numbers are not E.164 addresses, but I think
it's pretty clear that the mechanism developed by enum
will work just as well in other domains (say, nanpa.int).
The problem, of course, is that applications would need
to be able to determine whether a number exists
within the E.164 domain or a national numbering plan
domain.
 
> Is it appropriate at this time to formally Require ENUM to coordinate 
> efforts with ITU SG2 etc? 

Require?  I should think not.  At any right, the only
body I know of which now has a work item on E.164->IP
address resolution is ETSI Project TIPHON.  Eurescom has
a very large telecoms database project, but I think
that it's scoped somewhat differently.

Melinda
-- 
Melinda Shore
Member of the Scientific Staff
Nokia IP Telephony
127 West State Street
Ithaca, NY  14850
+1 607 273 0724 (office)
+1 607 275 3610 (fax)
+1 607 227 4096 (mobile)
[email-masked]

_______________________________________________
enum mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/enum

---

From: Richard Shockey <[email-masked]>
Date: Tue, 30 Nov 1999 15:09:45 -0600

>within the E.164 domain or a national numbering plan

I don't think this is a problem. Its clear to me now that specific national 
numbering plan features could be zoned specifically for that purpose in 
much the way you suggest if the zone .1 points to a specific delegation for 
.8.0.0.  or .8.8.8 etc. What I was not clear of originally was that 
multiple digits could combined in this way.

I think we all want to avoid clients having any prior knowledge of national 
plan specific features.

>that it's scoped somewhat differently.

You're right .. require is not the right word though I think this proposal 
will closely examined by  IETF "sister" standards bodies.

Richard Shockey
Shockey Consulting LLC
8045 Big Bend Blvd. Suite 110
St. Louis, MO 63119
Voice 314.918.9020
eFAX Fax to EMail 815.333.1237 (Preferred for Fax)
INTERNET Mail & IFAX : [email-masked]
GSTN Fax 314.918.9015
MediaGate iPost VoiceMail and Fax 800.260.4464
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: Christian Huitema <[email-masked]>
Date: Tue, 30 Nov 1999 17:39:44 -0500

At 03:09 PM 11/30/99 -0600, Richard Shockey wrote:
> [.. snip ..]

We debated this at length in DC, and we also debated it in previous
instantiations of the BOF. Dial plans are here to stay, and it is very
important to accomodate them.  Joe User or Jane Average have no idea of
what E.164 means. Frankly, how many times do you see phone numbers on
business cards written with the explicit "+" convention, as in "+1 973 829
5555"? You are much more likely to see the number printed exactly as the
person would have dialed it, using the local plan. And you may bet that
these numbers would be the most likely input to any translation system.

I think that the right architecture should assume that dial-plans, be they
national or private, are mapped into specific subtrees of the DNS, and that
the number resolution software is parametrized by the name of the
"translation root." Then, we have to make sure that we can use the right
technique, e.g. point *.0.0.dial-plan.fr to *.e164.int using DNS aliasing.

The usage of an explicit parametrization of the subtree has another
advantage.  It allows for the user to choose between parallel mapping
trees, thus allowing for competition between different mapping systems and
avoiding the monopoly capture of a single root.
-- Christian Huitema