Subject: [eppext] I-D Action: draft-ietf-eppext-reg-02.txt

From: [email-masked]
Date: Tue, 11 Mar 2014 09:07:35 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Extensible Provisioning Protocol Extensions Working Group of the IETF.

        Title           : Extension Registry for the Extensible Provisioning Protocol
        Author          : Scott Hollenbeck
	Filename        : draft-ietf-eppext-reg-02.txt
	Pages           : 10
	Date            : 2014-03-11

Abstract:
   The Extensible Provisioning Protocol (EPP) includes features to add
   functionality by extending the protocol.  It does not, however,
   describe how those extensions are managed.  This document describes a
   procedure for the registration and management of extensions to EPP
   and it specifies a format for an IANA registry to record those
   extensions.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-eppext-reg/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-eppext-reg-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-eppext-reg-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 11 Mar 2014 16:13:48 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, March 11, 2014 12:08 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [eppext] I-D Action: draft-ietf-eppext-reg-02.txt
> 
> 

This version contains updates to address our IETF-89 discussion[1]. I added a section to describe the designated expert function and guidelines for the experts. I also added a new optional field to the registration template for the inclusion of notes from the registrant. Here's a diff:

Scott

[1] http://www.ietf.org/mail-archive/web/eppext/current/msg00057.html

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 14 Mar 2014 09:35:59 +0100

op 11-03-14 17:13, Hollenbeck, Scott schreef:
> 
> This version contains updates to address our IETF-89 discussion[1].
> I added a section to describe the designated expert function and
> guidelines for the experts. I also added a new optional field to
> the registration template for the inclusion of notes from the
> registrant. Here's a diff:

Hi Scott,

I have not gone in detail over the added text, but it looks good!

One thing I'm missing though, is a method to delete extensions from
the registry when f.e. someone harmonizes it's proprietary extension
with more accepted one.
I'm also in doubt whether we should then "delete" the entry in the
registry, or mark it as "historic" or "deprecated" but leave it in
there. The risk of leaving it in the registry is off course that the
specification may not be available or maintained anymore.
Any thoughts?

- -- 
Antoin Verschuren

Technical Policy Advisor SIDN
Meander 501, PO Box 5022, 6802 EA Arnhem, The Netherlands

P: +31 26 3525500  M: +31 6 23368970
Mailto: [email-masked]
XMPP: [email-masked]
HTTP://www.sidn.nl/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 14 Mar 2014 10:41:52 +0000

> From: EppExt [mailto:[email-masked]] On Behalf Of Antoin
> Verschuren
> Sent: Friday, March 14, 2014 4:36 AM
> To: [email-masked]
> Subject: Re: [eppext] I-D Action: draft-ietf-eppext-reg-02.txt
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

There's also a risk of a specification going missing for an "active" registration. Should such entries be deprecated if/when someone notices? I'm going to say "yes" if attempts to reach the registrant are unsuccessful.

We could add a status field to the template to identify active and obsolete/deprecated extensions. We could also create two sections in the registry, with one section for active registrations and the other for deprecated extensions.

Scott