Subject: [eppext] Updates for eppext-reg Based on IETF-89 Discussion

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 10 Mar 2014 12:41:29 +0000

What I think I heard during the meeting in London:

IANA registration policy: Specification Required (which includes designated expert review)

Add guidelines for the designated expert function, including a recommendation to appoint a small group of people instead of just one person, use of the eppext mailing list for review and discussion, use of RFC 3735 (Guidelines for Extending the Extensible Provisioning Protocol) as a review guide, general goal is to lean towards a permissive registration policy for existing, deployed extensions while encouraging harmonization for new extensions.

Anything else?

Scott

---

From: "Gould, James" <[email-masked]>
Date: Mon, 10 Mar 2014 15:56:51 +0000

Scott,

That matches my take from the meeting.

Thanks,

-- 
 
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

On 3/10/14, 8:41 AM, "Hollenbeck, Scott" <[email-masked]> wrote:

>Add guidelines for the designated expert function, including a
>recommendation to appoint a small group of people instead of just one
>person, use of the eppext mailing list for review and discussion, use of
>RFC 3735 (Guidelines for Extending the Extensible Provisioning Protocol)
>as a review guide, general goal is to lean towards a permissive
>registration policy for existing, deployed extensions while encouraging
>harmonization for new extensions.
>
>Anything else?
>
>Scott
>
>_______________________________________________
>EppExt mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/eppext

---

From: Pete Resnick <[email-masked]>
Date: Fri, 14 Mar 2014 08:50:59 +0200

> Add guidelines for the designated expert function, including a recommendation to appoint a small group of people instead of just one person, use of the eppext mailing list for review and discussion…

This all sounds like what was said, but I don't remember hearing a final 
answer to one question: Is a specification required to get into the 
registry, or can the designated expert approve an entry before a proper 
specification is written up and a pointer to the specification is 
provided later?

pr

-- 
Pete Resnick<http://www.qualcomm.com/~presnick/>
Qualcomm Technologies, Inc. - +1 (858)651-4478

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 14 Mar 2014 09:23:03 +0100

op 14-03-14 07:50, Pete Resnick schreef:
>> recommendation to appoint a small group of people instead of just
>> one person, use of the eppext mailing list for review and
>> discussion, use of RFC 3735 (Guidelines for Extending the
>> Extensible Provisioning Protocol) as a review guide, general goal
>> is to lean towards a permissive registration policy for existing,
>> deployed extensions while encouraging harmonization for new
>> extensions.
> 
> This all sounds like what was said, but I don't remember hearing a
> final answer to one question: Is a specification required to get
> into the registry, or can the designated expert approve an entry
> before a proper specification is written up and a pointer to the
> specification is provided later?

I would say that it is very hard to encourage harmonization for new
extensions if you don't have a specification to compare against.
- From a registrar's perspective, harmonization is a goal for EPPEXT.
Judging if the extension fulfills RFC3735 guidelines is also hard when
there is no specification.
It will make the reviewer task impossible if there is no specification.

So I would say specification is required.

- -- 
Antoin Verschuren

Technical Policy Advisor SIDN
Meander 501, PO Box 5022, 6802 EA Arnhem, The Netherlands

P: +31 26 3525500  M: +31 6 23368970
Mailto: [email-masked]
XMPP: [email-masked]
HTTP://www.sidn.nl/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 14 Mar 2014 10:33:00 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Antoin
> Verschuren
> Sent: Friday, March 14, 2014 4:23 AM
> To: [email-masked]
> Subject: Re: [eppext] Updates for eppext-reg Based on IETF-89
> Discussion
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

I would as well.

Scott

---

From: Frederico A C Neves <[email-masked]>
Date: Tue, 18 Mar 2014 11:10:02 -0300

> > So I would say specification is required.

I would say as well but, when I mean "stable specification" is
required I don't mean RFC or even RFC draft format.

> Scott

Fred

---

From: Miek Gieben <[email-masked]>
Date: Tue, 18 Mar 2014 14:12:49 +0000

[ Quoting <[email-masked]> in "Re: [eppext] Updates for eppext-reg..." ]
> required I don't mean RFC or even RFC draft format.

Agreed. But what would a "specification" look like then? What is acceptable,
what is not acceptable?

/Miek

-- 
Miek Gieben

---

From: Frederico A C Neves <[email-masked]>
Date: Tue, 18 Mar 2014 11:18:56 -0300

> Agreed. But what would a "specification" look like then? What is acceptable,

What about a stable URL pointing to a document that respects RFC 3735
2.1 ?

Fred

---

From: "Gould, James" <[email-masked]>
Date: Tue, 18 Mar 2014 14:19:37 +0000

I propose taking the language from the registry agreement, which is
³Internet-Draft format following the guidelines described in RFC 3735².
-- 
 
JG

James Gould
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

---

From: Frederico A C Neves <[email-masked]>
Date: Tue, 18 Mar 2014 11:30:44 -0300

James,

> ³Internet-Draft format following the guidelines described in RFC 3735².

That was definitely not the consensus at the London meeting. Even 3735
2.1 last paragraph doesn't say that.

We need to remember that one of the intents of the registry is to
reference the extensions already out. Some of then are not documented
as internet-drafts and we should not impose this barrier if we want
this registry to be successful.

Fred

---

From: Gavin Brown <[email-masked]>
Date: Tue, 18 Mar 2014 14:45:27 +0000

I agree - a specification in I-D format should not be required, although I am fine with wording which recommends or encourages that format for new extensions.

G.

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: Miek Gieben <[email-masked]>
Date: Wed, 19 Mar 2014 10:32:03 +0000

> What about a stable URL pointing to a document that respects RFC 3735

That seems like a very sensible requirement.

/Miek

-- 
Miek Gieben

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 20 Mar 2014 00:49:38 +0000

> From: EppExt [mailto:[email-masked]] On Behalf Of Miek Gieben
> Sent: Wednesday, March 19, 2014 6:32 AM
> To: [email-masked]

This is the sentiment that's currently described in eppext-reg-02:

"The "Specification Required" policy described in RFC 5226 [RFC5226] MUST be followed.  Extension specifications MUST be written and available in the English language."

"Extensions should be evaluated for architectural soundness using the guidelines described in RFC 3735 [RFC3735]."

Should any of this text be changed?

Scott

---

From: Miek Gieben <[email-masked]>
Date: Thu, 20 Mar 2014 10:02:23 +0000

[ Quoting <[email-masked]> in "RE: [eppext] Updates for eppext-reg..." ]
> Should any of this text be changed?

Maybe refence the 2.1 section, but that is a minor nit. It looks fine as-is.

/Miek

-- 
Miek Gieben

---

From: Frederico A C Neves <[email-masked]>
Date: Thu, 20 Mar 2014 11:54:23 -0300

> Maybe refence the 2.1 section, but that is a minor nit. It looks fine as-is.

It's fine by me as well.

Fred

---

From: "Linlin Zhou" <[email-masked]>
Date: Fri, 21 Mar 2014 16:08:59 +0800

> From: EppExt [mailto:[email-masked]] On Behalf Of Frederico A C
> Neves
> Sent: Tuesday, March 18, 2014 10:19 PM
> To: [email-masked]
> Subject: Re: [eppext] Updates for eppext-reg Based on IETF-89 Discussion
> 
> > > > > I would say that it is very hard to encourage harmonization for
> > > > > new extensions if you don't have a specification to compare
against.
> > > > > Judging if the extension fulfills RFC3735 guidelines is also
> > > > > hard when there is no specification.
> > Agreed. But what would a "specification" look like then? What is
> > acceptable, what is not acceptable?
> 

Agreed