Subject: Re: [eppext] [tmch-tech] Type of encoding attribute in draft-lozano-tmch-smd-03

From: "Gould, James" <[email-masked]>
Date: Wed, 5 Mar 2014 16:08:37 +0000

Patrick, 

I support adding the type=³token² to the encoding attribute in
draft-ietf-eppext-tmch-smd.  I tested the change using the Verisign EPP
SDK with no issue. 

To note, draft-lozano-tmch-smd has been moved to
draft-ietf-eppext-tmch-smd and draft-tan-epp-launchphase has been moved to
draft-ietf-eppext-launchphase, since they are being moved forward with the
new eppext WG.  I¹ve copied the eppext mailing list on this reply and my
prior reply to your posting associated with draft-ietf-eppext-launchphase.

-- 
 
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

On 3/5/14, 10:28 AM, "Patrick Mevzek" <[email-masked]> wrote:

>Hello,
>
>One of my colleague remarks that this definition :
>    <complexType name="encodedSignedMarkType">
>      <simpleContent>
>        <extension base="token">
>          <attribute name="encoding" default="base64"/>
>        </extension>
>      </simpleContent>
>    </complexType>
>
>may lack a type for the encoding attribute.
>Without this, some XML frameworks (such as SOAP::WSDL in Perl) can not
>use this definition.
>Just changing it to
><attribute name="encoding" type="token" default="base64"/>
>solves the problem.
>
>-- 
>Patrick Mevzek
>

---

From: Michael Holloway <[email-masked]>
Date: Thu, 06 Mar 2014 09:13:39 +0100

> prior reply to your posting associated with draft-ietf-eppext-launchphase.

Keeping both lists on as its probably relevant to both.

Is there a way to forward the old drafts to the new ones on ietf.org (eg 
draft-tan-epp-launchphase-13 -> draft-ietf-eppext-launchphase-00) or a 
note somewhere that this has happened. I think this changed has gone 
unnoticed by a number of registries & registrars so any updates might be 
missed (though I realise there is no change from launchphase-12 -> 
launchphase-00 other than names/references). I have yet to see registry 
documentation referencing the new drafts.

This probably applies to a couple of other drafts (idnmap etc) that have 
changed the names.

*Michael Holloway
Senior Systems Administrator**| Com Laude*
2^nd Floor, 28-30 Little Russell Street
London, WC1A 2HN, United Kingdom
www.comlaude.com <http://www.comlaude.com>

---

From: James Galvin <[email-masked]>
Date: Thu, 6 Mar 2014 10:18:17 +0000

> On Mar 6, 2014, at 8:13 AM, Michael Holloway <[email-masked]> wrote:
> 
> Is there a way to forward the old drafts to the new ones on ietf.org (eg draft-tan-epp-launchphase-13 -> draft-ietf-eppext-launchphase-00) or a note somewhere that this has happened. I think this changed has gone unnoticed by a number of registries & registrars so any updates might be missed (though I realise there is no change from launchphase-12 -> launchphase-00 other than names/references). I have yet to see registry documentation referencing the new drafts.

Speaking as cochair of EPPEXT, there may be a short cut but there are two things that the authors of the docs should do.  First if the docs are going to remain as working group docs, the editors should move to editing a version with the new name.  Second, since the "00" version of the docs are created in the working group, the editors should upload the current version as the "01".

Jim

---

From: Antoin Verschuren <[email-masked]>
Date: Thu, 6 Mar 2014 12:43:23 +0100

op 06-03-14 09:13, Michael Holloway schreef:

> Is there a way to forward the old drafts to the new ones on
> ietf.org (eg draft-tan-epp-launchphase-13 ->
> draft-ietf-eppext-launchphase-00) or a note somewhere that this has
> happened. I think this changed has gone unnoticed by a number of
> registries & registrars so any updates might be missed (though I
> realise there is no change from launchphase-12 -> launchphase-00
> other than names/references). I have yet to see registry 
> This probably applies to a couple of other drafts (idnmap etc) that
> have changed the names.

There was some unclarity on how to do this in the datatracker, but
this has now been done for all documents that were adopted by EPPEXT.

- -- 
Antoin Verschuren

Technical Policy Advisor SIDN
Meander 501, PO Box 5022, 6802 EA Arnhem, The Netherlands

P: +31 26 3525500  M: +31 6 23368970
Mailto: [email-masked]
XMPP: [email-masked]
HTTP://www.sidn.nl/