Subject: [eppext] draft-ietf-eppext-launchphase and draft-ietf-eppext-tmch-smd status

From: "Gould, James" <[email-masked]>
Date: Mon, 8 Sep 2014 17:58:11 +0000

All,

The authors of both draft-ietf-eppext-launchphase and draft-ietf-eppext-tmch-smd believe that the drafts are ready for WG last call, but there is one additional development that I wanted to bring up to the WG.  There is work being done at ICANN in the protection of IGO, INGO, Red Cross, and IOC domain names that may require the need for a claims like service similar to what is currently supported by draft-ietf-eppext-launchphase for trademarks.  It is still early yet to discuss the details of this specific item, but it raises the question of whether draft-ietf-eppext-launchphase should be capable of supporting multiple distinct claims lists.  Currently draft-ietf-eppext-launchphase is not tied to a single Trademark Clearinghouse with the use of the optional “validatorID” attribute in the <launch:code>, <launch:claimKey>, and <launch:noticeID> elements, along with the extensibility of mark and signedMark defined in draft-ietf-eppext-tmch-smd.

If there is more than one claims list and claims notice service (TMCH, custom TMCH, and IGO/INGO/RC/IOC), then there is the possibility that a domain name may be in more than one list.  If that is the case, should draft-ietf-eppext-launchphase support zero or more <launch:claimKey> elements in the Claims Check Response and should draft-ietf-eppext-launchphase support zero or more <launch:noticeID> elements in the Domain Create Command in place of the existing zero to one cardinality?  The “validatorID” attribute would need to be mapped to the appropriate claims service by the client and server.

Thoughts and comments are appreciated.

Thanks,

—

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

“This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”

---

From: "Gould, James" <[email-masked]>
Date: Fri, 12 Sep 2014 12:01:34 +0000

All,

I received 2 positive responses privately for making the change to draft-ietf-eppext-launchphase that will make <launch:claimKey> and <launch:noticeID> a zero to many instead of a zero to one relationship under <launch:cd> and <launch:notice>, respectively.  This will support more than one parallel claims services if needed using the “validatorID” to identify the specific claims service.  Please post a reply to the list or to me privately if there is an issue with making this change.  I will go ahead and start making the draft upgrade with Gavin and Wil.

Thanks,

—

JG

James Gould

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Sep 8, 2014, at 1:58 PM, Gould, James <[email-masked]<mailto:[email-masked]>> wrote:

All,

Thanks,

—

JG

<BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png>

James Gould
Principal Software Engineer
[email-masked]<x-msg://56/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://verisigninc.com/>

“This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”
_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext