Subject: [eppext] draft-brown-epp-fees-03.txt - Query

From: Santosh Kalsangrah <[email-masked]>
Date: Tue, 23 Dec 2014 15:51:58 +0000

Hi There,

We have been reviewing this extension draft and have some suggestions/questions for mapping for domain <info> and domain <transfer> query commands.

Fee related information what is  checked by these 2 commands can also be done by domain <check> command described in this draft. We do not find anything specific achieved by these 2 commands. Functionality seems analogous to domain <check> command and seems redundant. So, there are couple of suggestions and questions:

-               Can you please help explain any specific reasons of having mapping for these 2 commands?
-               Can mapping of these 2 command can be removed from the draft as it seems to be redundant?
-               There could be answer that server MAY not support mapping for these 2 commands. For <info> command, there is way to do that by sending 2201 response. Here server can distinguish between domain <info> with this extension versus domain <info> without this extension. For <transfer> query, there is no such way to distinguish between <transfer> query command as there is no element added by this extension in request. If server does not include extension in <transfer> query response then, per this draft, server would not asses any fee for real transfer request which generally not the case. In essence, support of <transfer> query by server is MUST with no real benefit.

Thanks for your time,

Santosh Kalsangrah
Impetus Infotech (I) Pvt. Ltd

________________________________

NOTE: This message may contain information that is confidential, proprietary, privileged or otherwise protected by law. The message is intended solely for the named addressee. If received in error, please destroy and notify the sender. Any use of this email is prohibited when received in error. Impetus does not represent, warrant and/or guarantee, that the integrity of this communication has been maintained nor that the communication is free of errors, virus, interception or interference.

---

From: Gavin Brown <[email-masked]>
Date: Mon, 29 Dec 2014 15:40:01 +0000

Hi Santosh,

On 23/12/2014 15:51, Santosh Kalsangrah wrote:
> We have been reviewing this extension draft and have some
> suggestions/questions for mapping for domain <info> and domain
> <transfer> query commands.
> 
> Fee related information what is  checked by these 2 commands can also be
> done by domain <check> command described in this draft. We do not find
> anything specific achieved by these 2 commands. Functionality seems
> analogous to domain <check> command and seems redundant. So, there are
> couple of suggestions and questions:
>

You are correct that the <check> and <info> extensions provide virtually
identical information. Following discussion on this list and elsewhere,
there was no strong preference either way, so I chose to be flexible and
allow for both.

The <transfer> query extension allows a client to query the fee
associated with an existing pending transfer. This is not something that
can be obtained through another command.

G.

> 
> -               There could be answer that server MAY not support
> mapping for these 2 commands. For <info> command, there is way to do
> that by sending 2201 response. Here server can distinguish between
> domain <info> with this extension versus domain <info> without this
> extension. For <transfer> query, there is no such way to distinguish
> between <transfer> query command as there is no element added by this
> extension in request. If server does not include extension in <transfer>
> query response then, per this draft, server would not asses any fee for
> real transfer request which generally not the case. In essence, support
> of <transfer> query by server is MUST with no real benefit.
> 
>  
> 
>  
> 
> Thanks for your time,
> 
>  
> 
> Santosh Kalsangrah
> 
> ------------------------------------------------------------------------
> 
> 
> 
> 
> 
> 
> NOTE: This message may contain information that is confidential,
> proprietary, privileged or otherwise protected by law. The message is
> intended solely for the named addressee. If received in error, please
> destroy and notify the sender. Any use of this email is prohibited when
> received in error. Impetus does not represent, warrant and/or guarantee,
> that the integrity of this communication has been maintained nor that
> the communication is free of errors, virus, interception or interference.
> 
> 
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext
> 

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.