Subject: [eppext] draft-ietf-eppext-launchphase Support for a "Claims Service" post the Claims Phase

From: "Gould, James" <[email-masked]>
Date: Mon, 5 Jan 2015 23:18:20 +0000

All,

There was an issue raised privately in supporting claims as a Claims Service post the Claims Phase.   According to section 2.4.3 of the RPM Requirements, “...releases for Allocation or registration such reserved domain name at any time following the start date of the Claims Period, such domain MUST be subject to the Claims Services (as described in Section 3) for a period of ninety (90) calendar days following the date Registry Operator releases such domain name for registration…”.  This means that support for the Claims Check Form needs to be revised to indicate whether or not the Claims Create Form is needed for the domain name and the use of the Claims Create Form should be supported in phases other than “claims”.  There are no XML schema changes required to support this.  Please review and provide feedback to the proposed revised language in the draft below to include in the next version of the draft that will also include the Implementation Status section discussed at the IETF-91 EPPEXT meeting.

Change 3.1.1 "Claims Check Form" as follows:

   The Claims Check Form defines a new command called the Claims Check
   Command that is used to determine whether or not there are any
   matching trademarks, in the specified launch phase, for each domain
   name passed in the command, that requires the use of the "Claims Create Form"

   on a Domain Create Command.

   Instead of returning whether the domain name is available, the Claims
   Check Command will return whether or not at least one matching
   trademark exists for the domain name, that requires the use of the

   "Claims Create Form" on a Domain Create Command.

   <launch:name>  Contains the fully qualified name of the queried
           domain name.  This element MUST contain an "exists" attribute
           whose value indicates if a matching trademark exists for the
           domain name that requires the use of the "Claims Create Form" on a Domain Create Command.

           A value of "1" (or "true") means that a
           matching trademark does exist and that the "Claims Create Form" is required on

           a Domain Create Command.  A
           value of "0" (or "false") means that a matching trademark
           does not exist or that the "Claims Create Form" is NOT required on a Domain Create Command.

Change 3.3.2 "Claims Create Form" as follows:

<launch:phase>  SHOULD contain the value of "claims" to indicate the
       claims launch phase.  A value other than "claims" MAY be used to

pass the claims notice for domain names outside of the claims phase.

Based on the above revised language the following may be done:

  1.  During claims phase with a claims check command
     *   If domain has matching trademark
        *   return exists=true
     *   else
        *   return exists=false
  2.  During post claims phase with a claims check command
     *   If domain was released post claims phase start and is within 90 days of release and has matching trademark
        *   return exists=true
     *   else
        *   return exists=false

  1.  During claims phase with a create command
     *   If domain has matching trademark
        *   claims notice is required
     *   else
        *   claims notice is NOT required
  2.  During post claims phase with a create command
     *   If domain was released post claims phase start and is within 90 days of release and has matching trademark return
        *   claims notice is required
     *   else
        *   claims notice is NOT required

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

“This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”

---

From: Jody Kolker <[email-masked]>
Date: Thu, 8 Jan 2015 16:15:38 +0000

Thanks Jim.

>From a registrar perspective, this will solve the issue of domains that are released after the initial 90 day claims period but still require a claim to be presented to the customer.

Thanks,
Jody Kolker
319-294-3933 (office)
319-329-9805 (mobile) Please contact my direct supervisor Charles Beadnall ([email-masked]<mailto:[email-masked]>) with any feedback.

This email message and any attachments hereto is intended for use only by the addressee(s) named herein and may contain confidential information. If you have received this email in error, please immediately notify the sender and permanently delete the original and any copy of this message and its attachments.

From: EppExt [mailto:[email-masked]] On Behalf Of Gould, James
Sent: Monday, January 05, 2015 3:18 PM
To: [email-masked]
Subject: [eppext] draft-ietf-eppext-launchphase Support for a "Claims Service" post the Claims Phase

All,

There was an issue raised privately in supporting claims as a Claims Service post the Claims Phase.   According to section 2.4.3 of the RPM Requirements, "...releases for Allocation or registration such reserved domain name at any time following the start date of the Claims Period, such domain MUST be subject to the Claims Services (as described in Section 3) for a period of ninety (90) calendar days following the date Registry Operator releases such domain name for registration...".  This means that support for the Claims Check Form needs to be revised to indicate whether or not the Claims Create Form is needed for the domain name and the use of the Claims Create Form should be supported in phases other than "claims".  There are no XML schema changes required to support this.  Please review and provide feedback to the proposed revised language in the draft below to include in the next version of the draft that will also include the Implementation Status section discussed at the IETF-91 EPPEXT meeting.

        *   return exists=true

     *   else

        *   return exists=false

  1.  During post claims phase with a claims check command

        *   return exists=true

     *   else

        *   return exists=false

     *   else

  1.  During post claims phase with a create command

     *   else

Thanks,

-

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

"This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately."

---

From: Rik Ribbers <[email-masked]>
Date: Tue, 13 Jan 2015 12:14:22 +0000

James,

I'm not an expert on the sunrise and claims requirements, but the wording seems correct according the RPM requirements.

Gr,
Rik

From: EppExt [mailto:[email-masked]] On Behalf Of Gould, James
Sent: dinsdag 6 januari 2015 0:18
To: [email-masked]
Subject: [eppext] draft-ietf-eppext-launchphase Support for a "Claims Service" post the Claims Phase

All,

        *   return exists=true

     *   else

        *   return exists=false

        *   return exists=true

     *   else

        *   return exists=false

     *   else

     *   else

Thanks,

-

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190