Subject: [eppext] Fwd: New Version Notification for draft-wilcox-cira-idn-eppext-00.txt

From: JF Tremblay <[email-masked]>
Date: Fri, 6 Mar 2015 11:11:03 -0500

As discussed in Honolulu, a draft has now been published describing the EPP extension(s) used at CIRA to support French IDN in the .ca domain. 

Of course, a number of the objects described in the draft overlap with other drafts, for example draft-kong and idnmap. Comments are welcome. 

/JF

> Begin forwarded message:
> 
> From: [email-masked]
> To: "Jean-Francois Tremblay" <[email-masked]>, "Jacques Latour" <[email-masked]>, "Jacques Latour" <[email-masked]>, "Stuart Olmstead-Wilcox" <[email-masked]>, "Stuart Olmstead-Wilcox" <[email-masked]>, "JF Tremblay" <[email-masked]>
> Subject: New Version Notification for draft-wilcox-cira-idn-eppext-00.txt
> Date: March 6, 2015 at 10:47:09 AM GMT-5
> 
> 
> A new version of I-D, draft-wilcox-cira-idn-eppext-00.txt
> has been successfully submitted by Jean-Francois Tremblay and posted to the
> IETF repository.
> 
> Name:		draft-wilcox-cira-idn-eppext
> Revision:	00
> Title:		CIRA IDN EPP Extension
> Document date:	2015-03-06
> Group:		Individual Submission
> Pages:		22
> URL:            http://www.ietf.org/internet-drafts/draft-wilcox-cira-idn-eppext-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-wilcox-cira-idn-eppext/
> Htmlized:       http://tools.ietf.org/html/draft-wilcox-cira-idn-eppext-00
> 
> 
> Abstract:
>   The Canadian Internet Registration Authority (CIRA), administering
>   the .CA country-code top-level domain, offers internationalized
>   domain names (IDN) in French, one of Canada's official languages.
>   CIRA's Extensible Provisioning Protocol (EPP) services have been
>   augmented with an IDN EPP extension in order to support registrars
>   desiring to register internationalized domains using French
>   characters as bundled domains.
> 
>   This document defines the extension to the Extensible Provisioning
>   Protocol used at CIRA to support IDN operations.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Tongfeng Zhang <[email-masked]>
Date: Fri, 6 Mar 2015 17:12:27 +0000

Good stuff.
I have a couple of comments below.

- Section 5.1.4 should be titled "EPP <transfer> Query Command" because 5.1 is about "EPP Query Commands". The normal transfer command falls under "EPP Transform Commands".
- In Section 7, the statement "For a label size of 64 characters, the list of label variants may reach up to 320 entries." The 320 is not mathematically right. To be exact, it should be 5 power of 64. :)

Thanks,
Tongfeng

From: EppExt [mailto:[email-masked]] On Behalf Of JF Tremblay
Sent: March-06-15 11:11 AM
To: [email-masked]
Subject: [eppext] Fwd: New Version Notification for draft-wilcox-cira-idn-eppext-00.txt

/JF

Begin forwarded message:

Abstract:

The IETF Secretariat

---

From: JF Tremblay <[email-masked]>
Date: Sat, 7 Mar 2015 10:13:41 -0500

> On Mar 6, 2015, at 12:12 PM, Tongfeng Zhang <[email-masked]> wrote:
> 
> Good stuff.

Thanks for reviewing it. 

> - Section 5.1.4 should be titled "EPP <transfer> Query Command" because 5.1 is about "EPP Query Commands". The normal transfer command falls under "EPP Transform Commands”.

Noted, will update in next version. 

> - In Section 7, the statement "For a label size of 64 characters, the list of label variants may reach up to 320 entries." The 320 is not mathematically right. To be exact, it should be 5 power of…

Right… Must have written this on a pre-coffee morning. It’s 5 possible code variants over 64 positions, so 5x5x5x5x… 64 times, so 5^^64, or 5.4E44. More than enough to create a DOS on the server from a single registrar query, even if the registrar is unwillingly participating (might be an unchecked request from the public registrant side, the web interface for example). Will update that text.

JF

---

From: "Linlin Zhou" <[email-masked]>
Date: Tue, 24 Mar 2015 15:45:03 +0800

I found that 5.1.2.2 specifies a protocol level extension that some elements are similar with domain <info>. Whether or not a object or command-response extension is enough.

Regards,

Linlin Zhou
 
From: JF Tremblay
Date: 2015-03-07 00:11
To: eppext

/JF

Begin forwarded message:

Abstract:

The IETF Secretariat

---

From: JF Tremblay <[email-masked]>
Date: Tue, 24 Mar 2015 10:33:16 -0500

> On Mar 24, 2015, at 2:45 AM, Linlin Zhou <[email-masked]> wrote:
> 

Thank you for reading and commenting. 

However, I am not sure I understand your comment. Are you saying that existing elements of domain <info> should be used instead of the extension objects?

Of course, it’s clear this overlaps with other extensions proposed by other. This is actually something that could be added to the next version of the draft in order to facilitate the life of the expert reviewer.

JF