Subject: Re: [eppext] FW: [IANA #814923] INSERT “Low Balance Mapping for the Extensible Provisioning Protocol (EPP)"

From: Gavin Brown <[email-masked]>
Date: Fri, 03 Apr 2015 13:10:18 +0100

Here is my review as DE:

1. the functionality described in the specification seems complementary
to that in the "Balance Mapping for the Extensible Provisioning Protocol
(EPP)" that has also been submitted. Combining the two together would
make for a simpler implementation.

2. As others have, I'd also like to voice my concerns about the IP terms
in the Legal Disclaimer. The purpose of registering an EPP exension in
the registry is to facilitate harmonisation and interoperability, and
yet the Legal Disclaimer seems designed to discourage that.

4. The specification seems to meet the requirements in RFC 7451 Section
2.1.1, in that:

* it meets the guidelines in RFC 3735

* Security considerations have been addressed. Privacy considerations
are not addressed, but this specification does not have any particular
problems in these areas.

I recommend that this extension be registered in the registry.

G.

On 23/03/2015 17:42, Hollenbeck, Scott wrote:
> Submitted for DE evaluation.
> 
> Scott
> 
> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]] 
> Sent: Monday, March 23, 2015 12:47 PM
> Cc: Hollenbeck, Scott
> Subject: [IANA #814923] INSERT “Low Balance Mapping for the Extensible Provisioning Protocol (EPP)"
> 
> #14 of 18.
> 
> ----BEGIN FORM-----
> Name of Extension:
> “Low Balance Mapping for the Extensible Provisioning Protocol (EPP)"
> 
> Document Status: 
> Informational
> 
> Reference: 
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-extension_low-balance_v00.html
> 
> Registrant Name and Email Address:
> VeriSign Inc., [email-masked]
> 
> TLDs: Any
> 
> IPR Disclosure: None
> 
> Status: Active
> 
> Notes: None
> -----END FORM-----
> 
> —
> 
> 
> JG
> 
> 
> 
> 
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
> “This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”
> 
> Download BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png
> 
> image/png 4KiB
> Image not shown because display is disabled in system configuration.
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext
> 

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: "Gould, James" <[email-masked]>
Date: Fri, 3 Apr 2015 15:44:57 +0000

Gavin,

Thank you for your review.  Below is my feedback.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Apr 3, 2015, at 8:10 AM, Gavin Brown <[email-masked]<mailto:[email-masked]>> wrote:

Here is my review as DE:

Agreed.  The Low Balance Mapping was created first and while later (e.g. years) a request was made to enable a client to explicitly request for the balance information that resulted in the Balance Mapping.  Consolidation of the two would make sense if a standards track draft was created that matched the functionality.  Does such a draft complement the work being done on the Registry Fee extension?

Same feedback to the concern around the legal disclaimer.

G.

Scott

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]]
Sent: Monday, March 23, 2015 12:47 PM
Cc: Hollenbeck, Scott
Subject: [IANA #814923] INSERT “Low Balance Mapping for the Extensible Provisioning Protocol (EPP)"

#14 of 18.

----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

IPR Disclosure: None

Status: Active

Notes: None
-----END FORM-----

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

image/png 4KiB

---

From: James Galvin <[email-masked]>
Date: Mon, 06 Apr 2015 16:48:37 -0400

I have completed my designated expert review and I have no significant 
comments.

For the future I do want to note that this specification has 
functionality that may be subsumed by the fee extension work currently 
progressing in the IETF.  If that turns out to be true I would expect a 
comment to be added to the extension registry for this specification 
stating as such when the IETF work product is published.

I have not validated the XML Schema.

Jim

---

From: "Gould, James" <[email-masked]>
Date: Mon, 6 Apr 2015 21:27:29 +0000

Jim,

Thank you for the review.  There is some overlap with the option of the registry fee extension to return the credit limit and balance in the response, but I view that optional feature as not the primary purpose of the registry fee extension.  The Low Balance Mapping is targeted to enable the server to inform the client of a low balance / credit situation.  I believe that a combination of the Balance and the Low Balance mappings into a single mapping that meets the need of querying for the credit limit and balance information or getting a low balance poll message may be desirable as a compliment to the registry fee extension.  This is something that the EPPEXT WG could work on if there was general interest.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Apr 6, 2015, at 4:48 PM, James Galvin <[email-masked]<mailto:[email-masked]>> wrote:

I have completed my designated expert review and I have no significant comments.

For the future I do want to note that this specification has functionality that may be subsumed by the fee extension work currently progressing in the IETF.  If that turns out to be true I would expect a comment to be added to the extension registry for this specification stating as such when the IETF work product is published.

Jim

Scott

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]]
Sent: Monday, March 23, 2015 12:47 PM
Cc: Hollenbeck, Scott
Subject: [IANA #814923] INSERT “Low Balance Mapping for the Extensible Provisioning Protocol (EPP)"

#14 of 18.

----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

IPR Disclosure: None

Status: Active

Notes: None
-----END FORM-----

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

image/png 4KiB

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Apr 2015 21:28:30 +0000

I have sent a note to IANA indicating DE approval for this request.

Scott

> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Monday, March 23, 2015 1:42 PM
> To: [email-masked]
> Subject: [eppext] FW: [IANA #814923] INSERT “Low Balance Mapping for
> the Extensible Provisioning Protocol (EPP)"
> 
> “This message (including any attachments) is intended only for the use
> of the individual or entity to which it is addressed, and may contain
> information that is non-public, proprietary, privileged, confidential
> and exempt from disclosure under applicable law or may be constituted
> as attorney work product. If you are not the intended recipient, you
> are hereby notified that any use, dissemination, distribution, or
> copying of this communication is strictly prohibited. If you have
> received this message in error, notify sender immediately and delete
> this message immediately.”
>