Subject: Re: [eppext] FW: [IANA #814924] INSERT “Premium Domain Extension for the Extensible Provisioning Protocol (EPP)"

From: Gavin Brown <[email-masked]>
Date: Fri, 03 Apr 2015 17:23:23 +0100

Here is my review as DE:

1. This extension implements a subset of the functionality of
draft-brown-epp-fees. As they have been developed in parallel (and I am
the author of that draft) I won't comment on the duplication of
functionality.

2. The <premiumdomain:price> element has a mandatory "unit" attribute
which is only permitted to contain the string "USD". If there is only
one possible value, then there is no reason for the attribute to exist;
if the intention is to allow other values than "USD", the schema should
allow it (and the specification should probably reference ISO 4217 as
draft-brown-epp-fees does).

3. As others have, I'd also like to voice my concerns about the IP terms
in the Legal Disclaimer. The purpose of registering an EPP exension in
the registry is to facilitate harmonisation and interoperability, and
yet the Legal Disclaimer seems designed to discourage that.

4. The specification seems to meet the requirements in RFC 7451 Section
2.1.1, in that:

* it meets the guidelines in RFC 3735

* Security considerations have been addressed. Privacy considerations
are not addressed, but this specification does not have any particular
problems in these areas.

G.

On 23/03/2015 17:42, Hollenbeck, Scott wrote:
> Submitted for DE evaluation.
> 
> Scott
> 
> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]] 
> Sent: Monday, March 23, 2015 12:48 PM
> Cc: Hollenbeck, Scott
> Subject: [IANA #814924] INSERT “Premium Domain Extension for the Extensible Provisioning Protocol (EPP)"
> 
> #15 of 18.
> 
> -----BEGIN FORM-----
> Name of Extension:
> “Premium Domain Extension for the Extensible Provisioning Protocol (EPP)"
> 
> Document Status: 
> Informational
> 
> Reference: 
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-extension_premium-domain_v00.html
> 
> Registrant Name and Email Address:
> VeriSign Inc., [email-masked]
> 
> TLDs: Any
> 
> IPR Disclosure: None
> 
> Status: Active
> 
> Notes: None
> -----END FORM-----
> 
> —
> 
> 
> JG
> 
> 
> 
> 
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
> “This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”
> 
> Download BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png
> 
> image/png 4KiB
> Image not shown because display is disabled in system configuration.
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext
> 

-- 
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.

---

From: "Gould, James" <[email-masked]>
Date: Sun, 5 Apr 2015 13:47:58 +0000

Gavin,

Thank you for the review and feedback.  Below is my feedback.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Apr 3, 2015, at 12:23 PM, Gavin Brown <[email-masked]<mailto:[email-masked]>> wrote:

Here is my review as DE:

Yes, the premium domain extension was created prior the registry fee extension, and the plan is to transition to use the registry fee extension.

You are correct that the unit should have been just a token in the schema to support more units than “USD”.  This is noted, although the plan is to transition to the registry fee extension.

Same response to the copyright notice concern.

G.

Scott

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]]
Sent: Monday, March 23, 2015 12:48 PM
Cc: Hollenbeck, Scott
Subject: [IANA #814924] INSERT “Premium Domain Extension for the Extensible Provisioning Protocol (EPP)"

#15 of 18.

-----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

IPR Disclosure: None

Status: Active

Notes: None
-----END FORM-----

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

image/png 4KiB

---

From: James Galvin <[email-masked]>
Date: Mon, 06 Apr 2015 16:48:07 -0400

I have completed my designated expert review and I have no significant 
comments.

For the future I do want to note that this specification has 
functionality that may be subsumed by the fee extension work currently 
progressing in the IETF.  If that turns out to be true I would expect a 
comment to be added to the extension registry for this specification 
stating as such when the IETF work product is published.

I have not validated the XML Schema.

Jim

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Apr 2015 21:28:40 +0000

I have sent a note to IANA indicating DE approval for this request.

Scott

> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Monday, March 23, 2015 1:43 PM
> To: [email-masked]
> Subject: [eppext] FW: [IANA #814924] INSERT “Premium Domain Extension
> for the Extensible Provisioning Protocol (EPP)"
> 
> “This message (including any attachments) is intended only for the use
> of the individual or entity to which it is addressed, and may contain
> information that is non-public, proprietary, privileged, confidential
> and exempt from disclosure under applicable law or may be constituted
> as attorney work product. If you are not the intended recipient, you
> are hereby notified that any use, dissemination, distribution, or
> copying of this communication is strictly prohibited. If you have
> received this message in error, notify sender immediately and delete
> this message immediately.”
>