Subject: Re: [eppext] [IANA #814911] INSERT “IDN Language Tag for the Extensible Provisioning Protocol (EPP)"

From: Ning Kong <[email-masked]>
Date: Sat, 4 Apr 2015 16:18:58 +0800

I have completed my review of the extension as DE and I have the following comments to share: 
#1 I think a valid language tag SHOULD comply with RFC 5646, so RFC 5646 should be added as the reference of language tag representation.
#2 It seems to me that there is a little overlap between the name of this extension and draft-ietf-eppext-idnmap. Although draft-ietf-eppext-idnmap doesn’t cover this extension, the name of draft-ietf-eppext-idnmap seems to cover everything about IDN extension.

Ning

> 在 2015年3月24日，上午1:39，Hollenbeck, Scott <[email-masked]> 写道：
> 
> Submitted for DE evaluation.
> 
> Scott
> 
> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]] 
> Sent: Monday, March 23, 2015 12:41 PM
> Cc: Hollenbeck, Scott
> Subject: [IANA #814911] INSERT “IDN Language Tag for the Extensible Provisioning Protocol (EPP)"
> 
> #5 of 18.
> 
> -----BEGIN FORM-----
> Name of Extension:
> “IDN Language Tag for the Extensible Provisioning Protocol (EPP)"
> 
> Document Status: 
> Informational
> 
> Reference: 
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-extension_idn-lang_v00.html
> 
> Registrant Name and Email Address:
> VeriSign Inc., [email-masked]
> 
> TLDs: Any
> 
> IPR Disclosure: None
> 
> Status: Active
> 
> Notes: None
> -----END FORM-----
> 
> —
> 
> 
> JG
> 
> 
> 
> 
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
> “This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”
> 
> Download BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png
> 
> image/png 4KiB
> Image not shown because display is disabled in system configuration.
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: "Gould, James" <[email-masked]>
Date: Sun, 5 Apr 2015 14:03:02 +0000

Ning,

Thank you for the review.  Below is my feedback.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Apr 4, 2015, at 4:18 AM, Ning Kong <[email-masked]<mailto:[email-masked]>> wrote:

We support a subset of RFC 5646 (3 character ISO 639 codes), but I agree that RFC 5646 could be referenced.  I made note of this.

Yes, this is one of what I assume to be many forms of IDN language extensions for IDN domain names.  Much of the discussion on the eppext mailing list around draft-ietf-eppext-idnmap was passing IDN table identifiers and / or language tags.  We agreed to go with the IDN table identifier approach in draft-ietf-eppext-idnmap in combination with providing the valid set of IDN table identifiers within EPP via the IDN Table Mapping ( draft-gould-idn-table ).

Ning

在 2015年3月24日，上午1:39，Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> 写道：

Scott

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]]
Sent: Monday, March 23, 2015 12:41 PM
Cc: Hollenbeck, Scott
Subject: [IANA #814911] INSERT “IDN Language Tag for the Extensible Provisioning Protocol (EPP)"

#5 of 18.

-----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

IPR Disclosure: None

Status: Active

Notes: None
-----END FORM-----

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

image/png 4KiB

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: James Galvin <[email-masked]>
Date: Mon, 06 Apr 2015 16:47:01 -0400

I have completed my designated expert review and I have the following 
comment to share:

Since RFC5646 regarding the implementation and use of language tags was 
published 4 years before this extension was developed and it is an 
Internet Proposed Standard, I think this specification would be improved 
if it explained its relationship to that document.

I have not validated the XML Schema.

Jim

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Apr 2015 21:26:50 +0000

I have sent a note to IANA indicating DE approval for this request.

Scott

> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Monday, March 23, 2015 1:39 PM
> To: [email-masked]
> Subject: [eppext] FW: [IANA #814911] INSERT “IDN Language Tag for the
> Extensible Provisioning Protocol (EPP)"
> 
> “This message (including any attachments) is intended only for the use
> of the individual or entity to which it is addressed, and may contain
> information that is non-public, proprietary, privileged, confidential
> and exempt from disclosure under applicable law or may be constituted
> as attorney work product. If you are not the intended recipient, you
> are hereby notified that any use, dissemination, distribution, or
> copying of this communication is strictly prohibited. If you have
> received this message in error, notify sender immediately and delete
> this message immediately.”
>