Subject: Re: [eppext] [IANA #814919] INSERT “Whois Info Extension for the Extensible Provisioning Protocol (EPP)"

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 3 Apr 2015 11:29:41 +0000

I've completed my review of this extension. A few comments:

> "<whoisInf:flag>element MUST contain a boolean value of "1" or "true" to indicate that additional whois information is desired in the response or a value of "0" or "false" to indicate that no additional whois information is desired in the response."

One could also say "don't use this extension at all to indicate that you don't want additional WHOIS info.

> <whoisInf:irisServer>OPTIONAL element element that contains the sponsoring Registrar's referral IRIS server name.

Is anyone anywhere running IRIS servers?

Jim, have you given any thought to the future of this extension in the context of RDAP development and eventual deployment?

Scott

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Monday, March 23, 2015 1:42 PM
> To: [email-masked]
> Subject: [eppext] FW: [IANA #814919] INSERT “Whois Info Extension for
> the Extensible Provisioning Protocol (EPP)"
> 
> Submitted for DE evaluation.
> 
> Scott
> 
> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Monday, March 23, 2015 12:46 PM
> Cc: Hollenbeck, Scott
> Subject: [IANA #814919] INSERT “Whois Info Extension for the Extensible
> Provisioning Protocol (EPP)"
> 
> #12 of 18.
> 
> -----BEGIN FORM-----
> Name of Extension:
> “Whois Info Extension for the Extensible Provisioning Protocol (EPP)"
> 
> Document Status:
> Informational
> 
> Reference:
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-extension_whois-
> info_v00.html
> 
> Registrant Name and Email Address:
> VeriSign Inc., [email-masked]
> 
> TLDs: Any
> 
> IPR Disclosure: None
> 
> Status: Active
> 
> Notes: None
> -----END FORM-----
> 
> —
> 
> 
> JG
> 
> 
> 
> 
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
> “This message (including any attachments) is intended only for the use
> of the individual or entity to which it is addressed, and may contain
> information that is non-public, proprietary, privileged, confidential
> and exempt from disclosure under applicable law or may be constituted
> as attorney work product. If you are not the intended recipient, you
> are hereby notified that any use, dissemination, distribution, or
> copying of this communication is strictly prohibited. If you have
> received this message in error, notify sender immediately and delete
> this message immediately.”
> 
> Download BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png
> 
> image/png 4KiB
> Image not shown because display is disabled in system configuration.
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: "Gould, James" <[email-masked]>
Date: Fri, 3 Apr 2015 14:26:34 +0000

Scott,

Thanks for the review.  My feedback is below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Apr 3, 2015, at 7:29 AM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:

Yes, you are correct, a better approach would have been to include an empty <whoisInf:whoisInf/> element as the marker to include the extension in the response, as opposed to using the <whoisInf:flag> boolean sub-element.  We started using the empty marker elements in later extensions.

No, I’m not aware of the use of IRIS anywhere, so this is a historic element that never actually got used.  I really have not considered how inclusion of RDAP would impact the registrar and registry EPP interface in support of transfers, but I and we should start to.  This extension was created based on feedback from registrars that they needed to query WHOIS in support of transfers, which made little sense since they have a trusted connection directly to the registry.  It would be interesting to see if other registries have created similar WHOIS extensions based on registrar feedback, and how a transition to RDAP should be handled.

Scott

-----Original Message-----
To: [email-masked]<mailto:[email-masked]>

Scott

-----Original Message-----
From: Amanda Baber via RT [mailto:[email-masked]]
Sent: Monday, March 23, 2015 12:46 PM
Cc: Hollenbeck, Scott
Subject: [IANA #814919] INSERT “Whois Info Extension for the Extensible

#12 of 18.

-----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

IPR Disclosure: None

Status: Active

Notes: None
-----END FORM-----

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

image/png 4KiB
Image not shown because display is disabled in system configuration.
_______________________________________________
EppExt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eppext
_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: Ning Kong <[email-masked]>
Date: Sat, 4 Apr 2015 19:05:23 +0800

I have completed my review of the extension as DE and I have no significant comments. I'm not aware of any conflicts with existing IETF work or other known extensions.

One comments,
I have the same concerns as Scott about the IRIS. As far as I know, only DENIC uses IRIS. I’m not sure who is still interested in using this optional element.

One nits,
In section 3.1.2, “element element” should be “element"

Ning

> 在 2015年3月24日，上午1:41，Hollenbeck, Scott <[email-masked]> 写道：
> 
> Subject: [IANA #814919] INSERT “Whois Info Extension for the Extensible Provisioning Protocol (EPP)"
> 
> #12 of 18.
> 
> -----BEGIN FORM-----
> Name of Extension:
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-extension_whois-info_v00.html
> 
> “This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed, and may contain information that is non-public, proprietary, privileged, confidential and exempt from disclosure under applicable law or may be constituted as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this message in error, notify sender immediately and delete this message immediately.”
>

---

From: Patrick Mevzek <[email-masked]>
Date: Sat, 04 Apr 2015 13:22:09 +0200

> One could also say "don't use this extension at all to indicate that you don't want additional WHOIS info.

You might wish to do that per domain and not per EPP connection/message
(on a client side it may sometimes be simpler to switch a flag instead
of building messages completely differently), hence it seems worthwhile
to me.

> Is anyone anywhere running IRIS servers?

AFNIC as a registry is running IRIS servers for all its ccTLD
(.FR .RE .YT .PM .WF .TF)

I agree that the extension should/could be made for generic to handle
new RDAP works, but there are still other works ongoing related to whois
protocols/queries in other forums…

-- 
Patrick Mevzek

---

From: Patrick Mevzek <[email-masked]>
Date: Sat, 04 Apr 2015 13:32:58 +0200

> I have the same concerns as Scott about the IRIS. As far as I know, only DENIC uses IRIS. I’m not sure who is still interested in using this optional element.

DENIC stopped using IRIS long ago, see
www.denic.de/en/denic-in-dialogue/news/3767.html

Shutdown Notification: DENIC to discontinue DCHK (Domain Check) lookup
service as of 3 December 2013

[…]
Given that the protocol underlying DCHK, i.e. the Internet Registry
Information Service (IRIS) standard, has never gained a relevant
foothold in the market, and therefore DCHK kept being employed by a
small number of users only, continuing the service is no longer
justifiable, from a cost-benefit point of view.

</quote>

See my previous reply in this thread, AFAIK only AFNIC has an IRIS
server today.

-- 
Patrick Mevzek

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Apr 2015 21:28:12 +0000

I have sent a note to IANA indicating DE approval for this request.

Scott