Subject: Re: [eppext] : [IANA #814928] INSERT “Related Domain Extension for the Extensible Provisioning Protocol (EPP)"

From: Alexander Mayrhofer <[email-masked]>
Date: Mon, 6 Apr 2015 15:06:23 +0000

I have completed my review of the extension registration request, and i have no significant comments. Nits:

- Again, I'm concerned about the practicality of the implications of the "VERISIGN PROPRIETARY INFORMATION" paragraph
- Even though the extension tries to achieve a slightly different problem, there are other extensions attempting to solve "bundling related" problems.
- I have slight concerns about the process of the "transfer" of domain objects using this extension. Particularly because there's description of the "transfer request" command only, which makes me think about situations where a losing registrar would issue a "mixed" set of accepts and rejects for a pending transfer? However, i understand that this extension is in production for a TLD, so maybe the specification just needs more description of these cases.

Note: I have not  formally validated the XML Schema.

tia,
Alex

> -----BEGIN FORM-----
> Name of Extension:
> “Related Domain Extension for the Extensible Provisioning Protocol (EPP)"
> 
> Document Status:
> Informational
> 
> Reference:
> http://www.verisigninc.com/assets/epp-sdk/verisign_epp-
> extension_related-domain_v00.html
> 
> Registrant Name and Email Address:
> VeriSign Inc., [email-masked]
> 
> TLDs: Any
> 
> IPR Disclosure: https://datatracker.ietf.org/ipr/2553/
> 
> Status: Active
> 
> Notes: None
> -----END FORM-----

---

From: "Gould, James" <[email-masked]>
Date: Mon, 6 Apr 2015 15:45:01 +0000

Alexander,

Thank you for the review.  Below is my feedback.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Apr 6, 2015, at 11:06 AM, Alexander Mayrhofer <[email-masked]<mailto:[email-masked]>> wrote:

- Again, I'm concerned about the practicality of the implications of the "VERISIGN PROPRIETARY INFORMATION” paragraph

Same response to the copyright notice concern.

Yes, this extension addresses our specific approach to bundling.  in the end, we may want to look at how to solve the broader set of bundling problems by as stated in a prior reply “bundle the bundles”.

Any one of the transfer operations is supported, but you are correct that there is only a sample provided for the transfer request.  The goal is to enable clients (gaining or losing) to be capable of treating the related domains as a single set.

tia,
Alex

-----BEGIN FORM-----
Name of Extension:

Document Status:
Informational

Reference:

TLDs: Any

Status: Active

Notes: None
-----END FORM-----

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext