Subject: [eppext] IDN Tables in draft-ietf-eppext-idnmap-02

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 8 Jun 2015 18:24:45 +0000

I had an opportunity to take a closer look at draft-ietf-eppext-idnmap-02 while talking about it with folks at an EPP workshop hosted by .SE last week. I'd like to suggest that it would be helpful to add some text somewhere to explain how to find the IDN tables supported by the server.  Here's why: Section 3.2.1 says that this element is a MUST:

"A <idn:table> element that contains the IDN table identifier as provided by the server."

...but there's nothing I could find in the document that explains how to find the values provided by the server. A reference to draft-gould-idn-table-02 would do the trick if it is in fact an appropriate reference. So, here's suggested text for 3.2.1:

"An <idn:table> element that contains the IDN table identifier as provided by the server. The IDN tables provided by the server for a particular domain can be identified using the Domain Check Form or Domain Info Form specified in [draft-gould-idn-table]."

Scott

---

From: Francisco Obispo <[email-masked]>
Date: Mon, 8 Jun 2015 11:26:52 -0700

Hi Scott,

We’re working with James to support this via a separate draft, since it has to do more with IDN general policies, which codepoints are allowed, etc..

I’m working on an updated idnmap draft to include the statements from community members stating that they’ve implemented this draft.

regards,

> On Jun 8, 2015, at 11:24 AM, Hollenbeck, Scott <[email-masked]> wrote:
> 
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

Francisco Obispo
CTO - Registry Operations
____________________________

 <http://www.uniregistry.com/>
2161 San Joaquin Hills Road
Newport Beach, CA 92660

Office +1 949 706 2300 x4202
[email-masked]

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 8 Jun 2015 18:33:31 +0000

From: Francisco Obispo [mailto:[email-masked]]
Sent: Monday, June 08, 2015 2:27 PM
To: Hollenbeck, Scott
Cc: [email-masked]
Subject: Re: [eppext] IDN Tables in draft-ietf-eppext-idnmap-02

Hi Scott,

[SAH] OK, but are you willing to add text that explains how a client can figure out where to get the table identifiers that are need for the <create> command? What there now says it’s a MUST, but there’s nothing to explain how to determine a valid value.

Scott

---

From: Francisco Obispo <[email-masked]>
Date: Mon, 8 Jun 2015 11:34:48 -0700

Sure, I’ll add some text explainint it.

thanks

> On Jun 8, 2015, at 11:33 AM, Hollenbeck, Scott <[email-masked]> wrote:
> 
> From: Francisco Obispo [mailto:[email-masked] <mailto:[email-masked]>]
> Cc: [email-masked] <mailto:[email-masked]>

Francisco Obispo