Subject: Re: [eppext] [apps-discuss] D-BRIEF 00

From: Mike O'Connell <[email-masked]>
Date: Wed, 1 Jul 2015 11:17:21 +0200

Thanks for the feedback Scott, hand-coding XML is not for the faint of heart…

I’ve submitted 01 with the fixes.

> On 25 Jun 2015, at 8:55 PM, Hollenbeck, Scott <[email-masked]> wrote:
> 
> I'm not currently subscribed to apps-discuss. Please forward this as appropriate.
> 
> There are a few bugs in either the XML source file included in Appendix B or the XML Schema included in Appendix C. Here's one example:
> 
>> Attribute 'pc:name' is not allowed to appear in element 'pc:policylimit'.
> 
> The XML source includes this line:
> 
> <pc:policylimit pc:name="address_1" pc:min="8" pc:max="255"/>
> 
> The schema defines these attributes (note that the three described above (name, min, and max) are undefined):
> 
> <complexType name="policyLimit">
>  <attribute name="xpath" type="string" use="required"/>
>  <attribute name="minlen" type="int"/>
>  <attribute name="maxlen" type="int"/>
>  <attribute name="mincount" type="int"/>
>  <attribute name="maxcount" type="int"/>
>  <attribute name="regex" type="string"/>
>  <attribute name="code" type="int"/>
>  <attribute name="desc" type="string"/>
> </complexType>
> 
> Fixes are needed to the XML source or schema.
> 
> Scott
> 
>> -----Original Message-----
>> From: EppExt [mailto:[email-masked]] On Behalf Of Barry Leiba
>> Sent: Thursday, June 25, 2015 1:32 PM
>> To: Mike O'Connell; [email-masked]
>> Subject: Re: [eppext] [apps-discuss] D-BRIEF 00
>> 
>> I'm sending this along to the eppext folks, who seem like an
>> appropriate gang to ask for review here.  Mike is planning to send
>> this to the Independent Stream Editor (ISE) after he gets some
>> feedback.  What he's hoping for here is some review and comment to
>> improve the document before he does that.  If you have some time and
>> comments, please make them in the message thread on the apps-discuss
>> list (and to Mike).  Thanks.
>> 
>> Barry
>> 
>> On Tue, Jun 23, 2015 at 8:59 AM, Mike O'Connell <[email-masked]>
>> wrote:
>>> Hi Apps,
>>> 
>>> Thanks to Barry Leiba for guiding me along the process to submit this
>> draft.
>>> 
>>> I’ve submitted a draft for Dynamic Business-Rules Implementation and
>>> Execution Framework (D-BRIEF).
>>> 
>>> Summary:
>>> 
>>> D-BRIEF is an XML framework built to contain a scriptable language
>> which
>>> operates on business objects within a real-time system.
>>> 
>>> 
>>> Ideology:
>>> 
>>> The foundation concepts include:
>>> 
>>> Object -> Event mappings
>>> Scriptable language container for running “micro" commands on a
>> request
>>> based system
>>> In real-time refresh of business rules, rapid turn-around time
>>> UI Editable
>>> Unix style “micro” commands
>>> By utilising a “cron” style system one can implement an asynchronous
>>> interface that executes Object -> Events at a later stage.
>>> 
>>> 
>>> Within the referenced libraries we wrote additional meta style calls
>> which
>>> allowed us to manipulate the session as follows:
>>> 
>>> Invoke another Object -> Event synchronously which simplifies the
>> layout of
>>> the business policy, we use it for derivative objects.
>>> Exit execution at any point
>>> Queue a task for asynchronous processing
>>> 
>>> 
>>> 
>>> Unfortunately I’m not able to release the UI editor or the actual
>> engine
>>> code that operates the framework due to IP concerns; however I will
>> attempt
>>> again in a few weeks to release at least the engine code.
>>> 
>>> The framework is defined in:
>>> https://datatracker.ietf.org/doc/draft-oconnell-dbrief/
>>> 
>>> Thank you for your time.
>>> 
>>> Sincerely,
>>> 
>>> --
>>> 
>>> Mike O'Connell
>>> Domain Name Services (Pty) Ltd
>>> +27 11 568 2812
>>> 
>>> 
>>> _______________________________________________
>>> apps-discuss mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/apps-discuss
>>> 
>> 
>> _______________________________________________
>> EppExt mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/eppext
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 1 Jul 2015 20:54:50 +0000

Thanks for confirming. I'll check and report back as quickly as I can (I'm currently out on a personal travel obligation; maybe tomorrow or Friday).

Scott

> From: Mike O'Connell [mailto:[email-masked]]
> Sent: Wednesday, July 01, 2015 5:17 AM
> To: Hollenbeck, Scott
> Cc: Barry Leiba; [email-masked]
> > There are a few bugs in either the XML source file included in
> Appendix B or the XML Schema included in Appendix C. Here's one
> example:
> >
> > The schema defines these attributes (note that the three described
> above (name, min, and max) are undefined):
> >

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 2 Jul 2015 01:00:34 +0000

This version looks fine to me. Thanks for the update.

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 6 Jul 2015 11:05:11 +0000

One more comment regarding this statement below:

"Unfortunately I’m not able to release the UI editor or the actual engine code that operates the framework due to IP concerns; however I will attempt again in a few weeks to release at least the engine code."

I'd very much like to see an IPR statement included with the document. This will help ensure that anyone attempting to implement the framework is fully informed of the IP concerns.

Scott