Subject: [eppext] launchphase + domain check

From: Rik Ribbers <[email-masked]>
Date: Mon, 13 Jul 2015 15:25:33 +0000

All,

I've had a very interesting discussion regarding the launchphase draft. The discussion focusses around the domain check and the TMCH claims period. Section 2.3 of the I-D states that:

** quote on **
The server MAY support multiple launch phases sequentially or simultaneously.  The <launch:phase> element MUST be included by the client to define the target launch phase of the command.
** quote off **

So when doing a domain check during a TMCH claims period the domain check in the "Claims check form", "Availability Check Form" and "Trademark Check Form" must contain the <launch:phase> element describing the active phase.

So far so good. But what about the "normal operation" domain check. This is the standard epp domain check (without the launchphase extension). The draft does not explicitly say anything about it, but according to Section 2.3 one could argue that this is not allowed during a TMCH claims period as there is no <launch:phase> element provided.

I would love to here from other WG-members what they think about this...

Kind regards,
Rik Ribbers

---

From: Alexander Mayrhofer <[email-masked]>
Date: Tue, 14 Jul 2015 06:56:49 +0000

Hello Rik,

We understand that the element MUST only be included by the client when one of the "special" check forms is used. Therefore, we do allow "vanilla" EPP domain checks for the whole runtime of the registry, including all "launch phases".

This also seems what registrars are expecting even during the Claims period, because they usually perform a "normal" check before they attempt a create, and only when that fails, they re-query with the Claims check form..

Alex

Von: EppExt [mailto:[email-masked]] Im Auftrag von Rik Ribbers
Gesendet: Montag, 13. Juli 2015 17:26
An: [email-masked]
Betreff: [eppext] launchphase + domain check

All,

** quote on **

Kind regards,
Rik Ribbers

---

From: Rik Ribbers <[email-masked]>
Date: Tue, 14 Jul 2015 07:48:42 +0000

Alexander,

Thanks for your reply. I suggest to add an extra explanation to the draft as all of the implementers I know of have this behavior.

Something like this:

The <launch:phase> element MUST be included by the client to define the target launch phase of the command when using one the special check forms as defined in Section 3.1 of this I-D.

Kind regards,
Rik

From: Alexander Mayrhofer [mailto:[email-masked]]
Sent: dinsdag 14 juli 2015 8:57
To: Rik Ribbers; [email-masked]
Subject: AW: [eppext] launchphase + domain check

Hello Rik,

Alex

Von: EppExt [mailto:[email-masked]] Im Auftrag von Rik Ribbers
Gesendet: Montag, 13. Juli 2015 17:26
An: [email-masked]<mailto:[email-masked]>
Betreff: [eppext] launchphase + domain check

All,

** quote on **

Kind regards,
Rik Ribbers

---

From: Michael Holloway <[email-masked]>
Date: Tue, 14 Jul 2015 10:11:39 +0200

Yes, most registries have implemented it this way (but from memory one 
or two do require the extension during claims), so I agree with the 
wording change.

Additionally, I think the correct action when the extension is omitted 
at any stage would be for the server to always return the availability 
check form (default for launchphase extension) in the currently active 
phase unless there are multiple active phases - in which case it should 
return an error only if the availability of the domain depends on the 
phase (which is rare, but could be some sort of limited release). In 
other words, only complicate the issue if need be. Not sure if / how 
that can be worded.

Cheers,
Michael

On 07/14/2015 09:48 AM, Rik Ribbers wrote:
>
> Alexander,
>
> Thanks for your reply. I suggest to add an extra explanation to the 
> draft as all of the implementers I know of have this behavior.
>
> Something like this:
>
> The <launch:phase> element MUST be included by the client to define 
> the target launch phase of the command when using one the special 
> check forms as defined in Section 3.1 of this I-D.
>
> Kind regards,
>
> Rik
>
> *From:*Alexander Mayrhofer [mailto:[email-masked]]
> *Sent:* dinsdag 14 juli 2015 8:57
> *To:* Rik Ribbers; [email-masked]
> *Subject:* AW: [eppext] launchphase + domain check
>
> Hello Rik,
>
> We understand that the element MUST only be included by the client 
> when one of the „special“ check forms is used. Therefore, we do allow 
> „vanilla“ EPP domain checks for the whole runtime of the registry, 
> including all “launch phases”.
>
> This also seems what registrars are expecting even during the Claims 
> period, because they usually perform a “normal” check before they 
> attempt a create, and only when that fails, they re-query with the 
> Claims check form..
>
> Alex
>
> *Von:*EppExt [mailto:[email-masked]] *Im Auftrag von *Rik Ribbers
> *Gesendet:* Montag, 13. Juli 2015 17:26
> *An:* [email-masked] <mailto:[email-masked]>
> *Betreff:* [eppext] launchphase + domain check
>
> All,
>
> I've had a very interesting discussion regarding the launchphase 
> draft. The discussion focusses around the domain check and the TMCH 
> claims period. Section 2.3 of the I-D states that:
>
> ** quote on **
>
> The server MAY support multiple launch phases sequentially or 
> simultaneously.  The <launch:phase> element MUST be included by the 
> client to define the target launch phase of the command.
>
> ** quote off **
>
> So when doing a domain check during a TMCH claims period the domain 
> check in the "Claims check form", "Availability Check Form" and 
> "Trademark Check Form" must contain the <launch:phase> element 
> describing the active phase.
>
> So far so good. But what about the "normal operation" domain check. 
> This is the standard epp domain check (without the launchphase 
> extension). The draft does not explicitly say anything about it, but 
> according to Section 2.3 one could argue that this is not allowed 
> during a TMCH claims period as there is no <launch:phase> element 
> provided.
>
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: "Gould, James" <[email-masked]>
Date: Tue, 14 Jul 2015 12:49:05 +0000

We also support the standard check form for all launch phases.  The launchphase draft extends the domain mapping to define new forms of checks targeted for the launch phases, but there is no intent to disallow the use of the standard availability check defined in the domain mapping.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Jul 14, 2015, at 2:56 AM, Alexander Mayrhofer <[email-masked]<mailto:[email-masked]>> wrote:

Hello Rik,

We understand that the element MUST only be included by the client when one of the „special“ check forms is used. Therefore, we do allow „vanilla“ EPP domain checks for the whole runtime of the registry, including all “launch phases”.

This also seems what registrars are expecting even during the Claims period, because they usually perform a “normal” check before they attempt a create, and only when that fails, they re-query with the Claims check form..

Alex

All,

** quote on **

Kind regards,
Rik Ribbers
_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext