Subject: [eppext] rechartering

From: Andrew Newton <[email-masked]>
Date: Mon, 27 Jul 2015 20:21:22 +0200

All,

I'd like to offer another idea for the rechartering of this working group.
Instead of focusing exclusively on EPP extensions, would it be better if we
rechartered to focus on protocol issues of Internet registries... more
specifically EPP and RDAP.

Given that the constituencies for both have considerable overlap, and there
is already at least one draft covering the mapping between EPP and RDAP and
that there will likely be future drafts where the inputs of EPP and the
outputs of RDAP are correlated, this seems like an easier way forward.

I spoke privately with Scott, Barry, and Pete (the AD behind the chartering
of both EPPEXT and WEIRDS) just to see if I wasn't barking madd, and they
each thought it makes sense.

What are your thoughts and comments about such an approach?

-andy

---

From: "Marc Blanchet" <[email-masked]>
Date: Mon, 27 Jul 2015 14:43:41 -0400

> What are your thoughts and comments about such an approach?

+1. Marc.

>
> -andy
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 27 Jul 2015 18:46:44 +0000

From: EppExt [mailto:[email-masked]] On Behalf Of Andrew Newton
Sent: Monday, July 27, 2015 2:21 PM
To: [email-masked]
Subject: [eppext] rechartering

All,

I'd like to offer another idea for the rechartering of this working group. Instead of focusing exclusively on EPP extensions, would it be better if we rechartered to focus on protocol issues of Internet registries... more specifically EPP and RDAP.

Given that the constituencies for both have considerable overlap, and there is already at least one draft covering the mapping between EPP and RDAP and that there will likely be future drafts where the inputs of EPP and the outputs of RDAP are correlated, this seems like an easier way forward.

I spoke privately with Scott, Barry, and Pete (the AD behind the chartering of both EPPEXT and WEIRDS) just to see if I wasn't barking madd, and they each thought it makes sense.

I’d like to consider it. It would help to come up with alternative charter text.

Scott

---

From: Andrew Newton <[email-masked]>
Date: Tue, 28 Jul 2015 15:19:54 +0200

Since there has been no negative feedback, I'm cross-posting this to WEIRDS
to see what people over there think.

---------- Forwarded message ----------
From: Andrew Newton <[email-masked]>
Date: Mon, Jul 27, 2015 at 8:21 PM
Subject: rechartering
To: [email-masked]

All,

-andy

---

From: Ulrich Wisser <[email-masked]>
Date: Tue, 28 Jul 2015 13:27:35 +0000

Good idea! There is much overlap.

Andrew Newton <[email-masked]> schrieb am Di., 28. Juli 2015 um 15:20 Uhr:

> Since there has been no negative feedback, I'm cross-posting this to
> WEIRDS to see what people over there think.
>
> Given that the constituencies for both have considerable overlap, and
> there is already at least one draft covering the mapping between EPP and
> RDAP and that there will likely be future drafts where the inputs of EPP
> and the outputs of RDAP are correlated, this seems like an easier way
> forward.
>
> I spoke privately with Scott, Barry, and Pete (the AD behind the
> chartering of both EPPEXT and WEIRDS) just to see if I wasn't barking madd,
> and they each thought it makes sense.
>
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>
-- 
Ulrich Wisser
[email-masked]

---

From: Roger D Carney <[email-masked]>
Date: Tue, 28 Jul 2015 14:18:07 +0000

Good Morning,

This sounds like a good idea, Andy do you have any proposed wording for a combined charter?

Thanks
Roger

From: weirds [mailto:[email-masked]] On Behalf Of Andrew Newton
Sent: Tuesday, July 28, 2015 8:20 AM
To: [email-masked]; [email-masked]
Subject: [weirds] Fwd: rechartering

Since there has been no negative feedback, I'm cross-posting this to WEIRDS to see what people over there think.

---------- Forwarded message ----------
From: Andrew Newton <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jul 27, 2015 at 8:21 PM
Subject: rechartering
To: [email-masked]<mailto:[email-masked]>

All,

-andy

---

From: Andrew Newton <[email-masked]>
Date: Tue, 28 Jul 2015 18:58:04 +0200

> This sounds like a good idea, Andy do you have any proposed wording for a

Not yet, but I'll try to get something as soon as possible.

-andy

---

From: Patrick Mevzek <[email-masked]>
Date: Wed, 29 Jul 2015 02:03:15 +0200

Andrew Newton <[email-masked]> 2015-07-27 20:22
> specifically EPP and RDAP.

I find the idea interesting but I'm not 100% convinced.

As for EPP & RDAP I believe the timeframes and audiences are not the
same:

- EPP is now an "old" protocol, used by all gTLDs, and many ccTLDs
  registries ; AFAIK it is not used outside of the domain name
business, and seldom used outside of domain name registries; there is
no clear indication of any work, outside of technical areas, to try
improving EPP, for example by reducing the number of extensions,
forcing registries to implement some of them, etc…

- RDAP is new, used by a very small number of domain name registries,
  but also used outside of the domain name business, by RIRs. There is
a clear indication of work outside of IETF to impose a common set of
features/recommandations to all gTLDs registries that will need or may
need in the future to implement it, contractually.

So, having a place to discuss all internet registries protocol issues
is good/mandatory, but this may as well be the regops or the gtld-tech
or another mailing-list, not necessarily an IETF WG merging all
extensions issues.

Also, you could even argue that the lager WG could also be merged
(since it is related to protocol issues of Internet registries too),
and maybe even dane or dnsop…

At the end of the day, I think what could be used as a criteria is:
will this kind of merge in topics foster more work and feedback, and
hence going forward faster, or will it make no change?

-- 
Patrick Mevzek

---

From: Rik Ribbers <[email-masked]>
Date: Wed, 29 Jul 2015 08:44:45 +0000

Hello Andrew and others,

I am not completely convinced it is a good idea, but I do not have any objection to combine the work as the interested people are mostly the same.

The overlap between EPP an RDAP is mainly the data that is send using a different protocol (and a different purpose). Another thing is that I am not aware of any work that is being done for RDAP other than the EPP status mapping draft from James Gould.

But I can imagine there will we work on extensions for RDAP in the future as more parties are going to implement it.

Gr,
Rik

From: EppExt [mailto:[email-masked]] On Behalf Of Andrew Newton
Sent: maandag 27 juli 2015 20:21
To: [email-masked]
Subject: [eppext] rechartering

All,

-andy

---

From: Andrew Newton <[email-masked]>
Date: Wed, 29 Jul 2015 07:33:14 -0400

Hi Patrick,

> forcing registries to implement some of them, etc…

I believe that both LACNIC and NIC.br, which in addition to being a ccTLD
is also an NIR, use EPP.

The motivation for coordinating the extensions with EPP is the same for
RDAP. There are already a number registries designing extensions to RDAP,
and a good bit of it is overlap with EPP. One example
is draft-gould-epp-rdap-status-mapping.

> or another mailing-list, not necessarily an IETF WG merging all

Both regops and gtld-tech are not IETF activities, and therefore cannot be
the home for IETF document work.

However, there is work that starts in the gTLD community that has a broader
interest and application. For example, draft-hollenbeck-weirds-rdap-openid
comes from the gTLD space, but some RIRs are interested in it.

> hence going forward faster, or will it make no change?

I agree, that's an important question to ask. If the additional topic is
too large for this working group, that would be a bad thing. But to date,
EPPEXT has not exactly been high volume. That being said, we also wouldn't
want to derail the backlog of EPP extension work with new RDAP work items.
Therefore the proposed charter text states that the initial focus will be
EPP work.

-andy

---

From: Andrew Newton <[email-masked]>
Date: Wed, 29 Jul 2015 07:44:33 -0400

Hi Rik,

Scott has an interesting RDAP extension proposal
in draft-hollenbeck-weirds-rdap-openid.

Additionally we need an Informational RFC on guidelines for extending RDAP,
similar to the one for EPP. And there are several extensions being talked
about.

-andy

On Wed, Jul 29, 2015 at 4:44 AM, Rik Ribbers <[email-masked]> wrote:

>  Hello Andrew and others,
>
>
>
> I am not completely convinced it is a good idea, but I do not have any
> objection to combine the work as the interested people are mostly the same.
>
>
>
> The overlap between EPP an RDAP is mainly the data that is send using a
> different protocol (and a different purpose). Another thing is that I am
> not aware of any work that is being done for RDAP other than the EPP status
> mapping draft from James Gould.
>
>
>
> But I can imagine there will we work on extensions for RDAP in the future
> as more parties are going to implement it.
>
>
>
> Gr,
>
> Rik
>
>
>
>
>
> *From:* EppExt [mailto:[email-masked]] *On Behalf Of *Andrew
> Newton
> *Sent:* maandag 27 juli 2015 20:21
> *To:* [email-masked]
> *Subject:* [eppext] rechartering
>
>
>
> All,
>
>
>

---

From: Rik Ribbers <[email-masked]>
Date: Wed, 29 Jul 2015 13:32:37 +0000

That makes sense. I forgot the openid draft.... And looking forward to the other extensions.

Thx for the update.

Gr
Rik

Verstuurd vanaf mijn iPhone

Op 29 jul. 2015 om 13:44 heeft Andrew Newton <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

Hi Rik,

Scott has an interesting RDAP extension proposal in draft-hollenbeck-weirds-rdap-openid.

Additionally we need an Informational RFC on guidelines for extending RDAP, similar to the one for EPP. And there are several extensions being talked about.

-andy

On Wed, Jul 29, 2015 at 4:44 AM, Rik Ribbers <[email-masked]<mailto:[email-masked]>> wrote:
Hello Andrew and others,

Gr,
Rik

From: EppExt [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Andrew Newton
Sent: maandag 27 juli 2015 20:21
To: [email-masked]<mailto:[email-masked]>
Subject: [eppext] rechartering

All,

-andy

---

From: Frederico A C Neves <[email-masked]>
Date: Wed, 29 Jul 2015 11:09:41 -0300

> > forcing registries to implement some of them, etc…

I agree that there is very little to no incentive at all to
combine/merge old EPP extensions in production but for new work the
proposed "combined" charter seems attractive to me. We should leverage
as much as we can the history/experience on not spreading enough the
word and not exposing proposed extensions enough before they get
ossified on agreements and production systems. Focusing the work in a
single place is a good way of achieving this.

> I believe that both LACNIC and NIC.br, which in addition to being a ccTLD

Yes. NIC.br and NIC.mx, both NIRs, integrates to the LACNIC system
since Feb 2013 using the following extensions,

ftp://ftp.registro.br/pub/libepp-nicbr/draft-neves-epp-asn-02.txt
ftp://ftp.registro.br/pub/libepp-nicbr/draft-neves-epp-ipnetwork-02.txt

Besides of the NIR/RIR integration, LACNIC also provides this EPP
interface for direct customers.

...
> Therefore the proposed charter text states that the initial focus will be

+1

> -andy

Fred

---

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 29 Jul 2015 11:01:38 -0400

> Hi Patrick,
…

> Therefore the proposed charter text states that the initial focus will 

I disagree with putting a priority in the (new) charter. I think this is 
just a triage function that can be done by the chairs, depending on 
which topic needs more priority. We may end up having epp-ext-1 and 
rdap-ext-4 be higher priorities than epp-ext-2.  Again, just a chair+wg 
triage function to me.

I also think that the level of work is not too heavy and can easily be 
handled in a single working group.

Here is a proposal for the working group name: regext  (REGistration 
protocols EXTensions)

Regards, Marc.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 29 Jul 2015 15:42:13 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Marc
> Blanchet
> Sent: Wednesday, July 29, 2015 11:02 AM
> To: Andrew Newton
> Cc: Patrick Mevzek; eppext
> Subject: Re: [eppext] rechartering
> 
> 
> 
> > Therefore the proposed charter text states that the initial focus
> will
> > be
> > EPP work.
> 

I like that...

Scott

---

From: Andrew Newton <[email-masked]>
Date: Wed, 29 Jul 2015 11:56:02 -0400

On Wed, Jul 29, 2015 at 11:01 AM, Marc Blanchet
<[email-masked]> wrote:
> just a triage function that can be done by the chairs, depending on which
> topic needs more priority. We may end up having epp-ext-1 and rdap-ext-4 be
> higher priorities than epp-ext-2.  Again, just a chair+wg triage function to
> me.

I think it is important to be sensitive to the EPP work that has
already built up. I do not care about the mechanism to address it.
Another solution would be to add a 3rd co-chair if the necessary. You
need a blue dot, Marc? :)

> handled in a single working group.

Agreed.

> Here is a proposal for the working group name: regext  (REGistration

Or maybe PIRO: Protocols for Internet Registry Operations.

-andy

---

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 29 Jul 2015 12:02:22 -0400

On 29 Jul 2015, at 11:56, Andrew Newton wrote:

>> which

sure.

> already built up. I do not care about the mechanism to address it.

my point is that the priorities shall be off the charter itself, more a 
matter of wg management.

> Another solution would be to add a 3rd co-chair if the necessary.

not sure it does help. Increasing the number of managers usually 
decrease the efficiency of an organization, at least in my experience 
;-)

> You

I prefer the white ones.

Marc.

---

From: Patrick Mevzek <[email-masked]>
Date: Wed, 29 Jul 2015 23:19:46 +0200

Hello,

Summarizing my views:

- I agree there is a need to coordinate EPP extensions, and RDAP ones,
- however I do not see such a great overlap between the two (except
  the fact that both protocols will be run by the same entity), and I
do not have heard any other cases than Jim's and Scott's drafts (but
I'm an RDAP newbie for now, despite having promised to build a client), and
at least for the one on statuses, I see only work on the RDAP part,
and none on the EPP part
- I fear that merging topics will create more work, not less
and complicate things, for examples on building milestones
- and seeing already the discussions on how to prioritize things or
  how to name the new WG seem to prove that point.
- at the end of the day, I'm not against the idea, I just do not see
  it as a huge improvement. In all cases I would be happy to join and
participate in the new merged WG if it so happens after motivated
people going forward in that route

-- 
Patrick Mevzek