Subject: [eppext] revised draft charter - v2

From: James Galvin <[email-masked]>
Date: Fri, 28 Aug 2015 17:27:35 -0400

There were two suggestions on the list for extending the charter.  One 
seemed to suggest being the home for all protocol extensions.  A second 
was to focus on just RDAP and EPP extensions.

I believe the restriction to just RDAP and EPP had more support.  There 
were a few people who suggested they didn't really want to join the two 
protocols but they also said they would not object to joining them.  I 
counted this as support for the merge.

Marc Blanchet proposed a new name of REGistration protocols EXTensions 
(REGEXT).  There were no objections so I adopted it in this revised draft.

Here is a draft for consideration by the working group.  I have not yet 
added milestones, which are necessary before submitting this to the IESG 
for review.  I also have to finish reviewing the discussion for the 3 
documents in WGLC so I can make sure to include them appropriately in 
this charter.

Please comment on this charter and suggest milestones for inclusion by 
Friday, 4 September 2015.

Jim

---

From: Barry Leiba <[email-masked]>
Date: Fri, 28 Aug 2015 19:01:45 -0400

> (REGEXT).  There were no objections so I adopted it in this revised draft.

I think changing the name is a fine thing, but just to alert y'all so
it doesn't seem weird when I do it:

Because of the change to the short name (eppext to regext), and the
way things are keyed in the datatracker, I will handle this by
chartering a new working group with the same chairs, and then close
the eppext working group once the regext charter is approved and
active.

We can also change the mailing list name at the same time, and leave
"eppext" as an alias for it.  That way, everyone will still be
subscribed and no one will have to change anything.

Barry

---

From: James Galvin <[email-masked]>
Date: Sat, 29 Aug 2015 06:50:42 -0400

Thanks Barry.

Jim

---

From: Andrew Newton <[email-masked]>
Date: Sun, 30 Aug 2015 11:23:27 -0400

> subscribed and no one will have to change anything.

Would we also want to alias the WEIRDS list as well?

-andy

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 31 Aug 2015 11:02:16 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Andrew
> Newton
> Sent: Sunday, August 30, 2015 11:23 AM
> To: Barry Leiba
> Cc: eppext; James Galvin
> Subject: Re: [eppext] revised draft charter - v2
> 

I wouldn't object to that, but I can also see reasons for leaving it as-is. We still have RDAP-specific implementation and deployment steps ahead of us. It might make sense to talk about any issues that arise on an RDAP-specific list.

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 31 Aug 2015 11:06:22 +0000

> From: EppExt [mailto:[email-masked]] On Behalf Of James Galvin
> Sent: Friday, August 28, 2015 5:28 PM
> To: eppext
> Cc: Barry Leiba
> Subject: [eppext] revised draft charter - v2
> 

I support this proposal. I also like Barry's proposal to alias the eppext mailing list name. That will keeps things working as far as the instructions go for use of that list to discuss EPP extension proposals.

Scott

---

From: Rik Ribbers <[email-masked]>
Date: Mon, 31 Aug 2015 11:17:48 +0000

+1 for the charter text

One question. If we are creating aliases for mailingllist should we consider the provreg mailing list? Then at least all EPP mailing lists I am aware of are relayed to on place.

Gr,
Rik 

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of James Galvin
Sent: vrijdag 28 augustus 2015 23:28
To: eppext
Cc: Barry Leiba
Subject: [eppext] revised draft charter - v2

There were two suggestions on the list for extending the charter.  One seemed to suggest being the home for all protocol extensions.  A second was to focus on just RDAP and EPP extensions.

I believe the restriction to just RDAP and EPP had more support.  There were a few people who suggested they didn't really want to join the two protocols but they also said they would not object to joining them.  I counted this as support for the merge.

Marc Blanchet proposed a new name of REGistration protocols EXTensions (REGEXT).  There were no objections so I adopted it in this revised draft.

Here is a draft for consideration by the working group.  I have not yet added milestones, which are necessary before submitting this to the IESG for review.  I also have to finish reviewing the discussion for the 3 documents in WGLC so I can make sure to include them appropriately in this charter.

Please comment on this charter and suggest milestones for inclusion by Friday, 4 September 2015.

Jim

---

From: Roger D Carney <[email-masked]>
Date: Mon, 31 Aug 2015 11:55:50 +0000

Thanks Berry, makes sense and sounds great, I like Andy's suggest to include WEIRDS as well as Rik's to include provreg (I think many of us are on multiples of these but it would catch all those that are not).

Jim, I would like to suggest including Reseller, Bundling, and Fees to the milestones, in that order sounds good too.  I assume the Key Relay will be finished under the "old/current" WG/Charter.

Thanks
Roger

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Friday, August 28, 2015 6:02 PM
To: James Galvin
Cc: eppext
Subject: Re: [eppext] revised draft charter - v2

> (REGEXT).  There were no objections so I adopted it in this revised draft.

I think changing the name is a fine thing, but just to alert y'all so it doesn't seem weird when I do it:

Because of the change to the short name (eppext to regext), and the way things are keyed in the datatracker, I will handle this by chartering a new working group with the same chairs, and then close the eppext working group once the regext charter is approved and active.

We can also change the mailing list name at the same time, and leave "eppext" as an alias for it.  That way, everyone will still be subscribed and no one will have to change anything.

Barry

_______________________________________________
EppExt mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/eppext

---

From: Rik Ribbers <[email-masked]>
Date: Mon, 31 Aug 2015 12:15:12 +0000

> I assume the Key Relay will be finished under the "old/current" WG/Charter.

And of coarse the launchphase and smd drafts

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of Roger D Carney
Sent: maandag 31 augustus 2015 13:56
To: eppext
Subject: Re: [eppext] revised draft charter - v2

Jim, I would like to suggest including Reseller, Bundling, and Fees to the milestones, in that order sounds good too

Thanks
Roger

---

From: Marc Groeneweg <[email-masked]>
Date: Mon, 31 Aug 2015 12:57:00 +0000

+1

I agree to extend the EPPEXT with possible extensions to the RDAP protocol. And please do forward the eppext, provreg and weirds mail to a new regext list. 

Regards,
Marc Groeneweg

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of Rik Ribbers
Sent: maandag 31 augustus 2015 13:18
To: 'James Galvin'; [email-masked]
Subject: Re: [eppext] revised draft charter - v2

+1 for the charter text

Gr,
Rik 

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of James Galvin
Sent: vrijdag 28 augustus 2015 23:28
To: eppext
Cc: Barry Leiba
Subject: [eppext] revised draft charter - v2

Jim

---

From: Edward Lewis <[email-masked]>
Date: Mon, 31 Aug 2015 13:16:34 +0000

The practices of operating a registry have been evolving over the past 15
years.  Getting PROVREG chartered was a challenge back in 2000, as the
IETF felt that EPP wasn't a topic for the organization.  As soon as EPP's
first round of documents were approved, the WG was shutdown and the
PROVREG mail list continued in sort of a vacuum as the industry grew
around EPP, this was the root (or a root) cause of why EPPEXT came about.

I think having a registry-industry focused extensions WG is a good idea.
I'd float the request to pull in documents on data escrow of registry data
as well as documents related to trademark clearing house.  There are
documents related to those two functions already in the IETF floating in
individual submission space.

Two questions that come to mind are: Would creating a
registry-as-a-specific-function WG be something new to the IETF?  (I.e.,
precedent-setting?)  And would this be better placed in O&M?

The former is a question from what I recall was the stumbling block back
in 2000.  As much as I think there is a need for documenting how
registries work - without unifying in any way - so that ideas can be
shared, etc., I hope that the IETF is willing to take this on as a WG.

I'll add - I don't see registries continually evolving over time, past a
point of maturity.  So a WG would have a limited lifetime, not an
on-going, ever-expanding function.

On 8/31/15, 8:57, "EppExt on behalf of Marc Groeneweg"
<[email-masked] on behalf of [email-masked]> wrote:

>+1
>
>I agree to extend the EPPEXT with possible extensions to the RDAP
>protocol. And please do forward the eppext, provreg and weirds mail to a
>new regext list. 
>
>Regards,
>Marc Groeneweg
>
>One question. If we are creating aliases for mailingllist should we
>consider the provreg mailing list? Then at least all EPP mailing lists I
>am aware of are relayed to on place.
>
>Gr,
>Rik 
>