Subject: [eppext] Suggestion for check domain extension

From: Michael Hansen <[email-masked]>
Date: Fri, 2 Oct 2015 11:10:52 +0200

As a registrar I would like to see a standard way in check domain to get
information about if a domain is blocked or reserved, like in the AFNIC
extension ( http://www.afnic.fr/xml/epp/frnic-1.3):

...
<!--
AFNIC <check> response extensions details
-->
<complexType name="resChkDataType">
  <choice>
    <element name="domain" type="frnic:resChkDomDataType"/>
  </choice>
</complexType>

<complexType name="resChkDomDataType">
  <sequence>
    <element name="cd" type="frnic:domCheckType" maxOccurs="unbounded"/>
  </sequence>
</complexType>

<complexType name="domCheckType">
  <sequence>
    <element name="name" type="frnic:domCheckNameType"/>
    <element name="rsvReason" type="eppcom:reasonType" minOccurs="0"/>
    <element name="fbdReason" type="eppcom:reasonType" minOccurs="0"/>
  </sequence>
</complexType>

<complexType name="domCheckNameType">
  <simpleContent>
    <extension base="eppcom:labelType">
      <attribute name="reserved" type="boolean" use="required"/>
      <attribute name="forbidden" type="boolean" use="required"/>
    </extension>
  </simpleContent>
</complexType>
...

Using the current check domain it is not possible to identify
blocked/reserved domains unless the reason can be parsed, as most just
return unavailable for blocked domains, and available for reserved domains.

It might also be extended with some kind of identifier for who the
domain is reserved to (i.e. domain name for .uk domains, or VAT number
for .rio domains).

Regards

Michael Hansen
Senior Developer
One.com A/S

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 2 Oct 2015 10:58:17 +0000

Have you considered writing a draft describing such an extension?

It would be nice if the AFNIC extension was registered:

http://www.iana.org/assignments/epp-extensions/epp-extensions.xhtml#epp-extensions-1

Scott

From: EppExt [mailto:[email-masked]] On Behalf Of Michael Hansen
Sent: Friday, October 02, 2015 5:11 AM
To: [email-masked]
Subject: [eppext] Suggestion for check domain extension

As a registrar I would like to see a standard way in check domain to get information about if a domain is blocked or reserved, like in the AFNIC extension ( http://www.afnic.fr/xml/epp/frnic-1.3):

...
<!--

Using the current check domain it is not possible to identify blocked/reserved domains unless the reason can be parsed, as most just return unavailable for blocked domains, and available for reserved domains.

It might also be extended with some kind of identifier for who the domain is reserved to (i.e. domain name for .uk domains, or VAT number for .rio domains).

Regards

Michael Hansen
Senior Developer
One.com A/S

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 8 Oct 2015 15:52:49 +0800

We also have the same requirement. Moreover, some users want to know whether a domain is allocated/blocked/reserved in different language scripts, such as Chinese, Japanese and Korean. Because of different label generation rules, even the same domain may have different status. I'd like to help write an initial draft to specify this extension.

Regards,

Linlin Zhou
 
From: Hollenbeck, Scott
Date: 2015-10-02 18:58
To: Michael Hansen; [email-masked]
Subject: Re: [eppext] Suggestion for check domain extension
Have you considered writing a draft describing such an extension?

 
Scott

...
<!--

Regards

Michael Hansen
Senior Developer
One.com A/S