Subject: [eppext] RDAP adoption?

From: Dave Crocker <[email-masked]>
Date: Mon, 9 Nov 2015 19:43:15 -0800

(Andy Newton asked me to post this question to these lists...)

Hi.

I'm trying to discover the current field maturity of RDAP.

  *  How much operational deployment of servers supporting it is there?

  *  How much client deployment in software?

  *  But ultimately how much client/server use of the protocol is
     there, so far?

  *  Any sense of the adoption/use trends?

  *  Any sense of what is delaying more and better adoption/use?

  *  Any sense of what might improve things?

Thanks.

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Andrew Newton <[email-masked]>
Date: Tue, 10 Nov 2015 09:07:38 -0500

>   *  How much operational deployment of servers supporting it is there?

In the RIR space, 4 of the 5 RIRs have production systems with the 5th
working on moving their beta into production.

>   *  How much client deployment in software?

At the REGOPS workshop in Prague, I think .CZ mentioned they were
working on a client. And perhaps there was one other TLD doing so as
well.

I've put out NicInfo: https://github.com/arineng/nicinfo
And I do have a browser-based, pure Javascript client in
proof-of-concept stage awaiting my undivided attention to be
completed.

>From a server software standpoint, RIPE NCC's code is open sourced and
on GitHub. CNNIC has a server implementation developed under contract
with ICANN, and ARIN has developed a bootstrap sever (on GitHub) which
is also an ARIN service.

>   *  Any sense of the adoption/use trends?

I ran some stats on the ARIN service back in early September (we
deployed in late June, so around 70 days after deployment), and here
is what I had:

Entity queries:        173
Domain queries:        290
IP queries:          40818
Autnum queries:       9203
Registry queries     50224
Bootstrap queries      608
Total Queries        50817

Top 10 User Agents
23270 "-"
15457 "NicInfo
7712 "curl/7.30.0"
1258 "ColdFusion"
1027 "Mozilla/5.0
395 "python-requests/2.7.0
393 "libwww-perl/6.08"
359 "Apache-HttpAsyncClient/4.0
305 "Python-urllib/2.7"
165 "curl/7.19.7

So that is in the noise when compared to port 43 or even ARIN's
proprietary restful service, but it's also new.

>   *  Any sense of what might improve things?

Yes, movement in the gTLD space. We see a lot of domain queries.

-andy

---

From: Rik Ribbers <[email-masked]>
Date: Tue, 10 Nov 2015 14:30:40 +0000

I also recall from the REGOPS workshop the Brazilians (.br) have an server side implementation in production and there is a RDAP library for servers in JAVA available from DNS Belgium (.be).

Gr,
Rik  

> On 10 Nov 2015, at 15:07, Andrew Newton <[email-masked]> wrote:
> 
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext
>

---

From: Rubens Kuhl <[email-masked]>
Date: Tue, 10 Nov 2015 12:35:17 -0200

> Em 10 de nov de 2015, à(s) 12:30:000, Rik Ribbers <[email-masked]> escreveu:
> 

https://rdap.beta.registro.br/domain/nic.br
https://rdap.beta.registro.br/domain/foo.eng.br
https://rdap.beta.registro.br/ip/200.160.0.1
https://rdap.beta.registro.br/ip/2001:12ff::/32
https://rdap.beta.registro.br/autnum/22548
https://rdap.beta.registro.br/entity/h_05506560000136-NICBR

Rubens

---

From: Dave Crocker <[email-masked]>
Date: Tue, 10 Nov 2015 07:23:07 -0800

Andey, et al,

Many thanks for the responses.

I think what I read summarizes as:

     There is an active community effort to promote, deploy and use
RDAP.  It has made good, initial progress and does appear to be on a
healthy vector towards widespread use.

     Adoption by providers is excellent. Adoption in clients is still in
the very early stages.  There is actual traffic, but it is still quite
modest.

Does the above give anyone heartburn?

inline...

> deployed in late June, so around 70 days after deployment), and here
...
> proprietary restful service, but it's also new.

It might help folks get a sense of on-going progress to regularly show
the changes in traffic, both in terms of the client/server mix and the
overall traffic, compared against :43.  That is, how widespread is the
use and how much use is there?

We have quite a bit of unfortunate history with good efforts at
producing specs that lacked sustained community effort at adoption.
This one sounds much better than those unfortunate cases, but as DNSSec
demonstrated it is too easy to lose momentum.  You might want to have an
explicit -- if informal -- community effort organized at adoption and use.

Again, thanks for the followup.

d/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 10 Nov 2015 17:07:34 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Dave Crocker
> Sent: Tuesday, November 10, 2015 10:23 AM
> To: Andrew Newton
> Cc: [email-masked]; eppext
> Subject: Re: [eppext] RDAP adoption?

[snip]

> explicit -- if informal -- community effort organized at adoption and

RDAP has been the focus of a recent series of operationally-focused workshops that I've helped organize. There will be more in the future.

Scott

---

From: Mario Loffredo <[email-masked]>
Date: Tue, 10 Nov 2015 18:52:39 +0100

>    *  Any sense of what might improve things?
Dear Dave,

I speak on behalf  of .it and it seems to me that there are some big 
problems we have to face in order to implement a RDAP server.
The first three things coming in my mind about RDAP responses are the 
following:

- domain status
   Due to Italian regulation, we have introduced some statuses in 
addition to EPP standard and RGP extension statuses.
   At the moment, the only way to represent this statuses according to 
the RDAP profile is to add an unrecognized member together with a status 
reported in RFC7483

- Registrar role publicIDs member
   The RDAP profile states that the entity with the registrar role MUST 
contain a publicIDs member to identify IANA Registrar ID from the IANA's 
Registrar ID registry.
   In .it, we have a lot of medium/small registrars registering only .it 
domains so none of them appear in the IANA Registrar ID registry.
   Furthermore, there are some domains managed by the registry itself 
(nic.it for example) or by italian public entities registrars 
(government, regions, and so on)

- Registrant/admin/tech role required fields
According to .it regulation,  each contact cannot give the consent to 
publish the personal data on WHOIS.
Street,City and Country are part of the personal data so they might not 
appear in a RDAP response

Maybe these problems are common to other ccTLDs.
In my humble opinion, we need a discussion about the adoption of RDAP 
from ccTLDs in order to have, at the end, a RDAP profile for ccTLDs .

Regards,
Mario

---

From: Rubens Kuhl <[email-masked]>
Date: Tue, 10 Nov 2015 16:01:35 -0200

> 
> I speak on behalf  of .it and it seems to me that there are some big problems we have to face in order to implement a RDAP server.
> The first three things coming in my mind about RDAP responses are the following:
> 
> - domain status
>  Due to Italian regulation, we have introduced some statuses in addition to EPP standard and RGP extension statuses.
>  At the moment, the only way to represent this statuses according to the RDAP profile is to add an unrecognized member together with a status reported in RFC7483

It seems gTLDs are facing the same issue, and the same seems to be the same: an I-D defining those values. 

>  The RDAP profile states that the entity with the registrar role MUST contain a publicIDs member to identify IANA Registrar ID from the IANA's Registrar ID registry.
>  In .it, we have a lot of medium/small registrars registering only .it domains so none of them appear in the IANA Registrar ID registry.
>  Furthermore, there are some domains managed by the registry itself (nic.it for example) or by italian public entities registrars (government, regions, and so on)

The gTLD RDAP Profile only applies to gTLDs. ccTLDs don't have follow any of ICANN's specs in this regard; is there any IETF document precluding .it from using some kind of internal ID ? 

> According to .it regulation,  each contact cannot give the consent to publish the personal data on WHOIS.
> Street,City and Country are part of the personal data so they might not appear in a RDAP response
> 

Empty data might seem to solve it as well, but I wonder whether this requirement also came from gTLD profile or from a technical standard ? 

> In my humble opinion, we need a discussion about the adoption of RDAP from ccTLDs in order to have, at the end, a RDAP profile for ccTLDs .

ccTLDs are known for liking their independence, so it's really up to you to make the .it RDAP profile... but there are some commonalities in the EEE (European Economic Area) that might suggest an European ccTLD RDAP profile that could include VAT, Privacy Laws etc. Perhaps CENTR could be a venue to that development ? 

Rubens

---

From: Andrew Newton <[email-masked]>
Date: Tue, 10 Nov 2015 13:45:34 -0500

On Tue, Nov 10, 2015 at 12:52 PM, Mario Loffredo
<[email-masked]> wrote:

>   At the moment, the only way to represent this statuses according to the
> RDAP profile is to add an unrecognized member together with a status
> reported in RFC7483

Actually, there is an IANA registry for status values. Inventing new
JSON members for that need is not the right way to do it.

>   Furthermore, there are some domains managed by the registry itself (nic.it
> for example) or by italian public entities registrars (government, regions,
> and so on)
>

publicId is not a required field. And it can be used for more than
just ICANN identifiers.

-andy

---

From: Mario Loffredo <[email-masked]>
Date: Wed, 11 Nov 2015 09:49:58 +0100

Il 10/11/2015 19:01, Rubens Kuhl ha scritto:
> The gTLD RDAP Profile only applies to gTLDs. ccTLDs don't have follow any of ICANN's specs in this regard;
I know it

> is there any IETF document precluding .it from using some kind of internal ID ?
No there isn't

> Empty data might seem to solve it as well, but I wonder whether this requirement also came from gTLD profile or from a technical standard ?
No problem. I realized that these fields are required only in gTLD 
profile and can be empty in other cases.
> ccTLDs are known for liking their independence, so it's really up to you to make the .it RDAP profile... but there are some commonalities in the EEE (European Economic Area) that might suggest an E…
This is what I really hope. At the last EPP workshop in Stockholm about 
EPP extensions all the partecipants agreed that there are two many 
extensions. So I wonder, what is the sense to have a RDAP profile for 
.it, a RDAP profile for .fr, and so on ?
Maybe, for example, the concepts causing the introduction of non 
standard domain statuses in .it are similar to other countries.
Now that we have two standards, EPP and RDAP, allowing a very high 
degree of technical interoperability, we should work to increase 
conceptual interoperability as much as possible.
At least in Centr we should start a more standardized approach to the 
issue of local differences in order to limit the number of RDAP profiles 
as well as the number of EPP extensions.

Regards,
Mario