Subject: [eppext] Adding missing RDAP event action types for gTLDs

From: Gustavo Lozano <[email-masked]>
Date: Tue, 10 Nov 2015 18:29:21 +0000

Hello colleagues,

As you may know, two of the open issues in the RDAP profile for gTLDs
(http://mm.icann.org/pipermail/gtld-tech/attachments/20150928/35901409/gTLDR
DAPOperationalProfile-v06-0001.pdf) are missing event action types in the
base RDAP specification for:
* Last update time of the RDAP database
* Registrar registration expiration date

You may find the details in the following I-D:
https://www.ietf.org/id/draft-lozano-rdap-gtld-whois-additional-events-00.tx
t

It's important to promptly add these two event action types based on the
timeline for deployment of RDAP in the gTLDs.

As this appears to be a minor update, I am planning (in the last week of
November) on sending a request to IANA, in order to add these two action
event types to the RDAP JSON Values Registry following the Expert Review
Registration Procedure. I would like to get feedback from the list regarding
this proposal. 

If you agree with the proposal, it would be great if you can reply to the
list in order to show the expert reviewer that there is consensus on the
list.

Regards,
Gustavo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 10 Nov 2015 18:47:41 +0000

From: weirds [mailto:[email-masked]] On Behalf Of Gustavo Lozano
Sent: Tuesday, November 10, 2015 1:29 PM
To: [email-masked]
Cc: [email-masked]
Subject: [weirds] Adding missing RDAP event action types for gTLDs

Hello colleagues,

As you may know, two of the open issues in the RDAP profile for gTLDs (http://mm.icann.org/pipermail/gtld-tech/attachments/20150928/35901409/gTLDRDAPOperationalProfile-v06-0001.pdf) are missing event action types in the base RDAP specification for:
* Last update time of the RDAP database
* Registrar registration expiration date

You may find the details in the following I-D: https://www.ietf.org/id/draft-lozano-rdap-gtld-whois-additional-events-00.txt

It's important to promptly add these two event action types based on the timeline for deployment of RDAP in the gTLDs.

[snip]

If a recall what I heard in Dublin and Yokohama, the timeline is *proposed* and subject to a community review process that is supposed to start later this month - correct?

Scott

---

From: Roger D Carney <[email-masked]>
Date: Tue, 10 Nov 2015 21:19:50 +0000

Thanks Gustavo.

I agree with Scott, from what I recall this is just a proposed timeline.

As for this I-D, one comment, one clarification:

*         Comment: in reading Appendix B of RFC 7483 it states that events represent actions that have taken place against a registered object at a certain date and time. I don't see that Last Update of RDAP Database is an action against a registered object, against the "container" of these registered objects but not against a registered object. This may be just a definition issue, I don't recall reading a definition of Last Update of RDAP Database so it could be defined as: the date/time of the last change to a registration object (domain, host, contact) in the RDAP database. Lacking a definition I would have defined Last Update of RDAP Database literally, so any maintenance including restoration, reference table updates, etc I would say changes the Last Update of RDAP Database. Again maybe just a definition issue.

*         Clarification: this I-D tries to address the lack of some RDAP data modeling in regards to Registrar Expiration Date but there still is work needed to address getting this data from registrar to registry, correct? I am not aware of a way to do this currently or of work to make this happen.

Thanks
Roger

From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck, Scott
Sent: Tuesday, November 10, 2015 12:48 PM
To: Gustavo Lozano; [email-masked]
Cc: [email-masked]
Subject: Re: [eppext] Adding missing RDAP event action types for gTLDs

From: weirds [mailto:[email-masked]] On Behalf Of Gustavo Lozano
Sent: Tuesday, November 10, 2015 1:29 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [weirds] Adding missing RDAP event action types for gTLDs

Hello colleagues,

[snip]

Scott

---

From: Andrew Newton <[email-masked]>
Date: Wed, 11 Nov 2015 10:00:44 -0500

Hi Gustavo,

I've looked at your proposed new events, and it makes sense to me.

-andy

On Tue, Nov 10, 2015 at 1:29 PM, Gustavo Lozano
<[email-masked]> wrote:
> (http://mm.icann.org/pipermail/gtld-tech/attachments/20150928/35901409/gTLDRDAPOperationalProfile-v06-0001.pdf)
> are missing event action types in the base RDAP specification for:
> https://www.ietf.org/id/draft-lozano-rdap-gtld-whois-additional-events-00.txt
>
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds
>