Subject: [eppext] Minutes for our meeting in Yokohama IETF94

From: Ulrich Wisser <[email-masked]>
Date: Thu, 05 Nov 2015 09:09:28 +0000

Please find my minutes below.
Feedback is welcome!
/Ulrich

EPPEXT meeting at IETF94 Yokohama 2015-11-05 15:20-17:20

Scott Hollenbeck and Ning Kong as interim chair
Both chairs Jim Galvin and Antoin Verschueren in remote participation

draft-ietf-eppext-keyrelay
draft-eppext-tmch-smd
  Both are through last call and AD Barry Leiba is currently reviewing,
response expected in the coming weeks.

draft-ietf-epppext-launchphase
  Jim Gould updated the document and thinks it is ready for last call.
  shepherd Ulrich Wisser

draft-ietf-eppext-tmch-func-spec-00
  shepherd Ulrich Wisser

draft-ietf-eppext-idnmap-02
draft-gould-idn-table-02
draft-wilcox-cira-idn-eppext-00
  James Gould speaks on these drafts. idnmap needs even idntables as to
specify possible table name values.
  Several of the documents are expired. Renewal is requested or will be
directly after the meeting.
  Documents will become milestones in the new charter.
  wilcox will be retracted or moved to epp-registry.

Jim Galvin presents a list of documents currently in work and will be
milestones
for the new charter.

draft-gould-allocation-token
  James Goulds speaks on the reasoning behind the extensions.
  Opposition to use AuthInfo for this purpose

draft-gould-change-poll
  James Gould speaks on the reasoning of the document.
  Clients get updates on changes to objects through the poll queue.

draft-gould-epp-rdap-status-mapping
  James Gould presents on the reasoning behind the draft.
  Comments from the room about the question of standards track or
informational

draft-zhou-eppext-reseller-mapping
draft-zhou-eppext-reseller-ext
  Ning Kong presents
  Discussions about need for RDAP extension
  Registrar object suggested with support in the room

draft-gould-eppext-verificationcode
draft-xie-eppext-nv-mapping
  James Gould presents
  IPR disclosure

Discussion about adoption of informational documents
  Hum only for no objection

Discussion about documents to include in working group
  - not draft from Alexander Mayerhofer
  - Jim proposes to divide docs in groups for the milestones
  - opposition and support for nv-mapping document
  - Hum, no objections to milestones
  - charter presentation and discussions
  - Several submissions to not broaden the scope of the group to all things
ICANN

-- 
Ulrich Wisser
[email-masked]

---

From: Declan Ma <[email-masked]>
Date: Thu, 5 Nov 2015 17:42:05 +0800

Ulrich,

It seems that there is an inconsistency  between the minutes and jabber chatting.

According to the jabber, 

[email-masked]:
	is the WG opposed to taken onboard Informational
[email-masked]:
	hummmmm
[email-masked]:
	yes silence no loud hummmm

So, Discussion about adoption of informational documents

“Hum only for no objection” should be corrected to “Hum only for no, objection”.

Am I making sense here? 

Shall we review the milestone that contains documents that is still under discussion of adoption?

Di MA

ZDNS Ltd.

http://en.zdns.cn

> 在 2015年11月5日，17:09，Ulrich Wisser <[email-masked]> 写道：
> 
>   Both are through last call and AD Barry Leiba is currently reviewing, response expected in the coming weeks.
> 
> 
>   James Gould speaks on these drafts. idnmap needs even idntables as to specify possible table name values.
>   Several of the documents are expired. Renewal is requested or will be directly after the meeting.
> Jim Galvin presents a list of documents currently in work and will be milestones 
> for the new charter.
> 
>   Comments from the room about the question of standards track or informational
> 
>   - Several submissions to not broaden the scope of the group to all things ICANN
> 
> -- 
> Ulrich Wisser
> [email-masked]
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: Rik Ribbers <[email-masked]>
Date: Thu, 5 Nov 2015 10:06:35 +0000

Hello Declan

The conclusion for me is that there was no objection to work on informational document in general by the working group. There was no clear consensus on working on the informational verification draft James Gould was presenting.

As it is Thursday on the IETF (read: I am tired) I may be wrong, so feel free to confirm or correct me.

Gr,
Rik

> On 05 Nov 2015, at 18:42, Declan Ma <[email-masked]> wrote:
> 
> Ulrich,
>

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 5 Nov 2015 18:24:24 +0800

Dear Ulrich,
Thanks for the hardwork for taking meeting minutes. However, I feel that two points may be missed.
1. We have hum for adopting informational drafts in WG charter, but to the particular two drafts of verification signedcode and nv document, the WG seems having no clear cosensus on adopting them. Although it showed up in the milestone slide.
2. I recalled my memory that several people have comments on nv draft and it seems not be fully supported. Minutes does not include these records.

I'll try to confirm by listening to the recordings again. 

Regards,

Linlin Zhou
 
From: Ulrich Wisser
Date: 2015-11-05 17:09
To: EppExt
Subject: [eppext] Minutes for our meeting in Yokohama IETF94
Please find my minutes below.
Feedback is welcome!
/Ulrich

draft-gould-change-poll

-- 
Ulrich Wisser
[email-masked]

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 5 Nov 2015 18:52:28 +0800

Hi Rik,

> The conclusion for me is that there was no objection to work on informational
> document in general by the working group. There was no clear consensus on
> working on the informational verification draft James Gould was presenting.
> 

+1

> As it is Thursday on the IETF (read: I am tired) I may be wrong, so feel free to
I have the same conclusion.

> Rik
Regards,
Linlin

---

From: Rik Ribbers <[email-masked]>
Date: Thu, 5 Nov 2015 12:12:18 +0000

Hello Jiagui,

I see your point. I am a horrible jabber scribe….I missed that remark by Jim Galvin completely. 

@Chairs: Can you make a clear statement on the list to either confirm or decline my interpretation about the verification drafts being adopted or not. 

Gr,
Rik

> On 05 Nov 2015, at 20:52, [email-masked] wrote:
> 
> Hello Rik,
> Let me post the messages from the Jabber:
> 
> Jim Galvin(JimG?) has confirmed  this . 
> 
> We do think it's useful to discuss this draft in the WG, and any comments about this draft are welcome.
> 
> 
> Kind regards,
> Jiagui Xie
>  
> From: Rik Ribbers <mailto:[email-masked]>
> Date: 2015-11-05 18:06
> To: Declan Ma <mailto:[email-masked]>
> CC: Ulrich Wisser <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> Subject: Re: [eppext] Minutes for our meeting in Yokohama IETF94
> Hello Declan
>  
> > On 05 Nov 2015, at 18:42, Declan Ma <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Ulrich,
> > 
> > [email-masked] <mailto:[email-masked]>:
> > [email-masked] <mailto:[email-masked]>:
> > hummmmm
> > [email-masked] <mailto:[email-masked]>:
> > http://en.zdns.cn <http://en.zdns.cn/>
> > 
> > 
> > 
> > 
> >> 在 2015年11月5日，17:09，Ulrich Wisser <[email-masked] <mailto:[email-masked]>> 写道：
> >> 
> >> [email-masked] <mailto:[email-masked]>
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/eppext <https://www.ietf.org/mailman/listinfo/eppext>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/eppext <https://www.ietf.org/mailman/listinfo/eppext>
>  
>  
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/eppext <https://www.ietf.org/mailman/listinfo/eppext>

---

From: "Gould, James" <[email-masked]>
Date: Thu, 5 Nov 2015 12:46:47 +0000

Linlin,

I have a feedback to your points below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Nov 5, 2015, at 5:24 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Dear Ulrich,

The hum’s where associated with the informational drafts, which does not include the verificationcode draft since it is defined as standards track.  There was no expressed issue with the WG adopting the verificationcode draft.  It was agreed that informational track drafts can be brought into the WG.

There was not clear consensus on the nv draft since it was defined as informational and there was the question of applicability for the WG.  The verificationcode draft defines a standard framework for applying local verification policies where the nv draft defines a concrete use case for China.  Based on the number of registrars and registries that will need to address the verification regulations in China and potentially in other countries, I believe that it’s important for the WG to address the standards track verificationcode draft as well as the concrete use case for China with the nv draft.

Regards,
________________________________
Linlin Zhou

From: Ulrich Wisser<mailto:[email-masked]>
Date: 2015-11-05 17:09
To: EppExt<mailto:[email-masked]>
Subject: [eppext] Minutes for our meeting in Yokohama IETF94
Please find my minutes below.
Feedback is welcome!
/Ulrich

draft-gould-change-poll

--
Ulrich Wisser
[email-masked]<mailto:[email-masked]>
_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: Rik Ribbers <[email-masked]>
Date: Thu, 5 Nov 2015 13:08:09 +0000

Hello Jiagui,

I’m focussing now on getting the right information in the proceedings of the meeting as long as we have it fresh in our minds. So I’m not going to comment (yet) on my personal opinion on adopting the documents. I will do that later (actually when I’ve read the NV draft which I have not read completely) 

Gr,
Rik 

> On 05 Nov 2015, at 21:40, [email-masked] wrote:
> 
> Hi Rik,
> 
> Thanks for the effort and contribution. 
> 
> I think we do not need a rule to say that only standard ones can be adopted by the WG.
> Since here in IETF, we discuss the technical solutions which may commonly  be used.
> And we hope to improve the solution, through the discussion.
> 
> Take the two documents into consideration, they are mainly focus on one thing. 
> So both of the them  discussed togther are useful to the "Verification regulations"  topics.
> 
> Kind regards,
> Jiagui Xie
> Date: 2015-11-05 20:12
> To: [email-masked] <mailto:[email-masked]>
> CC: Ulrich Wisser <mailto:[email-masked]>; Declan Ma <mailto:[email-masked]>; eppext <mailto:[email-masked]>
>> On 05 Nov 2015, at 20:52, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> Hello Rik,

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 5 Nov 2015 21:38:19 +0800 (GMT+08:00)

Dear James,
> 
> 
> > 
> > On Nov 5, 2015, at 5:24 AM, Linlin Zhou <[email-masked]> wrote:
> > 
> > 
> > Dear Ulrich,

Sorry, my mistake. Verificationcode draft is standards track. So we have not reached consensus on the nv draft adoption.
> There was not clear consensus on the nv draft since it was defined as informational and there was the question of applicability for the WG.  The verificationcode draft defines a standard framework…

I feel that verificationcode draft is more like a general method which could be used for real name verification or anything else verification. But the local verification policies in China is really somthing complex that the nv draft may not be the best choice. Many Chinese registrars and registries already implemented some other interface based on HTTP. If WG indeed wants some standards to address this scenario over EPP, I am skepticle on whether EPP is appropriate to transfer large image files as I said in the Jabber room.

Regards,
Linlin

---

From: "Gould, James" <[email-masked]>
Date: Thu, 5 Nov 2015 13:58:22 +0000

Linlin,

I really don’t understand the concern related to passing large image files via EPP.  There is no technical reason why EPP cannot include elements that happen to contain a large amount of data to satisfy a specific provisioning use case.   In this case the client is attempting to create a signed code based on the verification of the input, which can include information like scanned images.

Do you have any specific technical limitation with EPP that will not work for this?

Do you know of a standards track HTTP interface for Chinese verification that can be used to help with what is defined in the nv draft?

Do you have any specific feedback on the elements that are passed with the nv draft other then the size of the image files?

Any feedback is welcome to help ensure that the nv draft covers what is needed for Chinese verification.  The fact that we’re discussing the interface that is needed for Chinese verification is a positive step in helping meet the goals of the working group.

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Nov 5, 2015, at 8:38 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Dear James,

Dear Ulrich,

Regards,
Linlin

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 5 Nov 2015 22:53:39 +0800 (GMT+08:00)

Hi James,
> Do you have any specific feedback on the elements that are passed with the nv draft other then the size of the image files?  
I just express my cocern about the large file transfer on EPP, after all the package size will increase sharply. Or do you have any performance test data on transfer image files over EPP to dispel my worries. Many thanks.

Regards,
Linlin

---

From: "Gould, James" <[email-masked]>
Date: Thu, 5 Nov 2015 15:13:24 +0000

Linlin, 

I do not see a technical issue with the EPP protocol passing large packets.  There is no specific performance numbers to dispel the concern, but I believe any packet size limitations would be based on server policy and the performance testing done by the server.  Since EPP rides on top of TCP and includes packet framing based on a network header, there really is no technical limitation that I am aware of.

Do you have any feedback on the interface elements?

Thanks,

Jim

Sent from my iPhone

> On Nov 5, 2015, at 9:53 AM, Linlin Zhou <[email-masked]> wrote:
> 
> Hi James,

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 5 Nov 2015 23:19:03 +0800 (GMT+08:00)

Dear WG,

> @Chairs: Can you make a clear statement on the list to either confirm or decline my interpretation about the verification drafts being adopted or not. 
Same question to chairs. Could you please confirm on the mailing list again whether nv draft is included in WG document?
I recalled my memory that several people have comments to express concerns on nv draft and it seems not be fully supported to be adopted. But it appeared in the milestone. It confused me a lot. Thanks.
> 
> 
> 
> 
> > 
> > On 05 Nov 2015, at 20:52, [email-masked]:
> > 
> > 
> > Hello Rik,
Regards,
Linlin

---

From: "Gould, James" <[email-masked]>
Date: Thu, 5 Nov 2015 15:30:07 +0000

I recall a vote around inclusion of informational drafts in general but I don’t remember a vote around inclusion of the nv draft itself.  It would be interesting to here from others on the list whether they support or don’t support inclusion of the nv draft based on what was discussed at the meeting and what has been discussed on this thread thus far.  I obviously feel that it is an important draft that deserves adoption by the working group.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Nov 5, 2015, at 10:19 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG,

On 05 Nov 2015, at 20:52, [email-masked]<mailto:[email-masked]>:

Hello Rik,

Regards,
Linlin

---

From: Antoin Verschuren <[email-masked]>
Date: Thu, 5 Nov 2015 17:29:50 +0100

As always, adoption of documents is not done in the meeting, but decisions are always taken on the mailinglist.
Hums during the meeting is an indication for the chairs of the direction the working group wants to go.
To my recollection, we had 2 hums during the meeting:

The first hum was on the general question if the working group wanted to work on Informational documents in general as the proposed charter states that informational RFC’s for EPP extensions can follow the Expert review path. The hum indicated strong consensus that we would not exclude working on informational documents so we will not exclude that in our proposed charter.

The second hum was if the working group agreed to divide the upcoming work into groups to set clear deadlines for our milestones as we cannot prioritize every document with our small working group with limited resources.

As specific for the nv draft, we didn’t make a final decision yet, but we would send the proposed list of milestones to the mailinglist, with the inclusion of the nv draft in group 1, and ask the mailinglist for approval of the milestones. Not everyone had read the nv draft yet, so one outcome could still be that the nv draft will not be in our milestones if there is objection on the mailinglist.
All the documents in our milestones will be working group documents off course.
When it is decided that the nv draft will not become a working group document, one can still request review from the working group members as an example for the verification framework.

Advise from me: I would suggest to the authors of the verification framework to replace the word "verification" with "validation" as that captures the process more then verification. Validation was also used for ENUM to verify the correctness of phone numbers and it’s owners, so there might be some good guidance in the ENUM documentation.

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

Op 5 nov. 2015, om 16:30 heeft Gould, James <[email-masked]> het volgende geschreven:

> <BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png>
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
>> On Nov 5, 2015, at 10:19 AM, Linlin Zhou <[email-masked]> wrote:
>> 
>> Dear WG,
>>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 5 Nov 2015 17:38:33 +0000

> -----Original Message-----
> From: EppExt [mailto:[email-masked]] On Behalf Of Linlin Zhou
> Sent: Thursday, November 05, 2015 9:54 AM
> To: Gould, James
> Cc: Ulrich Wisser; [email-masked]

[snip]

> > Do you have any specific feedback on the elements that are passed
> with the nv draft other then the size of the image files?
> >
> I just express my cocern about the large file transfer on EPP, after
> all the package size will increase sharply. Or do you have any
> performance test data on transfer image files over EPP to dispel my
> worries. Many thanks.

A correct implementation of EPP should not have any issues with encoded image files. If anything, it's a more efficient transport than a web service API (I believe I heard that mentioned as an alternative method) because there is no HTTP layer above TCP. One less software layer *should* be more efficient.

If TCP and your XML library can do it, EPP can do it.

Scott

---

From: Rik Ribbers <[email-masked]>
Date: Thu, 5 Nov 2015 20:32:33 +0000

Thanks for the clarification

Gr,
Rik

> On 06 Nov 2015, at 01:29, Antoin Verschuren <[email-masked]> wrote:
>

---

From: "Gould, James" <[email-masked]>
Date: Thu, 5 Nov 2015 20:44:34 +0000

Antoin,

Thank you for the information and the feedback.  

With your suggestion to switch verification to validation, verification is the common term used currently for this activity.  We actually use the term validation when the registry validates the signature of the VSP so not to confuse the two actions.

Thanks,

Jim

Sent from my iPhone

> On Nov 5, 2015, at 11:29 AM, Antoin Verschuren <[email-masked]> wrote:
> 
>> http://VerisignInc.com

---

From: Ulrich Wisser <[email-masked]>
Date: Thu, 19 Nov 2015 14:11:09 +0000

There has been some insecurity about the hums at the meeting. We did more
than two, but we couldn't really decide what we did hum about after the
fact. As I recall the meeting there were only two hums that did really
count. The two hums that Antoin mentioned.
These are reflected in the minutes.
Could one of the chairs please upload the minutes. It seems only chairs can
do that.

/Ulrich

-- 
Ulrich Wisser
[email-masked]