Subject: [eppext] what to do about IDN tables

From: James Galvin <[email-masked]>
Date: Wed, 4 Nov 2015 16:01:13 -0500

A question that will be asked in the working group meeting today is what 
to do about IDN tables?

There is a working group document that has recently expired:

draft-ietf-eppext-idnmap/

This document is languishing because Francisco has not gotten the 
required implementation statements yet.  We can certainly revive it but 
we may need to consider moving forward with incomplete implementation 
reports.

In addition, there were two related individual submissions that have 
also recently expired:

draft-gould-idn-table/
draft-wilcox-cira-idn-eppext/

These three documents are not all the same but they are related.  The 
question is how to move forward.

Are Gould and Wilcox withdrawing their documents?  Are they going to 
seek publication in the EPP Extensions Registry?

If they want to seek being adopted by the working group then we will 
need to address the apparent relationship with the existing working 
group document.

Comments and suggestions are welcome.

Thanks,

Jim

---

From: "Gould, James" <[email-masked]>
Date: Wed, 4 Nov 2015 21:23:32 +0000

Jim,

I will be speaking to draft-gould-idn-table at meeting.  I haven’t reviewed draft-wilcox-cira-idn-eppext, so I’m unsure of the overlap with draft-ietf-eppext-idnmap and draft-gould-idn-table.   The authors of draft-ietf-eppext-idnmap and I created draft-gould-idn-table to address one key item missing from draft-ietf-eppext-idnmap which was how to identify the valid set of table identifiers to pass using draft-ietf-eppext-idnmap for an IDN domain name.  We discussed the issue on the list over a period of time, where I was proposing to use language instead of a table identifier.  We agreed to stick with the table identifier, but we needed a reliable way to determine the table identifiers specific to the server, which is addressed with draft-gould-idn-table.  Both draft-ietf-eppext-idnmap and draft-gould-idn-table have been implemented in the Verisign EPP SDK that includes a client and server implementation.  Ideally draft-gould-idn-table and draft-ietf-eppext-idnmap would move up together, but if not draft-gould-idn-table should be included in the next set of working group documents.

Let me know if you have any additional questions.

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Nov 4, 2015, at 4:01 PM, James Galvin <[email-masked]<mailto:[email-masked]>> wrote:

A question that will be asked in the working group meeting today is what to do about IDN tables?

This document is languishing because Francisco has not gotten the required implementation statements yet.  We can certainly revive it but we may need to consider moving forward with incomplete implementation reports.

In addition, there were two related individual submissions that have also recently expired:

draft-gould-idn-table/

These three documents are not all the same but they are related.  The question is how to move forward.

Are Gould and Wilcox withdrawing their documents?  Are they going to seek publication in the EPP Extensions Registry?

If they want to seek being adopted by the working group then we will need to address the apparent relationship with the existing working group document.

Thanks,

Jim

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: James Galvin <[email-masked]>
Date: Wed, 4 Nov 2015 16:42:57 -0500

Thanks for bring this summary forward.

We just need to consider what to do with respect to the Wilcox document.

Jim

On 11/4/15 4:23 PM, Gould, James wrote:
> Jim,
>
> I will be speaking to draft-gould-idn-table at meeting.  I haven’t
> reviewed draft-wilcox-cira-idn-eppext, so I’m unsure of the overlap with
> draft-ietf-eppext-idnmap and draft-gould-idn-table.   The authors of
> draft-ietf-eppext-idnmap and I created draft-gould-idn-table to address
> one key item missing from draft-ietf-eppext-idnmap which was how to
> identify the valid set of table identifiers to pass using
> draft-ietf-eppext-idnmap for an IDN domain name.  We discussed the issue
> on the list over a period of time, where I was proposing to use language
> instead of a table identifier.  We agreed to stick with the table
> identifier, but we needed a reliable way to determine the table
> identifiers specific to the server, which is addressed with
> draft-gould-idn-table.  Both draft-ietf-eppext-idnmap and
> draft-gould-idn-table have been implemented in the Verisign EPP SDK that
> includes a client and server implementation.  Ideally
> draft-gould-idn-table and draft-ietf-eppext-idnmap would move up
> together, but if not draft-gould-idn-table should be included in the
> next set of working group documents.
>
> *James Gould
> *Distinguished Engineer
> VerisignInc.com <http://VerisignInc.com>
>
>> required implementation statements yet.  We can certainly revive it
>> but we may need to consider moving forward with incomplete
>> implementation reports.
>>
>> [email-masked] <mailto:[email-masked]>

---

From: "Gould, James" <[email-masked]>
Date: Wed, 4 Nov 2015 21:56:06 +0000

Can anyone speak to draft-wilcox-cira-idn-eppext at the meeting?

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Nov 4, 2015, at 4:42 PM, James Galvin <[email-masked]<mailto:[email-masked]>> wrote:

Jim

Thanks,

—

JG

*James Gould
*Distinguished Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Nov 4, 2015, at 4:01 PM, James Galvin <[email-masked]
<mailto:[email-masked]>> wrote:

A question that will be asked in the working group meeting today is
what to do about IDN tables?

draft-gould-idn-table/

Thanks,

Jim

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 4 Nov 2015 23:03:03 +0000

I know Jacques Latour is here. I’ll ask him.

Scott

From: EppExt [mailto:[email-masked]] On Behalf Of Gould, James
Sent: Wednesday, November 04, 2015 4:56 PM
To: James Galvin
Cc: eppext
Subject: Re: [eppext] what to do about IDN tables

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Jim

Jim,

Thanks,

—

JG

*James Gould
*Distinguished Engineer

703-948-3271
12061 Bluemont Way
Reston, VA 20190

draft-gould-idn-table/

Thanks,

Jim

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 5 Nov 2015 00:17:00 +0000

Jack will be in the room for a few minutes at the beginning of the session. He said this in email:

“The objective of the draft is to be informative, to represent CIRA’s implementation, and to be used as a reference for/and we’re going to
seek publication in the EPP Extensions Registry.

I don’t see any overlap with any other draft because it reflects specially our implementation.”

Scott

From: Hollenbeck, Scott
Sent: Wednesday, November 04, 2015 6:03 PM
To: Gould, James; James Galvin
Cc: eppext
Subject: RE: [eppext] what to do about IDN tables

Scott

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Jim

Thanks,

—

JG

*James Gould
*Distinguished Engineer

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Nov 4, 2015, at 4:01 PM, James Galvin <[email-masked]
<mailto:[email-masked]<mailto:[email-masked]%0b%3cmailto:[email-masked]>>> wrote:

draft-gould-idn-table/

Thanks,

Jim

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]> <mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: James Galvin <[email-masked]>
Date: Wed, 4 Nov 2015 19:49:43 -0500

Thanks for this Scott.

My interpretation of this for the working group, particularly since the 
draft is currently expired, is that the authors of the other documents 
could consider if they provide the features documented in the Wilcox 
draft and, if not, consider if they could incorporate them.  However, 
they are under no obligation and the Wilcox document does not need to be 
a working group document.

Do folks agree?

Jim

On 11/4/15 7:17 PM, Hollenbeck, Scott wrote:
> “The objective of the draft is to be informative, to represent CIRA’s
> implementation, and to be used as a reference for/and we’re going to
>
> *From:*Hollenbeck, Scott
> *Sent:* Wednesday, November 04, 2015 6:03 PM
> *To:* Gould, James; James Galvin
> *Cc:* eppext
> *Subject:* RE: [eppext] what to do about IDN tables
>
> *From:*EppExt [mailto:[email-masked]] *On Behalf Of *Gould, James
> *Sent:* Wednesday, November 04, 2015 4:56 PM
> *To:* James Galvin
> *Cc:* eppext
> *Subject:* Re: [eppext] what to do about IDN tables
>
>     [email-masked] <mailto:[email-masked]>
>
>     703-948-3271
>     12061 Bluemont Way
>     Reston, VA 20190
>
>     <mailto:[email-masked]
>     <mailto:[email-masked]%0b%3cmailto:[email-masked]>>> wrote:
>
>     [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>

---

From: Patrick Mevzek <[email-masked]>
Date: Thu, 5 Nov 2015 01:46:44 +0100

Gould, James <[email-masked]> 2015-11-04 22:25
> I will be speaking to draft-gould-idn-table at meeting.
> I haven’t reviewed draft-wilcox-cira-idn-eppext, so I’m unsure of the overlap with draft-ietf-eppext-idnmap and draft-gould-idn-table.  

I've implemented draft-wilcox-cira-idn-eppext and plan to implement
draft-gould-idn-table which I have read already.

There is not so much overlap between them.

First, the terminology is not the same, as I've outlined in the past
here (repertoire vs table). It would maybe be a good idea if the WG can 
come to some terminology guidelines for IDNs so that at least various 
extensions are using the same words.

The CIRA extension is more closely related to the problem of variants,
and how one domain can block registration of another, so that one is 
able to query the server for one domain and having back the list of
variants.

I believe both extensions can advance forward independently from each
other.
But, if needed, draft-wilcox-cira-idn-eppext could use
draft-gould-idn-table as a terminology basis.

HTH,

-- 
Patrick Mevzek

---

From: Francisco Arias <[email-masked]>
Date: Thu, 5 Nov 2015 05:56:41 +0000

Regarding IDN terminology, perhaps it would be a good idea to consider
reusing what is defined in the LAGER WG?

Regards,

-- 
Francisco.

On 11/5/15, 9:46 AM, "EppExt on behalf of Patrick Mevzek"
<[email-masked] on behalf of [email-masked]> wrote:

>> I haven’t reviewed draft-wilcox-cira-idn-eppext, so I’m unsure of the
>>overlap with draft-ietf-eppext-idnmap and draft-gould-idn-table.
>
>[email-masked]