Subject: [eppext] Recharter Milestones discussion

From: Antoin Verschuren <[email-masked]>
Date: Fri, 4 Dec 2015 12:09:07 +0100

Dear Working Group,

Apologies for this late starting of this discussion.
I had intended to start this discussion some weeks ago, but I was waiting for Jim to edit the draft charter text so we could be in agreement on the draft charter text and the milestones at the same time. Jim is very busy and didn’t get around to that yet, so as sugested by Linlin, let’s start the discussion on the proposed milestones and have that item concluded on.

Below you will find the list of proposed milestones.
I have reordered them based on our discussion in Yokohama.

What we would like to hear from the WG is if this list of milestones is accepted.
To order the discussion, comments can be made:
-Either on a specific document not to be in the milestones list so it will not become a WG item.
-Discussion on priority or grouping, but then there needs to be consensus on which documents to exchange in the priority because we cannot work on all documents at the same time.

To be clear:
-All of the documents on this list will become WG documents.
-As discussed in Yokohama, this WG focusses on Standards track documents, but at the WG request, we can review Informational documents, and the nv mapping draft in one such example where the authors have requested WG review.
-The order and priority can be changed in the future, but this is the initial order in which we think work can be done.
-There is room for new evolving documents to be added later.

MILESTONES

The proposal is to create a set of groups of our documents, order
those groups, and then create milestones for each group.

As a starting point for discussion there is a set of documents already
active and the rest have been distributed into 4 sets.

Here is the proposed set of milestones.  It is based on the model of 3
months per group.

Active Now

- WGLC completed by December 2015
- Submit for publication January 2016

Group 1

- WGLC completed by February 2016
- Submit for publication March 2016

Group 2

- WGLC completed by May 2016
- Submit for publication June 2016

Group 3

- WGLC completed by September 2016
- Submit for publication October 2016

Group 4

- WGLC completed by January 2017
- Submit for publication February 2017

Here is the proposed groupings of the documents.

Active now

draft-ietf-eppext-keyrelay
draft-ietf-eppext-tmch-smd

draft-ietf-eppext-launchphase
draft-ietf-eppext-tmch-func-spec

Group 1

-epp-rdap mapping (draft-gould-epp-rdap-status-mapping)
-verification code (draft-gould-eppext-verificationcode)
-nv mapping (draft-xie-eppext-nv-mapping)(Remains as Informational, but reviewed by WG)

Group 2

-reseller (draft-zhou-eppext-reseller and draft-zhou-eppext-reseller-mapping)
-allocation token (draft-gould-allocation-token)
-change poll (draft-gould-change-poll)

Group 3

-fees (draft-brown-epp-fees-05)
-bundling (draft-kong-eppext-bundling-registration)

Group 4

-IDN Table Mapping (draft-ietf-eppext-idnmap and draft-gould-idn-table
 and draft-wilcox-cira-idn-eppext)
-Relay (no draft yet, split from keyrelay)

Please send feedback to the list on these proposed milestones before December 25, so we can conclude our new charter and milestones before the end of this year.

Regards,

Jim and Antoin

- --
Antoin Verschuren

Tweevoren 6, 5672 SB Nuenen, NL
M: +31 6 37682392

---

From: "Marc Blanchet" <[email-masked]>
Date: Fri, 04 Dec 2015 06:50:59 -0500

On 4 Dec 2015, at 6:09, Antoin Verschuren wrote:

> I had intended to start this discussion some weeks ago, but I was 
> waiting for Jim to edit the draft charter text so we could be in 
> agreement on the draft charter text and the milestones at the same 
> time. Jim is very busy and didn’t get around to that yet, so as 
> sugested by Linlin, let’s start the discussion on the proposed 
> milestones and have that item concluded on.
>

I have said in Yokohama and continue to believe that this grouping is 
unnecessary. Just treat all these documents in an asynchronous mode. It 
makes everything simpler to manage, for both the chairs and the wg.

A priority is obviously needed, but not in a hard way. Just propose 
document priorities and let start with that. We may end up changing the 
priorities as we go, for various reasons, internal or external to the 
wg.

My 2 cents.

Marc.

> -Discussion on priority or grouping, but then there needs to be 
> consensus on which documents to exchange in the priority because we 
> cannot work on all documents at the same time.
>
> To be clear:
> -As discussed in Yokohama, this WG focusses on Standards track 
> documents, but at the WG request, we can review Informational 
> documents, and the nv mapping draft in one such example where the 
> authors have requested WG review.
> -The order and priority can be changed in the future, but this is the 
> initial order in which we think work can be done.
> Please send feedback to the list on these proposed milestones before 
> December 25, so we can conclude our new charter and milestones before 
> the end of this year.
>
> Regards,
>
> Jim and Antoin
>
> - --
> Antoin Verschuren
>
> _______________________________________________
> EppExt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eppext

---

From: Rik Ribbers <[email-masked]>
Date: Fri, 4 Dec 2015 12:22:57 +0000

All, 

General feedback: I don’t have a very strong opinion about priorities and order. If a document is ready for submission let’s just submit it and move on. 

> -nv mapping (draft-xie-eppext-nv-mapping)(Remains as Informational, but reviewed by WG)

I  have a question about the verification drafts. During the Yokohama meeting someone (James Gould?) stated that the verification drafts should have the highest priority over others and somehow they ended up in group 1. What I missed is the reasoning why. There are other drafts that are longer part of this working group and deserve higher priority in my opinion (like resellers and change poll en the fees drafts). Can somebody explain the reasoning why these are (so) important.

> -Relay (no draft yet, split from keyrelay)

There is no document so there is no need to add it to the milestones. The charter is explicit enough to add any document if the WG thinks it is of value. Personally I don’t see this document happening very soon.

Furthermore
Will there be an individual call-for-adoption per document or if the document is on the charter it is adopted? 
In the last case. How are we going to make sure the documents get enough review before submission?
In the first case. Can we explicitly ask for reviewers and people willing to work on the document during the adoption?

Gr,
Rik

---

From: "Marc Blanchet" <[email-masked]>
Date: Fri, 04 Dec 2015 09:05:14 -0500

Adding one more point to my opinion on milestones and grouping: Instead 
of spending time on groups of milestones vs non-groups of milestones, 
maybe we should work on the technical stuff and get the documents out. 
By the time we have spent and wait since months now for the new charter, 
we could have processed many documents already. Therefore, the issue 
here is not grouping or not, it is to make progress on the documents and 
move them forward to the IESG. So first priority is to get this new 
charter out ASAP and then move the documents.

My 2 cents.

Marc.

On 4 Dec 2015, at 6:50, Marc Blanchet wrote:

> unnecessary. Just treat all these documents in an asynchronous mode. 
> It makes everything simpler to manage, for both the chairs and the wg.
>
> document priorities and let start with that. We may end up changing 
> the priorities as we go, for various reasons, internal or external to 
> the wg.
>
> My 2 cents.
>
> Marc.
>
>>

---

From: "Gould, James" <[email-masked]>
Date: Fri, 4 Dec 2015 14:05:33 +0000

Rik,

My clarification is provided below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Dec 4, 2015, at 7:22 AM, Rik Ribbers <[email-masked]<mailto:[email-masked]>> wrote:

All,

Group 1

I stated that of the drafts on the list I viewed the verification drafts as my highest priority, but I’ll leave it up to the WG to decide the priority order.  The reason for this is not based on the age of the drafts, but based on a growing need for the registry community to be capable of applying locality based verification policies.  draft-gould-eppext-verificationcode defines the general framework that is applicable across any locality and draft-xie-eppext-nv-mapping provides a concrete interface for the Chinese verification policy that follows draft-gould-eppext-verificationcode.  This is an important topic ripe for the WG to take up.

Furthermore

Gr,
Rik

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: Antoin Verschuren <[email-masked]>
Date: Fri, 4 Dec 2015 15:17:10 +0100

> General feedback: I don’t have a very strong opinion about priorities and order. If a document is ready for submission let’s just submit it and move on.

Hi all,

Some clarification on grouping of the milestones again then.
We need milestones in our charter. We cannot be a working group if we just say we will do some work but we don’t know what and when we will be finished.
We need deadlines on our documents so we can see if progress is as we want.
The chairs will use these deadlines to give guidance to the working group on priorities and things to work on.
We realize that we cannot work on 10 documents at the same time and demand they will all be done in Februari.
We simply don’t have the resources for that.

That does not mean we cannot work on documents in group 3 before the deadline.
If we’re done earlier with documents in group 3 because there happens to be momentum for one of the drafts that’s fine too.
But we cannot demand all the documents to be worked on at the same time.
That’s why we need to set reasonable deadlines on the milestones in our charter.

The only question we have now is if this is the set of documents we agree to work on, and if the milestones dates give a reasonable priority on what we want to work on first.

> I  have a question about the verification drafts. During the Yokohama meeting someone (James Gould?) stated that the verification drafts should have the highest priority over others and somehow the…

[hat on]
The list of priorities only reflects what the working group suggested at the Yokohama meeting.
There was no objection during the meeting, but we said we would take the discussion to the list.
[/hat on]

[hat off]
I originally had the reseller draft in group 1 and the rdap mapping in group 2.
My reasoning being that the reseller draft is indeed more mature and has had more review, and more importantly, the rdap mapping seems to have been pushed in based on timelines set by ICANN more than by maturity or demand of the document in the IETF. I wonder if this will improve the quality of the document. We still have the tmch/launchphase/tmch-func-spec documents as leftovers to work on from our current charter, and looking at the IESG and IANA feedback on the tmch document, there is still quite some work to be done there which is also heavily reliant on ICANN staff. Perhaps the authors of these drafts can explain if there’s going to be extra resources from ICANN allocated to these drafts to have them all done within a month. But in my opinion it is more reasonable to work on the documents in an order that will allow for better review to improve the quality of the documents.
[/hat off]

> There is no document so there is no need to add it to the milestones. The charter is explicit enough to add any document if the WG thinks it is of value. Personally I don’t see this document happen…

Note taken.

> Will there be an individual call-for-adoption per document or if the document is on the charter it is adopted?

All the documents in the milestones will be adopted by the WG. So this is a call for adoption of all 10 documents.
Unless you state now that you don’t want to adopt document x in this list.

> In the last case. How are we going to make sure the documents get enough review before submission?

Most of the documents have already been discussed on the list.
For additional documents to be added to the milestones we will always ask for reviewers before we adopt a document as WG item.

> In the first case. Can we explicitly ask for reviewers and people willing to work on the document during the adoption?

A document can still fail after we decided to work on it.
Once we reach the deadline, we will ask the working group to review and comment, or remove the item from our milestones if it has failed.
We will always ask for explicit review before a document is last called, and we will ask for explicit comments if the chairs feel the document does not have enough support.

So let me ask differently: Which documents on the list do you want to work on or review?

- --
Antoin Verschuren

---

From: Andrew Newton <[email-masked]>
Date: Fri, 4 Dec 2015 11:40:18 -0500

> If we’re done earlier with documents in group 3 because there happens to be momentum for one of the drafts that’s fine too.

I think that is the important thing. No working group has ever been
penalized for completing work ahead of schedule (probably because no
working group has ever completed work ahead of schedule, but that's a
different matter).

As long as we recognize that milestones are malleable and that the
IESG wants an initial starting point, I'm good with what you have
stated.

-andy

---

From: Roger D Carney <[email-masked]>
Date: Fri, 4 Dec 2015 17:40:01 +0000

Good Morning, 

I agree with Andy.  Let's remove Relay as a milestone and get the charter approved with the list of milestones that we have and we will adapt as we move forward.

Thanks
Roger

-----Original Message-----
From: EppExt [mailto:[email-masked]] On Behalf Of Andrew Newton
Sent: Friday, December 04, 2015 10:40 AM
To: Antoin Verschuren
Cc: eppext
Subject: Re: [eppext] Recharter Milestones discussion

> If we’re done earlier with documents in group 3 because there happens to be momentum for one of the drafts that’s fine too.

I think that is the important thing. No working group has ever been penalized for completing work ahead of schedule (probably because no working group has ever completed work ahead of schedule, but that's a different matter).

As long as we recognize that milestones are malleable and that the IESG wants an initial starting point, I'm good with what you have stated.

-andy

---

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 7 Dec 2015 11:36:25 +0800

Dear chair,
Thanks for your work to propose the discussion.

I agree that the WG needs a milestone and schedule, since we do not have so
much time to work on these existing documents in parallel. In my opinion,
the logical working process of a draft is that first calling for WG
adoption, approved by WG (discussed and supported on the mailing list or at
the f2f meeting), included in the milestone, etc.. I believe that all the
document should follow the clear working path. If a document has opposed
comments, whether or not we should discuss the technical stuff first and
pend the document included in the charter. The nv draft as a single
informational document, which is related to some Chinese local policies, I
still do not see a clarified consensus on it. Shall we discuss if the
document is qualified to be a WG document?

For the priority issue, I think the document with most discussion and
support should be listed in the first priority. The verification drafts were
proposed before last IETF, there's still no thorough discussion about them
on the mailing list. It is somewhat a hurry to complete 3 drafts WGLC in a
period of time less than one month. Moreover, most of the WG members will
have a Christmas holiday, I guess. Though we don't have such a long holiday
in China :)

Again, I feel obliged to discuss more about the technical issues on existing
drafts. Let's move this recharter work and take action on drafts as soon as
possible.

Thanks and Regards,
Linlin

> -Discussion on priority or grouping, but then there needs to be consensus
on
> which documents to exchange in the priority because we cannot work on all
> documents at the same time.
> 
> To be clear:
> -As discussed in Yokohama, this WG focusses on Standards track documents,
> but at the WG request, we can review Informational documents, and the nv
> mapping draft in one such example where the authors have requested WG
> review.

> -The order and priority can be changed in the future, but this is the
initial order
> in which we think work can be done.
> The proposal is to create a set of groups of our documents, order those
groups,
> and then create milestones for each group.
> 
active and
> the rest have been distributed into 4 sets.
> 
> 
months
> per group.

> -allocation token (draft-gould-allocation-token) -change poll
> (draft-gould-change-poll)
> 
> 
> Group 3
> 
and
> draft-wilcox-cira-idn-eppext) -Relay (no draft yet, split from keyrelay)

---

From: Antoin Verschuren <[email-masked]>
Date: Tue, 8 Dec 2015 11:01:18 +0100

> document is qualified to be a WG document?

OK, so I already heard we want to remove the relay draft from the list of milestones.
That leaves us with a list of 9 documents for WG adoption.
You specifically want to hear a voice of adoption for the informational nv-mapping draft.
What does the WG think of this document?
Should we adopt it now, or remove it from the list of milestones and possibly add it later as a WG item?

> have a Christmas holiday, I guess. Though we don't have such a long holiday

So what do you propose here?
Should we prioritize the reseller draft since it had more review over the verification draft(s)?
So put reseller in group 1 and verification in group 2?
What does te WG think of this proposal?

> drafts. Let's move this recharter work and take action on drafts as soon as

I also want to speed up the technical discussion as we have enough work to do.
So let’s get this charter discussion out of our way and create a list of milestones so we know what work lies ahead.

Regards,

- --
Antoin Verschuren

---

From: "Gould, James" <[email-masked]>
Date: Tue, 8 Dec 2015 15:47:28 +0000

Antoin,

My feedback is below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Dec 8, 2015, at 5:01 AM, Antoin Verschuren <[email-masked]<mailto:[email-masked]>> wrote:

Op 7 dec. 2015, om 04:36 heeft Linlin Zhou <[email-masked]<mailto:[email-masked]>> het volgende geschreven:

Your proposal looks reasonable; although I recommend moving fees up to Group 1, moving the verification code and nv mapping drafts to group 2, and moving the allocation token and change poll drafts to group 3.  If there was bandwidth to move reseller up to Group 1 and change poll up to Group 2, that works for me.  There may be one small overlap between verification and reseller that we may want to consider.  My proposed groupings are below.

Group 1

-epp-rdap mapping (draft-gould-epp-rdap-status-mapping)
-fees (draft-brown-epp-fees)

Group 2

-reseller (draft-zhou-eppext-reseller and draft-zhou-eppext-reseller-mapping)
-verification (draft-gould-eppext-verificationcode and draft-xie-eppext-nv-mapping)

Group 3

Group 4

-IDN Table Mapping (draft-ietf-eppext-idnmap and draft-gould-idn-table and draft-wilcox-cira-idn-eppext)
-Relay (no draft yet, split from keyrelay)

Regards,

- --
Antoin Verschuren

---

From: Declan Ma <[email-masked]>
Date: Wed, 9 Dec 2015 00:08:21 +0800

> 在 2015年12月7日，11:36，Linlin Zhou <[email-masked]> 写道：
> 
> Dear chair,

Linlin,

I quite agree with you, speaking as a technical guy from Chinese DNS industry.

Since the nv draft bears relevances to the local policies in China and is intended to be Informational, thorough discussions are indispensable to see whether it is qualified to be a WG item.

It’s unwise to jump into the decision of putting nv draft in milestone and to-do list.

Di Ma

ZDNS

http://en.zdns.cn

---

From: "Gould, James" <[email-masked]>
Date: Tue, 8 Dec 2015 16:36:12 +0000

The proposal is to move draft-gould-eppext-verificationcode as a standards track WG document to define the locality verification framework, and to include draft-xie-eppext-nv-mapping as a concrete informational draft applicable to China.  This way the framework can be discussed along with a concrete implementation of the framework.  Do you have feedback on the contents of draft-xie-eppext-nv-mapping?

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Dec 8, 2015, at 11:08 AM, Declan Ma <[email-masked]<mailto:[email-masked]>> wrote:

在 2015年12月7日，11:36，Linlin Zhou <[email-masked]<mailto:[email-masked]>> 写道：

Dear chair,

Linlin,

Di Ma

ZDNS

http://en.zdns.cn

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 9 Dec 2015 10:12:07 +0800

Dear Colleagues,

Thanks for the effort and contribution to promote the eppext's WG work.

My feedback is below.

Regards,
Jiagui Xie

Teleinfo
 
From: Antoin Verschuren
Date: 2015-12-08 18:01
To: eppext

 
Jiagui: 
 Linlin & Antoin, Although the starting point of  the nv draft is from the local solution, We see that in
 the southeast asia and eastern europe, there are some countries have already considered the verification, they have the same requirments. 
 And this draft is not bound to China local policy too, it is just a third-party verification model which may be useful to the global technical community.
 I welcome any comments on this draft from this WG,  but I do think the discussion should be based on its technical merits and discussion
 ought to be focused on the technical solution itself and on any possible technical issues relating to it.

 
 
Regards,
 
- --
Antoin Verschuren

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 9 Dec 2015 10:27:24 +0800

Dear Colleagues，

I agree with James's proposal. 

Regards,
Jiagui Xie

Teleinfo

From: Gould, James
Date: 2015-12-08 23:47
To: Antoin Verschuren
CC: eppext

My feedback is below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com 

On Dec 8, 2015, at 5:01 AM, Antoin Verschuren <[email-masked]> wrote:

Group 1

Group 2

Group 3

Group 4

Regards,

- --
Antoin Verschuren

---

From: Declan Ma <[email-masked]>
Date: Wed, 9 Dec 2015 22:57:30 +0800

> 在 2015年12月9日，00:36，Gould, James <[email-masked]> 写道：
> 
> The proposal is to move draft-gould-eppext-verificationcode as a standards track WG document to define the locality verification framework, and to include draft-xie-eppext-nv-mapping as a concrete informational draft applicable to China.  This way the framework can be discussed along with a concrete implementation of the framework.  

I think the framework offered by your draft is brilliant and is shedding lights on the R&D work in my team. I support it adopted as WG item.

Besides, many registry operators in China, enlightened by your draft, are working on their implementations of verification mechanisms.

> Do you have feedback on the contents of draft-xie-eppext-nv-mapping?

I also appreciate the innovation of nv draft.

Granted, my concern is that using EPP to transport verification materials, pictures for instance, changes the light-weight EPP operation practice. 

Di,

> 
> Thanks,
> 
> —
> 
> JG
> 
> 
> <BF09FAA4-32D8-46E0-BED0-CD72F43BD6E0[81].png>
> 
> James Gould
> Distinguished Engineer
> [email-masked]
> 
> 703-948-3271
> 12061 Bluemont Way
> Reston, VA 20190
> 
> VerisignInc.com
> 
>> On Dec 8, 2015, at 11:08 AM, Declan Ma <[email-masked]> wrote:
>> 
>> 
>>

---

From: "Gould, James" <[email-masked]>
Date: Wed, 9 Dec 2015 15:41:21 +0000

Di,

I’m not aware of any technical limitations with EPP that would makes it unsuitable for passing the verification materials.  We previously discussed the applicability of EPP for this on the list.  Below are the relevant posts:

  1.  My reply to Linlin Zhou - http://www.ietf.org/mail-archive/web/eppext/current/msg00805.html
  2.  Scott Hollenbeck’s reply to Linlin Zhou - http://www.ietf.org/mail-archive/web/eppext/current/msg00809.html

Do you have any technical concerns with the use of EPP for this?

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Dec 9, 2015, at 9:57 AM, Declan Ma <[email-masked]<mailto:[email-masked]>> wrote:

在 2015年12月9日，00:36，Gould, James <[email-masked]<mailto:[email-masked]>> 写道：

Di,

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com

Dear chair,

Linlin,

Di Ma

ZDNS

http://en.zdns.cn