Subject: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt

From: "Linlin Zhou" <[email-masked]>
Date: Mon, 21 Dec 2015 09:49:11 +0800

The draft of contact verification has been submitted, which is now applied in practice in some registries of China. Any comments are welcome.

Regards,

Linlin Zhou
 
From: internet-drafts
Date: 2015-12-21 09:36
To: [email-masked]
Subject: I-D Action: draft-zhou-eppext-contact-verification-00.txt
 
A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Verification Extension for the Extensible Provisioning Protocol (EPP) Contact Mapping
        Authors         : Linlin Zhou
                          Di Ma
                          Wei Wang
                          Ning Kong
                          Xiaodong Lee
                          James Galvin
Filename        : draft-zhou-eppext-contact-verification-00.txt
Pages           : 17
Date            : 2015-12-20
 
Abstract:
   This mapping describes an verification extension to EPP contact
   mapping [RFC5733].  Specified in Extensible Markup Language (XML),
   this extended mapping is applied to provide additional features
   required for the provisioning of contact verification.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-zhou-eppext-contact-verification/
 
There's also a htmlized version available at:
https://tools.ietf.org/html/draft-zhou-eppext-contact-verification-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.
 
Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/
 
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "lidaiming" <[email-masked]>
Date: Mon, 21 Dec 2015 22:41:42 +0800

Linlin,

Thanks for your efforts. 

Since this draft together with draft-wang-eppext-domain-verification-00 is intended to describe the very EPP extensions relating to verification mechanism in China, you might include their background and usecases in these drafts, to shed light on their applications and implementations.

Daiming

KNET Technologies

发件人："Linlin Zhou" <[email-masked]>
发送时间：2015-12-21 09:49
主题：[eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
收件人："[email-masked]"<[email-masked]>
抄送：

Regards,

Linlin Zhou

From: internet-drafts
Date: 2015-12-21 09:36

Abstract:

---

From: "Gould, James" <[email-masked]>
Date: Mon, 21 Dec 2015 21:16:13 +0000

Hi,

I have a few high level questions:

  1.  In reviewing draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification, I see only extensions of the query responses (check and info), but I don't see extensions to the transform commands to submit the verification material.  Do you plan on adding extensions to the transform commands in the existing drafts or creating separate drafts for that purpose?
  2.  What is the relationship between the draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification drafts?
  3.  Is draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification only applicable to China verification or is being proposed as more general drafts?  I assume based on the Informational track that it's specific to China, but there is no reference to China in either draft.

Thanks,

Jim

________________________________
From: EppExt [[email-masked]] on behalf of lidaiming [[email-masked]]
Sent: Monday, December 21, 2015 9:41 AM
To: Linlin Zhou; [email-masked]
Subject: Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt

Linlin,

Thanks for your efforts.

Daiming

KNET Technologies

________________________________
发件人："Linlin Zhou" <[email-masked]>
发送时间：2015-12-21 09:49
主题：[eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
收件人："[email-masked]"<[email-masked]>
抄送：

Regards,
________________________________
Linlin Zhou

From: internet-drafts<mailto:[email-masked]>
Date: 2015-12-21 09:36
To: [email-masked]<mailto:[email-masked]>
Subject: I-D Action: draft-zhou-eppext-contact-verification-00.txt

Abstract:

---

From: "Linlin Zhou" <[email-masked]>
Date: Tue, 22 Dec 2015 12:52:04 +0800

Yes, that's a good point. I'll try to add some text to give an overview of the verification background and make a quick update.

Regards,

Linlin Zhou
 
From: lidaiming
Date: 2015-12-21 22:41
 
Thanks for your efforts. 

Daiming
 
KNET Technologies

Regards,

Linlin Zhou
 
From: internet-drafts
Date: 2015-12-21 09:36

 
Abstract:

---

From: "Linlin Zhou" <[email-masked]>
Date: Tue, 22 Dec 2015 15:07:04 +0800

Hi James,
Thanks for your review. I have following feedbacks about your questions.
1. The drafts specified the query commands only, which are now implemented in some registries in China, to fufill most of the critical requirements . We are not going to add transform extension in EPP drafts at present as this function of upload proof materials has been developed and implemented via HTTP. Maybe after a sufficient test of using EPP transform commands to transfer large files, we could consider standardizing this part in EPP extension. 
2. Actually in verification process, there are typically two phases, domain verification and contact verification. Domain verification is aimed to check whether a domain is reserved or prohibited. Contact verification is to check the facticity of a person. So These two drafts are seperated.
3. Yes, it is specific to China currently. But we don't exclude the possibility to make them as more general drafts if some other countries also have the verification regulations. Daiming Li mentioned to add some content about verification background as well. I think this is a good suggestion and a quick update will be posted soon.

Regards,

Linlin Zhou
 
发件人： Gould, James
发送时间： 2015-12-22 05:16
收件人： lidaiming; Linlin Zhou; [email-masked]
主题： Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
Hi, 

I have a few high level questions:
In reviewing draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification, I see only extensions of the query responses (check and info), but I don't see extensions to the transform commands to submit the verification material.  Do you plan on adding extensions to the transform commands in the existing drafts or creating separate drafts for that purpose?  
What is the relationship between the draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification drafts?  
Is draft-zhou-eppext-contact-verification and draft-wang-eppext-domain-verification only applicable to China verification or is being proposed as more general drafts?  I assume based on the Informational track that it's specific to China, but there is no reference to China in either draft.  
Thanks,

Jim

Linlin,
 
Thanks for your efforts. 

Daiming
 
KNET Technologies

Regards,

Linlin Zhou
 
From: internet-drafts
Date: 2015-12-21 09:36

 
Abstract:

---

From: "Gould, James" <[email-masked]>
Date: Wed, 23 Dec 2015 15:52:54 +0000

Linlin,

Thanks of the quick reply, my feedback is included below.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Dec 22, 2015, at 2:07 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Hi James,

Since they are informational drafts it makes sense to include what is currently implemented, but it does not provide a complete solution for verification.  My recommendation is to publish your HTTP API as informational drafts to cover the transform side of the solution or extend the transform commands in your EPP extensions.  As noted previously on the list, there is no technical reason that EPP cannot be used to submit the verification material.

There is added complexity in separating them since the aggregate verification (domain and real name) impacts the domain and not the contact.  In EPP contacts are managed separately from the domains, so putting the verification on the contacts raises some additional questions:

  1.  Do all contacts need to be verified (registrant, admin, tech, and billing), since contacts themselves don’t have the concept of type?
  2.  What is the expected behavior when a domain references a blocked or unverified registrant?
     *   Does it impact the status of the domain and if so how?
     *   How does the client get notified of the domain status change?  We’re leveraging draft-gould-change-poll for this purpose.
  3.  What happens when the domain is updated to reference a different set of contacts that have different statuses?
  4.  What happens to the domain when the contact statuses change?

Some of this behavior can be left to server policy and not explicitly defined in the protocol, but it would be good to know how you see this could work.

In the verification code draft we defined the concept of a verification profile, which enables the server to communicate the applicable profile and for the client to explicitly specify the desired verification profile to apply.  You may want to consider some sort of similar concept.  The question is whether a client can have more than one applicable profile (province or state within a country), which may not be the case in China but could be elsewhere.

Regards,

发件人： Gould, James<mailto:[email-masked]>
发送时间： 2015-12-22 05:16
收件人： lidaiming<mailto:[email-masked]>; Linlin Zhou<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题： Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
Hi,

Thanks,

Jim

________________________________
From: EppExt [[email-masked]<mailto:[email-masked]>] on behalf of lidaiming [[email-masked]<mailto:[email-masked]>]
Sent: Monday, December 21, 2015 9:41 AM
To: Linlin Zhou; [email-masked]<mailto:[email-masked]>
Subject: Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt

Linlin,

Thanks for your efforts.

Daiming

KNET Technologies

________________________________
发件人："Linlin Zhou" <[email-masked]<mailto:[email-masked]>>
发送时间：2015-12-21 09:49
主题：[eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
收件人："[email-masked]<mailto:[email-masked]>"<[email-masked]<mailto:[email-masked]>>
抄送：

Regards,

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
I-D-Announce mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: "Linlin Zhou" <[email-masked]>
Date: Thu, 24 Dec 2015 17:31:19 +0800

Hi James,
Thanks for your feedback.
Regards,

Linlin Zhou
 
From: Gould, James
Date: 2015-12-23 23:52
To: Linlin Zhou
CC: [email-masked]; lidaiming
Subject: Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
Linlin, 

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com 

On Dec 22, 2015, at 2:07 AM, Linlin Zhou <[email-masked]> wrote:

Hi James,

[Linlin] Thanks for your suggestion. We've considered this issue and found that BCP of HTTP API may be more proper. 

Do all contacts need to be verified (registrant, admin, tech, and billing), since contacts themselves don’t have the concept of type? 
        [Linlin] Actually only the registrant need to be verified according to the regulation in China.

What is the expected behavior when a domain references a blocked or unverified registrant?   
Does it impact the status of the domain and if so how?  
[Linlin] I think the simple process is to verify the domain, the verification status of a domain is pendingVerify. If it is a banned domain, after the period of pendingVerify, the domain will be deleted, no need to further check contact. If a domain passes verification but the registrant is unverified, the status of the domain maybe changed to serverHold and the status of the contact is failed. Updated proof materials are waited to be resubmitted.
How does the client get notified of the domain status change?  We’re leveraging draft-gould-change-poll for this purpose.
                    [Linlin] Yes, I think the poll command should be extented too.

What happens when the domain is updated to reference a different set of contacts that have different statuses?  
        [Linlin] If only the registrant should be verified, I think a domain will not have different statuses contatcts.
What happens to the domain when the contact statuses change?  
        [Linlin] Please see the above answer.

In the verification code draft we defined the concept of a verification profile, which enables the server to communicate the applicable profile and for the client to explicitly specify the desired verification profile to apply.  You may want to consider some sort of similar concept.  The question is whether a client can have more than one applicable profile (province or state within a country), which may not be the case in China but could be elsewhere.  
[Linlin]  From my rough understanding, a extensible protocol should support multiple applicable profiles.

Regards,

Linlin Zhou
 
发件人： Gould, James
发送时间： 2015-12-22 05:16

Jim

Linlin,
 
Thanks for your efforts. 

Daiming
 
KNET Technologies

Regards,

Linlin Zhou
 
From: internet-drafts
Date: 2015-12-21 09:36

 
Abstract:

 
 
[email-masked]

---

From: "Gould, James" <[email-masked]>
Date: Mon, 28 Dec 2015 16:38:39 +0000

Linlin,

My feedback is included below.

We've considered this issue and found that BCP of HTTP API may be more proper.

I assume that you mean SCP or HTTP.  Do you plan on submitting a draft that describes the protocol for transmitting the verification material for verification?  draft-xie-eppext-nv-mapping provides a mechanism to submit the verification material via EPP, which is the most straight forward mechanism.

Actually only the registrant need to be verified according to the regulation in China.

Yes, but since the contact mapping does not have the concept of type, the verification extension will apply to all contacts independent of the domain to contact relationship.  The contact verification status has interplay with the domain status that could be clarified in the contact extension, the domain extension, or both.

Yes, I think the poll command should be extented too.

draft-gould-change-poll can be used to extend the info response of the contact or domain to provide the client with the information associated with the server side verification change.

If only the registrant should be verified, I think a domain will not have different statuses contatcts.

Yes, the focus is on the registrant, but the registrant's contact verification status relationship with the domain status would be good to understand.  Also, the drafts should provide more detail into the relationship of the contact verification statuses of the other contact types (admin, tech, and billing).  This could be left to server policy, if the goal if for the drafts to be used more generically.  For example, what happens to the domain if it references contacts (registrant, admin, tech, and billing) with the supported set of verification statuses on a domain create or domain update?

From my rough understanding, a extensible protocol should support multiple applicable profiles.

Do you intend on targeting these drafts to meet only the China verification rules or to meet a more general set of verification rules?  If you intend on just meeting the China verification rules, then you can add more specific text to describe the China verification policies, and if you intend on meeting a more general set of verification rules, you may want to consider including the concept of verification profiles.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Dec 24, 2015, at 4:31 AM, Linlin Zhou <[email-masked]<mailto:[email-masked]>> wrote:

Hi James,

From: Gould, James<mailto:[email-masked]>
Date: 2015-12-23 23:52
To: Linlin Zhou<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; lidaiming<mailto:[email-masked]>
Subject: Re: [eppext] Fw: I-D Action: draft-zhou-eppext-contact-verification-00.txt
Linlin,

—

JG

James Gould
Distinguished Engineer
[email-masked]<x-msg://8/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://verisigninc.com/>

Hi James,

  1.  What is the expected behavior when a domain references a blocked or unverified registrant?
     *   Does it impact the status of the domain and if so how?
[Linlin] I think the simple process is to verify the domain, the verification status of a domain is pendingVerify. If it is a banned domain, after the period of pendingVerify, the domain will be deleted, no need to further check contact. If a domain passes verification but the registrant is unverified, the status of the domain maybe changed to serverHold and the status of the contact is failed. Updated proof materials are waited to be resubmitted.
     *   How does the client get notified of the domain status change?  We’re leveraging draft-gould-change-poll for this purpose.

  1.  What happens when the domain is updated to reference a different set of contacts that have different statuses?

  1.  What happens to the domain when the contact statuses change?

Regards,

Thanks,

Jim

Linlin,

Thanks for your efforts.

Daiming

KNET Technologies

Regards,

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.