Subject: Re: [eppext] I-D Action: draft-lozano-ietf-eppext-registrar-expiration-date-00.txt

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 21 Jan 2016 19:52:36 +0000

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, January 21, 2016 2:30 PM
> To: [email-masked]
> Subject: I-D Action: draft-lozano-ietf-eppext-registrar-expiration-
> date-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : Registrar Registration Expiration Date
> Extension Mapping for the Extensible Provisioning Protocol (EPP)
>         Author          : Gustavo Lozano
> 	Filename        : draft-lozano-ietf-eppext-registrar-expiration-
> date-00.txt
> 	Pages           : 15
> 	Date            : 2016-01-21
> 
> Abstract:
>    This document describes an Extensible Provisioning Protocol (EPP)
>    extension mapping for the provisioning and management of the
>    registrar registration expiration date for domain names stored in a
>    shared central repository.  Specified in XML, this mapping extends
>    the EPP domain name mapping.

Gustavo, I wish this document would explain what this value actually means given that registrars are not the authoritative source of information for domain expiration dates. Could you please add some text to the Introduction that explains the purpose of the value and what it means of the context of the expiration date maintained by registries? Can they ever be different? What does it mean if they are different? Why are both needed if they are supposed to be the same?

I'd also like to suggest that you add text to the different command descriptions to make it clear what the values represent when you're extending a renew, transfer, etc.

Scott

---

From: "Gould, James" <[email-masked]>
Date: Thu, 21 Jan 2016 20:08:02 +0000

Gustavo,

I agree with Scott, it is not clear the relationship between the two and the relevance in the registry of maintaining this value.  Can the registrar expiration date be greater then the domain expiration date, less then the domain expiration date, or completely different from the domain expiration date?  The reference for the ThickWhoisPolicy is incorrect in the draft.  Please provide the appropriate reference and highlight where in the Thick Whois Policy it defines the requirement for the registry to hold and display a registrar expiration date in addition to the authoritative domain expiration date.

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://VerisignInc.com>

On Jan 21, 2016, at 2:52 PM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:

-----Original Message-----
[email-masked]<mailto:[email-masked]>

Abstract:

Scott

_______________________________________________
EppExt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/eppext

---

From: Francisco Arias <[email-masked]>
Date: Thu, 21 Jan 2016 22:51:59 +0000

Hi Jim,

Please see https://whois.icann.org/sites/default/files/files/thick-rdds-consensus-policy-draft-25nov15-en.pdf, particularly section 2.1, starting on page 8. This document is in public comment at https://www.icann.org/public-comments/rdds-output-2015-12-03-en until 31 January.

The draft provides a reference to the “parent” document of the aforementioned document, which is already in final form. Perhaps the reference in the draft should be to the child document?

Regards,

--
Francisco

On 1/21/16, 12:08 PM, "EppExt on behalf of Gould, James" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Gustavo,

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

-----Original Message-----
To: [email-masked]<mailto:[email-masked]>

Abstract:

Scott

---

From: Gustavo Lozano <[email-masked]>
Date: Thu, 21 Jan 2016 23:32:06 +0000

Scott,

I don't think it's a good idea to define the meaning of the
registrar registration expiration date in this specification. The Registrar
Accreditation Agreement 2013
(https://www.icann.org/resources/pages/approved-with-specs-2013-09-17-en#wh
ois)
defines that the Whois output of the Registrar must show the "Registrar
Registration
Expiration Date", and the draft Thick Whois Policy
(https://whois.icann.org/sites/default/files/files/thick-rdds-consensus-pol
icy-draft-25nov15-en.pdf)
requires this field to be passed to the registry, who in turn will show it.

I have seen domains (e.g. whois -h whois.pir.org pir.org / whois
-h whois.godaddy.com pir.org) in the wild in which the registry expiration
date
is different from the registrar expiration date. It appears that sometimes
is
related to an auto-renew that has not been paid by the Registrant, other
cases
appear to be related to the business model of the registrar, etc.

>From the I-D perspective, the registrar registration
expiration date is just another data point with no meaning to the
lifecycle of
the domain name. 

Regards,
Gustavo

On 1/21/16, 11:52, "Hollenbeck, Scott" <[email-masked]> wrote:

>Gustavo, I wish this document would explain what this value actually
>means given that registrars are not the authoritative source of
>information for domain expiration dates. Could you please add some text
>to the Introduction that explains the purpose of the value and what it
>means of the context of the expiration date maintained by registries? Can
>they ever be different? What does it mean if they are different? Why are
>both needed if they are supposed to be the same?
>
>I'd also like to suggest that you add text to the different command
>descriptions to make it clear what the values represent when you're
>extending a renew, transfer, etc.
>
>Scott

---

From: Rubens Kuhl <[email-masked]>
Date: Thu, 21 Jan 2016 21:32:45 -0200

Francisco,

It's possible that Jim and Scott were looking at https://www.icann.org/resources/pages/registrars/consensus-policies-en <https://www.icann.org/resources/pages/registrars/consensus-policies-en> to find an in-force consensus policy covering such requirement. I tried finding it there as well and failed as well... that is consistent with the information that although the policy was approved by GNSO Council and the Board (https://www.icann.org/resources/board-material/resolutions-2014-02-07-en#2.c <https://www.icann.org/resources/board-material/resolutions-2014-02-07-en#2.c>) has still not come through with its IRT (Implementation Review Team), which is why the document is still in public comment and the policy is still a draft. 

So, perhaps the I-D is a few weeks premature and the registries opposing it might see first whether that really becomes in-force ? 

I also wander what happened to the reseller information relaying, which was foreseen in the policy... 

Rubens

> Em 21 de jan de 2016, à(s) 20:51:000, Francisco Arias <[email-masked]> escreveu:
> 
> Hi Jim,
> 
> Please see https://whois.icann.org/sites/default/files/files/thick-rdds-consensus-policy-draft-25nov15-en.pdf <https://whois.icann.org/sites/default/files/files/thick-rdds-consensus-policy-draft-25nov15-en.pdf>, particularly section 2.1, starting on page 8. This document is in public comment at https://www.icann.org/public-comments/rdds-output-2015-12-03-en <https://www.icann.org/public-comments/rdds-output-2015-12-03-en> until 31 January.
> 
> On 1/21/16, 12:08 PM, "EppExt on behalf of Gould, James" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>> Gustavo,
>> 
>> [email-masked] <x-msg://42/[email-masked]>
>> 
>> 703-948-3271
>> 12061 Bluemont Way
>> Reston, VA 20190
>> 
>> VerisignInc.com <http://verisigninc.com/>
>>> On Jan 21, 2016, at 2:52 PM, Hollenbeck, Scott <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> From: I-D-Announce [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of
>>>> [email-masked] <mailto:[email-masked]>
>>>> To: [email-masked] <mailto:[email-masked]>
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/eppext <https://www.ietf.org/mailman/listinfo/eppext>
>> 
> [email-masked]

---

From: "Gould, James" <[email-masked]>
Date: Fri, 22 Jan 2016 14:06:33 +0000

Francisco,

What is contained in section 2.1 of “Draft Thick RDDS (Whois) Consensus Policy” assumes that the Consensus Policy requires the display of the “Registrar Registration Expiration Date” field as a separate and additive value to the existing “Registry Expiry Date” field.   The only reference to the “Registrar Registration Expiration Date” in the Consensus Policy is provided in the sample Whois output of section 1.4.2 of the RAA.  There is a single expiration date field in the RAA ( “Registrar Registration Expiration Date” ), in the Consensus Policy ( “Registrar Registration Expiration Date” ), and in the RA ( “Registry Expiry Date” ).

There is no mention of a second expiration date field or its meaning in any of the agreements or the Consensus Policy.  There is also no description of the “Registrar Registration Expiration Date” in the RAA or Consensus Policy.  I believe it is a reach to assume that the “Registrar Registration Expiration Date” field in the RAA and the Consensus Policy has a different purpose then the “Registry Expiry Date” field in the RA.  In fact the value of these fields are exactly the same "2010-10-08T00:44:59Z” across all three.  A sample does not make a specification in any of these documents, and there is no basis to make the case that the “Registrar Registration Expiration Date” field has a different meaning or should override the “Registry Expiry Date” field in Thick RDDS. Any variance of the values in the wild is an architectural factor and not a factor of having a different purpose.

The existing registry domain expiration date should be used in Thick RDDS and we should not attempt to invent a second field for expiration date.

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

On Jan 21, 2016, at 5:51 PM, Francisco Arias <[email-masked]<mailto:[email-masked]>> wrote:

Hi Jim,

Regards,

--
Francisco

Gustavo,

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]<x-msg://133/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

VerisignInc.com<http://verisigninc.com/>

-----Original Message-----

Abstract:

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 22 Jan 2016 14:09:17 +0000

> From: Gustavo Lozano [mailto:[email-masked]]
> Sent: Thursday, January 21, 2016 6:32 PM
> To: Hollenbeck, Scott; [email-masked]
> Subject: Re: I-D Action: draft-lozano-ietf-eppext-registrar-expiration-
> date-00.txt
> 
> Scott,
> 

I will not support publication of an EPP extension RFC that is unclear about
the purpose of the extension or the fields that are being added. Something
needs to be added to the draft to make that purpose crystal clear. If that
means adding text to an external document, fine. However, you do need to
answer the questions I asked in my last note.
 
> appear to be related to the business model of the registrar, etc.

Then this needs to be spelled out in the draft. We can't publish a
specification that is unclear about the meaning of the information being
exchanged, and we do need to be clear about how that information relates to
other information that's currently part of the protocol.

I really don't like the idea of standardizing broken or otherwise confusing
operational practices. Perhaps the policies and practices should be revised
to ensure that the information is consistent.
 
> expiration date is just another data point with no meaning to the

So what's the point of publishing meaningless data?

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 22 Jan 2016 14:30:05 +0000

> From: EppExt [mailto:[email-masked]] On Behalf Of Hollenbeck,
> Scott
> Sent: Friday, January 22, 2016 9:09 AM
> To: Gustavo Lozano; [email-masked]
> Subject: Re: [eppext] I-D Action: draft-lozano-ietf-eppext-registrar-
> expiration-date-00.txt
> 

[snip]

> answer the questions I asked in my last note.

Sorry, there's a word missing in the text above. What it should say:

"means adding text to *describe* an external document"

Scott

---

From: Francisco Arias <[email-masked]>
Date: Fri, 22 Jan 2016 22:59:35 +0000

Good point, Rubens, not everyone knows how the policy implementation process works at ICANN. The authoritative reference is https://www.icann.org/policy/implementation

Paraphrasing and summarizing what is explained there you have:

  1.  The gNSO (through a working group composed of community members) works on a certain matter and reach consensus on a “policy recommendation”
  2.  The gNSO council adopts the policy recommendation
  3.  The ICANN Board adopts the policy recommendation and directs ICANN staff to implement it
  4.  ICANN staff issues a call for (community) volunteers to form an Implementation Review Team that works with ICANN staff to  help draft the policy language and implementation plan
  5.  The draft policy language and implementation plan go for public comment
  6.  Draft policy language and implementation are updated as relevant based on comment (if necessary, go back to step 5)
  7.  Then you have a new policy (which is announced with an effective day for implementation)

The Thick Whois policy implementation is currently on step 5.

Regarding the reseller field (from the 2013 RAA), which is another field currently not passed from registrar to registry, we were thinking that this requirement would be covered by the drafts draft-zhou-eppext-reseller-mapping and draft-zhou-eppext-reseller.

Regards,

--
Francisco

On 1/21/16, 3:32 PM, "Rubens Kuhl" <[email-masked]<mailto:[email-masked]>> wrote:

Francisco,

It's possible that Jim and Scott were looking at https://www.icann.org/resources/pages/registrars/consensus-policies-en to find an in-force consensus policy covering such requirement. I tried finding it there as well and failed as well... that is consistent with the information that although the policy was approved by GNSO Council and the Board (https://www.icann.org/resources/board-material/resolutions-2014-02-07-en#2.c) has still not come through with its IRT (Implementation Review Team), which is why the document is still in public comment and the policy is still a draft.

Rubens

Em 21 de jan de 2016, à(s) 20:51:000, Francisco Arias <[email-masked]<mailto:[email-masked]>> escreveu:

Hi Jim,

Regards,

--
Francisco

Gustavo,

Thanks,

—

JG

James Gould
Distinguished Engineer
[email-masked]<x-msg://42/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

-----Original Message-----

Abstract:

Scott

---

From: Francisco Arias <[email-masked]>
Date: Fri, 22 Jan 2016 23:02:59 +0000

Hi Jim,

If you have any concern regarding the draft Thick Whois policy language, I’d suggest you to participate in the public comment forum at https://www.icann.org/public-comments/rdds-output-2015-12-03-en. The public comment period ends in about a week on 31-Jan.

Regards,

--
Francisco

On 1/22/16, 6:06 AM, "Gould, James" <[email-masked]<mailto:[email-masked]>> wrote:

Francisco,

—

JG

James Gould
Distinguished Engineer
[email-masked]

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Hi Jim,

Regards,

--
Francisco

Gustavo,

Thanks,

—

JG

James Gould
Distinguished Engineer

703-948-3271
12061 Bluemont Way
Reston, VA 20190

-----Original Message-----

Abstract:

Scott

---

From: Gustavo Lozano <[email-masked]>
Date: Sat, 23 Jan 2016 01:46:28 +0000

Thank you Scott, 

@All: An interesting conversation about the registrar registration
expiration date is taking place in gtld-tech, you may find it here:
http://mm.icann.org/pipermail/gtld-tech/2016-January/000605.html. As
Francisco mentioned in the gtld-tech thread:

"The ³Registrar Registration Expiration Date² is **not** being proposed in
draft-lozano-ietf-eppext-registrar-expiration-date. The field is already
in gTLD Registrar's Whois and has been there for more than two years and
registrars use it as described by Pat, Thomas and others in this thread.
Please see the 2013 RAA RDDS spec at
https://www.icann.org/resources/pages/approved-with-specs-2013-09-17-en#who
is. The draft is simply a proposal to fill the vacuum to pass this field
from registrars to registries per the Thick Whois policy recommendation
that is in the process to finalize its policy language."

I will add text in the draft mentioning the origin (RAA2013) of the
registrar expiration date, and that registrars use this field to signal
the expiration date within the Registrar.

Regards,
Gustavo

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 25 Jan 2016 14:29:49 +0000

> Sent: Friday, January 22, 2016 8:46 PM

[snip]

> the expiration date within the Registrar.

Adding the reference would be good, but please keep in mind that more than a
reference may be needed. Something somewhere needs to explain what this
information means and how it relates to other information that is already
being exchanged or produced.

I still don't know what "expiration date within the Registrar" means when
the registrar isn't the authoritative source for the registration period. If
it has something to do with the registrar-registrant service relationship
perhaps it should be named something else to make sure there is no confusion
between this value and the expiration date managed by the registry.

Scott