Subject: [Extra] Call for objections and implementation experience:

From: Bron Gondwana <[email-masked]>
Date: Wed, 15 Nov 2017 16:40:23 +0800

For the document draft-ietf-extra-imap-list-myrights:

https://www.ietf.org/id/draft-ietf-extra-imap-list-myrights-00.txt

I am looking for any objections, implementation experience, or comments
on the draft.  Also, if you know of an implementation, please add it to
the list.  I already know of the following:
* Cyrus IMAPd

(we are using this in production at FastMail to display mailbox readonly
state in our web interface)
Thanks,

Bron.

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Stan Kalisch <[email-masked]>
Date: Mon, 20 Nov 2017 14:49:35 -0500

Hi,

> On Nov 15, 2017, at 3:40 AM, Bron Gondwana <[email-masked]> wrote:
> 
> I am looking for any objections, implementation experience, or comments on the draft.

I had a look at this draft, and it looks fine to me.  The only nit I found is in Section 4, Line 119.  Unless I missed something when I went back over the ABNFs, there should be only one space between ""."" and ""INBOX"", not two.

Thanks,
Stan

> Also, if you know of an implementation, please add it to the list.  I already know of the following:
> 
> * Cyrus IMAPd
> 
> (we are using this in production at FastMail to display mailbox readonly state in our web interface)
> 
> Thanks,
> 
> Bron.
> 
> --
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra

---

From: Bron Gondwana <[email-masked]>
Date: Tue, 21 Nov 2017 09:43:58 +1100

On Tue, 21 Nov 2017, at 06:49, Stan Kalisch wrote:
> Hi,
> 
> On Nov 15, 2017, at 3:40 AM, Bron Gondwana
> <[email-masked]> wrote:>> For the document draft-ietf-extra-imap-list-myrights:
>> 
>> I am looking for any objections, implementation experience, or
>> comments on the draft.> 
> I had a look at this draft, and it looks fine to me.  The only nit I
> found is in Section 4, Line 119.  Unless I missed something when I
> went back over the ABNFs, there should be only one space between "".""
> and ""INBOX"", not two.
Yep, I see what you mean.  That's definitely wrong.  Our server does the
right thing:
. LIST "" % RETURN (MYRIGHTS SPECIAL-USE)
* LIST (\HasChildren) "/" INBOX
* MYRIGHTS INBOX lrswipkxtecdn
* LIST (\HasNoChildren) "/" AICSA
* MYRIGHTS AICSA lrswipkxtecdn
* LIST (\HasChildren \Archive) "/" Archive
* MYRIGHTS Archive lrswipkxtecdn

or in the other namespace:

. LIST "" % RETURN (MYRIGHTS SPECIAL-USE)
* LIST (\HasChildren) "." INBOX
* MYRIGHTS INBOX lrswipkxtecdn
* LIST (\NonExistent \HasChildren) "." user
* MYRIGHTS user lrsp
. OK Completed (0.002 secs 98 calls)

> 
> Thanks,
> Stan
> 
>> Also, if you know of an implementation, please add it to the list.  I
>> already know of the following:>> 
>> * Cyrus IMAPd
>> 
>> (we are using this in production at FastMail to display mailbox
>> readonly state in our web interface)>> 
>> Thanks,
>> 
>> Bron.

Ken, could you please upload a fixed version with the space removed.

Jiankang, once that's done, and any other nits ready, if you could
shepherd this one that would be great.
Cheers,

Bron.