Subject: [Fecframe] using RTP and RTCP as the transport for the repair flow

From: "Ulaş C. Kozat" <[email-masked]>
Date: Tue, 18 Mar 2008 11:53:22 -0700

Since using RTP and RTCP as the transport for the repair flow was one of the
discussion items in the working group, some of you might find the following
document interesting to look at:

http://www.ietf.org/proceedings/08mar/slides/avt-11.pdf

I am not sure to what extent (if any) we should define FEC specific feedback
information in the FEC framework document(s). Since the framework document
will serve as a guideline, and since I remember that in the design team
meetings we had an agreement that it is a good idea to define some of the
feedback information, should we start a new discussion in the WG and
crystallize our thoughts on the matter?

Ulas
_______________________________________________
Fecframe mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/fecframe

---

From: "Ali Begen (abegen)" <[email-masked]>
Date: Tue, 18 Mar 2008 22:58:06 -0700

Hi Ulas,
 
I was in the AVT group when this draft was presented, and this is a quite useful document. I liked the slide #4 most. It is a good summary showing how RTCP could be used to report feedback in different ways (e.g., receiver reports for the RTP-based repair flows and extended reports for the FEC performance feedback). This is one of the reasons why I support using RTCP as a means of transmitting the feedback information for RTP-based repair flows. Non-RTP-based repair flows can use whatever they like to use, of course. Or nothing, if no feedback support is desired.
 
Regarding your question, you summarized my earlier email well ;) The WG should discuss whether we need to define the feedback information for the framework or whether we will leave this issue to the individual FEC schemes.
 
I am hoping your email will start the discussion. If nobody speakes up, I believe we will simply leave this issue to the individual schemes. 
 
-acbegen

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Ulas C. Kozat
	Sent: Tuesday, March 18, 2008 11:53 AM
	To: [email-masked]
	Subject: [Fecframe] using RTP and RTCP as the transport for the repair flow

	Since using RTP and RTCP as the transport for the repair flow was one of the discussion items in the working group, some of you might find the following document interesting to look at:

	I am not sure to what extent (if any) we should define FEC specific feedback information in the FEC framework document(s). Since the framework document will serve as a guideline, and since I remember that in the design team meetings we had an agreement that it is a good idea to define some of the feedback information, should we start a new discussion in the WG and crystallize our thoughts on the matter?
	
	Ulas