Subject: Re: [Fecframe] FW: New Version Notification for draft-begen-fecframe-1d2d-parity-scheme-00

From: Colin Perkins <[email-masked]>
Date: Mon, 10 Mar 2008 17:14:02 +0000

Ali,

On 19 Feb 2008, at 02:03, Ali Begen (abegen) wrote:
> New draft on using partiy codes and their RTP payload format.
>
> http://www.tools.ietf.org/id/draft-begen-fecframe-1d2d-parity- 
> scheme-00.txt

I'm assuming this will be presented in AVT at some point?

One comment: requiring the SSRC to be the same as the SSRC of the  
protected RTP stream requires the FEC stream to be sent separately  
from the protected stream (i.e. on a separate port). This was (just  
about) acceptable for RFC 5109, but does limit flexibility. You might  
consider allocating the SSRC in the usual way (random assignment with  
collision detection), and using the RTCP CNAME to associate the media  
stream and the FEC stream. This is more complex, but gives the  
flexibility to either multiplex FEC and media data on the same port,  
or to multiplex multiple FEC streams on a single port.

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
Fecframe mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/fecframe

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 10 Mar 2008 14:07:48 -0400

> I'm assuming this will be presented in AVT at some point?

That has been discussed and is the plan, assuming you'll have us.

Regards
Marshall

---

From: Colin Perkins <[email-masked]>
Date: Mon, 10 Mar 2008 18:58:23 +0000

> That has been discussed and is the plan, assuming you'll have us.

Sure - although looking at the AVT agenda, it may have to be in Dublin!

-- 
Colin Perkins
http://csperkins.org/